[jitsi-dev] SIP Via/Contact headers have wrong IP address on multhomed Mac


#1

Ingo,

:We're asking the OS to give us the source IP for the one we will
:connect to. I'm not aware of any changes related to that code. Given
:that you can apparently reach 192.168.x network through your 10.x
:network I'm not sure if this really is a failure.

My multihomed Mac can, but my SIP proxy can't. My SIP proxy doesn't
know anything aboout 10.x, but because new Jitsi connects with SIP
headers that say 10.x, that's where the replies go. It's not simply a
function of the OS, because my old copy of Jitsi on the same system
does the right thing.

: > I tried to use the mailing list search in the hopes of finding this,
: > but it don't seem to work very well for me. The swish-e Title/Body
: > mailing list search doesn't give results.
:
: There's likely no result because we haven't heard of such a problem before.

Go to http://lists.jitsi.org/pipermail/users/
Make sure Title/Body is selected
Search for the word "wrong"
Note the lack of results.

Go to http://lists.jitsi.org/pipermail/users/
Make sure Title/Body is selected
Search for the word "interface"
Note the lack of results.

Some searches do appear to give results, but it's hit-or-miss.
Those are just two examples -- I searched for other things. :slight_smile:
Also, if there's any way to do a full-text search of the Trac
bug database...

Thanks,
-Mike

ยทยทยท

--
Michael J. O'Connor mjo@dojo.mi.org
=--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--=
"Boy, I feel like a hundred dollars." -Chevy Chase