[jitsi-dev] SIP Registrar port number ignored (ref. JITSI-969)


#1

Hi all,

referring to JITSI-969 bug (http://java.net/jira/browse/JITSI-969), I have
experienced the same problem on the last Jitsi nightly build on Mac OSX
10.7.1.

Sniffing packets I can see that at SIP layer all is ok, but at the UDP layer
requests are sent via 5060 port.

My Jitsi listen on 15060 and 15061 port and in the requests these part is
ok.

My Asterisk server listen on 39560 SIP port and Jitsi contact the server on
5060 port.

See attachments for more informations.

Thanks.

Fabio.


#2

Hi,

do you have SRV records for the domain you use, containing the custom port.
The port specified as shown in the configuration is used for register
URI. If you look at the register uri in your dumps you can see there
the port 39560. As we always use outbound proxy, and in your settings
its set to auto configure - all it relays on is the DNS.
Auto-configuration searches in dns entries for the port and if it
doesn't find it uses the default one which is 5060. If yo have a
custom sip port you have two options:
- you can manually configure it by unchecking auto configure and enter
address, port and transport
- configure your dns SRV records for the domain you use to have the custom port.
Hope it helps.

Regards
damencho

···

On Tue, Sep 27, 2011 at 3:20 PM, Fabio Zingaro <fabio.zingaro@gmail.com> wrote:

My Asterisk server listen on 39560 SIP port and Jitsi contact the server on
5060 port.


#3

Hi damencho,

unchecking auto configure and entering address, port and transport only
Jitsi does not register.
If I also uncheck the parallel DNS resolution in the advanced options tab,
Jitsi register without problem.

Why this problem was inexistent 3 or 4 month ago?

Thanks for all.

···

On Tue, Sep 27, 2011 at 3:59 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

do you have SRV records for the domain you use, containing the custom port.
The port specified as shown in the configuration is used for register
URI. If you look at the register uri in your dumps you can see there
the port 39560. As we always use outbound proxy, and in your settings
its set to auto configure - all it relays on is the DNS.
Auto-configuration searches in dns entries for the port and if it
doesn't find it uses the default one which is 5060. If yo have a
custom sip port you have two options:
- you can manually configure it by unchecking auto configure and enter
address, port and transport
- configure your dns SRV records for the domain you use to have the custom
port.
Hope it helps.

Regards
damencho

On Tue, Sep 27, 2011 at 3:20 PM, Fabio Zingaro <fabio.zingaro@gmail.com> > wrote:
> My Asterisk server listen on 39560 SIP port and Jitsi contact the server
on
> 5060 port.


#4

Hi Fabio

unchecking auto configure and entering address, port and transport only
Jitsi does not register.
If I also uncheck the parallel DNS resolution in the advanced options tab,
Jitsi register without problem.

Usually the parallel DNS causes problems if your network blocks queries to "foreign" DNS servers. By foreign I mean servers outside your network, e.g. Google's public resolver. We try to use this external resolver if we don't receive a reply from the main DNS server within 1.5 seconds.

Could you describe your network setup and post the logs ([1]) so we can better understand your problem?

Why this problem was inexistent 3 or 4 month ago?

There were some changes in the code that does the SIP REGISTER. We no longer do a DNS lookup of the registrar address as it might only be known to the proxy and do some additional DNS lookups for the proxy auto-detection (specifically to _sips._tcp.yousipdomain and _sip._tcp.yoursipdomain).

Ingo

[1] http://jitsi.org/index.php/Documentation/FAQ#logs