[jitsi-dev] SIP Port number ignored


#1

Hi,

It seems to me there is a bug in SIP Configuration wizard.
Registrar "Port" field is currently ignored.

How to reproduce:

1. Add new SIP account.
2. Select Advanced wizard, enter your account details.
3. Switch to "Connection" tab and enter non-standard Registrar Port
(5566 in my case).
4. Click "Next"

Current behaviour: Jitsi ignores Port 5566 and sends traffic to port 5060
Expected behaviour: SIP traffic sent to port 5566

Tested with SVN code rev. 8777

Best regards,
Chris


#2

Hi Emil,

Thanks for explanation.

So what is the point of "Port" filed next to the "Registrar"?
Maybe it should be removed to avoid confusion.

Please see below for more details:
http://dl.dropbox.com/u/3182365/Jitsi-SIP-Port-wizard.png

Regards,
Chris

···

On 12 July 2011 14:10, Emil Ivov <emcho@jitsi.org> wrote:

Hey Chris,

Jitsi sends all packets to its outbound proxy. You'd have to change that port if you want packets to go somewhere else.

Cheers,
Emil
--sent from my mobile

On 12 juil. 2011, at 11:32, Chris Maciejewski <chris@wima.co.uk> wrote:

Hi,

It seems to me there is a bug in SIP Configuration wizard.
Registrar "Port" field is currently ignored.

How to reproduce:

1. Add new SIP account.
2. Select Advanced wizard, enter your account details.
3. Switch to "Connection" tab and enter non-standard Registrar Port
(5566 in my case).
4. Click "Next"

Current behaviour: Jitsi ignores Port 5566 and sends traffic to port 5060
Expected behaviour: SIP traffic sent to port 5566

Tested with SVN code rev. 8777

Best regards,
Chris


#3

The trouble is when I enter "5566" into Registrar "Port" field Jitsi
send REGISTER packets to port 5060. So it would still seem like there
is a bug?

PS. The only way to send REGISTER to port other than 5060 was to
uncheck "Configure proxy automatically" and enter Proxy "Port". But of
course all traffic (not just REGISTER) is than sent to that port.

···

On 12 July 2011 14:24, Emil Ivov <emcho@jitsi.org> wrote:

It's supposed to allow you to set a port for your registrar which mainly helps in cases where it is different from your proxy. I agree it may be confusing in some cases, but I am not sure I can think of an easy change that can fix that and yet keep the functionality.


#4

Hi,

The bug report created at: http://java.net/jira/browse/JITSI-969

Regards,
Chris

···

On 13 July 2011 12:53, Emil Ivov <emcho@jitsi.org> wrote:

On 13 juil. 2011, at 11:37, Chris Maciejewski <chris@wima.co.uk> wrote:

On 12 July 2011 14:24, Emil Ivov <emcho@jitsi.org> wrote:

It's supposed to allow you to set a port for your registrar which mainly helps in cases where it is different from your proxy. I agree it may be confusing in some cases, but I am not sure I can think of an easy change that can fix that and yet keep the functionality.

The trouble is when I enter "5566" into Registrar "Port" field Jitsi
send REGISTER packets to port 5060. So it would still seem like there
is a bug?

That in itself is not a bug. If there's an outbound proxy, then all messages go through it. It is up to the proxy to properly route SIP messages to the right registrar. Therefore, the only change that you would see if you change your registrar address and port, is the request URI of your REGISTER requests. Their destination would remain the same though.

Now it seems however, that this part doesn't work. :). It used to but I guess we must have broken it at some point. Could you please open an issue?

Emil

PS. The only way to send REGISTER to port other than 5060 was to
uncheck "Configure proxy automatically" and enter Proxy "Port". But of
course all traffic (not just REGISTER) is than sent to that port.