[jitsi-dev] SIP port ignored in Jitsi


#1

Hi,

It seems that the SIP port field in Jitsi account settings is ignored. It always tries to connect to SIP server on port 5060. So I can't tell Jitsi to connect to custom port, ie. 5080 (asterisk sip.conf -> udpbindaddr=0.0.0.0:5080).

I'm trying 2.1.4521.10591 and jitsi-2.1.4544.10688-x86 which I believe is the latest nightly. Both fail to connect to custom port.

Vieri

.


#2

Hi,

are you configuring the proxy manually and setting the port there?
(Unchecking "Configure proxy automatically").

Regards
Damian

···

On Thu, Apr 4, 2013 at 1:03 PM, Vieri <rentorbuy@yahoo.com> wrote:

Hi,

It seems that the SIP port field in Jitsi account settings is ignored. It
always tries to connect to SIP server on port 5060. So I can't tell Jitsi
to connect to custom port, ie. 5080 (asterisk sip.conf -> udpbindaddr=
0.0.0.0:5080).

I'm trying 2.1.4521.10591 and jitsi-2.1.4544.10688-x86 which I believe is
the latest nightly. Both fail to connect to custom port.

Vieri


#3

Hi,

I was provisioning the properties and if I do so then I also need to provision IS_SERVER_OVERRIDDEN and PREFERRED_TRANSPORT (at least).
I don't think it would be necessary to manually specify the proxy. In other words, what's the use of the "top" port field in the account settings? Changing that value doesn't really make a difference, does it?

Vieri

···

--- On Thu, 4/4/13, Damian Minkov <damencho@jitsi.org> wrote:

Hi,
are you configuring the proxy manually and setting the port there? (Unchecking "Configure proxy automatically").
Regards

Damian

On Thu, Apr 4, 2013 at 1:03 PM, Vieri <rentorbuy@yahoo.com> wrote:

Hi,

It seems that the SIP port field in Jitsi account settings is ignored. It always tries to connect to SIP server on port 5060. So I can't tell Jitsi to connect to custom port, ie. 5080 (asterisk sip.conf -> udpbindaddr=0.0.0.0:5080).

I'm trying 2.1.4521.10591 and jitsi-2.1.4544.10688-x86 which I believe is the latest nightly. Both fail to connect to custom port.

Vieri


#4

Hi,

the settings above proxy options, when changed they just change request URI of
your REGISTER requests, where the request is sent is discovered
automatically or manually by the options below.

Regards
Damian

···

On Thu, Apr 4, 2013 at 2:45 PM, Vieri <rentorbuy@yahoo.com> wrote:

Hi,

I was provisioning the properties and if I do so then I also need to
provision IS_SERVER_OVERRIDDEN and PREFERRED_TRANSPORT (at least).
I don't think it would be necessary to manually specify the proxy. In
other words, what's the use of the "top" port field in the account
settings? Changing that value doesn't really make a difference, does it?

Vieri

--- On *Thu, 4/4/13, Damian Minkov <damencho@jitsi.org>* wrote:

Hi,

are you configuring the proxy manually and setting the port there?
(Unchecking "Configure proxy automatically").

Regards
Damian

On Thu, Apr 4, 2013 at 1:03 PM, Vieri <rentorbuy@yahoo.com<http://mc/compose?to=rentorbuy@yahoo.com> > > wrote:

Hi,

It seems that the SIP port field in Jitsi account settings is ignored. It
always tries to connect to SIP server on port 5060. So I can't tell Jitsi
to connect to custom port, ie. 5080 (asterisk sip.conf -> udpbindaddr=
0.0.0.0:5080).

I'm trying 2.1.4521.10591 and jitsi-2.1.4544.10688-x86 which I believe is
the latest nightly. Both fail to connect to custom port.

Vieri


#5

Thanks Damian,

If the request URI specifies a custom SIP port (say, 5080) then why does Jitsi "automatically discover" 5060? I'm not familiar with the logic behind auto-discovery. In any case, it doesn't really matter now since I can successfully provision all the "manual proxy" settings necessary so that Jitsi connects to my custom SIP port.

Thanks again,

Vieri

···

--- On Thu, 4/4/13, Damian Minkov <damencho@jitsi.org> wrote:

Hi,
the settings above proxy options, when changed they just change request URI of your REGISTER requests, where the request is sent is discovered automatically or manually by the options below.

Regards

Damian
On Thu, Apr 4, 2013 at 2:45 PM, Vieri <rentorbuy@yahoo.com> wrote:

Hi,

I was provisioning the properties and if I do so then I also need to provision IS_SERVER_OVERRIDDEN and PREFERRED_TRANSPORT (at least).

I don't think it would be necessary to manually specify the proxy. In other words, what's the use of the "top" port field in the account settings? Changing that value doesn't really make a difference, does it?

Vieri

--- On Thu, 4/4/13, Damian Minkov <damencho@jitsi.org> wrote:

Hi,
are you configuring the proxy manually and setting the port there? (Unchecking "Configure proxy automatically").
Regards

Damian

On Thu, Apr 4, 2013 at 1:03 PM, Vieri <rentorbuy@yahoo.com> wrote:

Hi,

It seems that the SIP port field in Jitsi account settings is ignored. It always tries to connect to SIP server on port 5060. So I can't tell Jitsi to connect to custom port, ie. 5080 (asterisk sip.conf -> udpbindaddr=0.0.0.0:5080).

I'm trying 2.1.4521.10591 and jitsi-2.1.4544.10688-x86 which I believe is the latest nightly. Both fail to connect to custom port.

Vieri


#6

Hi,

the request URI is used by the proxy to correctly route your request to the
regitrar. But the destination of our packets are to the proxy which is
auto-discovered by dns entries or manually specified. http://tools.ietf
.org/html/rfc3263

Regards
Damian

···

On Thu, Apr 4, 2013 at 3:26 PM, Vieri <rentorbuy@yahoo.com> wrote:

Thanks Damian,

If the request URI specifies a custom SIP port (say, 5080) then why does
Jitsi "automatically discover" 5060? I'm not familiar with the logic behind
auto-discovery. In any case, it doesn't really matter now since I can
successfully provision all the "manual proxy" settings necessary so that
Jitsi connects to my custom SIP port.

Thanks again,

Vieri

--- On *Thu, 4/4/13, Damian Minkov <damencho@jitsi.org>* wrote:

Hi,

the settings above proxy options, when changed they just change request
URI of your REGISTER requests, where the request is sent is discovered
automatically or manually by the options below.

Regards
Damian

On Thu, Apr 4, 2013 at 2:45 PM, Vieri <rentorbuy@yahoo.com<http://mc/compose?to=rentorbuy@yahoo.com> > > wrote:

Hi,

I was provisioning the properties and if I do so then I also need to
provision IS_SERVER_OVERRIDDEN and PREFERRED_TRANSPORT (at least).
I don't think it would be necessary to manually specify the proxy. In
other words, what's the use of the "top" port field in the account
settings? Changing that value doesn't really make a difference, does it?

Vieri

--- On *Thu, 4/4/13, Damian Minkov <damencho@jitsi.org<http://mc/compose?to=damencho@jitsi.org> > >* wrote:

Hi,

are you configuring the proxy manually and setting the port there?
(Unchecking "Configure proxy automatically").

Regards
Damian

On Thu, Apr 4, 2013 at 1:03 PM, Vieri <rentorbuy@yahoo.com<http://mc/compose?to=rentorbuy@yahoo.com> > > wrote:

Hi,

It seems that the SIP port field in Jitsi account settings is ignored. It
always tries to connect to SIP server on port 5060. So I can't tell Jitsi
to connect to custom port, ie. 5080 (asterisk sip.conf -> udpbindaddr=
0.0.0.0:5080).

I'm trying 2.1.4521.10591 and jitsi-2.1.4544.10688-x86 which I believe is
the latest nightly. Both fail to connect to custom port.

Vieri