[jitsi-dev] Sip Communicator (logging?) uses the disk too frequently


#1

Hello,

I have a question: How can the Sip Communicator logging be disabled (Linux/Debian)?
I see it (with iotop) that the Sip Communicators java process writes to my hdd every second or so. I dont
like to have this on my laptop because it wakes up the drive constantly.

Is there a way preventing this?

···

--
Have a nice day,

Kertesz Laszlo

Using Opera's revolutionary email client: http://www.opera.com/mail/


#2

Hey Kertesz,

Glad to see your list problems are over.

(more inline)

На 29.01.11 16:16, Kertesz Laszlo написа:

Hello,

I have a question: How can the Sip Communicator logging be disabled
(Linux/Debian)?
I see it (with iotop) that the Sip Communicators java process writes to my
hdd every second or so. I dont
like to have this on my laptop because it wakes up the drive constantly.

Is there a way preventing this?

Yup, you'd need to edit the following file:

/usr/lib/sip-communicator/lib/logging.properties

then change all levels in there to OFF

In other words, every time you see something like

.level= FINEST
or
net.java.sip.communicator.util.FileHandler.level = INFO
or
net.java.sip.communicator...level = FINEST

they should become

.level= OFF
or
net.java.sip.communicator.util.FileHandler.level = OFF
or
net.java.sip.communicator...level = OFF

Let me know how this works for you.

Cheers,
Emil


#3

Hi,

Unfortunately does not seem to work. I attached the modified file.
Maybe a GUI option to disable logging would be helpful.

logging.properties (2.37 KB)

···

On Sat, 29 Jan 2011 16:53:48 +0200, Emil Ivov <emcho@sip-communicator.org> wrote:

Hey Kertesz,

Glad to see your list problems are over.

(more inline)

На 29.01.11 16:16, Kertesz Laszlo написа:

Hello,

I have a question: How can the Sip Communicator logging be disabled
(Linux/Debian)?
I see it (with iotop) that the Sip Communicators java process writes to my
hdd every second or so. I dont
like to have this on my laptop because it wakes up the drive constantly.

Is there a way preventing this?

Yup, you'd need to edit the following file:

/usr/lib/sip-communicator/lib/logging.properties

then change all levels in there to OFF

In other words, every time you see something like

.level= FINEST
or
net.java.sip.communicator.util.FileHandler.level = INFO
or
net.java.sip.communicator...level = FINEST

they should become

.level= OFF
or
net.java.sip.communicator.util.FileHandler.level = OFF
or
net.java.sip.communicator...level = OFF

Let me know how this works for you.

Cheers,
Emil

--
Have a nice day,

Kertesz Laszlo

Using Opera's revolutionary email client: http://www.opera.com/mail/


#4

На 29.01.11 22:54, Kertesz Laszlo написа:

In other words, every time you see something like

.level= FINEST
or
net.java.sip.communicator.util.FileHandler.level = INFO
or
net.java.sip.communicator...level = FINEST

they should become

.level= OFF
or
net.java.sip.communicator.util.FileHandler.level = OFF
or
net.java.sip.communicator...level = OFF

Unfortunately does not seem to work. I attached the modified file.

And by "doesn't work" you mean everything is just the way it was or that
there are still some logs being written? After deleting all my log files
and using a log configuration file similar to the one you attached, I
still see the pcap files being created but no .log files. Is this also
what you get?

Also, the location of the properties file I mentioned is only relevant
if you installed it from the deb package. It would be elsewhere otherwise.

Maybe a GUI option to disable logging would be helpful.

Yup, indeed.

Cheers,
Emil


#5

Sorry about the confusion. It does not create log files (no files in the logs folder), but it still writes to disk frequently (sometimes 2 separate threads).
iotop reports ~11.6 KB/s written every second or so by the Sip Communicators java process.
I have pcap logging set to "off" - maybe this logging uses some temporary files?

···

On Sat, 29 Jan 2011 23:07:20 +0200, Emil Ivov <emcho@sip-communicator.org> wrote:

На 29.01.11 22:54, Kertesz Laszlo написа:

In other words, every time you see something like

.level= FINEST
or
net.java.sip.communicator.util.FileHandler.level = INFO
or
net.java.sip.communicator...level = FINEST

they should become

.level= OFF
or
net.java.sip.communicator.util.FileHandler.level = OFF
or
net.java.sip.communicator...level = OFF

Unfortunately does not seem to work. I attached the modified file.

And by "doesn't work" you mean everything is just the way it was or that
there are still some logs being written? After deleting all my log files
and using a log configuration file similar to the one you attached, I
still see the pcap files being created but no .log files. Is this also
what you get?

Also, the location of the properties file I mentioned is only relevant
if you installed it from the deb package. It would be elsewhere otherwise.

Maybe a GUI option to disable logging would be helpful.

Yup, indeed.

Cheers,
Emil

--
Have a nice day,

Kertesz Laszlo

Using Opera's revolutionary email client: http://www.opera.com/mail/


#6

На 29.01.11 23:51, Kertesz Laszlo написа:

Sorry about the confusion. It does not create log files (no files in the
logs folder), but it still writes to disk frequently (sometimes 2 separate
threads).
iotop reports ~11.6 KB/s written every second or so by the Sip
Communicators java process.
I have pcap logging set to "off" - maybe this logging uses some temporary
files?

We'd need to look into this. Possible culprits could be

* The ConfigurationService - writing into sip-communicator.properties
* The MetaContactListService - writing into contactlist
* The avatar caching. If you did your measurement soon after a launch,
then this may be the most likely explanation.

Emil


#7

The situation is the same right after the launch or an hour later. I know that things have to be written here and there, but this is too frequent - no other programs do this (Pidgin/Empathy etc).

···

On Sat, 29 Jan 2011 23:59:20 +0200, Emil Ivov <emcho@sip-communicator.org> wrote:

На 29.01.11 23:51, Kertesz Laszlo написа:

Sorry about the confusion. It does not create log files (no files in the
logs folder), but it still writes to disk frequently (sometimes 2 separate
threads).
iotop reports ~11.6 KB/s written every second or so by the Sip
Communicators java process.
I have pcap logging set to "off" - maybe this logging uses some temporary
files?

We'd need to look into this. Possible culprits could be

* The ConfigurationService - writing into sip-communicator.properties
* The MetaContactListService - writing into contactlist
* The avatar caching. If you did your measurement soon after a launch,
then this may be the most likely explanation.

Emil

--
Have a nice day,

Kertesz Laszlo

Using Opera's revolutionary email client: http://www.opera.com/mail/


#8

Hello,

I had observed this issue with sip communicator and now jitsi:
It uses the disk too frequently, it writes every second or so. No other
similar software does this and i dont like it because on my laptop it
prevents the hard disk from stopping.
I use Debian Testing.

How to observe: Launch Jitsi the iotop in a terminal. I have jitsi
permanently writing at ~11.5 KB/s.
I turned off logging ant its the same and it does this until it runs,
it is not just a start up write/cache issue.

O zi buna,

Kertesz Laszlo


#9

Hi,

I was trying to reproduce this but cannot see any continuous writing
to the currently used files in the home folder of Jitsi. Then I looked
at the tool you are mentioning iotop, I think this tool shows the
overall I/O usage of the process, this also includes network usage and
depends of the accounts you use you may see more writes as there are
always some statuses and keep alives.

Regards
damencho

···

On Sat, May 21, 2011 at 1:56 AM, Kertesz Laszlo <laszlo.kertesz@gmail.com> wrote:

Hello,

I had observed this issue with sip communicator and now jitsi:
It uses the disk too frequently, it writes every second or so. No other
similar software does this and i dont like it because on my laptop it
prevents the hard disk from stopping.
I use Debian Testing.

How to observe: Launch Jitsi the iotop in a terminal. I have jitsi
permanently writing at ~11.5 KB/s.
I turned off logging ant its the same and it does this until it runs,
it is not just a start up write/cache issue.

O zi buna,

Kertesz Laszlo