[jitsi-dev] Simulcast disabling unneeded resolution?


#1

Hi all,

What is the name of the feature that allow to stop sending unneeded
resolutions?

For a 1:1 conference you don't need small and medium resolution, only high
most of the time
(in my tests i'm sending 1250Kbits and receiving 650Kbits, lots of wasted
bandwidth for the sender)

What the status of this feature if it exists?

output of jvb log when starting conference:

channelLastN: 4

adaptiveLastN: false
openSctp: true
simulcastMode: rewriting
disableRtx: true

Thanks in advance
Etienne


#2

Hi Etienne, you want `disableSimulcast: true`. We don’t dynamically enable-disable simulcast after a participant has joined, so if you start a 1-1 conference and then it becomes a multi-way call, you’re stuck with simulcast disabled. - George

···

On Apr 19, 2016, at 9:13 AM, Etienne Champetier <champetier.etienne@gmail.com> wrote:

Hi all,

What is the name of the feature that allow to stop sending unneeded resolutions?

For a 1:1 conference you don't need small and medium resolution, only high most of the time
(in my tests i'm sending 1250Kbits and receiving 650Kbits, lots of wasted bandwidth for the sender)

What the status of this feature if it exists?

output of jvb log when starting conference:

channelLastN: 4
adaptiveLastN: false
openSctp: true
simulcastMode: rewriting
disableRtx: true

Thanks in advance
Etienne
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi,

Hi Etienne, you want `disableSimulcast: true`. We don’t dynamically
enable-disable simulcast after a participant has joined, so if you start a
1-1 conference and then it becomes a multi-way call, you’re stuck with
simulcast disabled. - George

That was a poor example,
If i have 4 users with enough bandwidth, I need small and high resolution,
but often not medium one
If no one is watching a simulcast stream, is there a way to not send it?

···

2016-04-19 16:55 GMT+02:00 George Politis <gp@jitsi.org>:

On Apr 19, 2016, at 9:13 AM, Etienne Champetier < > champetier.etienne@gmail.com> wrote:

Hi all,

What is the name of the feature that allow to stop sending unneeded
resolutions?

For a 1:1 conference you don't need small and medium resolution, only high
most of the time
(in my tests i'm sending 1250Kbits and receiving 650Kbits, lots of wasted
bandwidth for the sender)

What the status of this feature if it exists?

output of jvb log when starting conference:

channelLastN: 4

adaptiveLastN: false
openSctp: true
simulcastMode: rewriting
disableRtx: true

Thanks in advance
Etienne


#4

Hi Etienne,

You could try that actually, the number of simulcast streams are controlled here https://github.com/jitsi/lib-jitsi-meet/blob/967ee8980c556b97520868d15a58b2e0f180bde6/modules/xmpp/TraceablePeerConnection.js, there’s a constant called SIMULCAST_LAYERS. You can set it to 2. If it works well, you can even expose this as a parameter to put in config.js.

Best,
George

···

On Apr 19, 2016, at 10:16 AM, Etienne Champetier <champetier.etienne@gmail.com> wrote:

Hi,

2016-04-19 16:55 GMT+02:00 George Politis <gp@jitsi.org>:
Hi Etienne, you want `disableSimulcast: true`. We don’t dynamically enable-disable simulcast after a participant has joined, so if you start a 1-1 conference and then it becomes a multi-way call, you’re stuck with simulcast disabled. - George

That was a poor example,
If i have 4 users with enough bandwidth, I need small and high resolution, but often not medium one
If no one is watching a simulcast stream, is there a way to not send it?

On Apr 19, 2016, at 9:13 AM, Etienne Champetier <champetier.etienne@gmail.com> wrote:

Hi all,

What is the name of the feature that allow to stop sending unneeded resolutions?

For a 1:1 conference you don't need small and medium resolution, only high most of the time
(in my tests i'm sending 1250Kbits and receiving 650Kbits, lots of wasted bandwidth for the sender)

What the status of this feature if it exists?

output of jvb log when starting conference:

channelLastN: 4
adaptiveLastN: false
openSctp: true
simulcastMode: rewriting
disableRtx: true

Thanks in advance
Etienne

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi George,

Hi Etienne,

You could try that actually, the number of simulcast streams are
controlled here
https://github.com/jitsi/lib-jitsi-meet/blob/967ee8980c556b97520868d15a58b2e0f180bde6/modules/xmpp/TraceablePeerConnection.js,
there’s a constant called SIMULCAST_LAYERS. You can set it to 2. If it
works well, you can even expose this as a parameter to put in config.js.

just tested but saddly this doesn't work, if i have client A and B, A with
SIMULCAST_LAYERS=3 and B with SIMULCAST_LAYERS=2, B will see A but A will
not see B

···

2016-04-19 17:39 GMT+02:00 George Politis <gp@jitsi.org>:

Best,
George

> On Apr 19, 2016, at 10:16 AM, Etienne Champetier < > champetier.etienne@gmail.com> wrote:
>
> Hi,
>
> 2016-04-19 16:55 GMT+02:00 George Politis <gp@jitsi.org>:
> Hi Etienne, you want `disableSimulcast: true`. We don’t dynamically
enable-disable simulcast after a participant has joined, so if you start a
1-1 conference and then it becomes a multi-way call, you’re stuck with
simulcast disabled. - George
>
>
> That was a poor example,
> If i have 4 users with enough bandwidth, I need small and high
resolution, but often not medium one
> If no one is watching a simulcast stream, is there a way to not send it?
>
>
>> On Apr 19, 2016, at 9:13 AM, Etienne Champetier < > champetier.etienne@gmail.com> wrote:
>>
>> Hi all,
>>
>> What is the name of the feature that allow to stop sending unneeded
resolutions?
>>
>> For a 1:1 conference you don't need small and medium resolution, only
high most of the time
>> (in my tests i'm sending 1250Kbits and receiving 650Kbits, lots of
wasted bandwidth for the sender)
>>
>> What the status of this feature if it exists?
>>
>> output of jvb log when starting conference:
>>
>> channelLastN: 4
>> adaptiveLastN: false
>> openSctp: true
>> simulcastMode: rewriting
>> disableRtx: true
>>
>>
>> Thanks in advance
>> Etienne
>>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Hi again,

Hi George,

Hi Etienne,

You could try that actually, the number of simulcast streams are
controlled here
https://github.com/jitsi/lib-jitsi-meet/blob/967ee8980c556b97520868d15a58b2e0f180bde6/modules/xmpp/TraceablePeerConnection.js,
there’s a constant called SIMULCAST_LAYERS. You can set it to 2. If it
works well, you can even expose this as a parameter to put in config.js.

just tested but saddly this doesn't work, if i have client A and B, A with
SIMULCAST_LAYERS=3 and B with SIMULCAST_LAYERS=2, B will see A but A will
not see B

(and of course if SIMULCAST_LAYERS=2 for both nothing work)

I see nothing obvious in the logs (jvb/jicofo/chrome console), if you have
any other ideas i'm ready to try anything

Thanks
Etienne

···

2016-04-20 9:38 GMT+02:00 Etienne Champetier <champetier.etienne@gmail.com>:

2016-04-19 17:39 GMT+02:00 George Politis <gp@jitsi.org>:

Best,
George

> On Apr 19, 2016, at 10:16 AM, Etienne Champetier < >> champetier.etienne@gmail.com> wrote:
>
> Hi,
>
> 2016-04-19 16:55 GMT+02:00 George Politis <gp@jitsi.org>:
> Hi Etienne, you want `disableSimulcast: true`. We don’t dynamically
enable-disable simulcast after a participant has joined, so if you start a
1-1 conference and then it becomes a multi-way call, you’re stuck with
simulcast disabled. - George
>
>
> That was a poor example,
> If i have 4 users with enough bandwidth, I need small and high
resolution, but often not medium one
> If no one is watching a simulcast stream, is there a way to not send it?
>
>
>> On Apr 19, 2016, at 9:13 AM, Etienne Champetier < >> champetier.etienne@gmail.com> wrote:
>>
>> Hi all,
>>
>> What is the name of the feature that allow to stop sending unneeded
resolutions?
>>
>> For a 1:1 conference you don't need small and medium resolution, only
high most of the time
>> (in my tests i'm sending 1250Kbits and receiving 650Kbits, lots of
wasted bandwidth for the sender)
>>
>> What the status of this feature if it exists?
>>
>> output of jvb log when starting conference:
>>
>> channelLastN: 4
>> adaptiveLastN: false
>> openSctp: true
>> simulcastMode: rewriting
>> disableRtx: true
>>
>>
>> Thanks in advance
>> Etienne
>>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Hi Etienne, could you please share the remote/local SDPs and the JVB logs (with INFO level for all loggers)? I remember this was working some time ago, so we must have broken something. - George

···

On Apr 20, 2016, at 8:08 AM, Etienne Champetier <champetier.etienne@gmail.com> wrote:

Hi again,

2016-04-20 9:38 GMT+02:00 Etienne Champetier <champetier.etienne@gmail.com <mailto:champetier.etienne@gmail.com>>:
Hi George,

2016-04-19 17:39 GMT+02:00 George Politis <gp@jitsi.org <mailto:gp@jitsi.org>>:
Hi Etienne,

You could try that actually, the number of simulcast streams are controlled here https://github.com/jitsi/lib-jitsi-meet/blob/967ee8980c556b97520868d15a58b2e0f180bde6/modules/xmpp/TraceablePeerConnection.js, there’s a constant called SIMULCAST_LAYERS. You can set it to 2. If it works well, you can even expose this as a parameter to put in config.js.

just tested but saddly this doesn't work, if i have client A and B, A with SIMULCAST_LAYERS=3 and B with SIMULCAST_LAYERS=2, B will see A but A will not see B

(and of course if SIMULCAST_LAYERS=2 for both nothing work)

I see nothing obvious in the logs (jvb/jicofo/chrome console), if you have any other ideas i'm ready to try anything

Thanks
Etienne

Best,
George

> On Apr 19, 2016, at 10:16 AM, Etienne Champetier <champetier.etienne@gmail.com <mailto:champetier.etienne@gmail.com>> wrote:
>
> Hi,
>
> 2016-04-19 16:55 GMT+02:00 George Politis <gp@jitsi.org <mailto:gp@jitsi.org>>:
> Hi Etienne, you want `disableSimulcast: true`. We don’t dynamically enable-disable simulcast after a participant has joined, so if you start a 1-1 conference and then it becomes a multi-way call, you’re stuck with simulcast disabled. - George
>
>
> That was a poor example,
> If i have 4 users with enough bandwidth, I need small and high resolution, but often not medium one
> If no one is watching a simulcast stream, is there a way to not send it?
>
>
>> On Apr 19, 2016, at 9:13 AM, Etienne Champetier <champetier.etienne@gmail.com <mailto:champetier.etienne@gmail.com>> wrote:
>>
>> Hi all,
>>
>> What is the name of the feature that allow to stop sending unneeded resolutions?
>>
>> For a 1:1 conference you don't need small and medium resolution, only high most of the time
>> (in my tests i'm sending 1250Kbits and receiving 650Kbits, lots of wasted bandwidth for the sender)
>>
>> What the status of this feature if it exists?
>>
>> output of jvb log when starting conference:
>>
>> channelLastN: 4
>> adaptiveLastN: false
>> openSctp: true
>> simulcastMode: rewriting
>> disableRtx: true
>>
>>
>> Thanks in advance
>> Etienne
>>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org <mailto:dev@jitsi.org>
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Hi Etienne, could you please share the remote/local SDPs and the JVB logs
(with INFO level for all loggers)? I remember this was working some time
ago, so we must have broken something. - George

I've no special config for loggers, is it ok?
here are the logs

Thanks again

jicofo.log (22.8 KB)

jvb.log (59.9 KB)

description (11.2 KB)

···

2016-04-20 17:08 GMT+02:00 George Politis <gp@jitsi.org>:

On Apr 20, 2016, at 8:08 AM, Etienne Champetier < > champetier.etienne@gmail.com> wrote:

Hi again,

2016-04-20 9:38 GMT+02:00 Etienne Champetier <champetier.etienne@gmail.com
>:

Hi George,

2016-04-19 17:39 GMT+02:00 George Politis <gp@jitsi.org>:

Hi Etienne,

You could try that actually, the number of simulcast streams are
controlled here
https://github.com/jitsi/lib-jitsi-meet/blob/967ee8980c556b97520868d15a58b2e0f180bde6/modules/xmpp/TraceablePeerConnection.js,
there’s a constant called SIMULCAST_LAYERS. You can set it to 2. If it
works well, you can even expose this as a parameter to put in config.js.

just tested but saddly this doesn't work, if i have client A and B, A
with SIMULCAST_LAYERS=3 and B with SIMULCAST_LAYERS=2, B will see A but A
will not see B

(and of course if SIMULCAST_LAYERS=2 for both nothing work)

I see nothing obvious in the logs (jvb/jicofo/chrome console), if you have
any other ideas i'm ready to try anything

Thanks
Etienne

Best,
George

> On Apr 19, 2016, at 10:16 AM, Etienne Champetier < >>> champetier.etienne@gmail.com> wrote:
>
> Hi,
>
> 2016-04-19 16:55 GMT+02:00 George Politis <gp@jitsi.org>:
> Hi Etienne, you want `disableSimulcast: true`. We don’t dynamically
enable-disable simulcast after a participant has joined, so if you start a
1-1 conference and then it becomes a multi-way call, you’re stuck with
simulcast disabled. - George
>
>
> That was a poor example,
> If i have 4 users with enough bandwidth, I need small and high
resolution, but often not medium one
> If no one is watching a simulcast stream, is there a way to not send
it?
>
>
>> On Apr 19, 2016, at 9:13 AM, Etienne Champetier < >>> champetier.etienne@gmail.com> wrote:
>>
>> Hi all,
>>
>> What is the name of the feature that allow to stop sending unneeded
resolutions?
>>
>> For a 1:1 conference you don't need small and medium resolution, only
high most of the time
>> (in my tests i'm sending 1250Kbits and receiving 650Kbits, lots of
wasted bandwidth for the sender)
>>
>> What the status of this feature if it exists?
>>
>> output of jvb log when starting conference:
>>
>> channelLastN: 4
>> adaptiveLastN: false
>> openSctp: true
>> simulcastMode: rewriting
>> disableRtx: true
>>
>>
>> Thanks in advance
>> Etienne
>>
>


#9

Hi Etienne,

The SDP looks good but unfortunately I can’t tell what the bridge is doing because the interesting logs are of level FINEST. It would be helpful to have the loggers configured appropriately.

Before spending more time on this, keep in mind that with 2 simulcast streams you’ll probably not be able to go above 360p. The simulcast formats are defined in simulcast.cc, in a constant called kSimulcastFormats.

- George

···

On Apr 20, 2016, at 11:05 AM, Etienne Champetier <champetier.etienne@gmail.com> wrote:

2016-04-20 17:08 GMT+02:00 George Politis <gp@jitsi.org <mailto:gp@jitsi.org>>:
Hi Etienne, could you please share the remote/local SDPs and the JVB logs (with INFO level for all loggers)? I remember this was working some time ago, so we must have broken something. - George

I've no special config for loggers, is it ok?
here are the logs

Thanks again

On Apr 20, 2016, at 8:08 AM, Etienne Champetier <champetier.etienne@gmail.com <mailto:champetier.etienne@gmail.com>> wrote:

Hi again,

2016-04-20 9:38 GMT+02:00 Etienne Champetier <champetier.etienne@gmail.com <mailto:champetier.etienne@gmail.com>>:
Hi George,

2016-04-19 17:39 GMT+02:00 George Politis <gp@jitsi.org <mailto:gp@jitsi.org>>:
Hi Etienne,

You could try that actually, the number of simulcast streams are controlled here https://github.com/jitsi/lib-jitsi-meet/blob/967ee8980c556b97520868d15a58b2e0f180bde6/modules/xmpp/TraceablePeerConnection.js, there’s a constant called SIMULCAST_LAYERS. You can set it to 2. If it works well, you can even expose this as a parameter to put in config.js.

just tested but saddly this doesn't work, if i have client A and B, A with SIMULCAST_LAYERS=3 and B with SIMULCAST_LAYERS=2, B will see A but A will not see B

(and of course if SIMULCAST_LAYERS=2 for both nothing work)

I see nothing obvious in the logs (jvb/jicofo/chrome console), if you have any other ideas i'm ready to try anything

Thanks
Etienne

Best,
George

> On Apr 19, 2016, at 10:16 AM, Etienne Champetier <champetier.etienne@gmail.com <mailto:champetier.etienne@gmail.com>> wrote:
>
> Hi,
>
> 2016-04-19 16:55 GMT+02:00 George Politis <gp@jitsi.org <mailto:gp@jitsi.org>>:
> Hi Etienne, you want `disableSimulcast: true`. We don’t dynamically enable-disable simulcast after a participant has joined, so if you start a 1-1 conference and then it becomes a multi-way call, you’re stuck with simulcast disabled. - George
>
>
> That was a poor example,
> If i have 4 users with enough bandwidth, I need small and high resolution, but often not medium one
> If no one is watching a simulcast stream, is there a way to not send it?
>
>
>> On Apr 19, 2016, at 9:13 AM, Etienne Champetier <champetier.etienne@gmail.com <mailto:champetier.etienne@gmail.com>> wrote:
>>
>> Hi all,
>>
>> What is the name of the feature that allow to stop sending unneeded resolutions?
>>
>> For a 1:1 conference you don't need small and medium resolution, only high most of the time
>> (in my tests i'm sending 1250Kbits and receiving 650Kbits, lots of wasted bandwidth for the sender)
>>
>> What the status of this feature if it exists?
>>
>> output of jvb log when starting conference:
>>
>> channelLastN: 4
>> adaptiveLastN: false
>> openSctp: true
>> simulcastMode: rewriting
>> disableRtx: true
>>
>>
>> Thanks in advance
>> Etienne
>>
>

<jicofo.log><jvb.log><description>_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

Hi Etienne,

The SDP looks good but unfortunately I can’t tell what the bridge is

doing because the interesting logs are of level FINEST. It would be helpful
to have the loggers configured appropriately.

Before spending more time on this, keep in mind that with 2 simulcast

streams you’ll probably not be able to go above 360p. The simulcast formats
are defined in simulcast.cc, in a constant called kSimulcastFormats.

Are you saying that there is no way (with current chrome) to have one small
(vignette) and one big video (full screen), without wasting bandwidth with
mid size video?

- George

Hi Etienne, could you please share the remote/local SDPs and the JVB

logs (with INFO level for all loggers)? I remember this was working some
time ago, so we must have broken something. - George

I've no special config for loggers, is it ok?
here are the logs

Thanks again

Hi again,

Hi George,

Hi Etienne,

You could try that actually, the number of simulcast streams are

controlled here
https://github.com/jitsi/lib-jitsi-meet/blob/967ee8980c556b97520868d15a58b2e0f180bde6/modules/xmpp/TraceablePeerConnection.js,
there’s a constant called SIMULCAST_LAYERS. You can set it to 2. If it
works well, you can even expose this as a parameter to put in config.js.

just tested but saddly this doesn't work, if i have client A and B, A

with SIMULCAST_LAYERS=3 and B with SIMULCAST_LAYERS=2, B will see A but A
will not see B

(and of course if SIMULCAST_LAYERS=2 for both nothing work)

I see nothing obvious in the logs (jvb/jicofo/chrome console), if you

have any other ideas i'm ready to try anything

Thanks
Etienne

Best,
George

>
> Hi,
>
> Hi Etienne, you want `disableSimulcast: true`. We don’t

dynamically enable-disable simulcast after a participant has joined, so if
you start a 1-1 conference and then it becomes a multi-way call, you’re
stuck with simulcast disabled. - George

>
>
> That was a poor example,
> If i have 4 users with enough bandwidth, I need small and high

resolution, but often not medium one

> If no one is watching a simulcast stream, is there a way to not

send it?

>
>
>>
>> Hi all,
>>
>> What is the name of the feature that allow to stop sending

unneeded resolutions?

>>
>> For a 1:1 conference you don't need small and medium resolution,

only high most of the time

>> (in my tests i'm sending 1250Kbits and receiving 650Kbits, lots

of wasted bandwidth for the sender)

>>
>> What the status of this feature if it exists?
>>
>> output of jvb log when starting conference:
>>
>> channelLastN: 4
>> adaptiveLastN: false
>> openSctp: true
>> simulcastMode: rewriting
>> disableRtx: true
>>
>>
>> Thanks in advance
>> Etienne
>>
>

<jicofo.log><jvb.log><description>_______________________________________________

···

Le 20 avr. 2016 6:20 PM, "George Politis" <gp@jitsi.org> a écrit :

On Apr 20, 2016, at 11:05 AM, Etienne Champetier < champetier.etienne@gmail.com> wrote:
2016-04-20 17:08 GMT+02:00 George Politis <gp@jitsi.org>:

On Apr 20, 2016, at 8:08 AM, Etienne Champetier < champetier.etienne@gmail.com> wrote:
2016-04-20 9:38 GMT+02:00 Etienne Champetier < champetier.etienne@gmail.com>:

2016-04-19 17:39 GMT+02:00 George Politis <gp@jitsi.org>:

> On Apr 19, 2016, at 10:16 AM, Etienne Champetier < champetier.etienne@gmail.com> wrote:
> 2016-04-19 16:55 GMT+02:00 George Politis <gp@jitsi.org>:
>> On Apr 19, 2016, at 9:13 AM, Etienne Champetier < champetier.etienne@gmail.com> wrote:

dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#11

> Before spending more time on this, keep in mind that with 2 simulcast streams you’ll probably not be able to go above 360p. The simulcast formats are defined in simulcast.cc, in a constant called kSimulcastFormats.

Are you saying that there is no way (with current chrome) to have one small (vignette) and one big video (full screen), without wasting bandwidth with mid size video?

Hi Etienne,

I’m only saying that with 2 simulcast streams you won’t be able to reach 720p. If you want 720p for the participant that’s on stage, then you have two options: either to disable simulcast completely (not a great idea in my opinion), or to have the sender stream 360p, even if it’s redundant most of the time.

I think it would make sense to file a bug against webrtc and ask them to add an additional simulcast format that streams 720p/180p. It shouldn’t be hard to implement either, so you could even submit a nice patch for them to accept :slight_smile:

- George


#12

> > Before spending more time on this, keep in mind that with 2 simulcast

streams you’ll probably not be able to go above 360p. The simulcast formats
are defined in simulcast.cc, in a constant called kSimulcastFormats.

>
> Are you saying that there is no way (with current chrome) to have one

small (vignette) and one big video (full screen), without wasting bandwidth
with mid size video?

Hi Etienne,

I’m only saying that with 2 simulcast streams you won’t be able to reach

720p. If you want 720p for the participant that’s on stage, then you have
two options: either to disable simulcast completely (not a great idea in my
opinion), or to have the sender stream 360p, even if it’s redundant most of
the time.

I think it would make sense to file a bug against webrtc and ask them to

add an additional simulcast format that streams 720p/180p. It shouldn’t be
hard to implement either, so you could even submit a nice patch for them to
accept :slight_smile:

No way to signal the sender it's not used?
If i patch chrome/webrtc, i will still need jvb to work with 2 stream.
Thinking about it I need to test without the resolution param in meet.

Will see tommorow
Thanks
Etienne

···

Le 20 avr. 2016 6:49 PM, "George Politis" <gp@jitsi.org> a écrit :

- George

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#13

No way to signal the sender it's not used?

No, unfortunately there’s no way, at least no way that I’m aware of.

If i patch chrome/webrtc, i will still need jvb to work with 2 stream.
Thinking about it I need to test without the resolution param in meet.

That’s a good guess, I’m curious to know how it went.

-George


#14

> No way to signal the sender it's not used?

No, unfortunately there’s no way, at least no way that I’m aware of.

> If i patch chrome/webrtc, i will still need jvb to work with 2 stream.
> Thinking about it I need to test without the resolution param in meet.

That’s a good guess, I’m curious to know how it went.

that's it, with resolution: '480' and SIMULCAST_LAYERS=2 it work
will try to build chromium to play with kSimulcastFormats

···

2016-04-20 19:03 GMT+02:00 George Politis <gp@jitsi.org>:

-George
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#15

That’s great Etienne! Please keep us posted with how it goes :slight_smile:

···

On Apr 21, 2016, at 1:53 AM, Etienne Champetier <champetier.etienne@gmail.com> wrote:

2016-04-20 19:03 GMT+02:00 George Politis <gp@jitsi.org>:
> No way to signal the sender it's not used?

No, unfortunately there’s no way, at least no way that I’m aware of.

> If i patch chrome/webrtc, i will still need jvb to work with 2 stream.
> Thinking about it I need to test without the resolution param in meet.

That’s a good guess, I’m curious to know how it went.

that's it, with resolution: '480' and SIMULCAST_LAYERS=2 it work
will try to build chromium to play with kSimulcastFormats