[jitsi-dev] Share desktop disappeared


#1

Hi

After upgrade my env today, with unstable packages of jitsi-meet,
dissappeared the "share dekstop" option.

So, I tried to roll back the old version, and nothing. After, I purged all
packages, and restarted the deploy, as explained in quick install, without
success. In this time, The system can't more connect people. I can enter in
a room and see my self, but a second person, can't see me or vice versa.
Some tip or suggestion?

So, this fact bring a question: the last unstable deb package is "stable",
considering the fact to connect at least two people? Is it working? I
understand that I'm using a "unstable" package. In other hand, I saw that
the stable package is a lot old, and I saw too that the testing is less.
So, how many time is the build cycle of testing? As I use in a "production"
env (all knows that is a lab env), I can play with this edge versions.

At last, I saw in other emails that you have jenkins. Have some public
place where we can follow the builds? Is interesting to know when we run a
env upgrade.

Since now, thanks in advance.

Regards,
Claudio Ferreira


#2

Hi,

Hi

After upgrade my env today, with unstable packages of jitsi-meet,
dissappeared the "share dekstop" option.

Did you have any changes in interface_config? Other than that
everything in the settings should be fine.

So, I tried to roll back the old version, and nothing. After, I purged all
packages, and restarted the deploy, as explained in quick install, without
success. In this time, The system can't more connect people. I can enter in
a room and see my self, but a second person, can't see me or vice versa.
Some tip or suggestion?

Check the logs, of the client, jicofo, videobridge.

So, this fact bring a question: the last unstable deb package is "stable",
considering the fact to connect at least two people? Is it working? I
understand that I'm using a "unstable" package. In other hand, I saw that
the stable package is a lot old, and I saw too that the testing is less. So,
how many time is the build cycle of testing? As I use in a "production" env
(all knows that is a lab env), I can play with this edge versions.

At last, I saw in other emails that you have jenkins. Have some public place
where we can follow the builds? Is interesting to know when we run a env
upgrade.

So on every commit to jitsi-meet, lib-jitsi-meet, jicofo and jvb there
is a build. There is a mailinglist named cruisecontrol where all mails
from the builds go, you can subscribe to it. There is no public
interface for jenkins.
The builds create debian packages and automatically deploy it to the
unstable repo, from there we update a machine called beta which is
used to test those builds and have uptodate deployment. The tests are
in jitsi-meet-torture repo, if they are successful the mail sent to
cruisecontrol mailinglist says so.

If the initial tests are fine, there are internal performance tests
which are kicked and if they are successful that build goes
automatically to testing.

Builds in testing are kept till we move a build from there to stable,
which for now is a manual step.

Regards
damencho

···

On Wed, May 10, 2017 at 7:08 PM, Claudio Ferreia Filho <filhocf@gmail.com> wrote:

Since now, thanks in advance.

Regards,
Claudio Ferreira

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi

> Hi
>
> After upgrade my env today, with unstable packages of jitsi-meet,
> dissappeared the "share dekstop" option.

Did you have any changes in interface_config? Other than that
everything in the settings should be fine.

Nothing. I only reinstalled the deb packages and did the common confs, like
certificates and domain.

After some fight, I purged all packages and reinstalled all from scratch.
It returned to life.

So, I tried to roll back the old version, and nothing. After, I purged all
> packages, and restarted the deploy, as explained in quick install,
without
> success. In this time, The system can't more connect people. I can enter
in
> a room and see my self, but a second person, can't see me or vice versa.
> Some tip or suggestion?

Check the logs, of the client, jicofo, videobridge.

Curious... In client have 1 error and 1 warning:

1) Error
Failed to load resource: the server responded with a status of 404 (Not
Found): select2.png

This error is old. Since begin of year I see this error, but without impact.

2) Warning
DEPRECATED JS - Cookie has been deprecated since 5.8.0 and will be removed
in a future release. Use cookie instead.
     at assign (<anonymous>)
...

About the share screen, need to insert a UID extension to get this resource
in the screen. Is working fine now.

In other hand, I saw that now we can mute all (the eye in the sidebar), but
when I select the language to brazilian portuguese, appears a square.
Changing again to en-US, the icon returns. I believe that is a bug.

In other hand, how I set the defaultLanguage, in config.js for "pt-BR" ?

And, when possible, please, update the pt-BR translation. I finished it
now. :wink:

So, this fact bring a question: the last unstable deb package is "stable",
> considering the fact to connect at least two people? Is it working? I
> understand that I'm using a "unstable" package. In other hand, I saw that
> the stable package is a lot old, and I saw too that the testing is less.
So,
> how many time is the build cycle of testing? As I use in a "production"
env
> (all knows that is a lab env), I can play with this edge versions.
>
> At last, I saw in other emails that you have jenkins. Have some public
place
> where we can follow the builds? Is interesting to know when we run a env
> upgrade.

So on every commit to jitsi-meet, lib-jitsi-meet, jicofo and jvb there
is a build. There is a mailinglist named cruisecontrol where all mails
from the builds go, you can subscribe to it. There is no public
interface for jenkins.
The builds create debian packages and automatically deploy it to the
unstable repo, from there we update a machine called beta which is
used to test those builds and have uptodate deployment. The tests are
in jitsi-meet-torture repo, if they are successful the mail sent to
cruisecontrol mailinglist says so.

If the initial tests are fine, there are internal performance tests
which are kicked and if they are successful that build goes
automatically to testing.

Builds in testing are kept till we move a build from there to stable,
which for now is a manual step.

Thank you, Damencho, by your explanation.

If I understood correctly, is better to use a testing package (that you
didn't speak about) that the unstable, because it can break in a production
env. Or not?

Testing is a bit more old (is not the latest release), but very more close
to unstable that to stable.

And, more one time, thank you.

Regards,
Claudio Ferreira

···

2017-05-10 21:53 GMT-03:00 Damian Minkov <damencho@jitsi.org>:

On Wed, May 10, 2017 at 7:08 PM, Claudio Ferreia Filho > <filhocf@gmail.com> wrote:


#4

Hi, Claudio.

Hi

Hi, Claudio.

In other hand, I saw that now we can mute all (the eye in the sidebar),
but when I select the language to brazilian portuguese, appears a
square. Changing again to en-US, the icon returns. I believe that is a bug.

In other hand, how I set the defaultLanguage, in config.js for "pt-BR" ?

I am also having this issue with the eye icon but it only happens in
Chromium. It does not happen in Firefox. I'm using the testing repo.

My configuration in config.js is "defaultLanguage: "es"", so maybe this
issue is related to the language.

Kind regards,
Daniel

···

On 11/05/17 17:04, Claudio Ferreia Filho wrote:


#5

Hi, Damian/Jitsi team.

···

On 14/05/17 16:57, Daniel Bareiro wrote:

In other hand, I saw that now we can mute all (the eye in the sidebar),
but when I select the language to brazilian portuguese, appears a
square. Changing again to en-US, the icon returns. I believe that is a bug.

In other hand, how I set the defaultLanguage, in config.js for "pt-BR" ?

I am also having this issue with the eye icon but it only happens in
Chromium. It does not happen in Firefox. I'm using the testing repo.

My configuration in config.js is "defaultLanguage: "es"", so maybe this
issue is related to the language.

Should we open a issue on Github for jitsi-meet about this?

Thanks.

Kind regards,
Daniel


#6

Please do. Make sure you put your config in a gist so we can take a look.

Cheers,

···

On May 18, 2017, at 21:32, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi, Damian/Jitsi team.

On 14/05/17 16:57, Daniel Bareiro wrote:

In other hand, I saw that now we can mute all (the eye in the sidebar),
but when I select the language to brazilian portuguese, appears a
square. Changing again to en-US, the icon returns. I believe that is a bug.

In other hand, how I set the defaultLanguage, in config.js for "pt-BR" ?

I am also having this issue with the eye icon but it only happens in
Chromium. It does not happen in Firefox. I'm using the testing repo.

My configuration in config.js is "defaultLanguage: "es"", so maybe this
issue is related to the language.

Should we open a issue on Github for jitsi-meet about this?

--
Saúl


#7

Hi, Saúl.

In other hand, I saw that now we can mute all (the eye in the sidebar),
but when I select the language to brazilian portuguese, appears a
square. Changing again to en-US, the icon returns. I believe that is a bug.

In other hand, how I set the defaultLanguage, in config.js for "pt-BR" ?

I am also having this issue with the eye icon but it only happens in
Chromium. It does not happen in Firefox. I'm using the testing repo.

My configuration in config.js is "defaultLanguage: "es"", so maybe this
issue is related to the language.

Should we open a issue on Github for jitsi-meet about this?

Please do. Make sure you put your config in a gist so we can take a look.

I've done a new test with a tab that I had open long ago with Jitsi Meet
and I was able to replicate the issue and the icon looks like a square.
But if I open a new tab with Jitsi Meet, the icon looks correctly with
Chromium. It's strange. Maybe cache? In the new open tabs everything
seems fine.

If it reappears, I will open an issue.

Thanks

Kind regards,
Daniel

···

On 18/05/17 17:58, Saúl Ibarra Corretgé wrote:


#8

Hi, Saúl.

In other hand, I saw that now we can mute all (the eye in the sidebar),
but when I select the language to brazilian portuguese, appears a
square. Changing again to en-US, the icon returns. I believe that is a bug.

In other hand, how I set the defaultLanguage, in config.js for "pt-BR" ?

I am also having this issue with the eye icon but it only happens in
Chromium. It does not happen in Firefox. I'm using the testing repo.

My configuration in config.js is "defaultLanguage: "es"", so maybe this
issue is related to the language.

Should we open a issue on Github for jitsi-meet about this?

Please do. Make sure you put your config in a gist so we can take a look.

I've done a new test with a tab that I had open long ago with Jitsi Meet
and I was able to replicate the issue and the icon looks like a square.
But if I open a new tab with Jitsi Meet, the icon looks correctly with
Chromium. It's strange. Maybe cache? In the new open tabs everything
seems fine.

Could be! At any rate, I’m happy it’s working for you now!

···

On May 18, 2017, at 22:29, Daniel Bareiro <daniel-listas@gmx.net> wrote:
On 18/05/17 17:58, Saúl Ibarra Corretgé wrote:

If it reappears, I will open an issue.

Thanks

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl


#9

Hi, Saúl.

···

On 19/05/17 08:38, Saúl Ibarra Corretgé wrote:

I've done a new test with a tab that I had open long ago with Jitsi Meet
and I was able to replicate the issue and the icon looks like a square.
But if I open a new tab with Jitsi Meet, the icon looks correctly with
Chromium. It's strange. Maybe cache? In the new open tabs everything
seems fine.

Could be! At any rate, I’m happy it’s working for you now!

I take the opportunity to ask the following: what is the difference
between the button with the eye to have only audio and the button on the
top button bar to deactivate the camera?

Buddhika: I'm using jitsi-meet 1.0.2070-1

Kind regards,
Daniel


#10

Hi,

What is the version you installed. I also got the same issue. I installed
version jitsi meet 1.0.2070-1 and the problem is not there.

···

On Fri, May 19, 2017 at 5:08 PM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

> On May 18, 2017, at 22:29, Daniel Bareiro <daniel-listas@gmx.net> wrote:
>
> Hi, Saúl.
>
> On 18/05/17 17:58, Saúl Ibarra Corretgé wrote:
>
>>>>> In other hand, I saw that now we can mute all (the eye in the
sidebar),
>>>>> but when I select the language to brazilian portuguese, appears a
>>>>> square. Changing again to en-US, the icon returns. I believe that is
a bug.
>>>>>
>>>>> In other hand, how I set the defaultLanguage, in config.js for
"pt-BR" ?
>>>
>>>> I am also having this issue with the eye icon but it only happens in
>>>> Chromium. It does not happen in Firefox. I'm using the testing repo.
>>>>
>>>> My configuration in config.js is "defaultLanguage: "es"", so maybe
this
>>>> issue is related to the language.
>>>
>>> Should we open a issue on Github for jitsi-meet about this?
>
>> Please do. Make sure you put your config in a gist so we can take a
look.
>
> I've done a new test with a tab that I had open long ago with Jitsi Meet
> and I was able to replicate the issue and the icon looks like a square.
> But if I open a new tab with Jitsi Meet, the icon looks correctly with
> Chromium. It's strange. Maybe cache? In the new open tabs everything
> seems fine.
>

Could be! At any rate, I’m happy it’s working for you now!

> If it reappears, I will open an issue.
>
> Thanks
>
> Kind regards,
> Daniel
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
Undergraduate | Department of Computer Science & Engineering
University of Moratuwa
*buddhika.12@cse.mrt.ac.lk <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>


#11

Hi,

Stopping local camera, means stop sending video. Audio only mode means not
only stop sending video, but also stop receiving any video.

Regards
damencho

···

On May 20, 2017 15:56, "Daniel Bareiro" <daniel-listas@gmx.net> wrote:

Hi, Saúl.

On 19/05/17 08:38, Saúl Ibarra Corretgé wrote:

>> I've done a new test with a tab that I had open long ago with Jitsi Meet
>> and I was able to replicate the issue and the icon looks like a square.
>> But if I open a new tab with Jitsi Meet, the icon looks correctly with
>> Chromium. It's strange. Maybe cache? In the new open tabs everything
>> seems fine.

> Could be! At any rate, I’m happy it’s working for you now!

I take the opportunity to ask the following: what is the difference
between the button with the eye to have only audio and the button on the
top button bar to deactivate the camera?

Buddhika: I'm using jitsi-meet 1.0.2070-1

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

Hi,

Hi, Damian.

Stopping local camera, means stop sending video. Audio only mode means
not only stop sending video, but also stop receiving any video.

Ah, perfect. That clarifies my doubt.

Thanks for your reply.

Kind regards,
Daniel

···

On 20/05/17 18:45, Damian Minkov wrote: