[jitsi-dev] Server port is not used?


#1

When you change the server port in an account it does not try to connect on that port, it only uses it in the domain registration. It still uses port 5060 to connect to the server.

My wireshark capture:

No. Time Source Destination Protocol Length Info
  23649 2015-10-29 09:47:58.860165000 172.17.1.38 192.168.240.200 SIP 537 Request: REGISTER sip:192.168.240.200:5061 (1 binding) |

Frame 23649: 537 bytes on wire (4296 bits), 537 bytes captured (4296 bits) on interface 0
Ethernet II, Src: Dell_4a:9b:b5 (ec:f4:bb:4a:9b:b5), Dst: Cisco_5d:2b:38 (7c:0e:ce:5d:2b:38)
Internet Protocol Version 4, Src: 172.17.1.38 (172.17.1.38), Dst: 192.168.240.200 (192.168.240.200)
User Datagram Protocol, Src Port: 5060 (5060), Dst Port: 5060 (5060)
    Source Port: 5060 (5060)
    Destination Port: 5060 (5060)
    Length: 503
    Checksum: 0xee06 [validation disabled]
    [Stream index: 9]
Session Initiation Protocol (REGISTER)
    Request-Line: REGISTER sip:192.168.240.200:5061 SIP/2.0
    Message Header
        Call-ID: 776dd06102010c3f60cf84219598d6e5@0:0:0:0:0:0:0:0
        CSeq: 1 REGISTER
            SIP Display info: "1002"
            SIP from address: sip:1002@192.168.240.200
            SIP from tag: a83ef78a

···

From: "1002" <sip:1002@192.168.240.200>;tag=a83ef78a
        To: "1002" <sip:1002@192.168.240.200>
            SIP Display info: "1002"
            SIP to address: sip:1002@192.168.240.200
        Via: SIP/2.0/UDP 172.17.1.38:5060;branch=z9hG4bK-383937-1e4fb8ba64a41b517a5054a41595e41a
        Max-Forwards: 70
        User-Agent: Jitsi2.8.5426Windows 7
        Expires: 600
        Contact: "1002" <sip:1002@172.17.1.38:5060;transport=udp;registering_acc=192_168_240_200>;expires=600
            SIP Display info: "1002"
            Contact URI: sip:1002@172.17.1.38:5060;transport=udp;registering_acc=192_168_240_200
            Contact parameter: expires=600
        Content-Length: 0

Best regards,
Joris Schoot


#2

When you change the server port in an account it does not try to connect

on

that port, it only uses it in the domain registration. It still uses port
5060 to connect to the server.

You configured the registrar-port, but I think you want to configure the
proxy port. You can do that by either manually configured the proxy or
setting up the proper NAPTR/SRV records in your DNS.

[...]

Best regards,

Joris Schoot

Ingo