[jitsi-dev] Sending of SIP instant messages to offline users


#1

Hi,

is there a reason why Jitsi doesn't send instant messages to offline users
when SIP accounts are used?

We are using Kamailio which supports IM storage for offline clients,
but when user tries to send an IM to one of his contacts which is
offline, Jitsi returns: "The above message could not be delivered. The
protocol you are using doesn't support offline messages. You could try to
reach this contact through another protocol or wait until he/she becomes
online."


#2

Hey Ozren,

Hi,

is there a reason why Jitsi doesn't send instant messages to offline
users when SIP accounts are used?

Yes. Because most SIP servers don't support them.

We are using Kamailio which supports IM storage for offline clients,
but when user tries to send an IM to one of his contacts which is
offline, Jitsi returns: "The above message could not be delivered. The
protocol you are using doesn't support offline messages. You could try
to reach this contact through another protocol or wait until he/she
becomes online."

You could currently change this by adding the following account property
to your jitsi.properties (or sip-communicator.properties):

OFFLINE_MSG_SUPPORTED

In other words, you have to find the section that contains your Kamailio
account. It would probably look a bit like this:

net.java.sip.communicator.impl.protocol.sip.acc1326037982775=acc1326037982775
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.ACCOUNT_UID=SIP\:ozren@kamailio.org
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.DEFAULT_ENCRYPTION=true
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.DEFAULT_SIPZRTP_ATTRIBUTE=true
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.DTMF_METHOD=AUTO_DTMF
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.ENCRYPTED_PASSWORD=asdfasdfasdfasdfasdfas
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.KEEP_ALIVE_INTERVAL=25
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.KEEP_ALIVE_METHOD=OPTIONS
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.PROXY_AUTO_CONFIG=true
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.SDES_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.SERVER_ADDRESS=kamailio.org
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.SUBSCRIPTION_EXPIRATION=3600
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.USER_ID=ozren@kamailio.org

There will probably be other properties here as well. To these you need
to add:

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.OFFLINE_MSG_SUPPORTED=true

Hope this helps,
Emil

P.S. Anyone wants to add that to our protocol wizards so that it could
be handleable through the GUI?

···

On 13.04.12 15:27, Ozren Lapcevic wrote:

--
http://jitsi.org


#3

Hi Emil,

thanks for the reply and detailed explanation. This worked for me.

Cheers
Ozren

···

On Sat, Apr 14, 2012 at 12:03 AM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Ozren,

On 13.04.12 15:27, Ozren Lapcevic wrote:
> Hi,
>
> is there a reason why Jitsi doesn't send instant messages to offline
> users when SIP accounts are used?

Yes. Because most SIP servers don't support them.

> We are using Kamailio which supports IM storage for offline clients,
> but when user tries to send an IM to one of his contacts which is
> offline, Jitsi returns: "The above message could not be delivered. The
> protocol you are using doesn't support offline messages. You could try
> to reach this contact through another protocol or wait until he/she
> becomes online."

You could currently change this by adding the following account property
to your jitsi.properties (or sip-communicator.properties):

OFFLINE_MSG_SUPPORTED

In other words, you have to find the section that contains your Kamailio
account. It would probably look a bit like this:

net.java.sip.communicator.impl.protocol.sip.acc1326037982775=acc1326037982775

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.ACCOUNT_UID=SIP\:
ozren@kamailio.org

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.DEFAULT_ENCRYPTION=true

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.DEFAULT_SIPZRTP_ATTRIBUTE=true

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.DTMF_METHOD=AUTO_DTMF

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.ENCRYPTED_PASSWORD=asdfasdfasdfasdfasdfas

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.KEEP_ALIVE_METHOD=OPTIONS

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.PROXY_AUTO_CONFIG=true

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.SDES_ENABLED=false

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.SERVER_ADDRESS=
kamailio.org

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.SUBSCRIPTION_EXPIRATION=3600
net.java.sip.communicator.impl.protocol.sip.acc1326037982575.USER_ID=
ozren@kamailio.org

There will probably be other properties here as well. To these you need
to add:

net.java.sip.communicator.impl.protocol.sip.acc1326037982575.OFFLINE_MSG_SUPPORTED=true

Hope this helps,
Emil

P.S. Anyone wants to add that to our protocol wizards so that it could
be handleable through the GUI?

--
http://jitsi.org