[jitsi-dev] Second component attempted to connect, denying connection


#1

Hello,

Having problems with a new installation of Jitsi Meet on an Ubuntu 14.04 server. I seem to have managed to get to the install jitsi videobridge stage ok, no major problems on the way.

Howver, when I run jvb.sh, I see the following error:

SEVERE: [1] util.UtilActivator.uncaughtException().108 An uncaught exception occurred in thread=Thread[main,5,main] and message was: conflict
org.xmpp.component.ComponentException: conflict

In prosody.log I get the following:

Jul 06 20:29:15 jcp1686a90 info Incoming Jabber component connection
Jul 06 20:29:15 jitsi-videobridge.jitsi.ukcolumn.org:component error Second component attempted to connect, denying connection
Jul 06 20:29:15 mod_component info Disconnecting component, <stream:error> is: <stream:error><conflict xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Component already connected</text></stream:error>

and in prosody.err, this:

Jul 06 20:29:15 jitsi-videobridge.jitsi.ukcolumn.org:component error Second component attempted to connect, denying connection

If I restart prosody, the following line appears in prosody.log after a few seconds after the "successfully daemonized" entry:

Jul 06 20:31:21 jcp23a9930 info Incoming Jabber component connection
Jul 06 20:31:21 jitsi-videobridge.jitsi.ukcolumn.org:component info External component successfully authenticated

I don't know where this videobridge connection is coming from. No instance of kvb.sh is running, and I have restarted the machine to make sure there are no strange processes hanging around.

Any help much appreciated.

Cheers,

Mike.