[jitsi-dev] screen sharing scaling issues in jitsi-meet


#1

Hello,

If a share my screen in jitsi-meet it will be displayed in fullscreen
mode (like normal webcam stream) for few seconds, but after that it
will be scaled, see screenshot: http://i.imgur.com/5d3EDZx.png
I've tried to hide previews of participant, but it doesn't change a
thing, it stays in scaled mode. Can I somehow force jitsi-meet to show
screen sharing always in fullscreen?

Thanks,
Stan


#2

Hi,

···

On Tue, May 26, 2015 at 6:11 PM, Stanislav Kopp <staskopp@gmail.com> wrote:

Hello,

If a share my screen in jitsi-meet it will be displayed in fullscreen
mode (like normal webcam stream) for few seconds, but after that it
will be scaled, see screenshot: http://i.imgur.com/5d3EDZx.png
I've tried to hide previews of participant, but it doesn't change a
thing, it stays in scaled mode. Can I somehow force jitsi-meet to show
screen sharing always in fullscreen?

Thanks for the report ! We are aware of this issue. You can track the
progress on resolving it here:

https://github.com/jitsi/jitsi-meet/issues/294

Regards,
Pawel


#3

Sorry actually I misunderstood you question.

No currently it's not possible to toggle between full screen and
scaled mode. We scale it to show the whole screen while keeping it's
width/height ratio.

Regards,
Pawel

···

On Tue, May 26, 2015 at 6:17 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

Hi,

On Tue, May 26, 2015 at 6:11 PM, Stanislav Kopp <staskopp@gmail.com> wrote:

Hello,

If a share my screen in jitsi-meet it will be displayed in fullscreen
mode (like normal webcam stream) for few seconds, but after that it
will be scaled, see screenshot: http://i.imgur.com/5d3EDZx.png
I've tried to hide previews of participant, but it doesn't change a
thing, it stays in scaled mode. Can I somehow force jitsi-meet to show
screen sharing always in fullscreen?


#4

Hi Paweł,

thanks for quick response, will it be possible in a future? Sometimes
it's important not to scale e.g. when I share my browser session or a
code, with scaling you can barely see it.
If I remember right, the firefox in my screenshot was not cropped in
fullscreen mode (where client had HD resolution and the "sharer"
FullHD), so in general it works I guess.

Thanks,
Stan

···

2015-05-26 18:18 GMT+02:00 Paweł Domas <pawel.domas@jitsi.org>:

On Tue, May 26, 2015 at 6:17 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

Hi,

On Tue, May 26, 2015 at 6:11 PM, Stanislav Kopp <staskopp@gmail.com> wrote:

Hello,

If a share my screen in jitsi-meet it will be displayed in fullscreen
mode (like normal webcam stream) for few seconds, but after that it
will be scaled, see screenshot: http://i.imgur.com/5d3EDZx.png
I've tried to hide previews of participant, but it doesn't change a
thing, it stays in scaled mode. Can I somehow force jitsi-meet to show
screen sharing always in fullscreen?

Sorry actually I misunderstood you question.

No currently it's not possible to toggle between full screen and
scaled mode. We scale it to show the whole screen while keeping it's
width/height ratio.

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev