[jitsi-dev] Running Jitsi with OSSv4 (Opensound)


#1

Just pasting a mail from a user who wanted to stay anonymous. After a
discussion on IRC he managed to run Jitsi without problems on arch
linux with OSSv4, previously he had no or bad audio.

···

____________

User report on how to get Jitsi to work with OSSv4 (on Archlinux in this case)

Info:
Linux/i686 3.1.6-1-ARCH
Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)

----------

ossinfo says:
OSS 4.2 (b 2005/201111292012) (0x00040100) GPL

oss_hdaudio0 ATI HD Audio interrupts=1447704 (1559379)
HD Audio controller ATI HD Audio
Vendor ID 0x10024383
  Subvendor ID 0x14627596
   Codec 3: ALC889 (0x10ec0889/0x14627596)

Mixer devices
0: High Definition Audio ALC889 (Mixer 0 of device object 1)

----------

Just installing and using Jitsi (with a Jabber/XMPP account) I got
echoing, stuttering and jittery audio both outgoing and incoming. I
tried many things, changing the rate from 48khz to 44.1khz etc,
nothing helped. Then damencho suggested looking in the audio options
and picking a different device. I realised that on top of the list,
hidden by default ("default" was selected and anything above was not
visible without scrolling) was "oss". I picked that and while I don't
remember what exactly happened this was the start to solving it. I had
to pick the correct device for the input.

So, set "Audio In" to your microphone input, eg "/dev/dsp7" (or 6 or 8 I guess)
and "Audio Out" to "oss"

With that I get crystal clear VOIP with Jitsi and OSSv4 (Opensound)

----------

To see what /dev/dsp# your microphone input is, check "ls -l
/dev/dsp*". In my case I have
/dev/dsp6 -> /dev/oss/oss_hdaudio0/pcmin0
/dev/dsp7 -> /dev/oss/oss_hdaudio0/pcmin1
/dev/dsp8 -> /dev/oss/oss_hdaudio0/pcmin2

Looking at it now I am not sure why I picked /dev/dsp7 but since 8
worked too I bet 6 would be fine as well. This might depend on your
OSS setup.