[jitsi-dev] Registration issues with Jitsi


#1

Hello All,

Jitsi 2.3.4950

I recently signed up with a SIP account from sip.us and I've been trying to
register my account with Jitsi but it continue to fail. After reviewing the
logs, it looks like some DNS problem but I don't know if that's the issue
or not.

SIP ID is the trunk # from sip.us
Password is the trunk password
Registrar is gw1.sip.us (also gw.sip.us)
authorization name is trunk #

I keep the proxy options enabled, disable security, presence, and make only
ulaw the available codec but it continues to fail.

17:00:12.254 INFO: [64] impl.dns.ParallelResolverImpl.send().219 Primary
DNS seems laggy: no response for gw.sip.us./NAPTR after 2500ms. Enabling
redundant mode.
17:00:12.257 INFO: [74] impl.dns.ParallelResolverImpl.run().556 Sending
query for gw.sip.us./NAPTR to backup resolvers
17:00:12.310 INFO: [75] impl.dns.ParallelResolverImpl.run().556 Sending
query for _sips._TCP.gw.sip.us./SRV to backup resolvers
17:00:12.324 INFO: [76] impl.dns.ParallelResolverImpl.run().556 Sending
query for _sips._TCP.gw.sip.us.Belkin./SRV to backup resolvers
17:00:12.339 INFO: [77] impl.dns.ParallelResolverImpl.run().556 Sending
query for _sip._TCP.gw.sip.us./SRV to backup resolvers
17:00:12.354 INFO: [64] impl.dns.ParallelResolverImpl.send().250 Primary
DNS seems back in biz. Disabling redundant mode.
17:00:14.904 INFO: [64] impl.dns.ParallelResolverImpl.send().219 Primary
DNS seems laggy: no response for gw1.sip.us./AAAA after 2500ms. Enabling
redundant mode.
17:00:14.904 INFO: [77] impl.dns.ParallelResolverImpl.run().556 Sending
query for gw1.sip.us./AAAA to backup resolvers
17:00:47.026 INFO: [72] impl.dns.ParallelResolverImpl.run().556 Sending
query for gw2.sip.us./A to backup resolvers
17:00:47.043 INFO: [77] impl.dns.ParallelResolverImpl.run().556 Sending
query for gw2.sip.us./AAAA to backup resolvers
17:01:19.239 INFO: [63] impl.protocol.sip.SipLogger.logInfo().185 Info from
the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
17:01:20.241 INFO: [63] impl.protocol.sip.SipLogger.logInfo().185 Info from
the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped

Does anyone have any suggestions on what could be the cause of the failed
registration?

*One possible bug is below*:

replication steps:
0. open jitsi
1. tools > options
2. advanced
3. DNS
4. replace fallback IP 8.8.8.8 with 1.2.3.4
5. Click on Logging
6. Click on DNS
7. Does it still show 1.2.3.4?

Mine does not. Is this expected behavior?

Updating the "start backup resolver" has a default value of 1500 and
modifying that to 2500 and navigating away from DNS and back to, you can
see the value remains at 2500. I would suspect the fallback IP would remain
to what you set it, not a default of Jitsi.

···

--
-------
inum: 883510009902611
sip: jungleboogie@sip2sip.info
xmpp: jungle-boogie@jit.si


#2

Hi All,

This continues to fail for me. Windows 7 network resource monitor shows a
bunch of loopback connections and it doesn't resolve the IP as I see when
connecting to jit.si

Has anyone experienced this issue before with an account that refuses to go
online?

Thanks,
jungle

···

On 3 December 2013 17:17, jungleboogie0 <jungleboogie0@gmail.com> wrote:

Hello All,

Jitsi 2.3.4950

I recently signed up with a SIP account from sip.us and I've been trying
to register my account with Jitsi but it continue to fail. After reviewing
the logs, it looks like some DNS problem but I don't know if that's the
issue or not.

SIP ID is the trunk # from sip.us
Password is the trunk password
Registrar is gw1.sip.us (also gw.sip.us)
authorization name is trunk #

I keep the proxy options enabled, disable security, presence, and make
only ulaw the available codec but it continues to fail.

17:00:12.254 INFO: [64] impl.dns.ParallelResolverImpl.send().219 Primary
DNS seems laggy: no response for gw.sip.us./NAPTR after 2500ms. Enabling
redundant mode.
17:00:12.257 INFO: [74] impl.dns.ParallelResolverImpl.run().556 Sending
query for gw.sip.us./NAPTR to backup resolvers
17:00:12.310 INFO: [75] impl.dns.ParallelResolverImpl.run().556 Sending
query for _sips._TCP.gw.sip.us./SRV to backup resolvers
17:00:12.324 INFO: [76] impl.dns.ParallelResolverImpl.run().556 Sending
query for _sips._TCP.gw.sip.us.Belkin./SRV to backup resolvers
17:00:12.339 INFO: [77] impl.dns.ParallelResolverImpl.run().556 Sending
query for _sip._TCP.gw.sip.us./SRV to backup resolvers
17:00:12.354 INFO: [64] impl.dns.ParallelResolverImpl.send().250 Primary
DNS seems back in biz. Disabling redundant mode.
17:00:14.904 INFO: [64] impl.dns.ParallelResolverImpl.send().219 Primary
DNS seems laggy: no response for gw1.sip.us./AAAA after 2500ms. Enabling
redundant mode.
17:00:14.904 INFO: [77] impl.dns.ParallelResolverImpl.run().556 Sending
query for gw1.sip.us./AAAA to backup resolvers
17:00:47.026 INFO: [72] impl.dns.ParallelResolverImpl.run().556 Sending
query for gw2.sip.us./A to backup resolvers
17:00:47.043 INFO: [77] impl.dns.ParallelResolverImpl.run().556 Sending
query for gw2.sip.us./AAAA to backup resolvers
17:01:19.239 INFO: [63] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
17:01:20.241 INFO: [63] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped

Does anyone have any suggestions on what could be the cause of the failed
registration?

*One possible bug is below*:

replication steps:
0. open jitsi
1. tools > options
2. advanced
3. DNS
4. replace fallback IP 8.8.8.8 with 1.2.3.4
5. Click on Logging
6. Click on DNS
7. Does it still show 1.2.3.4?

Mine does not. Is this expected behavior?

Updating the "start backup resolver" has a default value of 1500 and
modifying that to 2500 and navigating away from DNS and back to, you can
see the value remains at 2500. I would suspect the fallback IP would remain
to what you set it, not a default of Jitsi.

--
-------
inum: 883510009902611
sip: jungleboogie@sip2sip.info
xmpp: jungle-boogie@jit.si

--
-------
inum: 883510009902611
sip: jungleboogie@sip2sip.info
xmpp: jungle-boogie@jit.si


#3

This continues to fail for me. Windows 7 network resource monitor shows a
bunch of loopback connections and it doesn't resolve the IP as I see when
connecting to jit.si <http://jit.si>

I could successfully register with them (although calling failed, but probably because I can't dial an international number with the demo account). But please note, this seems to be a provider for business use and the specifically offer SIP trunks, which you usually use with SIP servers such as Asterisk.

You need to manually configure the account with the following settings:
- Account
  - SIP id: <your-phone-number>@gw1.sip.us
  - Password: Trunk-Password
- Connection
  - Authorization name: <Trunk-Id>
  - Proxy options: auto-detect

Emil:
When I tried to register there, I tried with <number>@sip.us as well. The server then sends a 403 forbidden WITHOUT a password challenge. Jitsi thinks there was a wrong password or something the like and enters an endless loop (without asking for a password, so essentially bombarding the server with useless REGISTERs). How should we handle such 403s?

Has anyone experienced this issue before with an account that refuses to
go online?

It seems to work for me, are you sure your Belkin router doesn't mess up the SIP messages?

Thanks,
jungle

Ingo


#4

Hi Ingo,

Thanks for looking into this!!

this seems to be a provider for business use and the specifically offer

SIP trunks, which you usually use with SIP servers such as Asterisk.

Understood that you would usually use something like asterisk, but I'm able
to register without any problems on Bria 3.0 for Android.

With you using the DID@gw1.sip.us I was able to register but there were
other complications below...

It seems to work for me, are you sure your Belkin router doesn't mess up

the SIP messages?

Well after disconnecting from that router and going to the wifi router
(netgear), I actually registered and signed on! The only issue is that the
status did not show online in sip.us interface, but I was able to make an
outbound call with two-way audio. I was not able to make an inbound call
because, I'm assuming, the services shows me as offline.

At this point, it seems like the Belkin is to blame, even though I have my
polycom phone with 11 different SIP account registered and jitsi with about
6 accounts.

Thanks,
jungle

···

On 9 January 2014 14:00, Ingo Bauersachs <ingo@jitsi.org> wrote:

> This continues to fail for me. Windows 7 network resource monitor shows a
> bunch of loopback connections and it doesn't resolve the IP as I see when
> connecting to jit.si <http://jit.si>

I could successfully register with them (although calling failed, but
probably because I can't dial an international number with the demo
account). But please note, this seems to be a provider for business use and
the specifically offer SIP trunks, which you usually use with SIP servers
such as Asterisk.

You need to manually configure the account with the following settings:
- Account
  - SIP id: <your-phone-number>@gw1.sip.us
  - Password: Trunk-Password
- Connection
  - Authorization name: <Trunk-Id>
  - Proxy options: auto-detect

Emil:
When I tried to register there, I tried with <number>@sip.us as well. The
server then sends a 403 forbidden WITHOUT a password challenge. Jitsi
thinks there was a wrong password or something the like and enters an
endless loop (without asking for a password, so essentially bombarding the
server with useless REGISTERs). How should we handle such 403s?

> Has anyone experienced this issue before with an account that refuses to
> go online?

It seems to work for me, are you sure your Belkin router doesn't mess up
the SIP messages?

> Thanks,
> jungle

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
-------
inum: 883510009902611
sip: jungleboogie@sip2sip.info
xmpp: jungle-boogie@jit.si