[jitsi-dev] red hat


#1

Good Morning Jitsi Developers,

I really love jitsi and use it everyday now that I got it to work on Red
hat. I just wanted to let you know that there are couple of issues to get
jitsi to run on red hat. First you need to use libjnportaudio with librt
linked in. Damian provided it to me. Also I found out yesterday that Enable
support to encrypt calls doesnt work on red hat. So All I did is set
DEFAULT_ENCRYPTION to false in the properties file and jitsi works now. Now
both side can hear.

I was wondering if jitsi can have DEFAULT_ENCRYPTION set to false as a
default. Also I was wondering if a feature can be added to make calls from
command line. Thank you very much for all your help and I really like the
project. Great job.

-Leo


#2

Hello Leo,

First you need to use libjnportaudio with librt
linked in. Damian provided it to me.

Please open an issue in our issue tracker for it (and mention in the
description that you've been authorized on the dev mailing list to do
so) so that we can get it done as soon as we have the time.

Also I found out yesterday that Enable
support to encrypt calls doesnt work on red hat. So All I did is set
DEFAULT_ENCRYPTION to false in the properties file and jitsi works now. Now
both side can hear.
I was wondering if jitsi can have DEFAULT_ENCRYPTION set to false as a
default.

Secure calls is one of the major features of Jitsi so I'd rather think
that we'd like to fix any issue related to it than disable it. You may
open a new issue for it as well but please notice that we have a lot
on our todo lists so we may not be able to handle it in the very near
future.

Also I was wondering if a feature can be added to make calls from
command line.

Well, Jitsi was supposed to already handle protocol URIs/addresses on
the command line by establishing calls to them. Have you already tried
a command line like "jitsi sip:echo@iptel.org"? Could you please
elaborate on your experience and expectations with respect to making
calls from the command line?

Regards,
Lyubomir

···

On Thu, Sep 22, 2011 at 7:41 PM, Leonid Nayer <lnayer@gmail.com> wrote:


#3

Good Afternoon Jitsi Developers,

Thank you for the email. I was trying to open the tickets today but couldnt
find the link to create a new ticket on jira. Can you please point me to the
right site? Thanks.

Also I had couple of more questions.

I was testing jitsi today and found out that something goes wrong with the
config files because it will not let me reopen jitsi after I closed it the
first time using quit. I checked that all the jitsi processes are killed. To
reopen jitsi I had to delete the .jitsi directory and than it would let me
open jitsi again. I also attached the warnings I get when I run jitsi.

The second question is that when I use command line argument jitsi sip:, it
calls the person but when we disconnect it doesn't quit jitsi correctly. I
attached the output from the terminal. I always have to kill the process
when I do this.

My last question is, if there is an easy way to change the accept call
interfece or any documentation that would help me do that . Thanks you very
much for the help. I look forward to your reply. Thanks.

Thanks,

Leo

jitsi-error1-jitsi doesnt start again (4.14 KB)

jitsi-error-jisti doesnt kill after command line run (6.83 KB)

···

On Thu, Sep 22, 2011 at 2:54 PM, Lyubomir Marinov <lubo@jitsi.org> wrote:

Hello Leo,

On Thu, Sep 22, 2011 at 7:41 PM, Leonid Nayer <lnayer@gmail.com> wrote:
> First you need to use libjnportaudio with librt
> linked in. Damian provided it to me.

Please open an issue in our issue tracker for it (and mention in the
description that you've been authorized on the dev mailing list to do
so) so that we can get it done as soon as we have the time.

> Also I found out yesterday that Enable
> support to encrypt calls doesnt work on red hat. So All I did is set
> DEFAULT_ENCRYPTION to false in the properties file and jitsi works now.
Now
> both side can hear.
> I was wondering if jitsi can have DEFAULT_ENCRYPTION set to false as a
> default.

Secure calls is one of the major features of Jitsi so I'd rather think
that we'd like to fix any issue related to it than disable it. You may
open a new issue for it as well but please notice that we have a lot
on our todo lists so we may not be able to handle it in the very near
future.

> Also I was wondering if a feature can be added to make calls from
> command line.

Well, Jitsi was supposed to already handle protocol URIs/addresses on
the command line by establishing calls to them. Have you already tried
a command line like "jitsi sip:echo@iptel.org"? Could you please
elaborate on your experience and expectations with respect to making
calls from the command line?

Regards,
Lyubomir


#4

Thank you for the email. I was trying to open the tickets today but couldnt
find the link to create a new ticket on jira. Can you please point me to the
right site? Thanks.

http://jitsi.org/index.php/Development/BugsAndIssues

I was testing jitsi today and found out that something goes wrong with the
config files because it will not let me reopen jitsi after I closed it the
first time using quit. I checked that all the jitsi processes are killed. To
reopen jitsi I had to delete the .jitsi directory and than it would let me
open jitsi again. I also attached the warnings I get when I run jitsi.

If this is a reproducible issue, please describe the steps to
reproduce it and attach the logs as specified at
http://jitsi.org/index.php/Documentation/FAQ#logs.

The second question is that when I use command line argument jitsi sip:, it
calls the person but when we disconnect it doesn't quit jitsi correctly. I
attached the output from the terminal. I always have to kill the process
when I do this.

The intended behavior of Jitsi is to stay running after being started
including in the case of being started on the command line.

My last question is, if there is an easy way to change the accept call
interfece or any documentation that would help me do that . Thanks you very
much for the help. I look forward to your reply. Thanks.

Jitsi's API documentation is in the form of javadoc comments inside
the source code files.

···

On Fri, Sep 23, 2011 at 8:03 PM, Leonid Nayer <lnayer@gmail.com> wrote:


#5

Hey Leonid,

Could you please tell us what made you think that the problems you were
experiencing were related to ZRTP?

Cheers,
Emil

На 23.09.11 19:03, Leonid Nayer написа:

···

Good Afternoon Jitsi Developers,

Thank you for the email. I was trying to open the tickets today but
couldnt find the link to create a new ticket on jira. Can you please
point me to the right site? Thanks.

Also I had couple of more questions.

I was testing jitsi today and found out that something goes wrong with
the config files because it will not let me reopen jitsi after I closed
it the first time using quit. I checked that all the jitsi processes are
killed. To reopen jitsi I had to delete the .jitsi directory and than it
would let me open jitsi again. I also attached the warnings I get when I
run jitsi.

The second question is that when I use command line argument jitsi sip:,
it calls the person but when we disconnect it doesn't quit jitsi
correctly. I attached the output from the terminal. I always have to
kill the process when I do this.

My last question is, if there is an easy way to change the accept call
interfece or any documentation that would help me do that . Thanks you
very much for the help. I look forward to your reply. Thanks.

Thanks,

Leo

On Thu, Sep 22, 2011 at 2:54 PM, Lyubomir Marinov <lubo@jitsi.org > <mailto:lubo@jitsi.org>> wrote:

    Hello Leo,

    On Thu, Sep 22, 2011 at 7:41 PM, Leonid Nayer <lnayer@gmail.com > <mailto:lnayer@gmail.com>> wrote:
    > First you need to use libjnportaudio with librt
    > linked in. Damian provided it to me.

    Please open an issue in our issue tracker for it (and mention in the
    description that you've been authorized on the dev mailing list to do
    so) so that we can get it done as soon as we have the time.

    > Also I found out yesterday that Enable
    > support to encrypt calls doesnt work on red hat. So All I did is set
    > DEFAULT_ENCRYPTION to false in the properties file and jitsi works
    now. Now
    > both side can hear.
    > I was wondering if jitsi can have DEFAULT_ENCRYPTION set to false as a
    > default.

    Secure calls is one of the major features of Jitsi so I'd rather think
    that we'd like to fix any issue related to it than disable it. You may
    open a new issue for it as well but please notice that we have a lot
    on our todo lists so we may not be able to handle it in the very near
    future.

    > Also I was wondering if a feature can be added to make calls from
    > command line.

    Well, Jitsi was supposed to already handle protocol URIs/addresses on
    the command line by establishing calls to them. Have you already tried
    a command line like "jitsi sip:echo@iptel.org
    <mailto:sip%3Aecho@iptel.org>"? Could you please
    elaborate on your experience and expectations with respect to making
    calls from the command line?

    Regards,
    Lyubomir

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#6

Thank you very much for the emails. I opened up the tickets.

···

On Sat, Sep 24, 2011 at 3:38 PM, Lyubomir Marinov <lubo@jitsi.org> wrote:

On Fri, Sep 23, 2011 at 8:03 PM, Leonid Nayer <lnayer@gmail.com> wrote:
> Thank you for the email. I was trying to open the tickets today but
couldnt
> find the link to create a new ticket on jira. Can you please point me to
the
> right site? Thanks.

http://jitsi.org/index.php/Development/BugsAndIssues

> I was testing jitsi today and found out that something goes wrong with
the
> config files because it will not let me reopen jitsi after I closed it
the
> first time using quit. I checked that all the jitsi processes are killed.
To
> reopen jitsi I had to delete the .jitsi directory and than it would let
me
> open jitsi again. I also attached the warnings I get when I run jitsi.

If this is a reproducible issue, please describe the steps to
reproduce it and attach the logs as specified at
http://jitsi.org/index.php/Documentation/FAQ#logs.

> The second question is that when I use command line argument jitsi sip:,
it
> calls the person but when we disconnect it doesn't quit jitsi correctly.
I
> attached the output from the terminal. I always have to kill the process
> when I do this.

The intended behavior of Jitsi is to stay running after being started
including in the case of being started on the command line.

> My last question is, if there is an easy way to change the accept call
> interfece or any documentation that would help me do that . Thanks you
very
> much for the help. I look forward to your reply. Thanks.

Jitsi's API documentation is in the form of javadoc comments inside
the source code files.


#7

Good Afternoon,

Is there a command line for conferencing? Thanks.

Leo

Worked*

Hey Emil,

Sorry for the late reply. Only one side could hear when it was on. When I
disabled it. Both sides world. Thanks.

Leo

Hey Leonid,

Could you please tell us what made you think that the problems you were
experiencing were related to ZRTP?

Cheers,
Emil

На 23.09.11 19:03, Leonid Nayer написа:

Good Afternoon Jitsi Developers,

Thank you for the email. I was trying to open the tickets today but
couldnt find the link to create a new ticket on jira. Can you please
point me to the right site? Thanks.

Also I had couple of more questions.

I was testing jitsi today and found out that something goes wrong with
the config files because it will not let me reopen jitsi after I closed
it the first time using quit. I checked that all the jitsi processes

are

killed. To reopen jitsi I had to delete the .jitsi directory and than

it

would let me open jitsi again. I also attached the warnings I get when

I

run jitsi.

The second question is that when I use command line argument jitsi

sip:,

it calls the person but when we disconnect it doesn't quit jitsi
correctly. I attached the output from the terminal. I always have to
kill the process when I do this.

My last question is, if there is an easy way to change the accept call
interfece or any documentation that would help me do that . Thanks you
very much for the help. I look forward to your reply. Thanks.

Thanks,

Leo

Hello Leo,

> First you need to use libjnportaudio with librt
> linked in. Damian provided it to me.

Please open an issue in our issue tracker for it (and mention in the
description that you've been authorized on the dev mailing list to do
so) so that we can get it done as soon as we have the time.

> Also I found out yesterday that Enable
> support to encrypt calls doesnt work on red hat. So All I did is set
> DEFAULT_ENCRYPTION to false in the properties file and jitsi works
now. Now
> both side can hear.
> I was wondering if jitsi can have DEFAULT_ENCRYPTION set to false as

a

···

On Oct 5, 2011 12:13 PM, "Leonid Nayer" <lnayer@gmail.com> wrote:

On Oct 5, 2011 12:12 PM, "Leonid Nayer" <lnayer@gmail.com> wrote:

On Sep 28, 2011 9:59 AM, "Emil Ivov" <emcho@jitsi.org> wrote:

On Thu, Sep 22, 2011 at 2:54 PM, Lyubomir Marinov <lubo@jitsi.org >>>> <mailto:lubo@jitsi.org>> wrote:
On Thu, Sep 22, 2011 at 7:41 PM, Leonid Nayer <lnayer@gmail.com >>>> <mailto:lnayer@gmail.com>> wrote:
> default.

Secure calls is one of the major features of Jitsi so I'd rather think
that we'd like to fix any issue related to it than disable it. You may
open a new issue for it as well but please notice that we have a lot
on our todo lists so we may not be able to handle it in the very near
future.

> Also I was wondering if a feature can be added to make calls from
> command line.

Well, Jitsi was supposed to already handle protocol URIs/addresses on
the command line by establishing calls to them. Have you already tried
a command line like "jitsi sip:echo@iptel.org
<mailto:sip%3Aecho@iptel.org>"? Could you please
elaborate on your experience and expectations with respect to making
calls from the command line?

Regards,
Lyubomir

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#8

Hi Leonid,

···

Le 05/10/11 20:15, Leonid Nayer a écrit :

Good Afternoon,

Is there a command line for conferencing? Thanks.

Unfortunately no.

Regards,
--
Seb

Leo

On Oct 5, 2011 12:13 PM, "Leonid Nayer" <lnayer@gmail.com > <mailto:lnayer@gmail.com>> wrote:
> Worked*
>
> On Oct 5, 2011 12:12 PM, "Leonid Nayer" <lnayer@gmail.com > <mailto:lnayer@gmail.com>> wrote:
>> Hey Emil,
>>
>> Sorry for the late reply. Only one side could hear when it was on. When I
>> disabled it. Both sides world. Thanks.
>>
>> Leo
>>
>> On Sep 28, 2011 9:59 AM, "Emil Ivov" <emcho@jitsi.org > <mailto:emcho@jitsi.org>> wrote:
>>> Hey Leonid,
>>>
>>> Could you please tell us what made you think that the problems you were
>>> experiencing were related to ZRTP?
>>>
>>> Cheers,
>>> Emil
>>>
>>> На 23.09.11 19:03, Leonid Nayer написа:
>>>> Good Afternoon Jitsi Developers,
>>>>
>>>> Thank you for the email. I was trying to open the tickets today but
>>>> couldnt find the link to create a new ticket on jira. Can you please
>>>> point me to the right site? Thanks.
>>>>
>>>> Also I had couple of more questions.
>>>>
>>>> I was testing jitsi today and found out that something goes wrong with
>>>> the config files because it will not let me reopen jitsi after I closed
>>>> it the first time using quit. I checked that all the jitsi processes are
>>>> killed. To reopen jitsi I had to delete the .jitsi directory and than it
>>>> would let me open jitsi again. I also attached the warnings I get when I
>>>> run jitsi.
>>>>
>>>> The second question is that when I use command line argument jitsi sip:,
>>>> it calls the person but when we disconnect it doesn't quit jitsi
>>>> correctly. I attached the output from the terminal. I always have to
>>>> kill the process when I do this.
>>>>
>>>> My last question is, if there is an easy way to change the accept call
>>>> interfece or any documentation that would help me do that . Thanks you
>>>> very much for the help. I look forward to your reply. Thanks.
>>>>
>>>> Thanks,
>>>>
>>>> Leo
>>>>
>>>> On Thu, Sep 22, 2011 at 2:54 PM, Lyubomir Marinov <lubo@jitsi.org > <mailto:lubo@jitsi.org> > >>>> <mailto:lubo@jitsi.org <mailto:lubo@jitsi.org>>> wrote:
>>>>
>>>> Hello Leo,
>>>>
>>>> On Thu, Sep 22, 2011 at 7:41 PM, Leonid Nayer <lnayer@gmail.com > <mailto:lnayer@gmail.com> > >>>> <mailto:lnayer@gmail.com <mailto:lnayer@gmail.com>>> wrote:
>>>> > First you need to use libjnportaudio with librt
>>>> > linked in. Damian provided it to me.
>>>>
>>>> Please open an issue in our issue tracker for it (and mention in the
>>>> description that you've been authorized on the dev mailing list to do
>>>> so) so that we can get it done as soon as we have the time.
>>>>
>>>> > Also I found out yesterday that Enable
>>>> > support to encrypt calls doesnt work on red hat. So All I did is set
>>>> > DEFAULT_ENCRYPTION to false in the properties file and jitsi works
>>>> now. Now
>>>> > both side can hear.
>>>> > I was wondering if jitsi can have DEFAULT_ENCRYPTION set to false as a
>>>> > default.
>>>>
>>>> Secure calls is one of the major features of Jitsi so I'd rather think
>>>> that we'd like to fix any issue related to it than disable it. You may
>>>> open a new issue for it as well but please notice that we have a lot
>>>> on our todo lists so we may not be able to handle it in the very near
>>>> future.
>>>>
>>>> > Also I was wondering if a feature can be added to make calls from
>>>> > command line.
>>>>
>>>> Well, Jitsi was supposed to already handle protocol URIs/addresses on
>>>> the command line by establishing calls to them. Have you already tried
>>>> a command line like "jitsi sip:echo@iptel.org <mailto:sip%3Aecho@iptel.org>
>>>> <mailto:sip%3Aecho@iptel.org <mailto:sip%253Aecho@iptel.org>>"? Could you please
>>>> elaborate on your experience and expectations with respect to making
>>>> calls from the command line?
>>>>
>>>> Regards,
>>>> Lyubomir
>>>>
>>>
>>> --
>>> Emil Ivov, Ph.D. 67000 Strasbourg,
>>> Project Lead France
>>> Jitsi
>>> emcho@jitsi.org <mailto:emcho@jitsi.org> PHONE: +33.1.77.62.43.30
>>> http://jitsi.org FAX: +33.1.77.62.47.31
>>>


#9

Thanks for the reply. Is there a way to add that feature? Thanks.

Leo

Hi Leonid,

Good Afternoon,

Is there a command line for conferencing? Thanks.

Unfortunately no.

Regards,
--
Seb

Leo

> Worked*
>
>> Hey Emil,
>>
>> Sorry for the late reply. Only one side could hear when it was on.
When I
>> disabled it. Both sides world. Thanks.
>>
>> Leo
>>
>>> Hey Leonid,
>>>
>>> Could you please tell us what made you think that the problems you
were
>>> experiencing were related to ZRTP?
>>>
>>> Cheers,
>>> Emil
>>>
>>> На 23.09.11 19:03, Leonid Nayer написа:
>>>> Good Afternoon Jitsi Developers,
>>>>
>>>> Thank you for the email. I was trying to open the tickets today but
>>>> couldnt find the link to create a new ticket on jira. Can you please
>>>> point me to the right site? Thanks.
>>>>
>>>> Also I had couple of more questions.
>>>>
>>>> I was testing jitsi today and found out that something goes wrong
with
>>>> the config files because it will not let me reopen jitsi after I
closed
>>>> it the first time using quit. I checked that all the jitsi
processes are
>>>> killed. To reopen jitsi I had to delete the .jitsi directory and
than it
>>>> would let me open jitsi again. I also attached the warnings I get
when I
>>>> run jitsi.
>>>>
>>>> The second question is that when I use command line argument
jitsi sip:,
>>>> it calls the person but when we disconnect it doesn't quit jitsi
>>>> correctly. I attached the output from the terminal. I always have to
>>>> kill the process when I do this.
>>>>
>>>> My last question is, if there is an easy way to change the accept
call
>>>> interfece or any documentation that would help me do that .
Thanks you
>>>> very much for the help. I look forward to your reply. Thanks.
>>>>
>>>> Thanks,
>>>>
>>>> Leo
>>>>
>>>>
>>>> Hello Leo,
>>>>
>>>> > First you need to use libjnportaudio with librt
>>>> > linked in. Damian provided it to me.
>>>>
>>>> Please open an issue in our issue tracker for it (and mention in the
>>>> description that you've been authorized on the dev mailing list to

do

>>>> so) so that we can get it done as soon as we have the time.
>>>>
>>>> > Also I found out yesterday that Enable
>>>> > support to encrypt calls doesnt work on red hat. So All I did
is set
>>>> > DEFAULT_ENCRYPTION to false in the properties file and jitsi works
>>>> now. Now
>>>> > both side can hear.
>>>> > I was wondering if jitsi can have DEFAULT_ENCRYPTION set to
false as a
>>>> > default.
>>>>
>>>> Secure calls is one of the major features of Jitsi so I'd rather
think
>>>> that we'd like to fix any issue related to it than disable it.
You may
>>>> open a new issue for it as well but please notice that we have a lot
>>>> on our todo lists so we may not be able to handle it in the very

near

>>>> future.
>>>>
>>>> > Also I was wondering if a feature can be added to make calls from
>>>> > command line.
>>>>
>>>> Well, Jitsi was supposed to already handle protocol URIs/addresses

on

···

On Oct 6, 2011 7:35 AM, "Sebastien Vincent" <seb@jitsi.org> wrote:

Le 05/10/11 20:15, Leonid Nayer a écrit :

On Oct 5, 2011 12:13 PM, "Leonid Nayer" <lnayer@gmail.com >> <mailto:lnayer@gmail.com>> wrote:
> On Oct 5, 2011 12:12 PM, "Leonid Nayer" <lnayer@gmail.com >> <mailto:lnayer@gmail.com>> wrote:
>> On Sep 28, 2011 9:59 AM, "Emil Ivov" <emcho@jitsi.org >> <mailto:emcho@jitsi.org>> wrote:
>>>> On Thu, Sep 22, 2011 at 2:54 PM, Lyubomir Marinov <lubo@jitsi.org >> <mailto:lubo@jitsi.org> >> >>>> <mailto:lubo@jitsi.org <mailto:lubo@jitsi.org>>> wrote:
>>>> On Thu, Sep 22, 2011 at 7:41 PM, Leonid Nayer <lnayer@gmail.com >> <mailto:lnayer@gmail.com> >> >>>> <mailto:lnayer@gmail.com <mailto:lnayer@gmail.com>>> wrote:
>>>> the command line by establishing calls to them. Have you already
tried
>>>> a command line like "jitsi sip:echo@iptel.org
<mailto:sip%3Aecho@iptel.org>
>>>> <mailto:sip%3Aecho@iptel.org <mailto:sip%253Aecho@iptel.org>>"?
Could you please
>>>> elaborate on your experience and expectations with respect to making
>>>> calls from the command line?
>>>>
>>>> Regards,
>>>> Lyubomir
>>>>
>>>>
>>>
>>> --
>>> Emil Ivov, Ph.D. 67000 Strasbourg,
>>> Project Lead France
>>> Jitsi
>>> emcho@jitsi.org <mailto:emcho@jitsi.org> PHONE: +33.1.77.62.43.30
>>> http://jitsi.org FAX: +33.1.77.62.47.31
>>>