[jitsi-dev] Re: UI: Notification window too small at Ubuntu


#1

oops - here is the screen shot.

Conrad
-------- Original-Nachricht --------

···

Datum: Thu, 10 Feb 2011 23:26:26 +0100
Von: "Conrad Beckert" <conrad_videokonferenz@gmx.de>
An: dev@jitsi.java.net
Betreff: [jitsi-dev] UI: Notification window too small at Ubuntu

Hi,

yesterday we had an outage of one of my configured Jabber servers. When
opening Jitsi, an error message gets displayed saying that something is wrong
with one of the servers.

The only problem: this message stops where it gets interesting. The part
mentioning the server affected gets cut. The text suggests that there is
more to come (see the colon at the end)

It might be caused by Ubuntu (the lower panel) or by the fact that German
texts tend to be longer than their English counterparts.

Incoming messages only display the fact that there is an incoming message
but not the content. I remember that this wasn't the case before. These
issues might be correlated.

See attached the error message.

Thank you
Conrad


#2

I see this regularly on either Linux or Windows 7 and even have no clue how it should look correctly.

Ingo

···

-----Original Message-----
From: Conrad Beckert [mailto:conrad_videokonferenz@gmx.de]
Sent: Donnerstag, 10. Februar 2011 23:38
To: dev@jitsi.java.net
Subject: [jitsi-dev] Re: UI: Notification window too small at Ubuntu

oops - here is the screen shot.

Conrad
-------- Original-Nachricht --------
> Datum: Thu, 10 Feb 2011 23:26:26 +0100
> Von: "Conrad Beckert" <conrad_videokonferenz@gmx.de>
> An: dev@jitsi.java.net
> Betreff: [jitsi-dev] UI: Notification window too small at Ubuntu

> Hi,
>
> yesterday we had an outage of one of my configured Jabber servers. When
> opening Jitsi, an error message gets displayed saying that something is
wrong
> with one of the servers.
>
> The only problem: this message stops where it gets interesting. The part
> mentioning the server affected gets cut. The text suggests that there is
> more to come (see the colon at the end)
>
> It might be caused by Ubuntu (the lower panel) or by the fact that
German
> texts tend to be longer than their English counterparts.
>
> Incoming messages only display the fact that there is an incoming
message
> but not the content. I remember that this wasn't the case before. These
> issues might be correlated.
>
> See attached the error message.
>
> Thank you
> Conrad


#3

Hi Conrad, Ingo,

(see inline)

I see this regularly on either Linux or Windows 7 and even have no clue how it should look correctly.

Ingo

From: Conrad Beckert [mailto:conrad_videokonferenz@gmx.de]
Sent: Donnerstag, 10. Februar 2011 23:38
To: dev@jitsi.java.net
Subject: [jitsi-dev] Re: UI: Notification window too small at Ubuntu

oops - here is the screen shot.

Conrad
-------- Original-Nachricht --------

Datum: Thu, 10 Feb 2011 23:26:26 +0100
Von: "Conrad Beckert" <conrad_videokonferenz@gmx.de>
An: dev@jitsi.java.net
Betreff: [jitsi-dev] UI: Notification window too small at Ubuntu

Hi,

yesterday we had an outage of one of my configured Jabber servers. When
opening Jitsi, an error message gets displayed saying that something is

wrong

with one of the servers.

The only problem: this message stops where it gets interesting. The part
mentioning the server affected gets cut. The text suggests that there is
more to come (see the colon at the end)

It might be caused by Ubuntu (the lower panel) or by the fact that

German

texts tend to be longer than their English counterparts.

For the error messages I think we could add a "more info" link that could open the whole message in a new window. Another enhancement could be to have two error messages - a simple/shorter one to show in the notification popup and a more descriptive one to show in the "more info" window. WDYT?

Incoming messages only display the fact that there is an incoming

message

but not the content. I remember that this wasn't the case before. These
issues might be correlated.

I'm not sure what have changed, if this wasn't the case before, but it could always happen because of the internationalization or the system font size. For incoming message notifications however the "more info" link has no sense, so here I think we should simply stick to a shorter text. May be change the text in english to a shorter one and add a comment in the properties files that translators should stick to a short text.

Also we should maybe explicitly set the font size (if we don't).

Conrad, could you please create an issues for those two?

Regards,
Yana

···

On Feb 11, 2011, at 7:56 AM, Bauersachs Ingo wrote:

-----Original Message-----

See attached the error message.

Thank you
Conrad


#4

Hey Yana,

For the error messages I think we could add a "more info" link that could
open the whole message in a new window. Another enhancement could be to
have two error messages - a simple/shorter one to show in the notification
popup and a more descriptive one to show in the "more info" window. WDYT?

A "more info" link and shorter texts sound good.

Incoming messages only display the fact that there is an incoming
message but not the content. I remember that this wasn't the case
before. These issues might be correlated.

I'm not sure what have changed, if this wasn't the case before, but it
could always happen because of the internationalization or the system font
size. For incoming message notifications however the "more info" link has
no sense, so here I think we should simply stick to a shorter text. May be
change the text in english to a shorter one and add a comment in the
properties files that translators should stick to a short text.

Also we should maybe explicitly set the font size (if we don't).

I never saw an untruncated popup, so if something changed, I think it wasn't recently.

Regards,
Ingo


#5

Dear all,
since latest updates (dont know which exactly) there are several problems using jitsi between windows-machines (windows-mac or windows-linux not tested):

currently observed with nb3283

1) no audio on both sides (we cannot hear each other), the audio levels for both microphone and headphones show no sound.
2) after ending the call the camera stays on (light is on near the integrated camera in the lid of the laptop) - observed with two labtops (Sony SZ1 XP /WinXP SP2 and Lenovo Z61m WinXP SP3)
3) the call window does not close when the other partner is closing the call.
3) video and encryption in both directions is ok.

1-3 tested with/between Sony SZ1 XP /WinXP SP2, Lenovo Z61m WinXP SP3 and another Lenovo with Win7 64bit in intranet of institute, same results also between Lenovo Z61m and Desktop PC (WinXP SP3) calling abroad.

can anybody reproduce this?

MS


#6

I confirm the Swing popups pretty much never show the text in full on
Windows 7 and Mac OS X 10.6. Most of the time I see just the title of
the popup and not its text.

···

On Fri, Feb 11, 2011 at 12:10 PM, Bauersachs Ingo <ingo.bauersachs@fhnw.ch> wrote:

I never saw an untruncated popup, so if something changed, I think it wasn't recently.


#7

На 11.02.11 17:50, Mr Smith написа:

Dear all,
since latest updates (dont know which exactly) there are several problems using jitsi between windows-machines (windows-mac or windows-linux not tested):

currently observed with nb3283

1) no audio on both sides (we cannot hear each other), the audio levels for both microphone and headphones show no sound.
2) after ending the call the camera stays on (light is on near the integrated camera in the lid of the laptop) - observed with two labtops (Sony SZ1 XP /WinXP SP2 and Lenovo Z61m WinXP SP3)
3) the call window does not close when the other partner is closing the call.
3) video and encryption in both directions is ok.

1-3 tested with/between Sony SZ1 XP /WinXP SP2, Lenovo Z61m WinXP SP3 and another Lenovo with Win7 64bit in intranet of institute, same results also between Lenovo Z61m and Desktop PC (WinXP SP3) calling abroad.

can anybody reproduce this?

I am afraid not. What's more, there haven't been any changes in the last
month or so that would explain such problems.

Cheers,
Emil


#8

Hi,

The only recent change related to Windows audio is commit 8235 ("Make sure we use directsound devices under windows if they are not set as default one").

Mr Smith, can you check that audio settings are correct (i.e. input/output devices configured).

···

--
Seb

Le 11/02/2011 18:53, Emil Ivov a écrit :

На 11.02.11 17:50, Mr Smith написа:
   

Dear all,
since latest updates (dont know which exactly) there are several problems using jitsi between windows-machines (windows-mac or windows-linux not tested):

currently observed with nb3283

1) no audio on both sides (we cannot hear each other), the audio levels for both microphone and headphones show no sound.
2) after ending the call the camera stays on (light is on near the integrated camera in the lid of the laptop) - observed with two labtops (Sony SZ1 XP /WinXP SP2 and Lenovo Z61m WinXP SP3)
3) the call window does not close when the other partner is closing the call.
3) video and encryption in both directions is ok.

1-3 tested with/between Sony SZ1 XP /WinXP SP2, Lenovo Z61m WinXP SP3 and another Lenovo with Win7 64bit in intranet of institute, same results also between Lenovo Z61m and Desktop PC (WinXP SP3) calling abroad.

can anybody reproduce this?
     

I am afraid not. What's more, there haven't been any changes in the last
month or so that would explain such problems.

Cheers,
Emil


#9

Hi Sebastien,

THANKS! that was it! The default settings have been PortAudio --> "Primaerer Soundaufnahmetreiber"
(only in German although my jitsi interface settings are in English; OS is in German) and no sound, after changing to "SoundMax" in my case it worked.
So probably windows users have to change this manually as two other users had same issue (laptop & desktop with WinXP/Win7)

thanks again and sorry...

MS

···

Hi,

The only recent change related to Windows audio is commit 8235 ("Make
sure we use directsound devices under windows if they are not set as
default one").

Mr Smith, can you check that audio settings are correct (i.e.
input/output devices configured).

--
Seb

Le 11/02/2011 18:53, Emil Ivov a écrit :

На 11.02.11 17:50, Mr Smith написа:
   

Dear all,
since latest updates (dont know which exactly) there are several problems using jitsi between windows-machines (windows-mac or windows-linux not tested):

currently observed with nb3283

1) no audio on both sides (we cannot hear each other), the audio levels for both microphone and headphones show no sound.
2) after ending the call the camera stays on (light is on near the integrated camera in the lid of the laptop) - observed with two labtops (Sony SZ1 XP /WinXP SP2 and Lenovo Z61m WinXP SP3)
3) the call window does not close when the other partner is closing the call.
3) video and encryption in both directions is ok.

1-3 tested with/between Sony SZ1 XP /WinXP SP2, Lenovo Z61m WinXP SP3 and another Lenovo with Win7 64bit in intranet of institute, same results also between Lenovo Z61m and Desktop PC (WinXP SP3) calling abroad.

can anybody reproduce this?
     

I am afraid not. What's more, there haven't been any changes in the last
month or so that would explain such problems.

Cheers,
Emil

--
Mit freundlichen Grüßen
Mr Smith
mailto:mr.smith476@googlemail.com