[jitsi-dev] Re: SIP Port number ignored


#1

Thanks Chris. Just so that we are clear though. The expected behaviour in
the ticket is NOT for packets to go elsewhere. As I explained in my previous
mail, packets in both cases go to the proxy address and port. The only
difference is that the request URI in the REGISTER should have an extra port
param and it currently doesn't. That extra port param will tell the proxy
where to route the request to.

Emil
-- sent from my mobile

···

On Jul 14, 2011 11:22 AM, "Chris Maciejewski" <chris@wima.co.uk> wrote:


#2

What if I wanted REGISTER packets sent to registrar_host:portA and all
other packets to proxy_host:portB ?

My understanding was that I can achieve the above by:

1. In "Connection" tab enter registrar_port into "Registrar" filed and
portA into Registrar "Port" field.
2. Deselect "Configure proxy automatically" checkbox
3. Enter proxy_host into "Proxy" field and portB into Proxy "Port" field.

But what you are saying is that all packets will be send to
proxy_host:portB anyway ?

Don't we want to support the scenario where Registrar and Proxy might
be on different hosts / ports ?

···

On 14 July 2011 10:58, Emil Ivov <emcho@jitsi.org> wrote:

Thanks Chris. Just so that we are clear though. The expected behaviour in
the ticket is NOT for packets to go elsewhere. As I explained in my previous
mail, packets in both cases go to the proxy address and port. The only
difference is that the request URI in the REGISTER should have an extra port
param and it currently doesn't. That extra port param will tell the proxy
where to route the request to.

Emil
-- sent from my mobile

On Jul 14, 2011 11:22 AM, "Chris Maciejewski" <chris@wima.co.uk> wrote: