[jitsi-dev] Re: Jitsi starts minimized after provisioning


#1

Dear Glaucio,

Thank you for the hint but it doesn't work for me. Jitsi still starts
minimized in the tray bar.
However, when I maximize it, it opens with dimensions and position given by
the provisioning config
Any other param that could help Jisti open maximized ?

Best regards,
Patrick

···

On Sat, Sep 24, 2011 at 03:29, <dev-request@jitsi.java.net> wrote:

Table of contents:

1. [jitsi-dev] Jitsi starts minimized after provisioning - Patrick <
java@ict-synergy.be>
2. [jitsi-dev] Re: Jitsi starts minimized after provisioning - Glaucio Vaz
de Mello <gvmello@yx.cl>
3. [jitsi-dev] Re: red hat - Leonid Nayer <lnayer@gmail.com>
4. [jitsi-dev] Issues in sending DTMF tones to GoogleVoice - shariq
muhammad <shariq.muhammad@gmail.com>
5. [jitsi-dev] jitsi is awesome - Joe Godwin <godwin.joe@gmail.com>
6. [jitsi-dev] Issues in sending DTMF tones to GoogleVoice - shariq
muhammad <shariq.muhammad@gmail.com>

---------- Forwarded message ----------
From: Patrick <java@ict-synergy.be>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 11:55:55 +0200
Subject: [jitsi-dev] Jitsi starts minimized after provisioning
Dear,

Jitsi always starts minimized in the traybar after a successful
provisioning via URI.
Is there a setting (that could be set via provisioning preferably) to
have it opening maximized after the user has entered its credentials
in the popup ?

Thanks in advance
Patrick

---------- Forwarded message ----------
From: Glaucio Vaz de Mello <gvmello@yx.cl>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 08:37:48 -0400
Subject: [jitsi-dev] Re: Jitsi starts minimized after provisioning
Adding some lines like these to the provisioning response worked for me:

net.java.sip.communicator.impl.gui.main.MainFrame.height=750
net.java.sip.communicator.impl.gui.main.MainFrame.width=520
net.java.sip.communicator.impl.gui.main.MainFrame.x=800
net.java.sip.communicator.impl.gui.main.MainFrame.y=20

On Fri, Sep 23, 2011 at 6:55 AM, Patrick <java@ict-synergy.be> wrote:

Dear,

Jitsi always starts minimized in the traybar after a successful
provisioning via URI.
Is there a setting (that could be set via provisioning preferably) to
have it opening maximized after the user has entered its credentials
in the popup ?

Thanks in advance
Patrick

---------- Forwarded message ----------
From: Leonid Nayer <lnayer@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 13:03:24 -0400
Subject: [jitsi-dev] Re: red hat
Good Afternoon Jitsi Developers,

Thank you for the email. I was trying to open the tickets today but couldnt
find the link to create a new ticket on jira. Can you please point me to the
right site? Thanks.

Also I had couple of more questions.

I was testing jitsi today and found out that something goes wrong with the
config files because it will not let me reopen jitsi after I closed it the
first time using quit. I checked that all the jitsi processes are killed. To
reopen jitsi I had to delete the .jitsi directory and than it would let me
open jitsi again. I also attached the warnings I get when I run jitsi.

The second question is that when I use command line argument jitsi sip:, it
calls the person but when we disconnect it doesn't quit jitsi correctly. I
attached the output from the terminal. I always have to kill the process
when I do this.

My last question is, if there is an easy way to change the accept call
interfece or any documentation that would help me do that . Thanks you very
much for the help. I look forward to your reply. Thanks.

Thanks,

Leo

On Thu, Sep 22, 2011 at 2:54 PM, Lyubomir Marinov <lubo@jitsi.org> wrote:

Hello Leo,

On Thu, Sep 22, 2011 at 7:41 PM, Leonid Nayer <lnayer@gmail.com> wrote:
> First you need to use libjnportaudio with librt
> linked in. Damian provided it to me.

Please open an issue in our issue tracker for it (and mention in the
description that you've been authorized on the dev mailing list to do
so) so that we can get it done as soon as we have the time.

> Also I found out yesterday that Enable
> support to encrypt calls doesnt work on red hat. So All I did is set
> DEFAULT_ENCRYPTION to false in the properties file and jitsi works now.
Now
> both side can hear.
> I was wondering if jitsi can have DEFAULT_ENCRYPTION set to false as a
> default.

Secure calls is one of the major features of Jitsi so I'd rather think
that we'd like to fix any issue related to it than disable it. You may
open a new issue for it as well but please notice that we have a lot
on our todo lists so we may not be able to handle it in the very near
future.

> Also I was wondering if a feature can be added to make calls from
> command line.

Well, Jitsi was supposed to already handle protocol URIs/addresses on
the command line by establishing calls to them. Have you already tried
a command line like "jitsi sip:echo@iptel.org"? Could you please
elaborate on your experience and expectations with respect to making
calls from the command line?

Regards,
Lyubomir

---------- Forwarded message ----------
From: shariq muhammad <shariq.muhammad@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 08:07:18 -0400
Subject: [jitsi-dev] Issues in sending DTMF tones to GoogleVoice

Hi,

I am using jitsi-1.0-beta1-nightly.build.3651-x64.exe<http://download.jitsi.org/jitsi/windows/jitsi-1.0-beta1-nightly.build.3651-x64.exe> installer
from the latest builds, And i hooked jitis to GoogleVoice, i have turned off
call screening in GoogleVoice even then its not allowing me to turn off that
feature, anyway the problem is jitis is unable to send DTMF tones, probably
looks to me as if it is using RFC standard but Google Voice is not
recognizing and requires audio DTMF streams to be injected. I am unable to
accept calls in google voice, however outgoing calls from jits to any other
phone works great. Both ways audio works awesome!

I have hooked GoogleVoice though an SIP as well before and it worked only
when i had turned on the Audio instead of DTMF RFC implementation. Now am
not sure how outgoing calls are handled to send number (Audio DTMF or RFC
implementation).

thanks,
Shariq

--
Profile <https://www.mcpvirtualbusinesscard.com/VBCServer/shariq/profile>

---------- Forwarded message ----------
From: Joe Godwin <godwin.joe@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 09:22:01 -0500
Subject: [jitsi-dev] jitsi is awesome
just wanted to say thanks. been using jitsi for three days now and it has
met and even exceeded my vast IM/Sip needs. it's like Pidgin on Steroids.
Keep up the good work! You guys rock!

---------- Forwarded message ----------
From: shariq muhammad <shariq.muhammad@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 16:23:58 -0400
Subject: [jitsi-dev] Issues in sending DTMF tones to GoogleVoice
Hi,

I am using jitsi-1.0-beta1-nightly.build.3651-x64.exe installer from the
latest builds, And i hooked jitis to GoogleVoice, i have turned off call
screening in GoogleVoice even then its not allowing me to turn off that
feature, anyway the problem is jitis is unable to send DTMF tones, probably
looks to me as if it is using RFC standard but Google Voice is not
recognizing and requires audio DTMF streams to be injected. I am unable to
accept calls in google voice, however outgoing calls from jits to any other
phone works great. Both ways audio works awesome!

I have hooked GoogleVoice though an SIP as well before and it worked only
when i had turned on the Audio instead of DTMF RFC implementation. Now am
not sure how outgoing calls are handled to send number (Audio DTMF or RFC
implementation).

thanks,
Shariq

End of digest for list dev@jitsi.java.net - Sat, 24 Sep 2011


#2

Try to set the following property:
net.java.sip.communicator.impl.systray.showApplication=true

While this will not maximize the window, it opens the main UI in the size you define with the other four props.

Ingo


#3

Dear dev team,

This mail to inform you that my question is now closed. I've digged into the
sources and found that the property
"net.java.sip.communicator.impl.systray.showApplication" rules the
visibility of the application.
Setting it to "true" result in Jitsi opening visible (and not only in
traybar)

Thanks anyway for the support

Best regards,
Patrick

···

On Sat, Sep 24, 2011 at 09:53, Patrick <java@ict-synergy.be> wrote:

Dear Glaucio,

Thank you for the hint but it doesn't work for me. Jitsi still starts
minimized in the tray bar.
However, when I maximize it, it opens with dimensions and position given by
the provisioning config
Any other param that could help Jisti open maximized ?

Best regards,
Patrick

On Sat, Sep 24, 2011 at 03:29, <dev-request@jitsi.java.net> wrote:

Table of contents:

1. [jitsi-dev] Jitsi starts minimized after provisioning - Patrick <
java@ict-synergy.be>
2. [jitsi-dev] Re: Jitsi starts minimized after provisioning - Glaucio Vaz
de Mello <gvmello@yx.cl>
3. [jitsi-dev] Re: red hat - Leonid Nayer <lnayer@gmail.com>
4. [jitsi-dev] Issues in sending DTMF tones to GoogleVoice - shariq
muhammad <shariq.muhammad@gmail.com>
5. [jitsi-dev] jitsi is awesome - Joe Godwin <godwin.joe@gmail.com>
6. [jitsi-dev] Issues in sending DTMF tones to GoogleVoice - shariq
muhammad <shariq.muhammad@gmail.com>

---------- Forwarded message ----------
From: Patrick <java@ict-synergy.be>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 11:55:55 +0200
Subject: [jitsi-dev] Jitsi starts minimized after provisioning
Dear,

Jitsi always starts minimized in the traybar after a successful
provisioning via URI.
Is there a setting (that could be set via provisioning preferably) to
have it opening maximized after the user has entered its credentials
in the popup ?

Thanks in advance
Patrick

---------- Forwarded message ----------
From: Glaucio Vaz de Mello <gvmello@yx.cl>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 08:37:48 -0400
Subject: [jitsi-dev] Re: Jitsi starts minimized after provisioning
Adding some lines like these to the provisioning response worked for me:

net.java.sip.communicator.impl.gui.main.MainFrame.height=750
net.java.sip.communicator.impl.gui.main.MainFrame.width=520
net.java.sip.communicator.impl.gui.main.MainFrame.x=800
net.java.sip.communicator.impl.gui.main.MainFrame.y=20

On Fri, Sep 23, 2011 at 6:55 AM, Patrick <java@ict-synergy.be> wrote:

Dear,

Jitsi always starts minimized in the traybar after a successful
provisioning via URI.
Is there a setting (that could be set via provisioning preferably) to
have it opening maximized after the user has entered its credentials
in the popup ?

Thanks in advance
Patrick

---------- Forwarded message ----------
From: Leonid Nayer <lnayer@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 13:03:24 -0400
Subject: [jitsi-dev] Re: red hat
Good Afternoon Jitsi Developers,

Thank you for the email. I was trying to open the tickets today but
couldnt find the link to create a new ticket on jira. Can you please point
me to the right site? Thanks.

Also I had couple of more questions.

I was testing jitsi today and found out that something goes wrong with the
config files because it will not let me reopen jitsi after I closed it the
first time using quit. I checked that all the jitsi processes are killed. To
reopen jitsi I had to delete the .jitsi directory and than it would let me
open jitsi again. I also attached the warnings I get when I run jitsi.

The second question is that when I use command line argument jitsi sip:,
it calls the person but when we disconnect it doesn't quit jitsi correctly.
I attached the output from the terminal. I always have to kill the process
when I do this.

My last question is, if there is an easy way to change the accept call
interfece or any documentation that would help me do that . Thanks you very
much for the help. I look forward to your reply. Thanks.

Thanks,

Leo

On Thu, Sep 22, 2011 at 2:54 PM, Lyubomir Marinov <lubo@jitsi.org> wrote:

Hello Leo,

On Thu, Sep 22, 2011 at 7:41 PM, Leonid Nayer <lnayer@gmail.com> wrote:
> First you need to use libjnportaudio with librt
> linked in. Damian provided it to me.

Please open an issue in our issue tracker for it (and mention in the
description that you've been authorized on the dev mailing list to do
so) so that we can get it done as soon as we have the time.

> Also I found out yesterday that Enable
> support to encrypt calls doesnt work on red hat. So All I did is set
> DEFAULT_ENCRYPTION to false in the properties file and jitsi works now.
Now
> both side can hear.
> I was wondering if jitsi can have DEFAULT_ENCRYPTION set to false as a
> default.

Secure calls is one of the major features of Jitsi so I'd rather think
that we'd like to fix any issue related to it than disable it. You may
open a new issue for it as well but please notice that we have a lot
on our todo lists so we may not be able to handle it in the very near
future.

> Also I was wondering if a feature can be added to make calls from
> command line.

Well, Jitsi was supposed to already handle protocol URIs/addresses on
the command line by establishing calls to them. Have you already tried
a command line like "jitsi sip:echo@iptel.org"? Could you please
elaborate on your experience and expectations with respect to making
calls from the command line?

Regards,
Lyubomir

---------- Forwarded message ----------
From: shariq muhammad <shariq.muhammad@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 08:07:18 -0400
Subject: [jitsi-dev] Issues in sending DTMF tones to GoogleVoice

Hi,

I am using jitsi-1.0-beta1-nightly.build.3651-x64.exe<http://download.jitsi.org/jitsi/windows/jitsi-1.0-beta1-nightly.build.3651-x64.exe> installer
from the latest builds, And i hooked jitis to GoogleVoice, i have turned off
call screening in GoogleVoice even then its not allowing me to turn off that
feature, anyway the problem is jitis is unable to send DTMF tones, probably
looks to me as if it is using RFC standard but Google Voice is not
recognizing and requires audio DTMF streams to be injected. I am unable to
accept calls in google voice, however outgoing calls from jits to any other
phone works great. Both ways audio works awesome!

I have hooked GoogleVoice though an SIP as well before and it worked only
when i had turned on the Audio instead of DTMF RFC implementation. Now am
not sure how outgoing calls are handled to send number (Audio DTMF or RFC
implementation).

thanks,
Shariq

--
Profile <https://www.mcpvirtualbusinesscard.com/VBCServer/shariq/profile>

---------- Forwarded message ----------
From: Joe Godwin <godwin.joe@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 09:22:01 -0500
Subject: [jitsi-dev] jitsi is awesome
just wanted to say thanks. been using jitsi for three days now and it has
met and even exceeded my vast IM/Sip needs. it's like Pidgin on Steroids.
Keep up the good work! You guys rock!

---------- Forwarded message ----------
From: shariq muhammad <shariq.muhammad@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 16:23:58 -0400
Subject: [jitsi-dev] Issues in sending DTMF tones to GoogleVoice
Hi,

I am using jitsi-1.0-beta1-nightly.build.3651-x64.exe installer from the
latest builds, And i hooked jitis to GoogleVoice, i have turned off call
screening in GoogleVoice even then its not allowing me to turn off that
feature, anyway the problem is jitis is unable to send DTMF tones, probably
looks to me as if it is using RFC standard but Google Voice is not
recognizing and requires audio DTMF streams to be injected. I am unable to
accept calls in google voice, however outgoing calls from jits to any other
phone works great. Both ways audio works awesome!

I have hooked GoogleVoice though an SIP as well before and it worked only
when i had turned on the Audio instead of DTMF RFC implementation. Now am
not sure how outgoing calls are handled to send number (Audio DTMF or RFC
implementation).

thanks,
Shariq

End of digest for list dev@jitsi.java.net - Sat, 24 Sep 2011


#4

Thank you Ingo, our mails have crossed :slight_smile:
(I'm in digest mode but it's not convenient when waiting for an answer, I'll
update this righ now)

···

On Sat, Sep 24, 2011 at 10:51, Patrick <java@ict-synergy.be> wrote:

Dear dev team,

This mail to inform you that my question is now closed. I've digged into
the sources and found that the property
"net.java.sip.communicator.impl.systray.showApplication" rules the
visibility of the application.
Setting it to "true" result in Jitsi opening visible (and not only in
traybar)

Thanks anyway for the support

Best regards,
Patrick

On Sat, Sep 24, 2011 at 09:53, Patrick <java@ict-synergy.be> wrote:

Dear Glaucio,

Thank you for the hint but it doesn't work for me. Jitsi still starts
minimized in the tray bar.
However, when I maximize it, it opens with dimensions and position given
by the provisioning config
Any other param that could help Jisti open maximized ?

Best regards,
Patrick

On Sat, Sep 24, 2011 at 03:29, <dev-request@jitsi.java.net> wrote:

Table of contents:

1. [jitsi-dev] Jitsi starts minimized after provisioning - Patrick <
java@ict-synergy.be>
2. [jitsi-dev] Re: Jitsi starts minimized after provisioning - Glaucio
Vaz de Mello <gvmello@yx.cl>
3. [jitsi-dev] Re: red hat - Leonid Nayer <lnayer@gmail.com>
4. [jitsi-dev] Issues in sending DTMF tones to GoogleVoice - shariq
muhammad <shariq.muhammad@gmail.com>
5. [jitsi-dev] jitsi is awesome - Joe Godwin <godwin.joe@gmail.com>
6. [jitsi-dev] Issues in sending DTMF tones to GoogleVoice - shariq
muhammad <shariq.muhammad@gmail.com>

---------- Forwarded message ----------
From: Patrick <java@ict-synergy.be>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 11:55:55 +0200
Subject: [jitsi-dev] Jitsi starts minimized after provisioning
Dear,

Jitsi always starts minimized in the traybar after a successful
provisioning via URI.
Is there a setting (that could be set via provisioning preferably) to
have it opening maximized after the user has entered its credentials
in the popup ?

Thanks in advance
Patrick

---------- Forwarded message ----------
From: Glaucio Vaz de Mello <gvmello@yx.cl>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 08:37:48 -0400
Subject: [jitsi-dev] Re: Jitsi starts minimized after provisioning
Adding some lines like these to the provisioning response worked for me:

net.java.sip.communicator.impl.gui.main.MainFrame.height=750
net.java.sip.communicator.impl.gui.main.MainFrame.width=520
net.java.sip.communicator.impl.gui.main.MainFrame.x=800
net.java.sip.communicator.impl.gui.main.MainFrame.y=20

On Fri, Sep 23, 2011 at 6:55 AM, Patrick <java@ict-synergy.be> wrote:

Dear,

Jitsi always starts minimized in the traybar after a successful
provisioning via URI.
Is there a setting (that could be set via provisioning preferably) to
have it opening maximized after the user has entered its credentials
in the popup ?

Thanks in advance
Patrick

---------- Forwarded message ----------
From: Leonid Nayer <lnayer@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 13:03:24 -0400
Subject: [jitsi-dev] Re: red hat
Good Afternoon Jitsi Developers,

Thank you for the email. I was trying to open the tickets today but
couldnt find the link to create a new ticket on jira. Can you please point
me to the right site? Thanks.

Also I had couple of more questions.

I was testing jitsi today and found out that something goes wrong with
the config files because it will not let me reopen jitsi after I closed it
the first time using quit. I checked that all the jitsi processes are
killed. To reopen jitsi I had to delete the .jitsi directory and than it
would let me open jitsi again. I also attached the warnings I get when I run
jitsi.

The second question is that when I use command line argument jitsi sip:,
it calls the person but when we disconnect it doesn't quit jitsi correctly.
I attached the output from the terminal. I always have to kill the process
when I do this.

My last question is, if there is an easy way to change the accept call
interfece or any documentation that would help me do that . Thanks you very
much for the help. I look forward to your reply. Thanks.

Thanks,

Leo

On Thu, Sep 22, 2011 at 2:54 PM, Lyubomir Marinov <lubo@jitsi.org>wrote:

Hello Leo,

On Thu, Sep 22, 2011 at 7:41 PM, Leonid Nayer <lnayer@gmail.com> wrote:
> First you need to use libjnportaudio with librt
> linked in. Damian provided it to me.

Please open an issue in our issue tracker for it (and mention in the
description that you've been authorized on the dev mailing list to do
so) so that we can get it done as soon as we have the time.

> Also I found out yesterday that Enable
> support to encrypt calls doesnt work on red hat. So All I did is set
> DEFAULT_ENCRYPTION to false in the properties file and jitsi works
now. Now
> both side can hear.
> I was wondering if jitsi can have DEFAULT_ENCRYPTION set to false as a
> default.

Secure calls is one of the major features of Jitsi so I'd rather think
that we'd like to fix any issue related to it than disable it. You may
open a new issue for it as well but please notice that we have a lot
on our todo lists so we may not be able to handle it in the very near
future.

> Also I was wondering if a feature can be added to make calls from
> command line.

Well, Jitsi was supposed to already handle protocol URIs/addresses on
the command line by establishing calls to them. Have you already tried
a command line like "jitsi sip:echo@iptel.org"? Could you please
elaborate on your experience and expectations with respect to making
calls from the command line?

Regards,
Lyubomir

---------- Forwarded message ----------
From: shariq muhammad <shariq.muhammad@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 08:07:18 -0400
Subject: [jitsi-dev] Issues in sending DTMF tones to GoogleVoice

Hi,

I am using jitsi-1.0-beta1-nightly.build.3651-x64.exe<http://download.jitsi.org/jitsi/windows/jitsi-1.0-beta1-nightly.build.3651-x64.exe> installer
from the latest builds, And i hooked jitis to GoogleVoice, i have turned off
call screening in GoogleVoice even then its not allowing me to turn off that
feature, anyway the problem is jitis is unable to send DTMF tones, probably
looks to me as if it is using RFC standard but Google Voice is not
recognizing and requires audio DTMF streams to be injected. I am unable to
accept calls in google voice, however outgoing calls from jits to any other
phone works great. Both ways audio works awesome!

I have hooked GoogleVoice though an SIP as well before and it worked only
when i had turned on the Audio instead of DTMF RFC implementation. Now am
not sure how outgoing calls are handled to send number (Audio DTMF or RFC
implementation).

thanks,
Shariq

--
Profile<https://www.mcpvirtualbusinesscard.com/VBCServer/shariq/profile>

---------- Forwarded message ----------
From: Joe Godwin <godwin.joe@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 09:22:01 -0500
Subject: [jitsi-dev] jitsi is awesome
just wanted to say thanks. been using jitsi for three days now and it has
met and even exceeded my vast IM/Sip needs. it's like Pidgin on Steroids.
Keep up the good work! You guys rock!

---------- Forwarded message ----------
From: shariq muhammad <shariq.muhammad@gmail.com>
To: dev@jitsi.java.net
Date: Fri, 23 Sep 2011 16:23:58 -0400
Subject: [jitsi-dev] Issues in sending DTMF tones to GoogleVoice
Hi,

I am using jitsi-1.0-beta1-nightly.build.3651-x64.exe installer from the
latest builds, And i hooked jitis to GoogleVoice, i have turned off call
screening in GoogleVoice even then its not allowing me to turn off that
feature, anyway the problem is jitis is unable to send DTMF tones, probably
looks to me as if it is using RFC standard but Google Voice is not
recognizing and requires audio DTMF streams to be injected. I am unable to
accept calls in google voice, however outgoing calls from jits to any other
phone works great. Both ways audio works awesome!

I have hooked GoogleVoice though an SIP as well before and it worked only
when i had turned on the Audio instead of DTMF RFC implementation. Now am
not sure how outgoing calls are handled to send number (Audio DTMF or RFC
implementation).

thanks,
Shariq

End of digest for list dev@jitsi.java.net - Sat, 24 Sep 2011