[jitsi-dev] Re: Issue Report: Jitsi does not allow make account registration on server which running on non-standard port


#1

Hi, Damian!

(probably gmail blocking incoming emails from this mailing list and I need
to reply manually coz I see your reply on mailing list's website but not in
mailbox even in spam folder on gmail)

Yes, it seems that server address and port overriding in "advanced
properties" doesn't works for new account registration, but works fine on
adding existing XMPP account to Jitsi.

Also in case on registration(creation) new XMPP account there is the simple
form with 5 text fields:

-server address,

-user name,

-password,

-pwd confirmation

-and port number.

This form is shown when adding new (not existing and need to be created)
XMPP account.

If you specify non-standard custom port there - it will not work also.

Jitsi always keep trying to create account using default hardcoded port
5222.

In this case there is no any chance to register new account within Jitsi, if
the server running on non-standard port.

At least I've not found a way, other than temporarily install port-mapping
service or change server's port to standard one.

Thank You,

Dmitry.

From: Damian Minkov <damencho@...>

To: dev Jitsi <dev@...>

Subject: [jitsi-dev] Re: Issue Report: Jitsi does not allow make account

registration on server which running on non-standart port

Date: Tue, 26 Mar 2013 12:42:45 +0200

Hi,

and when overriding server options in configuration form you specify

both server and port?

Regards

damencho

Hi!

On Win7 (64bit) Jitsi 2.0.4506.10553

Jitsi can't register new account on the server, if the jabber server

running

on non-standart port (for example, 4432),

As far as I see, Jitsi always attempts to register new account on the port

5222 even if different server port specified in the form.

It seems like Jitsi overrides the custom port to 5222 in procedure of

account registration. But if the account already exists and you add it -

it'll work fine.

To catch the issue - I installed port-mapping service on the server (to

map

···

On Tue, Mar 26, 2013 at 12:24 PM, Dmitry.Integral <dmitry.integral@...> wrote:

port from 5222 to our custom 4432) - and if it's running - Jitsi can

register successfully. If not - there are no chance to do it.

Thank You,

Dmitry.


#2

Hi,

can you create an issue for that so we don't miss it, we will come to
it when time permits.
And of course patches are always welcome :slight_smile:

Thanks for the report
damencho

···

On Tue, Mar 26, 2013 at 1:57 PM, Dmitry.Integral <dmitry.integral@gmail.com> wrote:

Hi, Damian!

(probably gmail blocking incoming emails from this mailing list and I need
to reply manually coz I see your reply on mailing list’s website but not in
mailbox even in spam folder on gmail)

Yes, it seems that server address and port overriding in “advanced
properties” doesn’t works for new account registration, but works fine on
adding existing XMPP account to Jitsi.

Also in case on registration(creation) new XMPP account there is the simple
form with 5 text fields:

-server address,

-user name,

-password,

-pwd confirmation

-and port number.

This form is shown when adding new (not existing and need to be created)
XMPP account.

If you specify non-standard custom port there – it will not work also.

Jitsi always keep trying to create account using default hardcoded port
5222.

In this case there is no any chance to register new account within Jitsi, if
the server running on non-standard port.

At least I’ve not found a way, other than temporarily install port-mapping
service or change server’s port to standard one.

Thank You,

Dmitry.

From: Damian Minkov <damencho@...>

To: dev Jitsi <dev@...>

Subject: [jitsi-dev] Re: Issue Report: Jitsi does not allow make account
registration on server which running on non-standart port

Date: Tue, 26 Mar 2013 12:42:45 +0200

Hi,

and when overriding server options in configuration form you specify

both server and port?

Regards

damencho

On Tue, Mar 26, 2013 at 12:24 PM, Dmitry.Integral > > <dmitry.integral@...> wrote:

Hi!

On Win7 (64bit) Jitsi 2.0.4506.10553

Jitsi can’t register new account on the server, if the jabber server
running

on non-standart port (for example, 4432),

As far as I see, Jitsi always attempts to register new account on the port

5222 even if different server port specified in the form.

It seems like Jitsi overrides the custom port to 5222 in procedure of

account registration. But if the account already exists and you add it –

it’ll work fine.

To catch the issue – I installed port-mapping service on the server (to
map

port from 5222 to our custom 4432) – and if it’s running – Jitsi can

register successfully. If not – there are no chance to do it.

Thank You,

Dmitry.