[jitsi-dev] Re: Generic Java dependency for Ubuntu/Debian?


#1

Newton, Joshua (contractor):

I'd like to test out Jitsi as an alternative to Pidgin--I could use
one--but I'm using OpenJDK 7 (Ubuntu release packages). Can the
requirement for the JRE/JDK be changed to something like >= 6 as opposed
to a specific requirement for 6?

The correct way to do this (AFAIK) in Debian based systems is to use
alternatives (indicated by a pipe) in the "Depends:" field, like:

Depends: default-jre | openjdk-6-jre | openjdk-7-jre | java6-runtime,
OTHERDEPENDENCIES...

This means:

- use the default java runtime vor your Distribution
- if one of the openjdk versions is already installed, those will be used
instead of fetching default-jre
- the dependency can also be fullfilled with any java runtime with version
greater then six, like the Oracle Java.

Regards,

Thomas Koch, http://www.koch.ro