[jitsi-dev] Re: Desktop sharing back anytime soon???


#1

Cool, that's good news. I'm looking forward to it.

Greetings
Conrad

···

----- Ursprüngliche Nachricht -----
Von: Emil Ivov
Gesendet: 01.02.13 00:57 Uhr
An: dev@jitsi.java.net
Betreff: [jitsi-dev] Re: Desktop sharing back anytime soon???

Hey Conrad, On 31.01.13, 20:23, Conrad Beckert wrote: > Hi, > > I know - I might repeat myself and anoy you guys a bit, but what > happened to Desktop Sharing and when would it come back? Hopefully we would be able to bring it back next week and relese over the next 10 days Emil > I constantly > support folks over the line (including someone very special). For the > time beeing I have to replace the back-channel by voice ("Move mouse > right .- no left - click there..." :slight_smile: ) which is not so effective. I > don't whant to revert to 1.0 either (I wonder if I could install both > versions at the same time and the same user account without interfering) > > Any perspective when that option is available again? > > Thanks and have Fun @FOSSDEM - which I have to miss again (it is a bit > far away from here :frowning: ) -- but at least, there are videos. > > Greetings from Berlin, Germany > Conrad > > > -- https://jitsi.org


#2

Hello Conrad,

Jitsi r10430 re-enables the desktop sharing functionality. I have not enough time to run an exhaustive test set, thus, please give it a try and give us some feedback about it.

Regards,
Vincent

···

On 2/1/13 7:42 PM, Conrad Beckert wrote:

Cool, that's good news. I'm looking forward to it.

  Greetings
  Conrad

----- Ursprüngliche Nachricht -----
Von: Emil Ivov
Gesendet: 01.02.13 00:57 Uhr
An: dev@jitsi.java.net
Betreff: [jitsi-dev] Re: Desktop sharing back anytime soon???

  Hey Conrad, On 31.01.13, 20:23, Conrad Beckert wrote: > Hi, > > I know - I might repeat myself and anoy you guys a bit, but what > happened to Desktop Sharing and when would it come back? Hopefully we would be able to bring it back next week and relese over the next 10 days Emil > I constantly > support folks over the line (including someone very special). For the > time beeing I have to replace the back-channel by voice ("Move mouse > right .- no left - click there..." :slight_smile: ) which is not so effective. I > don't whant to revert to 1.0 either (I wonder if I could install both > versions at the same time and the same user account without interfering) > > Any perspective when that option is available again? > > Thanks and have Fun @FOSSDEM - which I have to miss again (it is a bit > far away from here :frowning: ) -- but at least, there are videos. > > Greetings from Berlin, Germany > Conrad > > > -- https://jitsi.org

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org


#3

Steps to reproduce bug:
1. Ask a friend to share a screen with you.
2. For the incoming call click the phone icon to answer (instead of the video icon)

Expected behavior: You should be able to see your friends screen and talk via audio.

Actual behavior: Screen preview area is black (apart from a white dot in the center).

Work around: accept the screen-sharing call as a video call (unfortunately this means you are also sending a video of yourself).

David


#4

Steps to reproduce bug:
1. Using a multi-monitor setup, share full screen with friend
2. Click "OK" to confirm
3. In the monitor selection dialog, click on the screen selection menu

Expected behavior: Screen selection menu should appear on top of the screen preview

Actual behavior: Menu appears (mostly) behind the screen preview (see attached)

Tested using Jitsi 1.1.4462.10430, Windows 7

David


#5

Steps to reproduce:
1. Ask a friend to share their screen with you
2. Ask your friend to check "Enable remote control"
3. Click on one window on your friend's screen
4. Click on the task bar to select another window

Expected behavior: The second click should affect the friend's screen.

Actual behavior: The friend reports that mouse arrow on their screen hasn't moved since the first click and is stuck on a "mouse-down" (evidently the "mouse-up" event never fired after the first click).

Tested using Jitsi 1.1.4462.10430, Windows 7
For what it's worth, I remember having the same problem with Jitsi 1.0.