[jitsi-dev] Pulseaudio changes volume to maximum values


#1

Hi Lyubomir, devs,

Each time a call begins/ends, or the Tools->Options->Audio panel is opened, then the pulseaudio audio system sets the volumes (input and output) to maximum values.

This is due to the call to PA.cvolume_set(cvolume, channels, volume):

- line 530 from
src/net/java/sip/communicator/impl/neomedia/jmfext/media/protocol/pulseaudio/DataSource.java

-line 475 from
src/net/java/sip/communicator/impl/neomedia/jmfext/media/renderer/audio/PulseAudioRenderer.java

I do not know (does not have tested yet), but it is maybe a problem with the gainControl level obtained or with the pulseaudio volume conversion from linear.

Anyway, a temporary fix is to deactivate these 2 lines.

Regards,
Vincent

···

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org


#2

Hello, Vincent!

Thank you very much for the report!

Are you saying that the volume is set system-wide and/or affects the
volume of other Jitsi input and output stream? If that's the case,
could I please ask you to open an issue in our tracker? Could you
please include details about your operating system and PulseAudio
version as well?

Regards,
Lyubomir

···

2012/6/4 Vincent Lucas <chenzo@jitsi.org>:

Each time a call begins/ends, or the Tools->Options->Audio panel is opened,
then the pulseaudio audio system sets the volumes (input and output) to
maximum values.


#3

Hi Lyubomir,

Each time a call begins/ends, or the Tools->Options->Audio panel is opened,
then the pulseaudio audio system sets the volumes (input and output) to
maximum values.

Hello, Vincent!

Thank you very much for the report!

Are you saying that the volume is set system-wide and/or affects the
volume of other Jitsi input and output stream?

The volume is modified system wide, but does not modify other Jitsi input/output streams.

For example, when creating a call the following changes occur:

From "pavucontrol" point of view:
- new) Playback - Jitsi: Phone (126%) - another call will not affect the volume set (even if the volume was manually re-set before the second call started).
- new) Recording - Jitsi: Phone (100%) - another call will not affect the volume set (even if the volume was manually re-set before the second call started).
- modified) OutputDevice - Built-in Audio Analog Stereo (26% --> 126%)

From "alsamixer" point of view:
modified) - Playback - master (40% --> 100%)
modified) - Playback - speaker (78% --> 100%)
modified) - Playback - PCM (80% --> 100%)
modified) - Capture - capture (14% --> 93%)
modified) - Capture - internal mic boost (20% --> 100%)

If that's the case,

could I please ask you to open an issue in our tracker?

Ok, I will open an issue this afternoon.

Could you

please include details about your operating system and PulseAudio
version as well?

Operating System: Linux debian with kernel 3.1.0-1-amd64
Pulseaudio: version 2.0-3, architecture amd64

Regards,
Lyubomir

Regards,
Vincent

···

On 06/04/2012 11:55 AM, Lyubomir Marinov wrote:

2012/6/4 Vincent Lucas<chenzo@jitsi.org>:

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org


#4

Lyubomir Marinov wrote:

Each time a call begins/ends, or the Tools->Options->Audio panel is opened,
then the pulseaudio audio system sets the volumes (input and output) to
maximum values.

I had the same issue on Debian testing with pulseaudio 2.0.

The solution that worked for me (commands issued in a terminal):

touch ~/.pulse/daemon.conf
echo "flat-volumes = no" > ~/.pulse/daemon.conf
pulseaudio -k ; pulseaudio --start

Note that any application that uses sound and its running will have to
be restarted (skype, etc).

···

2012/6/4 Vincent Lucas <chenzo@jitsi.org>:

--
O zi buna,
Kertesz Laszlo


#5

Hi Lubo

The issue is open: http://java.net/jira/browse/JITSI-1050

Do not hesitate if you need more information or some help for testing/debugging.

Cheers,
Vincent

···

On 06/04/2012 11:55 AM, Lyubomir Marinov wrote:

the report!

Are you saying that the volume is set system-wide and/or affects the
volume of other Jitsi input and output stream? If that's the case,
could I please ask you to open an issue in our tracker? Could you
please include details about your operating system and PulseAudio
version as well?

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org