[jitsi-dev] provisioning


#1

Hi,

There's some confusing behavior when provisioning properties such as:

net.java.sip.communicator.plugin.dnsconfig.DISABLED

and

net.java.sip.communicator.plugin.provisionconfig.DISABLED

Here's a sample of my properties:

net.java.sip.communicator.plugin.certconfig.DISABLED=true
net.java.sip.communicator.plugin.chatconfig.DISABLED=true
net.java.sip.communicator.plugin.contactsourceconfig.DISABLED=true
net.java.sip.communicator.plugin.dnsconfig.DISABLED=false
net.java.sip.communicator.plugin.generalconfig.STARTUP_DISABLED=false
net.java.sip.communicator.plugin.generalconfig.autoawayconfig.DISABLED=false
net.java.sip.communicator.plugin.generalconfig.callconfig.DISABLED=true
net.java.sip.communicator.plugin.generalconfig.localeconfig.DISABLED=false
net.java.sip.communicator.plugin.generalconfig.messageconfig.DISABLED=false
net.java.sip.communicator.plugin.generalconfig.notificationconfig.DISABLED=false
net.java.sip.communicator.plugin.generalconfig.opusconfig.DISABLED=true
net.java.sip.communicator.plugin.generalconfig.silkconfig.DISABLED=true
net.java.sip.communicator.plugin.generalconfig.sipconfig.DISABLED=true
net.java.sip.communicator.plugin.generalconfig.startupconfig.DISABLED=true
net.java.sip.communicator.plugin.globalproxyconfig.DISABLED=true
net.java.sip.communicator.plugin.keybindingsconfig.DISABLED=true
net.java.sip.communicator.plugin.loggingconfig.DISABLED=true
net.java.sip.communicator.plugin.notificationconfiguration.DISABLED=true
net.java.sip.communicator.plugin.provisionconfig.DISABLED=false
net.java.sip.communicator.plugin.sipconfig.DISABLED=false
net.java.sip.communicator.plugin.skinconfig.DISABLED=true

I'm expecting to see the DNS and the provisioning configuration forms in "advanced" menu.
However, I'm seeing the DNS form but not the provisioning panel.

Any ideas why?

Thanks,

Vieri


#2

There's some confusing behavior when provisioning properties such as:
[...]
net.java.sip.communicator.plugin.dnsconfig.DISABLED=false
net.java.sip.communicator.plugin.provisionconfig.DISABLED=false

I'm expecting to see the DNS and the provisioning configuration forms in
"advanced" menu.
However, I'm seeing the DNS form but not the provisioning panel.

Any ideas why?

Just tried that and it works as intended. Are you sure the properties were
applied to the client as you'd expect?

Thanks,
Vieri

Ingo


#3

Hi Ingo,

I copy&pasted the properties in my previous e-mail right from the client sip-communicator.properties file and right after provisioning. So the values were correctly provisioned but they didn't seem to apply as expected.

Anyway I'm in the process of moving to the latest nightly and according to Damian the provisioning properties that had the .DISABLED suffix have been replaced by .ENABLED and should all default to false.
If so then I'm glad you made this change because it will be somewhat easier to provision/maintain.

I'll post back if I have any trouble with the new builds.

Thanks,

Vieri

···

--- On Wed, 4/10/13, Ingo Bauersachs <ingo@jitsi.org> wrote:

> There's some confusing behavior
when provisioning properties such as:
> [...]
>
net.java.sip.communicator.plugin.dnsconfig.DISABLED=false
>
net.java.sip.communicator.plugin.provisionconfig.DISABLED=false
>
> I'm expecting to see the DNS and the provisioning
configuration forms in
> "advanced" menu.
> However, I'm seeing the DNS form but not the
provisioning panel.
>
> Any ideas why?

Just tried that and it works as intended. Are you sure the
properties were
applied to the client as you'd expect?


#4

Hi Vieri,

There's some confusing behavior

when provisioning properties such as:

[...]

net.java.sip.communicator.plugin.dnsconfig.DISABLED=false

net.java.sip.communicator.plugin.provisionconfig.DISABLED=false

I'm expecting to see the DNS and the provisioning

configuration forms in

"advanced" menu.
However, I'm seeing the DNS form but not the

provisioning panel.

Any ideas why?

Just tried that and it works as intended. Are you sure the
properties were
applied to the client as you'd expect?

Hi Ingo,

I copy&pasted the properties in my previous e-mail right from the client sip-communicator.properties file and right after provisioning. So the values were correctly provisioned but they didn't seem to apply as expected.

Anyway I'm in the process of moving to the latest nightly and according to Damian the provisioning properties that had the .DISABLED suffix have been replaced by .ENABLED and should all default to false.
If so then I'm glad you made this change because it will be somewhat easier to provision/maintain.

Actually what Damian meant is that we try to have a default value of "false", which means that for features that by default are disabled like the skin mechanism the property would be named XXX_ENABLED, but for properties related to functionalities enabled by default the property would be XXX_DISABLED.

Note that we haven't made a complete renaming! The only properties that have been changed lately are:

* net.java.sip.communicator.plugin.skinconfig.DISABLED -> net.java.sip.communicator.plugin.skinconfig.ENABLED

* net.java.sip.communicator.impl.gui.main.call.SHOW_CALL_RECORD_BUTTON -> net.java.sip.communicator.impl.gui.main.call.HIDE_CALL_RECORD_BUTTON

Hope this helps and sorry for the confusion.

Cheers,
Yana

···

On Apr 11, 2013, at 7:50 AM, Vieri <rentorbuy@yahoo.com> wrote:

--- On Wed, 4/10/13, Ingo Bauersachs <ingo@jitsi.org> wrote:

I'll post back if I have any trouble with the new builds.

Thanks,

Vieri


#5

Thanks Yana. No problem.

···

--- On Thu, 4/11/13, Yana Stamcheva <yana@jitsi.org> wrote:

Hi Vieri,

On Apr 11, 2013, at 7:50 AM, Vieri <rentorbuy@yahoo.com> > wrote:

>
>
> --- On Wed, 4/10/13, Ingo Bauersachs <ingo@jitsi.org> > wrote:
>
>>> There's some confusing behavior
>> when provisioning properties such as:
>>> [...]
>>>
>>
net.java.sip.communicator.plugin.dnsconfig.DISABLED=false
>>>
>>
net.java.sip.communicator.plugin.provisionconfig.DISABLED=false
>>>
>>> I'm expecting to see the DNS and the
provisioning
>> configuration forms in
>>> "advanced" menu.
>>> However, I'm seeing the DNS form but not the
>> provisioning panel.
>>>
>>> Any ideas why?
>>
>> Just tried that and it works as intended. Are you
sure the
>> properties were
>> applied to the client as you'd expect?
>
> Hi Ingo,
>
> I copy&pasted the properties in my previous e-mail
right from the client sip-communicator.properties file and
right after provisioning. So the values were correctly
provisioned but they didn't seem to apply as expected.
>
> Anyway I'm in the process of moving to the latest
nightly and according to Damian the provisioning properties
that had the .DISABLED suffix have been replaced by .ENABLED
and should all default to false.
> If so then I'm glad you made this change because it
will be somewhat easier to provision/maintain.

Actually what Damian meant is that we try to have a default
value of "false", which means that for features that by
default are disabled like the skin mechanism the property
would be named XXX_ENABLED, but for properties related to
functionalities enabled by default the property would be
XXX_DISABLED.

Note that we haven't made a complete renaming! The only
properties that have been changed lately are:

* net.java.sip.communicator.plugin.skinconfig.DISABLED
-> net.java.sip.communicator.plugin.skinconfig.ENABLED

*
net.java.sip.communicator.impl.gui.main.call.SHOW_CALL_RECORD_BUTTON
->
net.java.sip.communicator.impl.gui.main.call.HIDE_CALL_RECORD_BUTTON

Hope this helps and sorry for the confusion.

Cheers,
Yana

>
> I'll post back if I have any trouble with the new
builds.
>
> Thanks,
>
> Vieri