[jitsi-dev] Prosody memory increasing rapidly when used with jitsi-meet suite


#1

Hi Pawel,

I tested the latest version from prosody.im's apt repo (0.9.8-1~trusty2),
and I still see the leak. The leak is very obvious if you set the
statistics interval to a silly level, like 10ms:

/usr/share/jitsi-videobridge/.sip-communicator/sip-communicator.properties
org.jitsi.videobridge.STATISTICS_INTERVAL=10

···

From: Paweł Domas <pawel.domas@jitsi.org>

Date: 17 August 2015 at 03:33
Subject: Re: [jitsi-dev] Prosody memory increasing rapidly when used with
jitsi-meet suite
To: Jitsi Developers <dev@jitsi.org>

Hi Simon,

Try updating Prosody - it fixed the problem for me. I belive there was
some bug in PubSub.

Regards,
Pawel

On Fri, Aug 14, 2015 at 7:06 PM, Simon Ditner <spditner@gmail.com> wrote:
> Hi,
>
> I've been performing some basic load testing with jitsi-meet, and while
> monitoring memory usage, I noticed that Prosody seems to be consuming
memory
> very quickly. Over 24 hours it was consuming 1GB of ram. This morning I
> started fresh, and ran a few scenarios, where I set no traffic, prosody,
> jicofo and jitsi-videobridge are idle, and I'm seeing prosody chew up
quite
> a bit of ram when using enabling PubSub for clustering.
>
> I'm not too familiar with XMPP PubSub, but it seems there is either a
bug in
> how jicofo and jitsi-videobridge are using PubSub, or there is a bug in
> Prosody's PubSub module.
>
> ---
>
> Senario 1 - cluster of 2 video bridges using PubSub, restarted all
processes
>
> Setup:
> server A running jvb, jicofo, prosody, nginx
> server B running jvb registered with A
>
> Software Versions:
> prosody: 0.9.1-1
> jitsi-videobridge: 491-1
> jicofo: 1.0-117-1
>
> Over 40 minutes, prosody was using 7 times it's earlier usage:
>
> Prosody Memory Usage:
>
> Time VSZ RSS
> 2015-08-14 10:17:06 49528 7888
> 2015-08-14 10:27:06 59948 18348
> 2015-08-14 10:37:06 74664 32992
> 2015-08-14 10:47:06 85892 44344
> 2015-08-14 10:57:06 101596 59920
>
> ---
>
> Senario 2 - rebooting, zero traffic, pubsub disabled in jicofo and
> jitsi-videobridge
>
> Setup:
> server A running jvb, jicofo, prosody, nginx
>
> Prosody Memory Usage:
>
> Time VSZ RSS
> 2015-08-14 11:22:55 49308 7676
> 2015-08-14 11:32:55 51552 9832
> 2015-08-14 11:42:55 51948 10368
> 2015-08-14 11:52:55 51948 10368
> 2015-08-14 12:02:55 51948 10368
> 2015-08-14 12:11:55 51948 10368
> <Enabled pubsub and restarted jicofo and jitis-videobridge>
> 2015-08-14 12:22:56 54852 13060
> 2015-08-14 12:32:56 72036 30380
> 2015-08-14 12:42:56 77724 35924
> 2015-08-14 12:52:56 83828 42260
> 2015-08-14 13:02:56 100452 58856
>
> ---
>
> Scenario 3 - Baseline comparision, a clean digital ocean instance I
started
> up just to monitor memory usage
>
> Setup:
> -completely- clean quick install of jitsi-meet, no clustering or pubsub
> server running jvb, jicofo, prosody, nginx
>
> Prosody Memory Usage:
>
> 2015-08-14 11:23:46 48060 6336
> 2015-08-14 11:33:46 49248 7680
> 2015-08-14 11:43:46 49248 7680
> 2015-08-14 11:53:46 50700 9000
> 2015-08-14 12:03:46 50700 9000
> 2015-08-14 12:13:46 50700 9000
> 2015-08-14 12:23:46 50700 9000
> 2015-08-14 12:33:46 50700 9000
> 2015-08-14 12:43:47 50700 9000
> 2015-08-14 12:53:47 50700 9000
> 2015-08-14 13:03:47 50700 9000
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#2

Hi,

···

On Wed, Aug 26, 2015 at 6:30 PM, Simon Ditner <spditner@gmail.com> wrote:

Hi Pawel,

I tested the latest version from prosody.im's apt repo (0.9.8-1~trusty2),
and I still see the leak. The leak is very obvious if you set the statistics
interval to a silly level, like 10ms:

/usr/share/jitsi-videobridge/.sip-communicator/sip-communicator.properties
org.jitsi.videobridge.STATISTICS_INTERVAL=10

I know that this[1] version worked. If it does not it means we may
have introduced some bug recently.

[1]: http://prosody.im/nightly/trunk/build546/

Regards,
Pawel


#3

Yes! It works, the memory usage in trunk_1nightly546-1~trusty_amd64 is
stable -- thank you.

Will it be the official stable version in the near future? The package name
(prosody-trunk) conflicts with the debian package, which is a tad annoying,
as I have to forcibly break dependencies to get it installed along side
jitsi-meet.

Simon P. Ditner <simon@uc.org>

http://www.facebook.com/spditner
http://www.linkedin.com/in/spditner

···

On Wed, Aug 26, 2015 at 12:35 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

Hi,

On Wed, Aug 26, 2015 at 6:30 PM, Simon Ditner <spditner@gmail.com> wrote:
> Hi Pawel,
>
> I tested the latest version from prosody.im's apt repo
(0.9.8-1~trusty2),
> and I still see the leak. The leak is very obvious if you set the
statistics
> interval to a silly level, like 10ms:
>
>
/usr/share/jitsi-videobridge/.sip-communicator/sip-communicator.properties
> org.jitsi.videobridge.STATISTICS_INTERVAL=10

I know that this[1] version worked. If it does not it means we may
have introduced some bug recently.

[1]: http://prosody.im/nightly/trunk/build546/

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev