[jitsi-dev] prosody for jitsi-meet on different than 5222 port


#1

Hi Jitsi Developers.

we are using 2 different xmpp servers on our server and i'm trying to configure prosody on different port.

i've found documentation for prosody https://prosody.im/doc/ports and made records in prosody config c2s_ports = { 5224, 5324 }

prosody starts well but jitsi-meet doesn't work.

how to configure jitsi-meet for working with prosody if prosody configured on different than 5222 port?

thanks.

--�
� ���������,
���� ��������
+375 (29) 9350117
admin@medicine-prof.com


#2

Hi,

Jitsi meet doesn’t really connect directly to prosody, it connects to it through BOSH. Also, if you followed the quick install method, or the manual install method, nginx proxies all the requests to `/http-bind` to localhost:5280. So, your XMPP server can listen on whichever port, all this should be transparent to Jitsi meet, it just uses /http-bind for BOSH XMPP.

Hope this helps.

Best,
George

···

On Oct 18, 2015, at 5:09 AM, Юрий Лапытько <admin@medicine-prof.com> wrote:

Hi Jitsi Developers.

we are using 2 different xmpp servers on our server and i'm trying to configure prosody on different port.

i've found documentation for prosody https://prosody.im/doc/ports and made records in prosody config c2s_ports = { 5224, 5324 }

prosody starts well but jitsi-meet doesn't work.

how to configure jitsi-meet for working with prosody if prosody configured on different than 5222 port?

thanks.

--
С уважением,
Юрий Лапытько
+375 (29) 9350117
admin@medicine-prof.com

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

I think Jicofo uses port 5222. Unfortunately, I have no idea how to make it use another port.

Boris

···

On 18/10/15 11:50, George Politis wrote:

Hi,

Jitsi meet doesn’t really connect directly to prosody, it connects to
it through BOSH. Also, if you followed the quick install method, or
the manual install method, nginx proxies all the requests to
`/http-bind` to localhost:5280. So, your XMPP server can listen on
whichever port, all this should be transparent to Jitsi meet, it just
uses /http-bind for BOSH XMPP.


#4

i see this log in jicofo.log but how to change this port setting:

Oct 18, 2015 6:29:27 AM net.java.sip.communicator.util.Logger error
SEVERE: net.java.sip.communicator.service.protocol.OperationFailedException: Failed to connect
net.java.sip.communicator.service.protocol.OperationFailedException: Failed to connect
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:182)
        at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:49)
Caused by: XMPPError connecting to localhost:5222.: remote-server-error(502) XMPPError connecting to localhost:5222.
  -- caused by: java.net.ConnectException: Connection refused
        at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection.java:529)
        at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:968)
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:164)
        ... 1 more

···

18.10.2015, 21:29, "Boris Grozev" <boris@jitsi.org>:

On 18/10/15 11:50, George Politis wrote:

Hi,

Jitsi meet doesn’t really connect directly to prosody, it connects to
it through BOSH. Also, if you followed the quick install method, or
the manual install method, nginx proxies all the requests to
`/http-bind` to localhost:5280. So, your XMPP server can listen on
whichever port, all this should be transparent to Jitsi meet, it just
uses /http-bind for BOSH XMPP.

I think Jicofo uses port 5222. Unfortunately, I have no idea how to make
it use another port.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
С уважением,
Юрий Лапытько
+375 (29) 9350117
admin@medicine-prof.com