[jitsi-dev] Problems in jitsi-hammer


#1

Hi

I'm trying to run jitsi-hammer in my env, finding a way to understand what
I can do to optimize my server.

I cloned the project, added java 8 and mvn, and when tried to run it,
returned the same reported in
https://github.com/jitsi/jitsi-hammer/issues/17.

Follow the log:

$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
[INFO] Scanning for projects...
[INFO]

[INFO]

···

------------------------------------------------------------------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO]
------------------------------------------------------------------------
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is
invalid, transitive dependencies (if any) will not be available, enable
debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is
invalid, transitive dependencies (if any) will not be available, enable
debug logging for more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @
jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory
/home/filhocf/git/jitsi-hammer/src/main/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @
jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to
/home/filhocf/git/jitsi-hammer/target/classes
[INFO]
/home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/SsrcPacketExtension.java:
Some input files use or override a deprecated API.
[INFO]
/home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/SsrcPacketExtension.java:
Recompile with -Xlint:deprecation for details.
[INFO]
/home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
/home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java
uses unchecked or unsafe operations.
[INFO]
/home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
Recompile with -Xlint:unchecked for details.
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 1.742 s
[INFO] Finished at: 2017-06-08T11:00:36-03:00
[INFO] Final Memory: 22M/306M
[INFO]
------------------------------------------------------------------------
[INFO] Scanning for projects...
Downloading:
https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-maven-plugin/1.4.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin
org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could
not be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plugin/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin
org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-surefire-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-install-plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-install-plugin:2.5.2: Plugin
org.apache.maven.plugins:maven-install-plugin:2.5.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-install-plugin:jar:2.5.2
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-deploy-plugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin
org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-site-plugin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-site-plugin:3.3: Plugin
org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-site-plugin:jar:3.3
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-antrun-plugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-antrun-plugin:1.7: Plugin
org.apache.maven.plugins:maven-antrun-plugin:1.7 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-antrun-plugin:jar:1.7
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-assembly-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-assembly-plugin:2.4.1: Plugin
org.apache.maven.plugins:maven-assembly-plugin:2.4.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-dependency-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-dependency-plugin:2.8: Plugin
org.apache.maven.plugins:maven-dependency-plugin:2.8 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-dependency-plugin:jar:2.8
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-release-plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-release-plugin:2.3.2: Plugin
org.apache.maven.plugins:maven-release-plugin:2.3.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-release-plugin:jar:2.3.2
Downloading:
https://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/3.0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.felix:maven-bundle-plugin:3.0.0: Plugin
org.apache.felix:maven-bundle-plugin:3.0.0 or one of its dependencies could
not be resolved: Failed to read artifact descriptor for
org.apache.felix:maven-bundle-plugin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin
org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-plugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-source-plugin:2.4: Plugin
org.apache.maven.plugins:maven-source-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-source-plugin:jar:2.4
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-javadoc-plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-javadoc-plugin:2.10.3: Plugin
org.apache.maven.plugins:maven-javadoc-plugin:2.10.3 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin
org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin
org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could
not be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading:
https://repo.maven.apache.org/maven2/org/sonatype/plugins/nexus-staging-maven-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6: Plugin
org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.sonatype.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-gpg-plugin/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-gpg-plugin:1.6: Plugin
org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-gpg-plugin:jar:1.6
Downloading:
https://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata.xml
[WARNING] Could not transfer metadata
org.apache.maven.plugins/maven-metadata.xml from/to central (
https://repo.maven.apache.org/maven2): java.lang.RuntimeException:
Unexpected error: java.security.InvalidAlgorithmParameterException: the
trustAnchors parameter must be non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml
from/to central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected error:
java.security.InvalidAlgorithmParameterException: the trustAnchors
parameter must be non-empty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml
from https://repo.maven.apache.org/maven2 was cached in the local
repository, resolution will not be reattempted until the update interval of
central has elapsed or updates are forced. Original error: Could not
transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to
central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException:
Unexpected error: java.security.InvalidAlgorithmParameterException: the
trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from
https://repo.maven.apache.org/maven2 was cached in the local repository,
resolution will not be reattempted until the update interval of central has
elapsed or updates are forced. Original error: Could not transfer metadata
org.codehaus.mojo/maven-metadata.xml from/to central (
https://repo.maven.apache.org/maven2): java.lang.RuntimeException:
Unexpected error: java.security.InvalidAlgorithmParameterException: the
trustAnchors parameter must be non-empty
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 14.705 s
[INFO] Finished at: 2017-06-08T11:00:52-03:00
[INFO] Final Memory: 10M/303M
[INFO]
------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'exec' in the current project and in the
plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available from
the repositories [local (/home/filhocf/.m2/repository), central (
https://repo.maven.apache.org/maven2)] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixException

---------

Any idea?

Since now, thanks by any help.

Regards,
Claudio


#2

Hi Claudio, have you tried the suggestion in the issue that you linked?

···

On Jun 8, 2017, at 9:30 AM, Claudio Ferreia Filho <filhocf@gmail.com> wrote:

Hi

I'm trying to run jitsi-hammer in my env, finding a way to understand what I can do to optimize my server.

I cloned the project, added java 8 and mvn, and when tried to run it, returned the same reported in https://github.com/jitsi/jitsi-hammer/issues/17.

Follow the log:

$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/filhocf/git/jitsi-hammer/src/main/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @ jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to /home/filhocf/git/jitsi-hammer/target/classes
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/SsrcPacketExtension.java: Some input files use or override a deprecated API.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/SsrcPacketExtension.java: Recompile with -Xlint:deprecation for details.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java uses unchecked or unsafe operations.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: Recompile with -Xlint:unchecked for details.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.742 s
[INFO] Finished at: 2017-06-08T11:00:36-03:00
[INFO] Final Memory: 22M/306M
[INFO] ------------------------------------------------------------------------
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-maven-plugin/1.4.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plugin/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-surefire-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-install-plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-install-plugin:2.5.2: Plugin org.apache.maven.plugins:maven-install-plugin:2.5.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-install-plugin:jar:2.5.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-deploy-plugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-site-plugin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-site-plugin:3.3: Plugin org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-site-plugin:jar:3.3
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-antrun-plugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-antrun-plugin:1.7: Plugin org.apache.maven.plugins:maven-antrun-plugin:1.7 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-antrun-plugin:jar:1.7
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-assembly-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-assembly-plugin:2.4.1: Plugin org.apache.maven.plugins:maven-assembly-plugin:2.4.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-dependency-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-dependency-plugin:2.8: Plugin org.apache.maven.plugins:maven-dependency-plugin:2.8 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-dependency-plugin:jar:2.8
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-release-plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-release-plugin:2.3.2: Plugin org.apache.maven.plugins:maven-release-plugin:2.3.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-release-plugin:jar:2.3.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/3.0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.felix:maven-bundle-plugin:3.0.0: Plugin org.apache.felix:maven-bundle-plugin:3.0.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.felix:maven-bundle-plugin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-plugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-source-plugin:2.4: Plugin org.apache.maven.plugins:maven-source-plugin:2.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-source-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-javadoc-plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-javadoc-plugin:2.10.3: Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.10.3 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/sonatype/plugins/nexus-staging-maven-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6: Plugin org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.sonatype.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-gpg-plugin/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-gpg-plugin:1.6: Plugin org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-gpg-plugin:jar:1.6
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata.xml
[WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml from https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 14.705 s
[INFO] Finished at: 2017-06-08T11:00:52-03:00
[INFO] Final Memory: 10M/303M
[INFO] ------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'exec' in the current project and in the plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available from the repositories [local (/home/filhocf/.m2/repository), central (https://repo.maven.apache.org/maven2)] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixException

---------

Any idea?

Since now, thanks by any help.

Regards,
Claudio
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi George.

Yes, I did.

Now, returns:
$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
Error: Could not find or load main class org.jitsi.hammer.Main

···

2017-06-08 12:20 GMT-03:00 George Politis <gp@jitsi.org>:

Hi Claudio, have you tried the suggestion in the issue that you linked?

On Jun 8, 2017, at 9:30 AM, Claudio Ferreia Filho <filhocf@gmail.com> > wrote:

Hi

I'm trying to run jitsi-hammer in my env, finding a way to understand what
I can do to optimize my server.

I cloned the project, added java 8 and mvn, and when tried to run it,
returned the same reported in https://github.com/jitsi/
jitsi-hammer/issues/17.

Follow the log:

$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
[INFO] Scanning for projects...
[INFO]

[INFO] ------------------------------------------------------------
------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------
------------
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is
invalid, transitive dependencies (if any) will not be available, enable
debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is
invalid, transitive dependencies (if any) will not be available, enable
debug logging for more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @
jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/filhocf/git/jitsi-
hammer/src/main/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @
jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to /home/filhocf/git/jitsi-
hammer/target/classes
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/
jitsi/hammer/extension/SsrcPacketExtension.java: Some input files use or
override a deprecated API.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/
jitsi/hammer/extension/SsrcPacketExtension.java: Recompile with
-Xlint:deprecation for details.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/
sip/communicator/impl/protocol/jabber/extensions/jingle/
NewAbstractExtensionElement.java: /home/filhocf/git/jitsi-
hammer/src/main/java/net/java/sip/communicator/impl/
protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java uses
unchecked or unsafe operations.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/
sip/communicator/impl/protocol/jabber/extensions/jingle/
NewAbstractExtensionElement.java: Recompile with -Xlint:unchecked for
details.
[INFO] ------------------------------------------------------------
------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------
------------
[INFO] Total time: 1.742 s
[INFO] Finished at: 2017-06-08T11:00:36-03:00
[INFO] Final Memory: 22M/306M
[INFO] ------------------------------------------------------------
------------
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-
maven-plugin/1.4.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin
org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-jar-plugin/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin
org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-surefire-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-install-plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-install-plugin:2.5.2: Plugin
org.apache.maven.plugins:maven-install-plugin:2.5.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-install-plugin:jar:2.5.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-deploy-plugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin
org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-site-plugin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-site-plugin:3.3: Plugin
org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-site-plugin:jar:3.3
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-antrun-plugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-antrun-plugin:1.7: Plugin
org.apache.maven.plugins:maven-antrun-plugin:1.7 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-antrun-plugin:jar:1.7
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-assembly-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-assembly-plugin:2.4.1: Plugin
org.apache.maven.plugins:maven-assembly-plugin:2.4.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-dependency-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-dependency-plugin:2.8: Plugin
org.apache.maven.plugins:maven-dependency-plugin:2.8 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-dependency-plugin:jar:2.8
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-release-plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-release-plugin:2.3.2: Plugin
org.apache.maven.plugins:maven-release-plugin:2.3.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-release-plugin:jar:2.3.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/felix/maven-
bundle-plugin/3.0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.felix:maven-bundle-plugin:3.0.0: Plugin
org.apache.felix:maven-bundle-plugin:3.0.0 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.felix:maven-bundle-plugin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin
org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-source-plugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-source-plugin:2.4: Plugin
org.apache.maven.plugins:maven-source-plugin:2.4 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-source-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-javadoc-plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-javadoc-plugin:2.10.3: Plugin
org.apache.maven.plugins:maven-javadoc-plugin:2.10.3 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin
org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin
org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/sonatype/plugins/
nexus-staging-maven-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6: Plugin
org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.sonatype.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-gpg-plugin/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-gpg-plugin:1.6: Plugin
org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-gpg-plugin:jar:1.6
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/
maven-metadata.xml
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-metadata.xml
[WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml
from/to central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected error: java.security.
InvalidAlgorithmParameterException: the trustAnchors parameter must be
non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml
from/to central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected error: java.security.
InvalidAlgorithmParameterException: the trustAnchors parameter must be
non-empty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml
from https://repo.maven.apache.org/maven2 was cached in the local
repository, resolution will not be reattempted until the update interval of
central has elapsed or updates are forced. Original error: Could not
transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to
central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected error: java.security.
InvalidAlgorithmParameterException: the trustAnchors parameter must be
non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from
https://repo.maven.apache.org/maven2 was cached in the local repository,
resolution will not be reattempted until the update interval of central has
elapsed or updates are forced. Original error: Could not transfer metadata
org.codehaus.mojo/maven-metadata.xml from/to central (
https://repo.maven.apache.org/maven2): java.lang.RuntimeException:
Unexpected error: java.security.InvalidAlgorithmParameterException: the
trustAnchors parameter must be non-empty
[INFO] ------------------------------------------------------------
------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------
------------
[INFO] Total time: 14.705 s
[INFO] Finished at: 2017-06-08T11:00:52-03:00
[INFO] Final Memory: 10M/303M
[INFO] ------------------------------------------------------------
------------
[ERROR] No plugin found for prefix 'exec' in the current project and in
the plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available
from the repositories [local (/home/filhocf/.m2/repository), central (
https://repo.maven.apache.org/maven2)] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the
-e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/
NoPluginFoundForPrefixException

---------

Any idea?

Since now, thanks by any help.

Regards,
Claudio
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Is the SIP Dialer an option in the current Jitsi-meet release.
Only see the standard PSTN dial option.


#5

The sip dial was just renamed as dial.
There is a known problem which we will be fixing soon, where if
dialOutCodes Url is not configured you will not see the country code
option. But this dialog still uses the same code to call jigasi.

···

On Thu, Jun 8, 2017 at 10:55 AM, <royblog@comcast.net> wrote:

Is the SIP Dialer an option in the current Jitsi-meet release.
Only see the standard PSTN dial option.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Hi

Following with my tests, hasn't possible to download a lot of things. I
tried in my job, that have a proxy (and I think that could be a problem
with proxy), and in my home, with a good connection. Also without success.

Someone did a recent clone and tried to run the jitsi-hammer.sh script in a
clean env? If yes and with success, could share your settings.xml?

Since now, thanks by any suggestion.

Regards,
Claudio Ferreira

---- logs -----
$ ./jitsi-hammer.sh -e -X https://myserver.com/myroom
./jitsi-hammer.sh: linha 17: [: =: expected a unary operator
[INFO] Scanning for projects...
[INFO]

[INFO]

···

------------------------------------------------------------------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO]
------------------------------------------------------------------------
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is
invalid, transitive d
ependencies (if any) will not be available, enable debug logging for more
details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is
invalid, transitiv
e dependencies (if any) will not be available, enable debug logging for
more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/Dropbox/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @
jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory
/home/filhocf/Dropbox/git/jitsi-hammer/src/mai
n/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @
jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to
/home/filhocf/Dropbox/git/jitsi-hammer/target/classes
[INFO]
/home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Some input files use or override a deprecated API.
[INFO]
/home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Recompile with -Xlint:deprecation for details.
[INFO]
/home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
/home/filhocf/Dropb
ox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensio
ns/jingle/NewAbstractExtensionElement.java uses unchecked or unsafe
operations.
[INFO]
/home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
Recompile with -Xli
nt:unchecked for details.
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 2.964 s
[INFO] Finished at: 2017-06-09T19:43:56-03:00
[INFO] Final Memory: 22M/265M
[INFO]
------------------------------------------------------------------------
[INFO] Scanning for projects...
Downloading:
https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-maven-plugin/1.4
.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its
dependencies could no
t be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plug
in/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its
dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-surefire
-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor
for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-install-
plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-install
-plugin:2.5.2: Plugin org.apache.maven.plugins:maven-install-plugin:2.5.2
or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for
org.apache.mave
n.plugins:maven-install-plugin:jar:2.5.2
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-deploy-p
lugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or
one of its dep
endencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-site-plu
gin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-site-pl
ugin:3.3: Plugin org.apache.maven.plugins:maven-site-plugin:3.3 or one of
its dependencie
s could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:
maven-site-plugin:jar:3.3
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-antrun-p
lugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-antrun-
plugin:1.7: Plugin org.apache.maven.plugins:maven-antrun-plugin:1.7 or one
of its depende
ncies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plug
ins:maven-antrun-plugin:jar:1.7
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-assembly
-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-assembl
y-plugin:2.4.1: Plugin org.apache.maven.plugins:maven-assembly-plugin:2.4.1
or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.ma
ven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-dependen
cy-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-depende
ncy-plugin:2.8: Plugin org.apache.maven.plugins:maven-dependency-plugin:2.8
or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.ma
ven.plugins:maven-dependency-plugin:jar:2.8
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-release-
plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-release
-plugin:2.3.2: Plugin org.apache.maven.plugins:maven-release-plugin:2.3.2
or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for
org.apache.mave
n.plugins:maven-release-plugin:jar:2.3.2
Downloading:
https://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/3.
0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.felix:maven-bundle-plugin:3
.0.0: Plugin org.apache.felix:maven-bundle-plugin:3.0.0 or one of its
dependencies could
not be resolved: Failed to read artifact descriptor for
org.apache.felix:maven-bundle-plu
gin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its
dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-p
lugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-source-
plugin:2.4: Plugin org.apache.maven.plugins:maven-source-plugin:2.4 or one
of its depende
ncies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plug
ins:maven-source-plugin:jar:2.4
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-javadoc-
plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-javadoc
-plugin:2.10.3: Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.10.3
or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.ma
ven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor
for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or
one of its dep
endencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its
dependencies could no
t be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading:
https://repo.maven.apache.org/maven2/org/sonatype/plugins/nexus-staging-mave
n-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.sonatype.plugins:nexus-staging-mav
en-plugin:1.6.6: Plugin
org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor
for org.sonatyp
e.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-gpg-plug
in/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-gpg-plu
gin:1.6: Plugin org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its
dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:ma
ven-gpg-plugin:jar:1.6
Downloading:
https://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata
.xml
[WARNING] Could not transfer metadata
org.apache.maven.plugins/maven-metadata.xml from/to
central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException:
Unexpected e
rror: java.security.InvalidAlgorithmParameterException: the trustAnchors
parameter must b
e non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml
from/to centra
l (https://repo.maven.apache.org/maven2): java.lang.RuntimeException:
Unexpected error: j
ava.security.InvalidAlgorithmParameterException: the trustAnchors parameter
must be non-e
mpty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml
from https://re
po.maven.apache.org/maven2 was cached in the local repository, resolution
will not be rea
ttempted until the update interval of central has elapsed or updates are
forced. Original
error: Could not transfer metadata
org.apache.maven.plugins/maven-metadata.xml from/to c
entral (https://repo.maven.apache.org/maven2): java.lang.RuntimeException:
Unexpected err
or: java.security.InvalidAlgorithmParameterException: the trustAnchors
parameter must be
non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from
https://repo.mave
n.apache.org/maven2 was cached in the local repository, resolution will not
be reattempte
d until the update interval of central has elapsed or updates are forced.
Original error:
Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to
central (https:
//repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected
error: java.secur
ity.InvalidAlgorithmParameterException: the trustAnchors parameter must be
non-empty
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 6.828 s
[INFO] Finished at: 2017-06-09T19:44:04-03:00
[INFO] Final Memory: 9M/150M
[INFO]
------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'exec' in the current project and in the
plugin groups
[org.apache.maven.plugins, org.codehaus.mojo] available from the
repositories [local (/h
ome/filhocf/.m2/repository), central (https://repo.maven.apache.org/maven2)]
-> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the fol
lowing articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixE
xception

2017-06-08 13:55 GMT-03:00 Claudio Ferreia Filho <filhocf@gmail.com>:

Hi George.

Yes, I did.

Now, returns:
$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
Error: Could not find or load main class org.jitsi.hammer.Main

2017-06-08 12:20 GMT-03:00 George Politis <gp@jitsi.org>:

Hi Claudio, have you tried the suggestion in the issue that you linked?

On Jun 8, 2017, at 9:30 AM, Claudio Ferreia Filho <filhocf@gmail.com> >> wrote:

Hi

I'm trying to run jitsi-hammer in my env, finding a way to understand
what I can do to optimize my server.

I cloned the project, added java 8 and mvn, and when tried to run it,
returned the same reported in https://github.com/jitsi/ji
tsi-hammer/issues/17.

Follow the log:

$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
[INFO] Scanning for projects...
[INFO]

[INFO] ------------------------------------------------------------
------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------
------------
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is
invalid, transitive dependencies (if any) will not be available, enable
debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is
invalid, transitive dependencies (if any) will not be available, enable
debug logging for more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @
jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/filhocf/git/jitsi-hammer
/src/main/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @
jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to /home/filhocf/git/jitsi-hammer
/target/classes
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/
hammer/extension/SsrcPacketExtension.java: Some input files use or
override a deprecated API.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/
hammer/extension/SsrcPacketExtension.java: Recompile with
-Xlint:deprecation for details.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/
communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
/home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/
communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java
uses unchecked or unsafe operations.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/
communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
Recompile with -Xlint:unchecked for details.
[INFO] ------------------------------------------------------------
------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------
------------
[INFO] Total time: 1.742 s
[INFO] Finished at: 2017-06-08T11:00:36-03:00
[INFO] Final Memory: 22M/306M
[INFO] ------------------------------------------------------------
------------
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-
maven-plugin/1.4.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin
org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-jar-plugin/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin
org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-surefire-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-install-plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-install-plugin:2.5.2: Plugin
org.apache.maven.plugins:maven-install-plugin:2.5.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-install-plugin:jar:2.5.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-deploy-plugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin
org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-site-plugin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-site-plugin:3.3: Plugin
org.apache.maven.plugins:maven-site-plugin:3.3 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-site-plugin:jar:3.3
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-antrun-plugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-antrun-plugin:1.7: Plugin
org.apache.maven.plugins:maven-antrun-plugin:1.7 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-antrun-plugin:jar:1.7
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-assembly-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-assembly-plugin:2.4.1: Plugin
org.apache.maven.plugins:maven-assembly-plugin:2.4.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-dependency-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-dependency-plugin:2.8: Plugin
org.apache.maven.plugins:maven-dependency-plugin:2.8 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-dependency-plugin:jar:2.8
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-release-plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-release-plugin:2.3.2: Plugin
org.apache.maven.plugins:maven-release-plugin:2.3.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-release-plugin:jar:2.3.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/felix/maven-
bundle-plugin/3.0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.felix:maven-bundle-plugin:3.0.0: Plugin
org.apache.felix:maven-bundle-plugin:3.0.0 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.felix:maven-bundle-plugin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin
org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-source-plugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-source-plugin:2.4: Plugin
org.apache.maven.plugins:maven-source-plugin:2.4 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-source-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-javadoc-plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-javadoc-plugin:2.10.3: Plugin
org.apache.maven.plugins:maven-javadoc-plugin:2.10.3 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin
org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin
org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/sonatype/plugins/ne
xus-staging-maven-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6: Plugin
org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.sonatype.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-gpg-plugin/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-gpg-plugin:1.6: Plugin
org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-gpg-plugin:jar:1.6
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/maven
-metadata.xml
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugin
s/maven-metadata.xml
[WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml
from/to central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException:
the trustAnchors parameter must be non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml
from/to central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException:
the trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml
from https://repo.maven.apache.org/maven2 was cached in the local
repository, resolution will not be reattempted until the update interval of
central has elapsed or updates are forced. Original error: Could not
transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to
central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException:
the trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from
https://repo.maven.apache.org/maven2 was cached in the local repository,
resolution will not be reattempted until the update interval of central has
elapsed or updates are forced. Original error: Could not transfer metadata
org.codehaus.mojo/maven-metadata.xml from/to central (
https://repo.maven.apache.org/maven2): java.lang.RuntimeException:
Unexpected error: java.security.InvalidAlgorithmParameterException: the
trustAnchors parameter must be non-empty
[INFO] ------------------------------------------------------------
------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------
------------
[INFO] Total time: 14.705 s
[INFO] Finished at: 2017-06-08T11:00:52-03:00
[INFO] Final Memory: 10M/303M
[INFO] ------------------------------------------------------------
------------
[ERROR] No plugin found for prefix 'exec' in the current project and in
the plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available
from the repositories [local (/home/filhocf/.m2/repository), central (
https://repo.maven.apache.org/maven2)] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the
-e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/conflu
ence/display/MAVEN/NoPluginFoundForPrefixException

---------

Any idea?

Since now, thanks by any help.

Regards,
Claudio
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Hi Claudio,

I’m not sure what the -X and -e parameters do but the correct syntax is:

    ./jitsi-hammer.sh -u https://myserver.com/http-bind -room myroom

I’ve made a PR that attempts to fix issue 17 (the one that you linked in your first email).

Could you please use the correct syntax and my PR and see if it works better for you?

I hope this helps.

Best,
George

···

On Jun 9, 2017, at 6:02 PM, Claudio Ferreia Filho <filhocf@gmail.com> wrote:

Hi

Following with my tests, hasn't possible to download a lot of things. I tried in my job, that have a proxy (and I think that could be a problem with proxy), and in my home, with a good connection. Also without success.

Someone did a recent clone and tried to run the jitsi-hammer.sh script in a clean env? If yes and with success, could share your settings.xml?

Since now, thanks by any suggestion.

Regards,
Claudio Ferreira

---- logs -----
$ ./jitsi-hammer.sh -e -X https://myserver.com/myroom
./jitsi-hammer.sh: linha 17: [: =: expected a unary operator
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive d
ependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitiv
e dependencies (if any) will not be available, enable debug logging for more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/Dropbox/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/filhocf/Dropbox/git/jitsi-hammer/src/mai
n/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @ jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to /home/filhocf/Dropbox/git/jitsi-hammer/target/classes
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Some input files use or override a deprecated API.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Recompile with -Xlint:deprecation for details.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: /home/filhocf/Dropb
ox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensio
ns/jingle/NewAbstractExtensionElement.java uses unchecked or unsafe operations.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: Recompile with -Xli
nt:unchecked for details.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.964 s
[INFO] Finished at: 2017-06-09T19:43:56-03:00
[INFO] Final Memory: 22M/265M
[INFO] ------------------------------------------------------------------------
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-maven-plugin/1.4
.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could no
t be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plug
in/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-surefire
-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-install-
plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-install
-plugin:2.5.2: Plugin org.apache.maven.plugins:maven-install-plugin:2.5.2 or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for org.apache.mave
n.plugins:maven-install-plugin:jar:2.5.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-deploy-p
lugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dep
endencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-site-plu
gin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-site-pl
ugin:3.3: Plugin org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencie
s could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:
maven-site-plugin:jar:3.3
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-antrun-p
lugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-antrun-
plugin:1.7: Plugin org.apache.maven.plugins:maven-antrun-plugin:1.7 or one of its depende
ncies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plug
ins:maven-antrun-plugin:jar:1.7
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-assembly
-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-assembl
y-plugin:2.4.1: Plugin org.apache.maven.plugins:maven-assembly-plugin:2.4.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for org.apache.ma <http://org.apache.ma/>
ven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-dependen
cy-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-depende
ncy-plugin:2.8: Plugin org.apache.maven.plugins:maven-dependency-plugin:2.8 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for org.apache.ma <http://org.apache.ma/>
ven.plugins:maven-dependency-plugin:jar:2.8
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-release-
plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-release
-plugin:2.3.2: Plugin org.apache.maven.plugins:maven-release-plugin:2.3.2 or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for org.apache.mave
n.plugins:maven-release-plugin:jar:2.3.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/3.
0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.felix:maven-bundle-plugin:3
.0.0: Plugin org.apache.felix:maven-bundle-plugin:3.0.0 or one of its dependencies could
not be resolved: Failed to read artifact descriptor for org.apache.felix:maven-bundle-plu
gin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-p
lugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-source-
plugin:2.4: Plugin org.apache.maven.plugins:maven-source-plugin:2.4 or one of its depende
ncies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plug
ins:maven-source-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-javadoc-
plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-javadoc
-plugin:2.10.3: Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.10.3 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for org.apache.ma <http://org.apache.ma/>
ven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dep
endencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could no
t be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/sonatype/plugins/nexus-staging-mave
n-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.sonatype.plugins:nexus-staging-mav
en-plugin:1.6.6: Plugin org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor for org.sonatyp
e.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-gpg-plug
in/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-gpg-plu
gin:1.6: Plugin org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:ma
ven-gpg-plugin:jar:1.6
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata
.xml
[WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to
central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected e
rror: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must b
e non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to centra
l (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: j
ava.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-e
mpty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml from https://re <https://re/>
po.maven.apache.org/maven2 <http://po.maven.apache.org/maven2> was cached in the local repository, resolution will not be rea
ttempted until the update interval of central has elapsed or updates are forced. Original
error: Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to c
entral (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected err
or: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be
non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from https://repo.mave <https://repo.mave/>
n.apache.org/maven2 <http://n.apache.org/maven2> was cached in the local repository, resolution will not be reattempte
d until the update interval of central has elapsed or updates are forced. Original error:
Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to central (https:
//repo.maven.apache.org/maven2 <http://repo.maven.apache.org/maven2>): java.lang.RuntimeException: Unexpected error: java.secur
ity.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 6.828 s
[INFO] Finished at: 2017-06-09T19:44:04-03:00
[INFO] Final Memory: 9M/150M
[INFO] ------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'exec' in the current project and in the plugin groups
[org.apache.maven.plugins, org.codehaus.mojo] available from the repositories [local (/h
ome/filhocf/.m2/repository), central (https://repo.maven.apache.org/maven2)] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the fol
lowing articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixE
xception

2017-06-08 13:55 GMT-03:00 Claudio Ferreia Filho <filhocf@gmail.com <mailto:filhocf@gmail.com>>:
Hi George.

Yes, I did.

Now, returns:
$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
Error: Could not find or load main class org.jitsi.hammer.Main

2017-06-08 12:20 GMT-03:00 George Politis <gp@jitsi.org <mailto:gp@jitsi.org>>:
Hi Claudio, have you tried the suggestion in the issue that you linked?

On Jun 8, 2017, at 9:30 AM, Claudio Ferreia Filho <filhocf@gmail.com <mailto:filhocf@gmail.com>> wrote:

Hi

I'm trying to run jitsi-hammer in my env, finding a way to understand what I can do to optimize my server.

I cloned the project, added java 8 and mvn, and when tried to run it, returned the same reported in https://github.com/jitsi/jitsi-hammer/issues/17.

Follow the log:

$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/filhocf/git/jitsi-hammer/src/main/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @ jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to /home/filhocf/git/jitsi-hammer/target/classes
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/SsrcPacketExtension.java: Some input files use or override a deprecated API.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/SsrcPacketExtension.java: Recompile with -Xlint:deprecation for details.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java uses unchecked or unsafe operations.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: Recompile with -Xlint:unchecked for details.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.742 s
[INFO] Finished at: 2017-06-08T11:00:36-03:00
[INFO] Final Memory: 22M/306M
[INFO] ------------------------------------------------------------------------
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-maven-plugin/1.4.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plugin/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-surefire-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-install-plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-install-plugin:2.5.2: Plugin org.apache.maven.plugins:maven-install-plugin:2.5.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-install-plugin:jar:2.5.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-deploy-plugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-site-plugin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-site-plugin:3.3: Plugin org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-site-plugin:jar:3.3
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-antrun-plugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-antrun-plugin:1.7: Plugin org.apache.maven.plugins:maven-antrun-plugin:1.7 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-antrun-plugin:jar:1.7
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-assembly-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-assembly-plugin:2.4.1: Plugin org.apache.maven.plugins:maven-assembly-plugin:2.4.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-dependency-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-dependency-plugin:2.8: Plugin org.apache.maven.plugins:maven-dependency-plugin:2.8 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-dependency-plugin:jar:2.8
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-release-plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-release-plugin:2.3.2: Plugin org.apache.maven.plugins:maven-release-plugin:2.3.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-release-plugin:jar:2.3.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/3.0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.felix:maven-bundle-plugin:3.0.0: Plugin org.apache.felix:maven-bundle-plugin:3.0.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.felix:maven-bundle-plugin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-plugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-source-plugin:2.4: Plugin org.apache.maven.plugins:maven-source-plugin:2.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-source-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-javadoc-plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-javadoc-plugin:2.10.3: Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.10.3 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/sonatype/plugins/nexus-staging-maven-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6: Plugin org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.sonatype.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-gpg-plugin/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-gpg-plugin:1.6: Plugin org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-gpg-plugin:jar:1.6
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata.xml
[WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml from https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 14.705 s
[INFO] Finished at: 2017-06-08T11:00:52-03:00
[INFO] Final Memory: 10M/303M
[INFO] ------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'exec' in the current project and in the plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available from the repositories [local (/home/filhocf/.m2/repository), central (https://repo.maven.apache.org/maven2)] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixException

---------

Any idea?

Since now, thanks by any help.

Regards,
Claudio
_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Hi George

Wow! Now it gone a lot. Thanks by your orientation.

IMHO, I think that is a good idea add this line in a "Example" section in
to Readme.md at jitsi-hammer project.

In other hand, -X and -e options are described in the error, to get more
log and verbosity, but has my mistake, because these are options of maven
and not of script.

At final, I continue with a error when run the script.

Any suggestion?

Regards,
Claudio Ferreira

···

------------
$ ./jitsi-hammer.sh -u https://myserver.com/http-bind -room myroom
[INFO] Scanning for projects...
[INFO]

[INFO]
------------------------------------------------------------------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO]
------------------------------------------------------------------------
Downloading:
https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/commons
-codec/commons-codec/maven-metadata.xml
Downloading:
https://repo.maven.apache.org/maven2/commons-codec/commons-codec/maven-metad
ata.xml
Downloading:
https://github.com/jitsi/jitsi-maven-repository/raw/master/releases/commons-
codec/commons-codec/maven-metadata.xml
Downloaded:
https://repo.maven.apache.org/maven2/commons-codec/commons-codec/maven-metada
ta.xml (612 B at 0.4 KB/sec)
Downloading:
https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/jit
si/jitsi-universe/1.0-SNAPSHOT/maven-metadata.xml
Downloaded:
https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/jits
i/jitsi-universe/1.0-SNAPSHOT/maven-metadata.xml (598 B at 0.3 KB/sec)
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is
invalid, transitive d
ependencies (if any) will not be available, enable debug logging for more
details
Downloading:
https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/ign
iterealtime/jbosh/jbosh/maven-metadata.xml
Downloading:
https://repo.maven.apache.org/maven2/org/igniterealtime/jbosh/jbosh/maven-me
tadata.xml
Downloading:
https://github.com/jitsi/jitsi-maven-repository/raw/master/releases/org/igni
terealtime/jbosh/jbosh/maven-metadata.xml
Downloaded:
https://repo.maven.apache.org/maven2/org/igniterealtime/jbosh/jbosh/maven-met
adata.xml (429 B at 0.9 KB/sec)
Downloading:
https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/jit
si/jitsi/2.9-SNAPSHOT/maven-metadata.xml
Downloaded:
https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/jits
i/jitsi/2.9-SNAPSHOT/maven-metadata.xml (587 B at 0.4 KB/sec)
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is
invalid, transitiv
e dependencies (if any) will not be available, enable debug logging for
more details
Downloading:
https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/ign
iterealtime/smack/smack-universe/3.2.2-jitsi-1-SNAPSHOT/maven-metadata.xml
Downloaded:
https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/igni
terealtime/smack/smack-universe/3.2.2-jitsi-1-SNAPSHOT/maven-metadata.xml
(631 B at 0.7 K
B/sec)
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/Dropbox/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @
jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory
/home/filhocf/Dropbox/git/jitsi-hammer/src/mai
n/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @
jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to
/home/filhocf/Dropbox/git/jitsi-hammer/target/classes
[INFO]
/home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Some input files use or override a deprecated API.
[INFO]
/home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Recompile with -Xlint:deprecation for details.
[INFO]
/home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
/home/filhocf/Dropb
ox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensio
ns/jingle/NewAbstractExtensionElement.java uses unchecked or unsafe
operations.
[INFO]
/home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
Recompile with -Xli
nt:unchecked for details.
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 10.162 s
[INFO] Finished at: 2017-06-11T17:14:51-03:00
[INFO] Final Memory: 22M/211M
[INFO]
------------------------------------------------------------------------
[INFO] Scanning for projects...
Downloading:
https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-maven-plugin/1.4
.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its
dependencies could no
t be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plug
in/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its
dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-surefire
-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor
for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-install-
plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-install
-plugin:2.5.2: Plugin org.apache.maven.plugins:maven-install-plugin:2.5.2
or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for
org.apache.mave
n.plugins:maven-install-plugin:jar:2.5.2
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-deploy-p
lugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or
one of its dep
endencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-site-plu
gin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-site-pl
ugin:3.3: Plugin org.apache.maven.plugins:maven-site-plugin:3.3 or one of
its dependencie
s could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:
maven-site-plugin:jar:3.3
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-antrun-p
lugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-antrun-
plugin:1.7: Plugin org.apache.maven.plugins:maven-antrun-plugin:1.7 or one
of its depende
ncies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plug
ins:maven-antrun-plugin:jar:1.7
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-assembly
-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-assembl
y-plugin:2.4.1: Plugin org.apache.maven.plugins:maven-assembly-plugin:2.4.1
or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.ma
ven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-dependen
cy-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-depende
ncy-plugin:2.8: Plugin org.apache.maven.plugins:maven-dependency-plugin:2.8
or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.ma
ven.plugins:maven-dependency-plugin:jar:2.8
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-release-
plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-release
-plugin:2.3.2: Plugin org.apache.maven.plugins:maven-release-plugin:2.3.2
or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for
org.apache.mave
n.plugins:maven-release-plugin:jar:2.3.2
Downloading:
https://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/3.
0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.felix:maven-bundle-plugin:3
.0.0: Plugin org.apache.felix:maven-bundle-plugin:3.0.0 or one of its
dependencies could
not be resolved: Failed to read artifact descriptor for
org.apache.felix:maven-bundle-plu
gin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its
dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-p
lugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-source-
plugin:2.4: Plugin org.apache.maven.plugins:maven-source-plugin:2.4 or one
of its depende
ncies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plug
ins:maven-source-plugin:jar:2.4
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-javadoc-
plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-javadoc
-plugin:2.10.3: Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.10.3
or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.ma
ven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor
for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or
one of its dep
endencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its
dependencies could no
t be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading:
https://repo.maven.apache.org/maven2/org/sonatype/plugins/nexus-staging-mave
n-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.sonatype.plugins:nexus-staging-mav
en-plugin:1.6.6: Plugin
org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor
for org.sonatyp
e.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-gpg-plug
in/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-gpg-plu
gin:1.6: Plugin org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its
dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:ma
ven-gpg-plugin:jar:1.6
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata
.xml
Downloading:
https://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml
[WARNING] Could not transfer metadata
org.apache.maven.plugins/maven-metadata.xml from/to
central (https://repo.maven.apache.org/maven2):
sun.security.validator.ValidatorExceptio
n: PKIX path building failed:
sun.security.provider.certpath.SunCertPathBuilderException:
unable to find valid certification path to requested target
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml
from/to centra
l (https://repo.maven.apache.org/maven2):
sun.security.validator.ValidatorException: PKIX
path building failed:
sun.security.provider.certpath.SunCertPathBuilderException: unable
to find valid certification path to requested target
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml
from https://re
po.maven.apache.org/maven2 was cached in the local repository, resolution
will not be rea
ttempted until the update interval of central has elapsed or updates are
forced. Original
error: Could not transfer metadata
org.apache.maven.plugins/maven-metadata.xml from/to c
entral (https://repo.maven.apache.org/maven2):
sun.security.validator.ValidatorException:
PKIX path building failed:
sun.security.provider.certpath.SunCertPathBuilderException: u
nable to find valid certification path to requested target
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from
https://repo.mave
n.apache.org/maven2 was cached in the local repository, resolution will not
be reattempte
d until the update interval of central has elapsed or updates are forced.
Original error:
Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to
central (https:
//repo.maven.apache.org/maven2): sun.security.validator.ValidatorException:
PKIX path bui
lding failed: sun.security.provider.certpath.SunCertPathBuilderException:
unable to find
valid certification path to requested target
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 7.045 s
[INFO] Finished at: 2017-06-11T17:15:00-03:00
[INFO] Final Memory: 10M/155M
[INFO]
------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'exec' in the current project and in the
plugin groups
[org.apache.maven.plugins, org.codehaus.mojo] available from the
repositories [local (/h
ome/filhocf/.m2/repository), central (https://repo.maven.apache.org/maven2)]
-> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the fol
lowing articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixE
xception

2017-06-09 21:41 GMT-03:00 George Politis <gp@jitsi.org>:

Hi Claudio,

I’m not sure what the -X and -e parameters do but the correct syntax is:

    ./jitsi-hammer.sh -u https://myserver.com/http-bind -room myroom

I’ve made a PR that attempts to fix issue 17 (the one that you linked in
your first email).

Could you please use the correct syntax and my PR and see if it works
better for you?

I hope this helps.

Best,
George

On Jun 9, 2017, at 6:02 PM, Claudio Ferreia Filho <filhocf@gmail.com> > wrote:

Hi

Following with my tests, hasn't possible to download a lot of things. I
tried in my job, that have a proxy (and I think that could be a problem
with proxy), and in my home, with a good connection. Also without success.

Someone did a recent clone and tried to run the jitsi-hammer.sh script in
a clean env? If yes and with success, could share your settings.xml?

Since now, thanks by any suggestion.

Regards,
Claudio Ferreira

---- logs -----
$ ./jitsi-hammer.sh -e -X https://myserver.com/myroom
./jitsi-hammer.sh: linha 17: [: =: expected a unary operator
[INFO] Scanning for projects...
[INFO]

[INFO] ------------------------------------------------------------------------

[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------

[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is
invalid, transitive d
ependencies (if any) will not be available, enable debug logging for more
details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is
invalid, transitiv
e dependencies (if any) will not be available, enable debug logging for
more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/Dropbox/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @
jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/filhocf/Dropbox/git/
jitsi-hammer/src/mai
n/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @
jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to /home/filhocf/Dropbox/git/jitsi-hammer/target/classes

[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/
org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Some input files use or override a deprecated API.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/
org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Recompile with -Xlint:deprecation for details.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/
net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
/home/filhocf/Dropb
ox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/
jabber/extensio
ns/jingle/NewAbstractExtensionElement.java uses unchecked or unsafe
operations.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/
net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
Recompile with -Xli
nt:unchecked for details.
[INFO] ------------------------------------------------------------------------

[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------

[INFO] Total time: 2.964 s
[INFO] Finished at: 2017-06-09T19:43:56-03:00
[INFO] Final Memory: 22M/265M
[INFO] ------------------------------------------------------------------------

[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-
maven-plugin/1.4
.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its
dependencies could no
t be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-jar-plug
in/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of
its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-surefire
-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1
or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor
for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-install-
plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-install
-plugin:2.5.2: Plugin org.apache.maven.plugins:maven-install-plugin:2.5.2
or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for
org.apache.mave
n.plugins:maven-install-plugin:jar:2.5.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-deploy-p
lugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2
or one of its dep
endencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-site-plu
gin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-site-pl
ugin:3.3: Plugin org.apache.maven.plugins:maven-site-plugin:3.3 or one of
its dependencie
s could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:
maven-site-plugin:jar:3.3
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-antrun-p
lugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-antrun-
plugin:1.7: Plugin org.apache.maven.plugins:maven-antrun-plugin:1.7 or
one of its depende
ncies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plug
ins:maven-antrun-plugin:jar:1.7
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-assembly
-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-assembl
y-plugin:2.4.1: Plugin org.apache.maven.plugins:maven-assembly-plugin:2.4.1
or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.ma
ven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-dependen
cy-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-depende
ncy-plugin:2.8: Plugin org.apache.maven.plugins:maven-dependency-plugin:2.8
or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.ma
ven.plugins:maven-dependency-plugin:jar:2.8
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-release-
plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-release
-plugin:2.3.2: Plugin org.apache.maven.plugins:maven-release-plugin:2.3.2
or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for
org.apache.mave
n.plugins:maven-release-plugin:jar:2.3.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/felix/maven-
bundle-plugin/3.
0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.felix:maven-bundle-plugin:3
.0.0: Plugin org.apache.felix:maven-bundle-plugin:3.0.0 or one of its
dependencies could
not be resolved: Failed to read artifact descriptor for
org.apache.felix:maven-bundle-plu
gin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of
its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-source-p
lugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-source-
plugin:2.4: Plugin org.apache.maven.plugins:maven-source-plugin:2.4 or
one of its depende
ncies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plug
ins:maven-source-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-javadoc-
plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-javadoc
-plugin:2.10.3: Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.10.3
or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.ma
ven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1
or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor
for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2
or one of its dep
endencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its
dependencies could no
t be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/sonatype/plugins/
nexus-staging-mave
n-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.sonatype.plugins:nexus-staging-mav
en-plugin:1.6.6: Plugin org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6
or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor
for org.sonatyp
e.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-gpg-plug
in/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-gpg-plu
gin:1.6: Plugin org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of
its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:ma
ven-gpg-plugin:jar:1.6
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/
maven-metadata.xml
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/
plugins/maven-metadata
.xml
[WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml
from/to
central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected e
rror: java.security.InvalidAlgorithmParameterException: the trustAnchors
parameter must b
e non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml
from/to centra
l (https://repo.maven.apache.org/maven2): java.lang.RuntimeException:
Unexpected error: j
ava.security.InvalidAlgorithmParameterException: the trustAnchors
parameter must be non-e
mpty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml
from https://re
po.maven.apache.org/maven2 was cached in the local repository, resolution
will not be rea
ttempted until the update interval of central has elapsed or updates are
forced. Original
error: Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml
from/to c
entral (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected err
or: java.security.InvalidAlgorithmParameterException: the trustAnchors
parameter must be
non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from
https://repo.mave
n.apache.org/maven2 was cached in the local repository, resolution will
not be reattempte
d until the update interval of central has elapsed or updates are forced.
Original error:
Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to
central (https:
//repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected
error: java.secur
ity.InvalidAlgorithmParameterException: the trustAnchors parameter must
be non-empty
[INFO] ------------------------------------------------------------------------

[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------

[INFO] Total time: 6.828 s
[INFO] Finished at: 2017-06-09T19:44:04-03:00
[INFO] Final Memory: 9M/150M
[INFO] ------------------------------------------------------------------------

[ERROR] No plugin found for prefix 'exec' in the current project and in
the plugin groups
[org.apache.maven.plugins, org.codehaus.mojo] available from the
repositories [local (/h
ome/filhocf/.m2/repository), central (https://repo.maven.apache.org/maven2)]
-> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the
-e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the fol
lowing articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/
NoPluginFoundForPrefixE
xception

2017-06-08 13:55 GMT-03:00 Claudio Ferreia Filho <filhocf@gmail.com>:

Hi George.

Yes, I did.

Now, returns:
$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
Error: Could not find or load main class org.jitsi.hammer.Main

2017-06-08 12:20 GMT-03:00 George Politis <gp@jitsi.org>:

Hi Claudio, have you tried the suggestion in the issue that you linked?

On Jun 8, 2017, at 9:30 AM, Claudio Ferreia Filho <filhocf@gmail.com> >>> wrote:

Hi

I'm trying to run jitsi-hammer in my env, finding a way to understand
what I can do to optimize my server.

I cloned the project, added java 8 and mvn, and when tried to run it,
returned the same reported in https://github.com/jitsi/ji
tsi-hammer/issues/17.

Follow the log:

$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
[INFO] Scanning for projects...
[INFO]

[INFO] ------------------------------------------------------------
------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------
------------
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is
invalid, transitive dependencies (if any) will not be available, enable
debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is
invalid, transitive dependencies (if any) will not be available, enable
debug logging for more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer
---
[INFO] Deleting /home/filhocf/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @
jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/filhocf/git/jitsi-hammer
/src/main/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @
jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to /home/filhocf/git/jitsi-hammer
/target/classes
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/hamme
r/extension/SsrcPacketExtension.java: Some input files use or override
a deprecated API.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/hamme
r/extension/SsrcPacketExtension.java: Recompile with -Xlint:deprecation
for details.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/co
mmunicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
/home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/co
mmunicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java
uses unchecked or unsafe operations.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/co
mmunicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java:
Recompile with -Xlint:unchecked for details.
[INFO] ------------------------------------------------------------
------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------
------------
[INFO] Total time: 1.742 s
[INFO] Finished at: 2017-06-08T11:00:36-03:00
[INFO] Final Memory: 22M/306M
[INFO] ------------------------------------------------------------
------------
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/
maven2/org/codehaus/mojo/exec-maven-plugin/1.4.0/exec-maven-
plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin
org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-jar-plugin/2.4/maven-j
ar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin
org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-surefire-plugin/2.18.1
/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-install-plugin/2.5.2/m
aven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-install-plugin:2.5.2: Plugin
org.apache.maven.plugins:maven-install-plugin:2.5.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-install-plugin:jar:2.5.2
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-deploy-plugin/2.8.2/ma
ven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin
org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-site-plugin/3.3/maven-
site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-site-plugin:3.3: Plugin
org.apache.maven.plugins:maven-site-plugin:3.3 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-site-plugin:jar:3.3
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-antrun-plugin/1.7/mave
n-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-antrun-plugin:1.7: Plugin
org.apache.maven.plugins:maven-antrun-plugin:1.7 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-antrun-plugin:jar:1.7
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-assembly-plugin/2.4.1/
maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-assembly-plugin:2.4.1: Plugin
org.apache.maven.plugins:maven-assembly-plugin:2.4.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-dependency-plugin/2.8/
maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-dependency-plugin:2.8: Plugin
org.apache.maven.plugins:maven-dependency-plugin:2.8 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-dependency-plugin:jar:2.8
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-release-plugin/2.3.2/m
aven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-release-plugin:2.3.2: Plugin
org.apache.maven.plugins:maven-release-plugin:2.3.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-release-plugin:jar:2.3.2
Downloading: https://repo.maven.apache.org/
maven2/org/apache/felix/maven-bundle-plugin/3.0.0/maven-bund
le-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.felix:maven-bundle-plugin:3.0.0: Plugin
org.apache.felix:maven-bundle-plugin:3.0.0 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.felix:maven-bundle-plugin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin
org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-source-plugin/2.4/mave
n-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-source-plugin:2.4: Plugin
org.apache.maven.plugins:maven-source-plugin:2.4 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-source-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-javadoc-plugin/2.10.3/
maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-javadoc-plugin:2.10.3: Plugin
org.apache.maven.plugins:maven-javadoc-plugin:2.10.3 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin
org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin
org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/
maven2/org/sonatype/plugins/nexus-staging-maven-plugin/1.6.6
/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6: Plugin
org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.sonatype.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-gpg-plugin/1.6/maven-g
pg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-gpg-plugin:1.6: Plugin
org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-gpg-plugin:jar:1.6
Downloading: https://repo.maven.apache.org/
maven2/org/codehaus/mojo/maven-metadata.xml
Downloading: https://repo.maven.apache.org/
maven2/org/apache/maven/plugins/maven-metadata.xml
[WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml
from/to central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException:
the trustAnchors parameter must be non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml
from/to central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException:
the trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml
from https://repo.maven.apache.org/maven2 was cached in the local
repository, resolution will not be reattempted until the update interval of
central has elapsed or updates are forced. Original error: Could not
transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to
central (https://repo.maven.apache.org/maven2):
java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException:
the trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from
https://repo.maven.apache.org/maven2 was cached in the local
repository, resolution will not be reattempted until the update interval of
central has elapsed or updates are forced. Original error: Could not
transfer metadata org.codehaus.mojo/maven-metadata.xml from/to central (
https://repo.maven.apache.org/maven2): java.lang.RuntimeException:
Unexpected error: java.security.InvalidAlgorithmParameterException: the
trustAnchors parameter must be non-empty
[INFO] ------------------------------------------------------------
------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------
------------
[INFO] Total time: 14.705 s
[INFO] Finished at: 2017-06-08T11:00:52-03:00
[INFO] Final Memory: 10M/303M
[INFO] ------------------------------------------------------------
------------
[ERROR] No plugin found for prefix 'exec' in the current project and in
the plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available
from the repositories [local (/home/filhocf/.m2/repository), central (
https://repo.maven.apache.org/maven2)] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the
-e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/conflu
ence/display/MAVEN/NoPluginFoundForPrefixException

---------

Any idea?

Since now, thanks by any help.

Regards,
Claudio
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Hi Claudio, did you execute something like this:

    git checkout -b issue-17 -t origin/issue-17

To get my fixes?

Best,
George

···

On Jun 11, 2017, at 3:33 PM, Claudio Ferreia Filho <filhocf@gmail.com> wrote:

Hi George

Wow! Now it gone a lot. Thanks by your orientation.

IMHO, I think that is a good idea add this line in a "Example" section in to Readme.md at jitsi-hammer project.

In other hand, -X and -e options are described in the error, to get more log and verbosity, but has my mistake, because these are options of maven and not of script.

At final, I continue with a error when run the script.

Any suggestion?

Regards,
Claudio Ferreira

------------
$ ./jitsi-hammer.sh -u https://myserver.com/http-bind -room myroom
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
Downloading: https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/commons
-codec/commons-codec/maven-metadata.xml
Downloading: https://repo.maven.apache.org/maven2/commons-codec/commons-codec/maven-metad
ata.xml
Downloading: https://github.com/jitsi/jitsi-maven-repository/raw/master/releases/commons-
codec/commons-codec/maven-metadata.xml
Downloaded: https://repo.maven.apache.org/maven2/commons-codec/commons-codec/maven-metada
ta.xml (612 B at 0.4 KB/sec)
Downloading: https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/jit
si/jitsi-universe/1.0-SNAPSHOT/maven-metadata.xml
Downloaded: https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/jits
i/jitsi-universe/1.0-SNAPSHOT/maven-metadata.xml (598 B at 0.3 KB/sec)
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive d
ependencies (if any) will not be available, enable debug logging for more details
Downloading: https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/ign
iterealtime/jbosh/jbosh/maven-metadata.xml
Downloading: https://repo.maven.apache.org/maven2/org/igniterealtime/jbosh/jbosh/maven-me
tadata.xml
Downloading: https://github.com/jitsi/jitsi-maven-repository/raw/master/releases/org/igni
terealtime/jbosh/jbosh/maven-metadata.xml
Downloaded: https://repo.maven.apache.org/maven2/org/igniterealtime/jbosh/jbosh/maven-met
adata.xml (429 B at 0.9 KB/sec)
Downloading: https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/jit
si/jitsi/2.9-SNAPSHOT/maven-metadata.xml
Downloaded: https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/jits
i/jitsi/2.9-SNAPSHOT/maven-metadata.xml (587 B at 0.4 KB/sec)
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitiv
e dependencies (if any) will not be available, enable debug logging for more details
Downloading: https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/ign
iterealtime/smack/smack-universe/3.2.2-jitsi-1-SNAPSHOT/maven-metadata.xml
Downloaded: https://github.com/jitsi/jitsi-maven-repository/raw/master/snapshots/org/igni
terealtime/smack/smack-universe/3.2.2-jitsi-1-SNAPSHOT/maven-metadata.xml (631 B at 0.7 K
B/sec)
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/Dropbox/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/filhocf/Dropbox/git/jitsi-hammer/src/mai
n/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @ jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to /home/filhocf/Dropbox/git/jitsi-hammer/target/classes
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Some input files use or override a deprecated API.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Recompile with -Xlint:deprecation for details.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: /home/filhocf/Dropb
ox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensio
ns/jingle/NewAbstractExtensionElement.java uses unchecked or unsafe operations.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: Recompile with -Xli
nt:unchecked for details.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 10.162 s
[INFO] Finished at: 2017-06-11T17:14:51-03:00
[INFO] Final Memory: 22M/211M
[INFO] ------------------------------------------------------------------------
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-maven-plugin/1.4
.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could no
t be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plug
in/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-surefire
-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-install-
plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-install
-plugin:2.5.2: Plugin org.apache.maven.plugins:maven-install-plugin:2.5.2 or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for org.apache.mave
n.plugins:maven-install-plugin:jar:2.5.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-deploy-p
lugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dep
endencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-site-plu
gin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-site-pl
ugin:3.3: Plugin org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencie
s could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:
maven-site-plugin:jar:3.3
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-antrun-p
lugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-antrun-
plugin:1.7: Plugin org.apache.maven.plugins:maven-antrun-plugin:1.7 or one of its depende
ncies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plug
ins:maven-antrun-plugin:jar:1.7
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-assembly
-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-assembl
y-plugin:2.4.1: Plugin org.apache.maven.plugins:maven-assembly-plugin:2.4.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for org.apache.ma
ven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-dependen
cy-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-depende
ncy-plugin:2.8: Plugin org.apache.maven.plugins:maven-dependency-plugin:2.8 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for org.apache.ma
ven.plugins:maven-dependency-plugin:jar:2.8
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-release-
plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-release
-plugin:2.3.2: Plugin org.apache.maven.plugins:maven-release-plugin:2.3.2 or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for org.apache.mave
n.plugins:maven-release-plugin:jar:2.3.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/3.
0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.felix:maven-bundle-plugin:3
.0.0: Plugin org.apache.felix:maven-bundle-plugin:3.0.0 or one of its dependencies could
not be resolved: Failed to read artifact descriptor for org.apache.felix:maven-bundle-plu
gin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-p
lugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-source-
plugin:2.4: Plugin org.apache.maven.plugins:maven-source-plugin:2.4 or one of its depende
ncies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plug
ins:maven-source-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-javadoc-
plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-javadoc
-plugin:2.10.3: Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.10.3 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for org.apache.ma
ven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dep
endencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could no
t be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/sonatype/plugins/nexus-staging-mave
n-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.sonatype.plugins:nexus-staging-mav
en-plugin:1.6.6: Plugin org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor for org.sonatyp
e.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-gpg-plug
in/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-gpg-plu
gin:1.6: Plugin org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:ma
ven-gpg-plugin:jar:1.6
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata
.xml
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml
[WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to
central (https://repo.maven.apache.org/maven2): sun.security.validator.ValidatorExceptio
n: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException:
unable to find valid certification path to requested target
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to centra
l (https://repo.maven.apache.org/maven2): sun.security.validator.ValidatorException: PKIX
path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable
to find valid certification path to requested target
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml from https://re
po.maven.apache.org/maven2 was cached in the local repository, resolution will not be rea
ttempted until the update interval of central has elapsed or updates are forced. Original
error: Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to c
entral (https://repo.maven.apache.org/maven2): sun.security.validator.ValidatorException:
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: u
nable to find valid certification path to requested target
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from https://repo.mave
n.apache.org/maven2 was cached in the local repository, resolution will not be reattempte
d until the update interval of central has elapsed or updates are forced. Original error:
Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to central (https:
//repo.maven.apache.org/maven2): sun.security.validator.ValidatorException: PKIX path bui
lding failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find
valid certification path to requested target
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 7.045 s
[INFO] Finished at: 2017-06-11T17:15:00-03:00
[INFO] Final Memory: 10M/155M
[INFO] ------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'exec' in the current project and in the plugin groups
[org.apache.maven.plugins, org.codehaus.mojo] available from the repositories [local (/h
ome/filhocf/.m2/repository), central (https://repo.maven.apache.org/maven2)] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the fol
lowing articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixE
xception

2017-06-09 21:41 GMT-03:00 George Politis <gp@jitsi.org>:
Hi Claudio,

I’m not sure what the -X and -e parameters do but the correct syntax is:

    ./jitsi-hammer.sh -u https://myserver.com/http-bind -room myroom

I’ve made a PR that attempts to fix issue 17 (the one that you linked in your first email).

Could you please use the correct syntax and my PR and see if it works better for you?

I hope this helps.

Best,
George

On Jun 9, 2017, at 6:02 PM, Claudio Ferreia Filho <filhocf@gmail.com> wrote:

Hi

Following with my tests, hasn't possible to download a lot of things. I tried in my job, that have a proxy (and I think that could be a problem with proxy), and in my home, with a good connection. Also without success.

Someone did a recent clone and tried to run the jitsi-hammer.sh script in a clean env? If yes and with success, could share your settings.xml?

Since now, thanks by any suggestion.

Regards,
Claudio Ferreira

---- logs -----
$ ./jitsi-hammer.sh -e -X https://myserver.com/myroom
./jitsi-hammer.sh: linha 17: [: =: expected a unary operator
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive d
ependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitiv
e dependencies (if any) will not be available, enable debug logging for more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/Dropbox/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/filhocf/Dropbox/git/jitsi-hammer/src/mai
n/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @ jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to /home/filhocf/Dropbox/git/jitsi-hammer/target/classes
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Some input files use or override a deprecated API.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/Ss
rcPacketExtension.java: Recompile with -Xlint:deprecation for details.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: /home/filhocf/Dropb
ox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensio
ns/jingle/NewAbstractExtensionElement.java uses unchecked or unsafe operations.
[INFO] /home/filhocf/Dropbox/git/jitsi-hammer/src/main/java/net/java/sip/communicator/imp
l/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: Recompile with -Xli
nt:unchecked for details.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.964 s
[INFO] Finished at: 2017-06-09T19:43:56-03:00
[INFO] Final Memory: 22M/265M
[INFO] ------------------------------------------------------------------------
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-maven-plugin/1.4
.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could no
t be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plug
in/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-surefire
-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-install-
plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-install
-plugin:2.5.2: Plugin org.apache.maven.plugins:maven-install-plugin:2.5.2 or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for org.apache.mave
n.plugins:maven-install-plugin:jar:2.5.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-deploy-p
lugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dep
endencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-site-plu
gin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-site-pl
ugin:3.3: Plugin org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencie
s could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:
maven-site-plugin:jar:3.3
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-antrun-p
lugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-antrun-
plugin:1.7: Plugin org.apache.maven.plugins:maven-antrun-plugin:1.7 or one of its depende
ncies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plug
ins:maven-antrun-plugin:jar:1.7
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-assembly
-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-assembl
y-plugin:2.4.1: Plugin org.apache.maven.plugins:maven-assembly-plugin:2.4.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for org.apache.ma
ven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-dependen
cy-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-depende
ncy-plugin:2.8: Plugin org.apache.maven.plugins:maven-dependency-plugin:2.8 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for org.apache.ma
ven.plugins:maven-dependency-plugin:jar:2.8
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-release-
plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-release
-plugin:2.3.2: Plugin org.apache.maven.plugins:maven-release-plugin:2.3.2 or one of its d
ependencies could not be resolved: Failed to read artifact descriptor for org.apache.mave
n.plugins:maven-release-plugin:jar:2.3.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/3.
0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.felix:maven-bundle-plugin:3
.0.0: Plugin org.apache.felix:maven-bundle-plugin:3.0.0 or one of its dependencies could
not be resolved: Failed to read artifact descriptor for org.apache.felix:maven-bundle-plu
gin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plu
gin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:ma
ven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-p
lugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-source-
plugin:2.4: Plugin org.apache.maven.plugins:maven-source-plugin:2.4 or one of its depende
ncies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plug
ins:maven-source-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-javadoc-
plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-javadoc
-plugin:2.10.3: Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.10.3 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for org.apache.ma
ven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefir
e-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor for org.apache.
maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-
plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dep
endencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.
plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.
4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could no
t be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin
:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/sonatype/plugins/nexus-staging-mave
n-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.sonatype.plugins:nexus-staging-mav
en-plugin:1.6.6: Plugin org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of i
ts dependencies could not be resolved: Failed to read artifact descriptor for org.sonatyp
e.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-gpg-plug
in/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-gpg-plu
gin:1.6: Plugin org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:ma
ven-gpg-plugin:jar:1.6
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata
.xml
[WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to
central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected e
rror: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must b
e non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to centra
l (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: j
ava.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-e
mpty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml from https://re
po.maven.apache.org/maven2 was cached in the local repository, resolution will not be rea
ttempted until the update interval of central has elapsed or updates are forced. Original
error: Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to c
entral (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected err
or: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be
non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from https://repo.mave
n.apache.org/maven2 was cached in the local repository, resolution will not be reattempte
d until the update interval of central has elapsed or updates are forced. Original error:
Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to central (https:
//repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.secur
ity.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 6.828 s
[INFO] Finished at: 2017-06-09T19:44:04-03:00
[INFO] Final Memory: 9M/150M
[INFO] ------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'exec' in the current project and in the plugin groups
[org.apache.maven.plugins, org.codehaus.mojo] available from the repositories [local (/h
ome/filhocf/.m2/repository), central (https://repo.maven.apache.org/maven2)] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the fol
lowing articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixE
xception

2017-06-08 13:55 GMT-03:00 Claudio Ferreia Filho <filhocf@gmail.com>:
Hi George.

Yes, I did.

Now, returns:
$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
Error: Could not find or load main class org.jitsi.hammer.Main

2017-06-08 12:20 GMT-03:00 George Politis <gp@jitsi.org>:
Hi Claudio, have you tried the suggestion in the issue that you linked?

On Jun 8, 2017, at 9:30 AM, Claudio Ferreia Filho <filhocf@gmail.com> wrote:

Hi

I'm trying to run jitsi-hammer in my env, finding a way to understand what I can do to optimize my server.

I cloned the project, added java 8 and mvn, and when tried to run it, returned the same reported in https://github.com/jitsi/jitsi-hammer/issues/17.

Follow the log:

$ ./jitsi-hammer.sh -X -BOSHuri https://200.152.42.35/
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building jitsi-hammer 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ jitsi-hammer ---
[INFO] Deleting /home/filhocf/git/jitsi-hammer/target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ jitsi-hammer ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/filhocf/git/jitsi-hammer/src/main/resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @ jitsi-hammer ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 49 source files to /home/filhocf/git/jitsi-hammer/target/classes
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/SsrcPacketExtension.java: Some input files use or override a deprecated API.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/org/jitsi/hammer/extension/SsrcPacketExtension.java: Recompile with -Xlint:deprecation for details.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java uses unchecked or unsafe operations.
[INFO] /home/filhocf/git/jitsi-hammer/src/main/java/net/java/sip/communicator/impl/protocol/jabber/extensions/jingle/NewAbstractExtensionElement.java: Recompile with -Xlint:unchecked for details.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.742 s
[INFO] Finished at: 2017-06-08T11:00:36-03:00
[INFO] Final Memory: 22M/306M
[INFO] ------------------------------------------------------------------------
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-maven-plugin/1.4.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plugin/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-surefire-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-install-plugin/2.5.2/maven-install-plugin-2.5.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-install-plugin:2.5.2: Plugin org.apache.maven.plugins:maven-install-plugin:2.5.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-install-plugin:jar:2.5.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-deploy-plugin/2.8.2/maven-deploy-plugin-2.8.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-site-plugin/3.3/maven-site-plugin-3.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-site-plugin:3.3: Plugin org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-site-plugin:jar:3.3
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-antrun-plugin/1.7/maven-antrun-plugin-1.7.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-antrun-plugin:1.7: Plugin org.apache.maven.plugins:maven-antrun-plugin:1.7 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-antrun-plugin:jar:1.7
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-assembly-plugin/2.4.1/maven-assembly-plugin-2.4.1.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-assembly-plugin:2.4.1: Plugin org.apache.maven.plugins:maven-assembly-plugin:2.4.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-assembly-plugin:jar:2.4.1
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-dependency-plugin/2.8/maven-dependency-plugin-2.8.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-dependency-plugin:2.8: Plugin org.apache.maven.plugins:maven-dependency-plugin:2.8 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-dependency-plugin:jar:2.8
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-release-plugin/2.3.2/maven-release-plugin-2.3.2.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-release-plugin:2.3.2: Plugin org.apache.maven.plugins:maven-release-plugin:2.3.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-release-plugin:jar:2.3.2
Downloading: https://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/3.0.0/maven-bundle-plugin-3.0.0.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.felix:maven-bundle-plugin:3.0.0: Plugin org.apache.felix:maven-bundle-plugin:3.0.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.felix:maven-bundle-plugin:jar:3.0.0
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-plugin/2.4/maven-source-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-source-plugin:2.4: Plugin org.apache.maven.plugins:maven-source-plugin:2.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-source-plugin:jar:2.4
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-javadoc-plugin/2.10.3/maven-javadoc-plugin-2.10.3.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-javadoc-plugin:2.10.3: Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.10.3 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-javadoc-plugin:jar:2.10.3
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-deploy-plugin:2.8.2: Plugin org.apache.maven.plugins:maven-deploy-plugin:2.8.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-deploy-plugin:jar:2.8.2
[WARNING] Failed to retrieve plugin descriptor for org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading: https://repo.maven.apache.org/maven2/org/sonatype/plugins/nexus-staging-maven-plugin/1.6.6/nexus-staging-maven-plugin-1.6.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6: Plugin org.sonatype.plugins:nexus-staging-maven-plugin:1.6.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.sonatype.plugins:nexus-staging-maven-plugin:jar:1.6.6
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-gpg-plugin/1.6/maven-gpg-plugin-1.6.pom
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.plugins:maven-gpg-plugin:1.6: Plugin org.apache.maven.plugins:maven-gpg-plugin:1.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-gpg-plugin:jar:1.6
Downloading: https://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml
Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata.xml
[WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml from https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 14.705 s
[INFO] Finished at: 2017-06-08T11:00:52-03:00
[INFO] Final Memory: 10M/303M
[INFO] ------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'exec' in the current project and in the plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available from the repositories [local (/home/filhocf/.m2/repository), central (https://repo.maven.apache.org/maven2)] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixException

---------

Any idea?

Since now, thanks by any help.

Regards,
Claudio
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev