[jitsi-dev] Problem with audio on calls and notification of incoming calls


#1

Hello,

Since this commit was reversed has a fix been developed again?

I really need auto answer on sip calls to open the dialog and complete the answer process. As it is now, it answers the call but will continue to auto answer additional calls placing call 1 on hold.

Call waiting disabled only seems to wotk when the call has been completely answered.

Curtis Raams
Chief Technical Officer
Level 6, 140 Queen St. Melbourne Victoria 3000
T: 03 8665 8305 F: 03 9945 7502 M: 0404 394 904
E: craams@staff.ains.net.au W: www.ains.com.au

···

-----Original Message-----
From: Damian Minkov [damencho@jitsi.org]
Received: Friday, 11 Oct 2013, 3:10
To: Jitsi Developers [dev@jitsi.org]
Subject: Re: [jitsi-dev] Problem with audio on calls and notification of incoming calls

Hey,

I think I got it, fix was just committed you can test it with build
4858 does it fix it for you?

Thanks
damencho

On Thu, Oct 10, 2013 at 3:21 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

thanks for keep reporting :slight_smile: Boris also ping me for this one, that he
had seen it while ago. I was testing with xmpp, by the way. Now when I
tested with SIP it seems we had broke it. Will look at it, and will
write when there is something to test. So stay tuned.

Thanks
damencho

On Thu, Oct 10, 2013 at 2:34 PM, Curtis Raams <craams@staff.ains.net.au> wrote:

Hi Damien,

I downloaded the latest nightly, set auto answer all calls and sure enough
it answers the call but the screen remains on the middle alert where I must
press answer or hangup.

Even though I am talking to the caller.

Pressing the answer button shows the main call dialog for hold etc, I have
not tried hangup.

This seems to be different for you. You are saying auto answer immediately
opens the full call dialog and you do not even see the answer/terminate
dialog that should show on a standard call offer?

-----Original Message-----
From: Damian Minkov [damencho@jitsi.org]
Received: Thursday, 10 Oct 2013, 19:23
To: Jitsi Developers [dev@jitsi.org]
Subject: Re: [jitsi-dev] Problem with audio on calls and notification of
incoming calls

Hi,

yes it is answered as it is supposed to, opens the call dialog and
everything else is hidden, download and try it with Jitsi.
Please when you report an issue test it first with Jitsi, if possible
of course. And if the problem persist then report the problem.

Thanks
damencho

On Wed, Oct 9, 2013 at 10:49 PM, Curtis Raams <craams@staff.ains.net.au> >> wrote:

Hell Damien,

I will have the team look at it again.

When you used auto answer, did the whole call dialog box open up, or did
the
call answer but you still needed to press the answer button on screen to
bring the call dialog box up?

-----Original Message-----
From: Damian Minkov [damencho@jitsi.org]
Received: Wednesday, 09 Oct 2013, 23:33
To: Jitsi Developers [dev@jitsi.org]
Subject: Re: [jitsi-dev] Problem with audio on calls and notification of
incoming calls

Hi,

On Wed, Oct 9, 2013 at 1:47 PM, Curtis Raams <craams@staff.ains.net.au> >>> wrote:

Here is the errors that appeared to directly cause the two calls to both
auto answer and the user to speak to both callers (UI showed the
accept/decline box for both calls)....

16:32:10.742 SEVERE: [2689]
plugin.notificationwiring.NotificationManager.incomingCallReceived().992
An
error occurred while trying to notify about an incoming call
java.lang.NoClassDefFoundError:
net/java/sip/communicator/impl/protocol/sip/OperationSetAutoAnswerSipImpl
        at

net.java.sip.communicator.plugin.notificationwiring.NotificationManager.incomingCallReceived(NotificationManager.java:947)

Tested with vanilla Jitsi distribution and auto answer is working fine
without any exception. So it must be your modifications that brings
the problem.

Normally NoClassDefFoundError are because of wrong import/export of
packages in felix, or just missing such. You can check the mailinglist
archives for details.

Regards
damencho

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________


#2

Hi,

we didn't have time to do so, will fix this or next week and will let you
know.

Regards
damencho

···

On Wed, Oct 23, 2013 at 12:07 AM, Curtis Raams <craams@staff.ains.net.au>wrote:

Hello,

Since this commit was reversed has a fix been developed again?

I really need auto answer on sip calls to open the dialog and complete the
answer process. As it is now, it answers the call but will continue to auto
answer additional calls placing call 1 on hold.

Call waiting disabled only seems to wotk when the call has been completely
answered.

Curtis Raams
Chief Technical Officer
Level 6, 140 Queen St. Melbourne Victoria 3000
T: 03 8665 8305 F: 03 9945 7502 M: 0404 394 904
E: craams@staff.ains.net.au W: www.ains.com.au

-----Original Message-----
*From:* Damian Minkov [damencho@jitsi.org]
*Received:* Friday, 11 Oct 2013, 3:10
*To:* Jitsi Developers [dev@jitsi.org]
*Subject:* Re: [jitsi-dev] Problem with audio on calls and notification
of incoming calls

Hey,

I think I got it, fix was just committed you can test it with build
4858 does it fix it for you?

Thanks
damencho

On Thu, Oct 10, 2013 at 3:21 PM, Damian Minkov <damencho@jitsi.org> wrote:
> Hi,
>
> thanks for keep reporting :slight_smile: Boris also ping me for this one, that he
> had seen it while ago. I was testing with xmpp, by the way. Now when I
> tested with SIP it seems we had broke it. Will look at it, and will
> write when there is something to test. So stay tuned.
>
> Thanks
> damencho
>
>
> On Thu, Oct 10, 2013 at 2:34 PM, Curtis Raams <craams@staff.ains.net.au> > wrote:
>> Hi Damien,
>>
>> I downloaded the latest nightly, set auto answer all calls and sure
enough
>> it answers the call but the screen remains on the middle alert where I
must
>> press answer or hangup.
>>
>> Even though I am talking to the caller.
>>
>> Pressing the answer button shows the main call dialog for hold etc, I
have
>> not tried hangup.
>>
>> This seems to be different for you. You are saying auto answer
immediately
>> opens the full call dialog and you do not even see the answer/terminate
>> dialog that should show on a standard call offer?
>>
>> -----Original Message-----
>> From: Damian Minkov [damencho@jitsi.org]
>> Received: Thursday, 10 Oct 2013, 19:23
>> To: Jitsi Developers [dev@jitsi.org]
>> Subject: Re: [jitsi-dev] Problem with audio on calls and notification of
>> incoming calls
>>
>> Hi,
>>
>> yes it is answered as it is supposed to, opens the call dialog and
>> everything else is hidden, download and try it with Jitsi.
>> Please when you report an issue test it first with Jitsi, if possible
>> of course. And if the problem persist then report the problem.
>>
>> Thanks
>> damencho
>>
>>
>> On Wed, Oct 9, 2013 at 10:49 PM, Curtis Raams <craams@staff.ains.net.au > > > >> wrote:
>>> Hell Damien,
>>>
>>> I will have the team look at it again.
>>>
>>> When you used auto answer, did the whole call dialog box open up, or
did
>>> the
>>> call answer but you still needed to press the answer button on screen
to
>>> bring the call dialog box up?
>>>
>>>
>>> -----Original Message-----
>>> From: Damian Minkov [damencho@jitsi.org]
>>> Received: Wednesday, 09 Oct 2013, 23:33
>>> To: Jitsi Developers [dev@jitsi.org]
>>> Subject: Re: [jitsi-dev] Problem with audio on calls and notification
of
>>> incoming calls
>>>
>>> Hi,
>>>
>>> On Wed, Oct 9, 2013 at 1:47 PM, Curtis Raams <craams@staff.ains.net.au > > > >>> wrote:
>>>> Here is the errors that appeared to directly cause the two calls to
both
>>>> auto answer and the user to speak to both callers (UI showed the
>>>> accept/decline box for both calls)....
>>>>
>>>> 16:32:10.742 SEVERE: [2689]
>>>>
plugin.notificationwiring.NotificationManager.incomingCallReceived().992
>>>> An
>>>> error occurred while trying to notify about an incoming call
>>>> java.lang.NoClassDefFoundError:
>>>>
net/java/sip/communicator/impl/protocol/sip/OperationSetAutoAnswerSipImpl
>>>> at
>>>>
>>>>
net.java.sip.communicator.plugin.notificationwiring.NotificationManager.incomingCallReceived(NotificationManager.java:947)
>>>
>>> Tested with vanilla Jitsi distribution and auto answer is working fine
>>> without any exception. So it must be your modifications that brings
>>> the problem.
>>>
>>> Normally NoClassDefFoundError are because of wrong import/export of
>>> packages in felix, or just missing such. You can check the mailinglist
>>> archives for details.
>>>
>>> Regards
>>> damencho
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>
>>> ______________________________________________________________________
>>> This email has been scanned by the Symantec Email Security.cloud
service.
>>> For more information please visit http://www.symanteccloud.com
>>> ______________________________________________________________________
>>>
>>> ______________________________________________________________________
>>> This email has been scanned by the Symantec Email Security.cloud
service.
>>> For more information please visit http://www.symanteccloud.com
>>> ______________________________________________________________________
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>> ______________________________________________________________________
>> This email has been scanned by the Symantec Email Security.cloud
service.
>> For more information please visit http://www.symanteccloud.com
>> ______________________________________________________________________
>>
>> ______________________________________________________________________
>> This email has been scanned by the Symantec Email Security.cloud
service.
>> For more information please visit http://www.symanteccloud.com
>> ______________________________________________________________________
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi,

checkout build 4875.

Regards
damencho

···

On Wed, Oct 23, 2013 at 9:17 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

we didn't have time to do so, will fix this or next week and will let you
know.

Regards
damencho

On Wed, Oct 23, 2013 at 12:07 AM, Curtis Raams <craams@staff.ains.net.au>wrote:

Hello,

Since this commit was reversed has a fix been developed again?

I really need auto answer on sip calls to open the dialog and complete
the answer process. As it is now, it answers the call but will continue to
auto answer additional calls placing call 1 on hold.

Call waiting disabled only seems to wotk when the call has been
completely answered.

Curtis Raams
Chief Technical Officer
Level 6, 140 Queen St. Melbourne Victoria 3000
T: 03 8665 8305 F: 03 9945 7502 M: 0404 394 904
E: craams@staff.ains.net.au W: www.ains.com.au

-----Original Message-----
*From:* Damian Minkov [damencho@jitsi.org]
*Received:* Friday, 11 Oct 2013, 3:10
*To:* Jitsi Developers [dev@jitsi.org]
*Subject:* Re: [jitsi-dev] Problem with audio on calls and notification
of incoming calls

Hey,

I think I got it, fix was just committed you can test it with build
4858 does it fix it for you?

Thanks
damencho

On Thu, Oct 10, 2013 at 3:21 PM, Damian Minkov <damencho@jitsi.org> >> wrote:
> Hi,
>
> thanks for keep reporting :slight_smile: Boris also ping me for this one, that he
> had seen it while ago. I was testing with xmpp, by the way. Now when I
> tested with SIP it seems we had broke it. Will look at it, and will
> write when there is something to test. So stay tuned.
>
> Thanks
> damencho
>
>
> On Thu, Oct 10, 2013 at 2:34 PM, Curtis Raams <craams@staff.ains.net.au> >> wrote:
>> Hi Damien,
>>
>> I downloaded the latest nightly, set auto answer all calls and sure
enough
>> it answers the call but the screen remains on the middle alert where I
must
>> press answer or hangup.
>>
>> Even though I am talking to the caller.
>>
>> Pressing the answer button shows the main call dialog for hold etc, I
have
>> not tried hangup.
>>
>> This seems to be different for you. You are saying auto answer
immediately
>> opens the full call dialog and you do not even see the answer/terminate
>> dialog that should show on a standard call offer?
>>
>> -----Original Message-----
>> From: Damian Minkov [damencho@jitsi.org]
>> Received: Thursday, 10 Oct 2013, 19:23
>> To: Jitsi Developers [dev@jitsi.org]
>> Subject: Re: [jitsi-dev] Problem with audio on calls and notification
of
>> incoming calls
>>
>> Hi,
>>
>> yes it is answered as it is supposed to, opens the call dialog and
>> everything else is hidden, download and try it with Jitsi.
>> Please when you report an issue test it first with Jitsi, if possible
>> of course. And if the problem persist then report the problem.
>>
>> Thanks
>> damencho
>>
>>
>> On Wed, Oct 9, 2013 at 10:49 PM, Curtis Raams < >> craams@staff.ains.net.au> >> >> wrote:
>>> Hell Damien,
>>>
>>> I will have the team look at it again.
>>>
>>> When you used auto answer, did the whole call dialog box open up, or
did
>>> the
>>> call answer but you still needed to press the answer button on screen
to
>>> bring the call dialog box up?
>>>
>>>
>>> -----Original Message-----
>>> From: Damian Minkov [damencho@jitsi.org]
>>> Received: Wednesday, 09 Oct 2013, 23:33
>>> To: Jitsi Developers [dev@jitsi.org]
>>> Subject: Re: [jitsi-dev] Problem with audio on calls and notification
of
>>> incoming calls
>>>
>>> Hi,
>>>
>>> On Wed, Oct 9, 2013 at 1:47 PM, Curtis Raams < >> craams@staff.ains.net.au> >> >>> wrote:
>>>> Here is the errors that appeared to directly cause the two calls to
both
>>>> auto answer and the user to speak to both callers (UI showed the
>>>> accept/decline box for both calls)....
>>>>
>>>> 16:32:10.742 SEVERE: [2689]
>>>>
plugin.notificationwiring.NotificationManager.incomingCallReceived().992
>>>> An
>>>> error occurred while trying to notify about an incoming call
>>>> java.lang.NoClassDefFoundError:
>>>>
net/java/sip/communicator/impl/protocol/sip/OperationSetAutoAnswerSipImpl
>>>> at
>>>>
>>>>
net.java.sip.communicator.plugin.notificationwiring.NotificationManager.incomingCallReceived(NotificationManager.java:947)
>>>
>>> Tested with vanilla Jitsi distribution and auto answer is working fine
>>> without any exception. So it must be your modifications that brings
>>> the problem.
>>>
>>> Normally NoClassDefFoundError are because of wrong import/export of
>>> packages in felix, or just missing such. You can check the mailinglist
>>> archives for details.
>>>
>>> Regards
>>> damencho
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>
>>> ______________________________________________________________________
>>> This email has been scanned by the Symantec Email Security.cloud
service.
>>> For more information please visit http://www.symanteccloud.com
>>> ______________________________________________________________________
>>>
>>> ______________________________________________________________________
>>> This email has been scanned by the Symantec Email Security.cloud
service.
>>> For more information please visit http://www.symanteccloud.com
>>> ______________________________________________________________________
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>> ______________________________________________________________________
>> This email has been scanned by the Symantec Email Security.cloud
service.
>> For more information please visit http://www.symanteccloud.com
>> ______________________________________________________________________
>>
>> ______________________________________________________________________
>> This email has been scanned by the Symantec Email Security.cloud
service.
>> For more information please visit http://www.symanteccloud.com
>> ______________________________________________________________________
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev