[jitsi-dev] Problem connecting to the XMPP server


#1

Dear vide bridge gurus,

I was trying to bring up Jitsi video bridge on my local machine. And everything went more or less
smooth (beside missing slf4j-nop.jar, which I resolved). But when I tried to launch the bridge I got
"Connection refused" error, which I assume is failed attempt to connect to the XMPP server. Here
is more extended output I got:

Exception in thread "main" org.xmpp.component.ComponentException: java.net.ConnectException: Connection refused
     at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:272)

     at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)

     at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)

     at org.jitsi.videobridge.Main.main(Main.java:159)
Caused by: java.net.ConnectException: Connection refused
     at java.net.PlainSocketImpl.socketConnect(Native Method)
     at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
     at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
     at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
     at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
     at java.net.Socket.connect(Socket.java:529)
     at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:151)

Here is all the information which might be relevant:

1. I am running on ubuntu 10.04 (I tried both 32-bit and 64-bit installations). My hostname is "ubuntu".

2. I am using ejabberd XMPP server running also locally on the same machine, and here is the only change I made to
the ejabberd.cfg file as Jitsi website suggested:

{5275, ejabberd_service, [{host, "jitsi-videobridge.ubuntu", [{password, "password1234"}]}]},

3. The way I am trying to launch the video bridge is the following:

./jvb.sh --secret=password1234 --domain='ubuntu'

I did try various combinations and permutations of the command line parameters but to no avail.

4. There is absolutely nothing in the ejabberd log (/var/log/ejabberd/ejabberd.log) which would help to identify the
problem. Beside the following error which appears on the start of the service:

=ERROR REPORT==== 2014-01-03 20:00:06 ===
C(<0.253.0>:ejabberd_captcha:331) : The option captcha_cmd is not configured, but some module wants to use the CAPTCHA feature.

Please let me know if there is anything else I can provide. I will greatly appreciate any piece of advise as I would like to be able to start using the video conference as soon as possible.

Thanks
Yan


#2

I apologize for the unintended spam. As soon as I posted a question I figured out that I was editing
the wrong ejabberd.cfg file. I got the connection now. I might get other problems down the road but
at least this one is solved.

Thanks again
Yan

···

On 01/04/2014 08:21 AM, Yan Brenman wrote:

Dear vide bridge gurus,

I was trying to bring up Jitsi video bridge on my local machine. And everything went more or less
smooth (beside missing slf4j-nop.jar, which I resolved). But when I tried to launch the bridge I got
"Connection refused" error, which I assume is failed attempt to connect to the XMPP server. Here
is more extended output I got:

Exception in thread "main" org.xmpp.component.ComponentException: java.net.ConnectException: Connection refused
    at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:272)

    at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)

    at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)

    at org.jitsi.videobridge.Main.main(Main.java:159)
Caused by: java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
    at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
    at java.net.Socket.connect(Socket.java:529)
    at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:151)

Here is all the information which might be relevant:

1. I am running on ubuntu 10.04 (I tried both 32-bit and 64-bit installations). My hostname is "ubuntu".

2. I am using ejabberd XMPP server running also locally on the same machine, and here is the only change I made to
the ejabberd.cfg file as Jitsi website suggested:

{5275, ejabberd_service, [{host, "jitsi-videobridge.ubuntu", [{password, "password1234"}]}]},

3. The way I am trying to launch the video bridge is the following:

./jvb.sh --secret=password1234 --domain='ubuntu'

I did try various combinations and permutations of the command line parameters but to no avail.

4. There is absolutely nothing in the ejabberd log (/var/log/ejabberd/ejabberd.log) which would help to identify the
problem. Beside the following error which appears on the start of the service:

=ERROR REPORT==== 2014-01-03 20:00:06 ===
C(<0.253.0>:ejabberd_captcha:331) : The option captcha_cmd is not configured, but some module wants to use the CAPTCHA feature.

Please let me know if there is anything else I can provide. I will greatly appreciate any piece of advise as I would like to be able to start using the video conference as soon as possible.

Thanks
Yan

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev