[jitsi-dev] Persistence of changes after package updates


#1

Hi Jitsi team!

I've been making some changes to
/usr/share/jitsi-meet/interface_config.js: DEFAULT_REMOTE_DISPLAY_NAME
and APP_NAME variables. I would like to know if these configurations
would remain unchanged every time I do a package update using the
testing repository.

I would also like to change the title of the page so that instead of
saying "Jitsi Meet" it says something different. Where could I change
this so that this change is maintained with each package update?

Thanks in advance.

Kind regards,
Daniel

P.S.: Damian, if you read this, I know I still have to answer for your
email about the issue with Jigasi. Sorry for the delay. I will respond
to you as soon as possible to check that.


#2

Hi,

Hi Jitsi team!

I've been making some changes to
/usr/share/jitsi-meet/interface_config.js: DEFAULT_REMOTE_DISPLAY_NAME
and APP_NAME variables. I would like to know if these configurations
would remain unchanged every time I do a package update using the
testing repository.

Currently, this will be overridden on update, I have on my todo list
to move that file to /etc/jitsi/meet.
You can copy it and use the copy by overriding the location in nginx config.

I would also like to change the title of the page so that instead of
saying "Jitsi Meet" it says something different. Where could I change
this so that this change is maintained with each package update?

There is a virtual include of title.html in index, where you can set
your custom header tags. And you can have also use nginx to overide
the location in nginx to use a custom file so it will not be
overridden.

Regards
damencho

Thanks in advance.

Kind regards,
Daniel

P.S.: Damian, if you read this, I know I still have to answer for your
email about the issue with Jigasi. Sorry for the delay. I will respond
to you as soon as possible to check that.

No problem :slight_smile:

···

On Sat, May 27, 2017 at 9:45 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi,

Hi, Damian.

I've been making some changes to
/usr/share/jitsi-meet/interface_config.js: DEFAULT_REMOTE_DISPLAY_NAME
and APP_NAME variables. I would like to know if these configurations
would remain unchanged every time I do a package update using the
testing repository.

Currently, this will be overridden on update, I have on my todo list
to move that file to /etc/jitsi/meet.
You can copy it and use the copy by overriding the location in nginx config.

Do you mean to put some directive of Nginx to look for a file
/usr/share/jitsi-meet/interface_config.js in some path that is not
overwritten by the package update?

I would also like to change the title of the page so that instead of
saying "Jitsi Meet" it says something different. Where could I change
this so that this change is maintained with each package update?

There is a virtual include of title.html in index, where you can set
your custom header tags. And you can have also use nginx to overide
the location in nginx to use a custom file so it will not be
overridden.

I was checking the file you suggested:

···

On 27/05/17 11:56, Damian Minkov wrote:

------------------------------------------------------------------------
root@Jitsi:/usr/share/jitsi-meet# cat title.html
<title>Jitsi Meet</title>
<meta property="og:title" content="Jitsi Meet"/>
<meta property="og:image" content="/images/jitsilogo.png?v=1"/>
<meta property="og:description" content="Join a WebRTC video conference
powered by the Jitsi Videobridge"/>
<meta description="Join a WebRTC video conference powered by the Jitsi
Videobridge"/>
<meta itemprop="name" content="Jitsi Meet"/>
<meta itemprop="description" content="Join a WebRTC video conference
powered by the Jitsi Videobridge"/>
<meta itemprop="image" content="/images/jitsilogo.png?v=1"/>
<link rel="icon" type="image/png" href="/images/favicon.ico?v=1"/>
------------------------------------------------------------------------

Changing the text between <title></title> seems to work. Thanks for
that. Sorry but I'm not sure how I would have to do the changes with
Nginx or the content that I would have to put in this file that you
mention. Could you give me an example, please?

Thanks for your time.

Kind regards,
Daniel


#4

Hi, Damian.

···

On 27/05/17 11:56, Damian Minkov wrote:

I've been making some changes to
/usr/share/jitsi-meet/interface_config.js: DEFAULT_REMOTE_DISPLAY_NAME
and APP_NAME variables. I would like to know if these configurations
would remain unchanged every time I do a package update using the
testing repository.

Currently, this will be overridden on update, I have on my todo list
to move that file to /etc/jitsi/meet.
You can copy it and use the copy by overriding the location in nginx config.

A related question: the same applies to /etc/jitsi/meet/*-config.js? Ie,
are the changes lost after an update?

Thanks in advance.

Kind regards,
Daniel


#5

Hi,

First make sure your deployment is using nginx.

Hi,

Hi, Damian.

I've been making some changes to
/usr/share/jitsi-meet/interface_config.js: DEFAULT_REMOTE_DISPLAY_NAME
and APP_NAME variables. I would like to know if these configurations
would remain unchanged every time I do a package update using the
testing repository.

Currently, this will be overridden on update, I have on my todo list
to move that file to /etc/jitsi/meet.
You can copy it and use the copy by overriding the location in nginx config.

Do you mean to put some directive of Nginx to look for a file
/usr/share/jitsi-meet/interface_config.js in some path that is not
overwritten by the package update?

Something like this:
https://github.com/jitsi/jitsi-meet/blob/master/doc/debian/jitsi-meet/jitsi-meet.example#L25

location /interface_config.js {
.....

I would also like to change the title of the page so that instead of
saying "Jitsi Meet" it says something different. Where could I change
this so that this change is maintained with each package update?

There is a virtual include of title.html in index, where you can set
your custom header tags. And you can have also use nginx to overide
the location in nginx to use a custom file so it will not be
overridden.

I was checking the file you suggested:

------------------------------------------------------------------------
root@Jitsi:/usr/share/jitsi-meet# cat title.html
<title>Jitsi Meet</title>
<meta property="og:title" content="Jitsi Meet"/>
<meta property="og:image" content="/images/jitsilogo.png?v=1"/>
<meta property="og:description" content="Join a WebRTC video conference
powered by the Jitsi Videobridge"/>
<meta description="Join a WebRTC video conference powered by the Jitsi
Videobridge"/>
<meta itemprop="name" content="Jitsi Meet"/>
<meta itemprop="description" content="Join a WebRTC video conference
powered by the Jitsi Videobridge"/>
<meta itemprop="image" content="/images/jitsilogo.png?v=1"/>
<link rel="icon" type="image/png" href="/images/favicon.ico?v=1"/>
------------------------------------------------------------------------

Changing the text between <title></title> seems to work. Thanks for
that. Sorry but I'm not sure how I would have to do the changes with
Nginx or the content that I would have to put in this file that you
mention. Could you give me an example, please?

The same example for title.html as the one above for interface_config.js.
location /title.html {
....

Cheers
damencho

···

On Sat, May 27, 2017 at 11:22 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 27/05/17 11:56, Damian Minkov wrote:

Thanks for your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

No, if something changes in /etc/ and a file needs override, the dpkg
system is supposed to ask the user. So whatever is configured in /etc/
should not be overridden.

···

On Mon, May 29, 2017 at 5:46 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi, Damian.

On 27/05/17 11:56, Damian Minkov wrote:

I've been making some changes to
/usr/share/jitsi-meet/interface_config.js: DEFAULT_REMOTE_DISPLAY_NAME
and APP_NAME variables. I would like to know if these configurations
would remain unchanged every time I do a package update using the
testing repository.

Currently, this will be overridden on update, I have on my todo list
to move that file to /etc/jitsi/meet.
You can copy it and use the copy by overriding the location in nginx config.

A related question: the same applies to /etc/jitsi/meet/*-config.js? Ie,
are the changes lost after an update?

Thanks in advance.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Hi, Damian.

···

On 29/05/17 19:51, Damian Minkov wrote:

> A related question: the same applies to
> /etc/jitsi/meet/*-config.js? Ie, are the changes lost after
> an update?

No, if something changes in /etc/ and a file needs override, the dpkg
system is supposed to ask the user. So whatever is configured in /etc/
should not be overridden.

It is true. After I submitted this question to the list, I was
meditating for a moment and remembered that my config.js settings
remained unchanged when I upgrade from stable repo to testing repo :slight_smile:

Thanks for your reply.

Kind regards,
Daniel


#8

Hi,

Hi, Damian.

First make sure your deployment is using nginx.

Yes, I'm using Nginx.

I've been making some changes to
/usr/share/jitsi-meet/interface_config.js: DEFAULT_REMOTE_DISPLAY_NAME
and APP_NAME variables. I would like to know if these configurations
would remain unchanged every time I do a package update using the
testing repository.

Currently, this will be overridden on update, I have on my todo list
to move that file to /etc/jitsi/meet.
You can copy it and use the copy by overriding the location in nginx config.

Do you mean to put some directive of Nginx to look for a file
/usr/share/jitsi-meet/interface_config.js in some path that is not
overwritten by the package update?

Something like this:
https://github.com/jitsi/jitsi-meet/blob/master/doc/debian/jitsi-meet/jitsi-meet.example#L25

location /interface_config.js {
.....

I would also like to change the title of the page so that instead of
saying "Jitsi Meet" it says something different. Where could I change
this so that this change is maintained with each package update?

There is a virtual include of title.html in index, where you can set
your custom header tags. And you can have also use nginx to overide
the location in nginx to use a custom file so it will not be
overridden.

I was checking the file you suggested:

------------------------------------------------------------------------
root@Jitsi:/usr/share/jitsi-meet# cat title.html
<title>Jitsi Meet</title>
<meta property="og:title" content="Jitsi Meet"/>
<meta property="og:image" content="/images/jitsilogo.png?v=1"/>
<meta property="og:description" content="Join a WebRTC video conference
powered by the Jitsi Videobridge"/>
<meta description="Join a WebRTC video conference powered by the Jitsi
Videobridge"/>
<meta itemprop="name" content="Jitsi Meet"/>
<meta itemprop="description" content="Join a WebRTC video conference
powered by the Jitsi Videobridge"/>
<meta itemprop="image" content="/images/jitsilogo.png?v=1"/>
<link rel="icon" type="image/png" href="/images/favicon.ico?v=1"/>
------------------------------------------------------------------------

Changing the text between <title></title> seems to work. Thanks for
that. Sorry but I'm not sure how I would have to do the changes with
Nginx or the content that I would have to put in this file that you
mention. Could you give me an example, please?

The same example for title.html as the one above for interface_config.js.
location /title.html {
....

Thanks Damian. This seems to work:

···

On 27/05/17 15:24, Damian Minkov wrote:

-------------------------------------------------------------------------
    location /title.html {
        alias /usr/share/jitsi-meet/title-persistent.html;
    }

    location /interface_config.js {
        alias /usr/share/jitsi-meet/interface_config-persistent.js;
    }
-------------------------------------------------------------------------

But now, for some reason, I'm not seeing the "Fellow Jitster" box. I
commented the recent changes in Nginx in case it was related to that,
but it did not make any difference.

Any idea what might have happened? If I can provide more information,
please let me know.

Thanks in advance.

Kind regards,
Daniel


#9

Are you talking about the new one-to-one interface? Join 3 participants, is
it different? Are you seeing the same on meet.jit.si?

···

On May 27, 2017 6:39 PM, "Daniel Bareiro" <daniel-listas@gmx.net> wrote:

On 27/05/17 15:24, Damian Minkov wrote:

> Hi,

Hi, Damian.

> First make sure your deployment is using nginx.

Yes, I'm using Nginx.

>>>> I've been making some changes to
>>>> /usr/share/jitsi-meet/interface_config.js:
DEFAULT_REMOTE_DISPLAY_NAME
>>>> and APP_NAME variables. I would like to know if these configurations
>>>> would remain unchanged every time I do a package update using the
>>>> testing repository.

>>> Currently, this will be overridden on update, I have on my todo list
>>> to move that file to /etc/jitsi/meet.
>>> You can copy it and use the copy by overriding the location in nginx
config.

>> Do you mean to put some directive of Nginx to look for a file
>> /usr/share/jitsi-meet/interface_config.js in some path that is not
>> overwritten by the package update?

> Something like this:
> https://github.com/jitsi/jitsi-meet/blob/master/doc/
debian/jitsi-meet/jitsi-meet.example#L25
>
> location /interface_config.js {
> .....

>>>> I would also like to change the title of the page so that instead of
>>>> saying "Jitsi Meet" it says something different. Where could I change
>>>> this so that this change is maintained with each package update?

>>> There is a virtual include of title.html in index, where you can set
>>> your custom header tags. And you can have also use nginx to overide
>>> the location in nginx to use a custom file so it will not be
>>> overridden.

>> I was checking the file you suggested:
>>
>> ------------------------------------------------------------
------------
>> root@Jitsi:/usr/share/jitsi-meet# cat title.html
>> <title>Jitsi Meet</title>
>> <meta property="og:title" content="Jitsi Meet"/>
>> <meta property="og:image" content="/images/jitsilogo.png?v=1"/>
>> <meta property="og:description" content="Join a WebRTC video conference
>> powered by the Jitsi Videobridge"/>
>> <meta description="Join a WebRTC video conference powered by the Jitsi
>> Videobridge"/>
>> <meta itemprop="name" content="Jitsi Meet"/>
>> <meta itemprop="description" content="Join a WebRTC video conference
>> powered by the Jitsi Videobridge"/>
>> <meta itemprop="image" content="/images/jitsilogo.png?v=1"/>
>> <link rel="icon" type="image/png" href="/images/favicon.ico?v=1"/>
>> ------------------------------------------------------------
------------

>> Changing the text between <title></title> seems to work. Thanks for
>> that. Sorry but I'm not sure how I would have to do the changes with
>> Nginx or the content that I would have to put in this file that you
>> mention. Could you give me an example, please?
>
> The same example for title.html as the one above for interface_config.js.
> location /title.html {
> ....

Thanks Damian. This seems to work:

-------------------------------------------------------------------------
    location /title.html {
        alias /usr/share/jitsi-meet/title-persistent.html;
    }

    location /interface_config.js {
        alias /usr/share/jitsi-meet/interface_config-persistent.js;
    }
-------------------------------------------------------------------------

But now, for some reason, I'm not seeing the "Fellow Jitster" box. I
commented the recent changes in Nginx in case it was related to that,
but it did not make any difference.

Any idea what might have happened? If I can provide more information,
please let me know.

Thanks in advance.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

Hi, Damian.

Are you talking about the new one-to-one interface? Join 3 participants,
is it different? Are you seeing the same on meet.jit.si

Before each participant had two boxes in the bottom: one that says "me"
and another saying "Fellow Jitster" where the video of the other was
shown. I can corroborate this behavior in an installation I have with
the following package versions:

* Jicofo: 1.0-355-1 (testing repo)
* Jitsi Videobridge: 951-1 (testing repo)
* jitsi-meet: 1.0.2084-1 (testing repo)
* jitsi-meet-web: 1.0.1957-1 (testing repo)

But in the most recent version each participant only sees a box saying
"me". In this case I am using these versions of packages:

* Jicofo: 1.0-357-1 (testing repo)
* Jitsi Videobridge: 953-1 (testing repo)
* jitsi-meet: 1.0.2111-1 (testing repo)
* jitsi-meet-web: 1.0.1980-1 (testing repo)

Yesterday I did a test with jitsi-meet 1.0.2104-1, jitsi-meet-prosody
1.0.1973-1, jitsi-meet-web 1.0.1973-1 and jitsi-meet-web-config
1.0.1973-1 and I also noticed the same behavior.

In meet.jit.si also in the small boxes of video only appears a single
box saying "me". Maybe this is expected behavior in newer versions?

I also noticed that in the most recent version of "testing" repo there
is no icon with the eye for audio only mode which was present with
jitsi-meet 1.0.2084-1. I noticed that in this version there was also the
drop-down menu in the upper right corner with "Audio Only / Video".
Maybe you removed the icon because it was redundant because of the
existence of that drop-down menu?

Thanks for your reply.

Kind regards,
Daniel

···

On 28/05/17 11:10, Damian Minkov wrote:


#11

Hi, Damian.

···

On 28/05/17 14:10, Daniel Bareiro wrote:

Are you talking about the new one-to-one interface? Join 3 participants,
is it different? Are you seeing the same on meet.jit.si

Before each participant had two boxes in the bottom: one that says "me"
and another saying "Fellow Jitster" where the video of the other was
shown. I can corroborate this behavior in an installation I have with
the following package versions:

* Jicofo: 1.0-355-1 (testing repo)
* Jitsi Videobridge: 951-1 (testing repo)
* jitsi-meet: 1.0.2084-1 (testing repo)
* jitsi-meet-web: 1.0.1957-1 (testing repo)

But in the most recent version each participant only sees a box saying
"me". In this case I am using these versions of packages:

* Jicofo: 1.0-357-1 (testing repo)
* Jitsi Videobridge: 953-1 (testing repo)
* jitsi-meet: 1.0.2111-1 (testing repo)
* jitsi-meet-web: 1.0.1980-1 (testing repo)

Yesterday I did a test with jitsi-meet 1.0.2104-1, jitsi-meet-prosody
1.0.1973-1, jitsi-meet-web 1.0.1973-1 and jitsi-meet-web-config
1.0.1973-1 and I also noticed the same behavior.

In meet.jit.si also in the small boxes of video only appears a single
box saying "me". Maybe this is expected behavior in newer versions?

I also noticed that in the most recent version of "testing" repo there
is no icon with the eye for audio only mode which was present with
jitsi-meet 1.0.2084-1. I noticed that in this version there was also the
drop-down menu in the upper right corner with "Audio Only / Video".
Maybe you removed the icon because it was redundant because of the
existence of that drop-down menu?

When you have a moment, kindly confirm if this is the expected behavior.

Thanks in advance.

Kind regards,
Daniel


#12

Hi,

So the case where you are in one-to-one call and you see only one
thumbnail was merged 10 days ago, approximately. The behavior you see
on meet.jit.si is the default now.
Also the audio only mode is enabled now only through the hd/sd label on top.

So what you observe is what is expected.

Regards
damencho

···

On Mon, May 29, 2017 at 12:16 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi, Damian.

On 28/05/17 14:10, Daniel Bareiro wrote:

Are you talking about the new one-to-one interface? Join 3 participants,
is it different? Are you seeing the same on meet.jit.si

Before each participant had two boxes in the bottom: one that says "me"
and another saying "Fellow Jitster" where the video of the other was
shown. I can corroborate this behavior in an installation I have with
the following package versions:

* Jicofo: 1.0-355-1 (testing repo)
* Jitsi Videobridge: 951-1 (testing repo)
* jitsi-meet: 1.0.2084-1 (testing repo)
* jitsi-meet-web: 1.0.1957-1 (testing repo)

But in the most recent version each participant only sees a box saying
"me". In this case I am using these versions of packages:

* Jicofo: 1.0-357-1 (testing repo)
* Jitsi Videobridge: 953-1 (testing repo)
* jitsi-meet: 1.0.2111-1 (testing repo)
* jitsi-meet-web: 1.0.1980-1 (testing repo)

Yesterday I did a test with jitsi-meet 1.0.2104-1, jitsi-meet-prosody
1.0.1973-1, jitsi-meet-web 1.0.1973-1 and jitsi-meet-web-config
1.0.1973-1 and I also noticed the same behavior.

In meet.jit.si also in the small boxes of video only appears a single
box saying "me". Maybe this is expected behavior in newer versions?

I also noticed that in the most recent version of "testing" repo there
is no icon with the eye for audio only mode which was present with
jitsi-meet 1.0.2084-1. I noticed that in this version there was also the
drop-down menu in the upper right corner with "Audio Only / Video".
Maybe you removed the icon because it was redundant because of the
existence of that drop-down menu?

When you have a moment, kindly confirm if this is the expected behavior.

Thanks in advance.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#13

Hi, Damian.

···

On 29/05/17 19:49, Damian Minkov wrote:

So the case where you are in one-to-one call and you see only one
thumbnail was merged 10 days ago, approximately. The behavior you see
on meet.jit.si is the default now.
Also the audio only mode is enabled now only through the hd/sd label on top.

So what you observe is what is expected.

Thank you very much for confirming.

Kind regards,
Daniel


#14

Hi, Damian.

Also the audio only mode is enabled now only through the hd/sd label on top.

Regarding SD/HD, in meet.jit.si I see "HD" but in my installation I see
"SD". I was comparing the config.js files of both environments, and I
noticed that in meet.jit.si they are using "resolution: 720". Adding
that would have to be enough to work in HD mode?

Thanks in advance.

Kind regards,
Daniel

···

On 29/05/17 19:49, Damian Minkov wrote:


#15

Yes.

···

On May 30, 2017 08:18, "Daniel Bareiro" <daniel-listas@gmx.net> wrote:

Hi, Damian.

On 29/05/17 19:49, Damian Minkov wrote:

> Also the audio only mode is enabled now only through the hd/sd label on
top.

Regarding SD/HD, in meet.jit.si I see "HD" but in my installation I see
"SD". I was comparing the config.js files of both environments, and I
noticed that in meet.jit.si they are using "resolution: 720". Adding
that would have to be enough to work in HD mode?

Thanks in advance.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#16

Perfect. Thanks! :slight_smile:

Kind regards,
Daniel

···

On 30/05/17 10:19, Damian Minkov wrote:

> > Also the audio only mode is enabled now only through the hd/sd
> > label on top.

> Regarding SD/HD, in meet.jit.si <http://meet.jit.si> I see "HD" but
> in my installation I see "SD". I was comparing the config.js files
> of both environments, and I noticed that in meet.jit.si they
> are using "resolution: 720". Adding that would have to be enough to
> work in HD mode?

Yes.


#17

Updated cert resulted in now prevented from opening Jitsi-meet due to password get-id error.

1) Any suggestions where to address issue?
2) How can we turn off password authentication temporarily?

Both jicofo & JVB set to port= 5347, XMPP set to port 5275
In syslog :

prosody[12789]: jitsi-videobridge.our.domain.com:component: Second component attempted to connect, denying connection

May 30 21:24:44 prosody[12789]: focus.our.domain.com:component: Second component attempted to connect, denying connection

May 30 21:24:49 prosody[12789]: jitsi-videobridge.our.domain.com:component: Second component attempted to connect, denying connection

May 30 21:24:49 prosody[12789]: focus.our.domain.com:component: Second component attempted to connect, denying connection

prosody log

May 30 21:44:46 focus.our.domain.com:component error Second component attempted to connect, denying connection

May 30 21:44:46 mod_component info Disconnecting component, <stream:error> is: <stream:error><conflict xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Component already connected</text></stream:error>

May 30 21:44:46 jcp28abfd0 info component disconnected: focus.our.domain.com (false)

May 30 21:44:48 c2s28db120 info Client connected

May 30 21:44:48 sasl warn Client is violating RFC 3920 (section 6.1, point 7).

May 30 21:44:48 c2s28db120 info c2s stream for <127.0.0.1> closed: session closed

May 30 21:44:48 c2s28db120 info Client disconnected: connection closed

May 30 21:44:50 c2s2fd67d0 info Client connected

May 30 21:44:50 sasl warn Client is violating RFC 3920 (section 6.1, point 7).

May 30 21:44:51 jcp26eafa0 info Incoming Jabber component connection

May 30 21:44:51 jitsi-videobridge.our.domain.com:component error Second component attempted to connect, denying connection

May 30 21:44:51 mod_component info Disconnecting component, <stream:error> is: <stream:error><conflict xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Component already connected</text></stream:error>

May 30 21:44:51 jcp26eafa0 info component disconnected: jitsi-videobridge.our.domain.com (false)

May 30 21:44:51 jcp1b6d940 info Incoming Jabber component connection

May 30 21:44:51 focus.our.domain.com:component error Second component attempted to connect, denying connection

May 30 21:44:51 mod_component info Disconnecting component, <stream:error> is: <stream:error><conflict xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Component already connected</text></stream:error>

May 30 21:44:51 jcp1b6d940 info component disconnected: focus.our.domain.com (false)

jicofo log

Jicofo 2017-05-30 21:50:18.374 SEVERE: [116] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.log() Failed to connect/login: SASL authentication DIGEST-MD5 failed: text

SASL authentication DIGEST-MD5 failed: text:

at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:341)

at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)

at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:224)

at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:47)

at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:192)

at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:187)

at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

at java.util.concurrent.FutureTask.run(FutureTask.java:266)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

at java.lang.Thread.run(Thread.java:745)

Jicofo 2017-05-30 21:50:23.702 SEVERE: [116] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.log() Failed to connect/login: SASL authentication DIGEST-MD5 failed: text

SASL authentication DIGEST-MD5 failed: text:

at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:341)

at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)

at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:224)

at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:47)

at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:192)

at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:187)

at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

at java.util.concurrent.FutureTask.run(FutureTask.java:266)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

at java.lang.Thread.run(Thread.java:745)

JVB log

JVB 2017-05-25 06:30:23.037 SEVERE: [19] org.jitsi.meet.ComponentMain.call().278 conflict, host:localhost, port:5347

org.xmpp.component.ComponentException: conflict

at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)

at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)

at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)

at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:270)

at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:255)

at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

at java.util.concurrent.FutureTask.run(FutureTask.java:266)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

at java.lang.Thread.run(Thread.java:745)

JVB 2017-05-25 06:30:28.039 SEVERE: [19] org.jitsi.meet.ComponentMain.call().278 conflict, host:localhost, port:5347

org.xmpp.component.ComponentException: conflict

at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)

at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)

at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)

at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:270)

at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:255)

at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

auth.log log

Failed password for root from 221.194.47.242 port 37495 ssh2

May 30 21:58:03 sshd[7417]: message repeated 2 times: [ Failed password for root from 221.194.47.242 port 37495 ssh2]

May 30 21:58:03 sshd[7417]: Received disconnect from 221.194.47.242: 11: [preauth]

May 30 21:58:03 sshd[7417]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=221.194.47.242 user=root

May 30 21:58:07 sshd[8940]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=221.194.47.242 user=root

May 30 21:58:09 sshd[8940]: Failed password for root from 221.194.47.242 port 52016 ssh2

May 30 21:58:13 sshd[8940]: message repeated 2 times: [ Failed password for root from 221.194.47.242 port 52016 ssh2]

May 30 21:58:14 sshd[8940]: Received disconnect from 221.194.47.242: 11: [preauth]

May 30 21:58:14 sshd[8940]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=221.194.47.242 user=root

May 30 21:58:15 sshd[10466]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=221.194.47.242 user=root

May 30 21:58:17 sshd[10466]: Failed password for root from 221.194.47.242 port 36002 ssh2

May 30 21:58:21 sshd[10466]: message repeated 2 times: [ Failed password for root from 221.194.47.242 port 36002 ssh2]

May 30 21:58:21 sshd[10466]: Received disconnect from 221.194.47.242: 11: [preauth]

May 30 21:58:21 sshd[10466]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=221.194.47.242 user=root

May 30 21:58:25 sshd[11231]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=221.194.47.242 user=root

May 30 21:58:27 sshd[11231]: Failed password for root from 221.194.47.242 port 38070 ssh2

···

----- Original Message -----


#18

Prosody should listen on 5347, jicofo and jvb should both connect on 5347. Only one component is allowed per domain name, and the errors that you see are due to a component trying to connect using a name which is already connected. This usually happens when you have e.g. two videobridge processes running.

Port 5275 is not used unless you specifically configured something to use it.

I hope this helps.

Boris

···

On 30/05/2017 17:07, royblog@comcast.net wrote:

Updated cert resulted in now prevented from opening Jitsi-meet due to password get-id error.

1) Any suggestions where to address issue?
2) How can we turn off password authentication temporarily?

Both jicofo & JVB set to port= 5347, XMPP set to port 5275


#19

Changed our cert which has caused unstable jibri connection and authentication issues.
Getting Get session-id error, and focus unavailable retry.

Any suggestions on how to address issue?
Attached is our Jicofo log. Only 1 JVB & Jicofo running.

jicofo log file : a ttached

Prosody log last entries:

May 31 16:38:08 sasl warn Client is violating RFC 3920 (section 6.1, point 7).

May 31 16:38:09 c2s25e7430 info c2s stream for <127.0.0.1> closed: session closed

May 31 16:38:09 c2s25e7430 info Client disconnected: connection closed

May 31 16:38:14 c2s25c1840 info Client connected

May 31 16:38:14 sasl warn Client is violating RFC 3920 (section 6.1, point 7).

May 31 16:38:15 c2s25c1840 info c2s stream for <127.0.0.1> closed: session closed

May 31 16:38:15 c2s25c1840 info Client disconnected: connection closed

May 31 16:38:20 c2s2a58330 info Client connected

May 31 16:38:20 sasl warn Client is violating RFC 3920 (section 6.1, point 7).

May 31 16:38:22 c2s2a58330 info c2s stream for <127.0.0.1> closed: session closed

May 31 16:38:22 c2s2a58330 info Client disconnected: connection closed

May 31 16:38:27 c2s27fb590 info Client connected

May 31 16:38:27 sasl warn Client is violating RFC 3920 (section 6.1, point 7).

May 31 16:38:28 c2s27fb590 info c2s stream for <127.0.0.1> closed: session closed

May 31 16:38:28 c2s27fb590 info Client disconnected: connection closed

May 31 16:38:33 c2s2890ba0 info Client connected

May 31 16:38:33 sasl warn Client is violating RFC 3920 (section 6.1, point 7).

May 31 16:38:34 c2s2890ba0 info c2s stream for <127.0.0.1> closed: session closed

May 31 16:38:34 c2s2890ba0 info Client disconnected: connection closed

Jicofo_log_May31.docx (208 KB)

···

----- Original Message -----

From: "Boris Grozev" <boris@jitsi.org>
To: royblog@comcast.net
Sent: Tuesday, May 30, 2017 5:47:08 PM
Subject: Re: [jitsi-dev] Focus failed to connect/ Get session ID error / conflict port 5347

On 30/05/2017 19:39, royblog@comcast.net wrote:

Boris,
Any suggestions welcome.

Attached are larger log files for :
Prosody http://drops.oritor.com/vv6zF5 This looked different from
prior logs
Jicofo http://drops.oritor.com/O8rBK1

This is a separate problem. If the "conflict" logs are missing, this
would mean that jicofo is connected as a component.

Auth http://drops.oritor.com/cQcWWU

It looks like someone is trying to brute force your ssh server, this is
not related to jitsi at all.

JVB http://drops.oritor.com/PDcazf

This bridge appears healthy.

Boris