[jitsi-dev] Permissions denied for camera and micro without even asking in ifame jitsi room


#1

Hi everyone,

I'm working with the jitsi meet external api to embed a visio conference
system in an existing web app.
I am able to create a room in an iframe and the connection with the jitsi
server is working correctly, but the camera and the microphone are not
starting, and it does not even asks me for it (the server is working fine,
I'm able to create working rooms with micro and camera by connecting to my
server ip).

The only différence I can see for now I'm on https in my server, and the
application is not, but the request url for the iframe is also in https.

Any help would be greatly appreciated.

Best regards

Jimmy


#2

Hi again,

to answer my own question in case someone runs in the same problem, the
fact is google chrome does not allow access to microphone or camera if
you're not in https. So even so I was creating an iframe with a https url,
as long as I was not in https in my web app it would not work. Switching
the app to https solved the problem.

Best regards

Jimmy

···

2016-06-23 15:09 GMT+02:00 Jimmy Kasprzak <jimmyk.dsi@gmail.com>:

Hi everyone,

I'm working with the jitsi meet external api to embed a visio conference
system in an existing web app.
I am able to create a room in an iframe and the connection with the jitsi
server is working correctly, but the camera and the microphone are not
starting, and it does not even asks me for it (the server is working fine,
I'm able to create working rooms with micro and camera by connecting to my
server ip).

The only différence I can see for now I'm on https in my server, and the
application is not, but the request url for the iframe is also in https.

Any help would be greatly appreciated.

Best regards

Jimmy