[jitsi-dev] [PATCH] Push to talk


#1

Hello,

I'm attaching the patch for the push to talk global shortcut.

The feature can be tested if you are in call when you press the shortcut
for the push to talk the call is unmuted, when you release the shortcut the
call is muted again. You can set the key combinations from
Tools->Options->Advanced->Keybindings.

Note: on windows 64 the global shortcuts are not working at all for me. I
haven't investigated it yet.

To run the project with this patch the native files for globalshortcut
should be compiled too.

While I was implementing this feature I made the following improvements to
global shortcuts functionality:

On windows:
There was a situation when some of the shortcuts could be missed. In this
case jitsi won't receive the events for key press.
I added a flag when the shortcuts are registered to prevent repeating of
the pressed events when the key is hold down.Now jitsi receives only 1
event for press when a shortcut is hold down.

On mac:
The shortcuts are changed to work on press instead of on release of the
keys.

Regards.

push_to_talk.txt (39.9 KB)


#2

Hey Hristo,

I've just applied and tested your patch. I find it a really cool feature!

It works great, I've just encountered one small problem. When I press my key combination I'm un-muted, which is perfect, but then if I just release only one of the control keys of the shortcut I stay un-muted. The thing is that it's very easy to not un-press the keys in the "right" order, so this could happen very often and one could think they're muted again, but they won't be.

(more inline)

Hello,

I'm attaching the patch for the push to talk global shortcut.

The feature can be tested if you are in call when you press the shortcut for the push to talk the call is unmuted, when you release the shortcut the call is muted again. You can set the key combinations from Tools->Options->Advanced->Keybindings.

Note: on windows 64 the global shortcuts are not working at all for me. I haven't investigated it yet.

To run the project with this patch the native files for globalshortcut should be compiled too.

While I was implementing this feature I made the following improvements to global shortcuts functionality:

On windows:
There was a situation when some of the shortcuts could be missed. In this case jitsi won't receive the events for key press.
I added a flag when the shortcuts are registered to prevent repeating of the pressed events when the key is hold down.Now jitsi receives only 1 event for press when a shortcut is hold down.

On mac:
The shortcuts are changed to work on press instead of on release of the keys.

What about linux, does this feature work on linux?

Cheers,
Yana

···

On Mar 8, 2013, at 3:16 PM, Hristo Terezov <hristoterezov@gmail.com> wrote:

Regards.
<push_to_talk.txt>


#3

Hi Yana,

Thanks for applying my patch.

I think it's working on linux ( I made some changes in the native code
there and I tested it). Sorry I forgot to mention it.

About the issue I didn't noticed it while I was testing the feature. I'll
test it and fix it.

Regards,
Hristo.

···

On Fri, Mar 22, 2013 at 9:20 PM, Yana Stamcheva <yana@jitsi.org> wrote:

Hey Hristo,

I've just applied and tested your patch. I find it a really cool feature!

It works great, I've just encountered one small problem. When I press my
key combination I'm un-muted, which is perfect, but then if I just release
only one of the control keys of the shortcut I stay un-muted. The thing is
that it's very easy to not un-press the keys in the "right" order, so this
could happen very often and one could think they're muted again, but they
won't be.

(more inline)

On Mar 8, 2013, at 3:16 PM, Hristo Terezov <hristoterezov@gmail.com> > wrote:

> Hello,
>
> I'm attaching the patch for the push to talk global shortcut.
>
> The feature can be tested if you are in call when you press the shortcut
for the push to talk the call is unmuted, when you release the shortcut the
call is muted again. You can set the key combinations from
Tools->Options->Advanced->Keybindings.
>
> Note: on windows 64 the global shortcuts are not working at all for me.
I haven't investigated it yet.
>
> To run the project with this patch the native files for globalshortcut
should be compiled too.
>
> While I was implementing this feature I made the following improvements
to global shortcuts functionality:
>
> On windows:
> There was a situation when some of the shortcuts could be missed. In
this case jitsi won't receive the events for key press.
> I added a flag when the shortcuts are registered to prevent repeating of
the pressed events when the key is hold down.Now jitsi receives only 1
event for press when a shortcut is hold down.
>
> On mac:
> The shortcuts are changed to work on press instead of on release of the
keys.

What about linux, does this feature work on linux?

Cheers,
Yana

>
> Regards.
> <push_to_talk.txt>


#4

Hello,

I'm attaching next version of the patch where the issue on mac os is fixed.

When the user first releases one of the control keys the call stays unmuted
when all keys are released.

With the fix when the user releases all the keys the call is muted again
and the behavior doesn't depend on the order of releasing the keys.

Regards,

push_to_talk_v2.txt (40 KB)

···

On Fri, Mar 22, 2013 at 9:42 PM, Hristo Terezov <hristoterezov@gmail.com>wrote:

Hi Yana,

Thanks for applying my patch.

I think it's working on linux ( I made some changes in the native code
there and I tested it). Sorry I forgot to mention it.

About the issue I didn't noticed it while I was testing the feature. I'll
test it and fix it.

Regards,
Hristo.

On Fri, Mar 22, 2013 at 9:20 PM, Yana Stamcheva <yana@jitsi.org> wrote:

Hey Hristo,

I've just applied and tested your patch. I find it a really cool feature!

It works great, I've just encountered one small problem. When I press my
key combination I'm un-muted, which is perfect, but then if I just release
only one of the control keys of the shortcut I stay un-muted. The thing is
that it's very easy to not un-press the keys in the "right" order, so this
could happen very often and one could think they're muted again, but they
won't be.

(more inline)

On Mar 8, 2013, at 3:16 PM, Hristo Terezov <hristoterezov@gmail.com> >> wrote:

> Hello,
>
> I'm attaching the patch for the push to talk global shortcut.
>
> The feature can be tested if you are in call when you press the
shortcut for the push to talk the call is unmuted, when you release the
shortcut the call is muted again. You can set the key combinations from
Tools->Options->Advanced->Keybindings.
>
> Note: on windows 64 the global shortcuts are not working at all for me.
I haven't investigated it yet.
>
> To run the project with this patch the native files for globalshortcut
should be compiled too.
>
> While I was implementing this feature I made the following improvements
to global shortcuts functionality:
>
> On windows:
> There was a situation when some of the shortcuts could be missed. In
this case jitsi won't receive the events for key press.
> I added a flag when the shortcuts are registered to prevent repeating
of the pressed events when the key is hold down.Now jitsi receives only 1
event for press when a shortcut is hold down.
>
> On mac:
> The shortcuts are changed to work on press instead of on release of the
keys.

What about linux, does this feature work on linux?

Cheers,
Yana

>
> Regards.
> <push_to_talk.txt>


#5

Hi Hristo,

Thanks for fixing the problem! It works great!

Your patch is now committed and ack-ed.

Cheers,
Yana

···

On Mar 25, 2013, at 11:01 AM, Hristo Terezov <hristoterezov@gmail.com> wrote:

Hello,

I'm attaching next version of the patch where the issue on mac os is fixed.

When the user first releases one of the control keys the call stays unmuted when all keys are released.

With the fix when the user releases all the keys the call is muted again and the behavior doesn't depend on the order of releasing the keys.

Regards,

On Fri, Mar 22, 2013 at 9:42 PM, Hristo Terezov <hristoterezov@gmail.com> wrote:
Hi Yana,

Thanks for applying my patch.

I think it's working on linux ( I made some changes in the native code there and I tested it). Sorry I forgot to mention it.

About the issue I didn't noticed it while I was testing the feature. I'll test it and fix it.

Regards,
Hristo.

On Fri, Mar 22, 2013 at 9:20 PM, Yana Stamcheva <yana@jitsi.org> wrote:
Hey Hristo,

I've just applied and tested your patch. I find it a really cool feature!

It works great, I've just encountered one small problem. When I press my key combination I'm un-muted, which is perfect, but then if I just release only one of the control keys of the shortcut I stay un-muted. The thing is that it's very easy to not un-press the keys in the "right" order, so this could happen very often and one could think they're muted again, but they won't be.

(more inline)

On Mar 8, 2013, at 3:16 PM, Hristo Terezov <hristoterezov@gmail.com> wrote:

> Hello,
>
> I'm attaching the patch for the push to talk global shortcut.
>
> The feature can be tested if you are in call when you press the shortcut for the push to talk the call is unmuted, when you release the shortcut the call is muted again. You can set the key combinations from Tools->Options->Advanced->Keybindings.
>
> Note: on windows 64 the global shortcuts are not working at all for me. I haven't investigated it yet.
>
> To run the project with this patch the native files for globalshortcut should be compiled too.
>
> While I was implementing this feature I made the following improvements to global shortcuts functionality:
>
> On windows:
> There was a situation when some of the shortcuts could be missed. In this case jitsi won't receive the events for key press.
> I added a flag when the shortcuts are registered to prevent repeating of the pressed events when the key is hold down.Now jitsi receives only 1 event for press when a shortcut is hold down.
>
> On mac:
> The shortcuts are changed to work on press instead of on release of the keys.

What about linux, does this feature work on linux?

Cheers,
Yana

>
> Regards.
> <push_to_talk.txt>

<push_to_talk_v2.txt>