[jitsi-dev] Notifications provisioning


#1

Hi,

for some time i am experimenting with provisioning options. My current goal is to disable proactive notifications (those popups which shows that somebody is typing to you) ... some people find them intrusive.

From source code i found node net.java.sip.communicator.impl.notifications.eventType, then large number with milliseconds from epoch ... i tried to append some notification settings in provisioning (PopupMessageAction, default and enabled set to false). But it does not seem to have any effect (proactive notifications still enabled in settings).

Is there any recommended way how to provision notification settings?

Cheers,
Richard

···

________________________________

Prohlášení: k tomuto e-mailu je připojeno prohlášení, jehož
plné znění naleznete na stránce http://www.ipex.cz/prohlaseni


#2

for some time i am experimenting with provisioning options. My current

goal

is to disable proactive notifications (those popups which shows that

somebody

is typing to you) ... some people find them intrusive.

From source code i found node
net.java.sip.communicator.impl.notifications.eventType, then large
number with milliseconds from epoch ... i tried to append some
notification settings in provisioning (PopupMessageAction, default and
enabled set to false). But it does not seem to have any effect
(proactive notifications still enabled in settings).

Is there any recommended way how to provision notification settings?

You should be able to simply copy/distribute the settings from a manually
configured client. I have the proactive notifications disabled with these
settings:

net.java.sip.communicator.impl.notifications.eventType1299000468001=Proactiv
eNotification
net.java.sip.communicator.impl.notifications.eventType1299000468001.actions.
actionType1299000468004=PopupMessageAction
net.java.sip.communicator.impl.notifications.eventType1299000468001.actions.
actionType1299000468004.default=true
net.java.sip.communicator.impl.notifications.eventType1299000468001.actions.
actionType1299000468004.enabled=true
net.java.sip.communicator.impl.notifications.eventType1299000468001.actions.
actionType1299000468004.timeout=-1
net.java.sip.communicator.impl.notifications.eventType1299000468001.active=f
alse

The last line (.active) completely disables the event, not just the popup.

Cheers,
Richard

Ingo