[jitsi-dev] non unicode messages have problems showing german umlaute


#1

Hi all,

someone in an irc chan is sending non unicode messages. The german umlaute he sends are all replaced by „�“.

Guess this is expected, but maybe jitsi can become more tolerant and detect the format and or interpret it correctly?


#2

Hi,

I can have a look at this. Do you know if the same happens if 2
Jitsi-clients are chatting?
Also, do you have an easy reproduction recipe by any chance?

Danny

···

On 06-01-15 11:57, foss wrote:

Hi all,

someone in an irc chan is sending non unicode messages. The german
umlaute he sends are all replaced by „�“.

Guess this is expected, but maybe jitsi can become more tolerant and
detect the format and or interpret it correctly?

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi,

Hi,

I can have a look at this. Do you know if the same happens if 2
Jitsi-clients are chatting?
Also, do you have an easy reproduction recipe by any chance?

Okay, I realise that the second question may sound pretty stupid. What
I'm actually referring to is whether or not *any* client in which you
type an char + umlaut will result in this issue, or whether it might be
related to specific client(s). I'm wondering if you might have tried
this out already. (This is also why I asked if this happens with Jitsi too.)

Danny

···

On 06-01-15 23:51, Danny van Heumen wrote:

Danny

On 06-01-15 11:57, foss wrote:

Hi all,

someone in an irc chan is sending non unicode messages. The german
umlaute he sends are all replaced by „�“.

Guess this is expected, but maybe jitsi can become more tolerant and
detect the format and or interpret it correctly?

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Hi Danny,

I’ve not yet seen this with two jitsi clients communicating.

The easiest way to reproduce this, or see this error in action rather, is by joining the ##fritzbox irc channel on freenode and wait for user hippie2000 to say something (don’t worry he’s quite active in there).

···

Am 06.01.2015 um 23:51 schrieb Danny van Heumen <danny@dannyvanheumen.nl>:

now if the same happens if 2
Jitsi-clients are chatting?