[jitsi-dev] (no subject)


#1

Hi,
I'm testing jitsi-Meet and jigasi.
I'm assuming that Jigasi is using 5060 port to register.
Is there a way to change the default port for registration?

here is the log snippet where registrating fails to reach server even if I
can ping/telnet to it on desired port:
LOG:

23:35:32.157 WARNING: [16] impl.protocol.sip.SipLogger.logWarning().174
Warning from the JAIN-SIP stackusing default tls security policy
23:35:32.171 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
23:35:32.465 INFO: [25] org.jitsi.jigasi.SipGateway.registrationStateChanged().159
REG STATE CHANGE ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP))
-> RegistrationStateChangeEvent[ oldState=Unregistered;
newState=RegistrationState=Registering; reasonCode=-1; reason=null]
23:36:04.554 INFO: [23] org.jitsi.jigasi.SipGateway.registrationStateChanged().159
REG STATE CHANGE ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP))
-> RegistrationStateChangeEvent[ oldState=Registering;
newState=RegistrationState=*Connection Failed; reasonCode=-1; reason=A
timeout occurred while trying to connect to the server.]*
23:36:04.555 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
23:36:05.559 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
(END)

JIGASI sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:<USER>@<SERVER.IP>

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=.......

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=
*<SERVER.IP>:<CUSTOM_PORT>*

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=<USER>@<SERVER.IP>

Any suggestion is helpful.
Thanks,

Mirko

···

--
S postovanjem,
Mirko


#2

Hi,

the easiest way is to use jitsi the desktop client to register to the
server (successfully configure the sip account through the sip account
wizard) and then open the config properties file and use the generated
properties.

Regards
damencho

···

On Fri, Mar 6, 2015 at 1:39 PM, Mirko Brankovic <mirkobrankovic@gmail.com> wrote:

Hi,
I'm testing jitsi-Meet and jigasi.
I'm assuming that Jigasi is using 5060 port to register.
Is there a way to change the default port for registration?

here is the log snippet where registrating fails to reach server even if I
can ping/telnet to it on desired port:
LOG:

23:35:32.157 WARNING: [16] impl.protocol.sip.SipLogger.logWarning().174
Warning from the JAIN-SIP stackusing default tls security policy
23:35:32.171 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
23:35:32.465 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().159 REG STATE CHANGE
ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP)) ->
RegistrationStateChangeEvent[ oldState=Unregistered;
newState=RegistrationState=Registering; reasonCode=-1; reason=null]
23:36:04.554 INFO: [23]
org.jitsi.jigasi.SipGateway.registrationStateChanged().159 REG STATE CHANGE
ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP)) ->
RegistrationStateChangeEvent[ oldState=Registering;
newState=RegistrationState=Connection Failed; reasonCode=-1; reason=A
timeout occurred while trying to connect to the server.]
23:36:04.555 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
23:36:05.559 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
(END)

JIGASI sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:<USER>@<SERVER.IP>

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=.......

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=<SERVER.IP>:<CUSTOM_PORT>

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=<USER>@<SERVER.IP>

Any suggestion is helpful.
Thanks,

Mirko

--
S postovanjem,
Mirko

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi,
Thanks for the tip, I see there is:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=

property, but what is failing is that registration is failing due to other
problems, since jitsi client is failing to register too.

Regards,
Mirko

···

On Fri, Mar 6, 2015 at 12:45 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

the easiest way is to use jitsi the desktop client to register to the
server (successfully configure the sip account through the sip account
wizard) and then open the config properties file and use the generated
properties.

Regards
damencho

On Fri, Mar 6, 2015 at 1:39 PM, Mirko Brankovic > <mirkobrankovic@gmail.com> wrote:
> Hi,
> I'm testing jitsi-Meet and jigasi.
> I'm assuming that Jigasi is using 5060 port to register.
> Is there a way to change the default port for registration?
>
> here is the log snippet where registrating fails to reach server even if
I
> can ping/telnet to it on desired port:
> LOG:
>>
>> 23:35:32.157 WARNING: [16] impl.protocol.sip.SipLogger.logWarning().174
>> Warning from the JAIN-SIP stackusing default tls security policy
>> 23:35:32.171 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info
>> from the JAIN-SIP stack: the sip stack timer
>> gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
>> 23:35:32.465 INFO: [25]
>> org.jitsi.jigasi.SipGateway.registrationStateChanged().159 REG STATE
CHANGE
>> ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP)) ->
>> RegistrationStateChangeEvent[ oldState=Unregistered;
>> newState=RegistrationState=Registering; reasonCode=-1; reason=null]
>> 23:36:04.554 INFO: [23]
>> org.jitsi.jigasi.SipGateway.registrationStateChanged().159 REG STATE
CHANGE
>> ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP)) ->
>> RegistrationStateChangeEvent[ oldState=Registering;
>> newState=RegistrationState=Connection Failed; reasonCode=-1; reason=A
>> timeout occurred while trying to connect to the server.]
>> 23:36:04.555 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
>> from the JAIN-SIP stack: the sip stack timer
>> gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
>> 23:36:05.559 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
>> from the JAIN-SIP stack: the sip stack timer
>> gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
>> (END)
>
>
> JIGASI sip-communicator.properties:
>>
>>
>>
net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
>>
>>
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:<USER>@<SERVER.IP>
>>
>>
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=.......
>>
>>
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
>>
>>
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=<SERVER.IP>:<CUSTOM_PORT>
>>
>>
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=<USER>@<SERVER.IP>
>
>
> Any suggestion is helpful.
> Thanks,
>
> Mirko
>
> --
> S postovanjem,
> Mirko
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
S postovanjem,
Mirko


#4

You need to configure proxy manually (uncheck "configure proxy
automatically"). The other address and port are used for the register
(in the request URI).

···

On Fri, Mar 6, 2015 at 2:09 PM, Mirko Brankovic <mirkobrankovic@gmail.com> wrote:

Hi,
Thanks for the tip, I see there is:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=

property, but what is failing is that registration is failing due to other
problems, since jitsi client is failing to register too.

Regards,
Mirko

On Fri, Mar 6, 2015 at 12:45 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

the easiest way is to use jitsi the desktop client to register to the
server (successfully configure the sip account through the sip account
wizard) and then open the config properties file and use the generated
properties.

Regards
damencho

On Fri, Mar 6, 2015 at 1:39 PM, Mirko Brankovic >> <mirkobrankovic@gmail.com> wrote:
> Hi,
> I'm testing jitsi-Meet and jigasi.
> I'm assuming that Jigasi is using 5060 port to register.
> Is there a way to change the default port for registration?
>
> here is the log snippet where registrating fails to reach server even if
> I
> can ping/telnet to it on desired port:
> LOG:
>>
>> 23:35:32.157 WARNING: [16] impl.protocol.sip.SipLogger.logWarning().174
>> Warning from the JAIN-SIP stackusing default tls security policy
>> 23:35:32.171 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info
>> from the JAIN-SIP stack: the sip stack timer
>> gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
>> 23:35:32.465 INFO: [25]
>> org.jitsi.jigasi.SipGateway.registrationStateChanged().159 REG STATE
>> CHANGE
>> ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP)) ->
>> RegistrationStateChangeEvent[ oldState=Unregistered;
>> newState=RegistrationState=Registering; reasonCode=-1; reason=null]
>> 23:36:04.554 INFO: [23]
>> org.jitsi.jigasi.SipGateway.registrationStateChanged().159 REG STATE
>> CHANGE
>> ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP)) ->
>> RegistrationStateChangeEvent[ oldState=Registering;
>> newState=RegistrationState=Connection Failed; reasonCode=-1; reason=A
>> timeout occurred while trying to connect to the server.]
>> 23:36:04.555 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
>> from the JAIN-SIP stack: the sip stack timer
>> gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
>> 23:36:05.559 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
>> from the JAIN-SIP stack: the sip stack timer
>> gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
>> (END)
>
>
> JIGASI sip-communicator.properties:
>>
>>
>>
>> net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
>>
>>
>> net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:<USER>@<SERVER.IP>
>>
>>
>> net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=.......
>>
>>
>> net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
>>
>>
>> net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=<SERVER.IP>:<CUSTOM_PORT>
>>
>>
>> net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=<USER>@<SERVER.IP>
>
>
> Any suggestion is helpful.
> Thanks,
>
> Mirko
>
> --
> S postovanjem,
> Mirko
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
S postovanjem,
Mirko

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev