[jitsi-dev] No audio devices found


#1

Hello,

I think I have the same problem as was discussed from
http://lists.jitsi.org/pipermail/dev/2014-October/022291.html to
http://lists.jitsi.org/pipermail/dev/2014-November/022558.html: Jitsi
unstable on Ubuntu 14.04 64bit finds only the "audiosilence" device.
Chatting with OTR works, but every audio or video call remains unencrypted
and no sound comes through.

I read through that thread and found the advice about JNI libraries: They
are present in /usr/share/jitsi/lib/native, but I'm not sure how much more
I can help debug this: The computer is with a relative and who I can't ask
for long TeamViewer sessions or direct via screen sharing in Skype.

Here's the first warning from the logs that seems to be relevant:

*WARNING: [13] org.jitsi.impl.neomedia.codec.FMJPlugInConfiguration.warn()
Codec org.jitsi.impl.neomedia.codec.audio.opus.JNIDecoder is NOT
successfully registeredjava.lang.UnsatisfiedLinkError:
/usr/share/jitsi/lib/native/libjnopus.so:
/usr/share/jitsi/lib/native/libjnopus.so: wrong ELF-class: ELFCLASS32
(Possible cause: architecture word width mismatch)*

Does "architecture word width mismatch" refer to a 32/64bit problem? Please
help! Jitsi was my only encrypted channel to that person :frowning:

Kind regards,

Cathryne


#2

Yes. Did you somehow install the "i386" jitsi package? You need the "amd64" one.

Regards,
Boris

···

On 22/02/15 16:05, Cathryne Linenweaver wrote:

Hello,

I think I have the same problem as was discussed from
http://lists.jitsi.org/pipermail/dev/2014-October/022291.html to
http://lists.jitsi.org/pipermail/dev/2014-November/022558.html: Jitsi
unstable on Ubuntu 14.04 64bit finds only the "audiosilence" device.
Chatting with OTR works, but every audio or video call remains
unencrypted and no sound comes through.

I read through that thread and found the advice about JNI libraries:
They are present in /usr/share/jitsi/lib/native, but I'm not sure how
much more I can help debug this: The computer is with a relative and who
I can't ask for long TeamViewer sessions or direct via screen sharing in
Skype.

Here's the first warning from the logs that seems to be relevant:

    /WARNING: [13]
    org.jitsi.impl.neomedia.codec.FMJPlugInConfiguration.warn() Codec
    org.jitsi.impl.neomedia.codec.audio.opus.JNIDecoder is NOT
    successfully registered
    java.lang.UnsatisfiedLinkError:
    /usr/share/jitsi/lib/native/libjnopus.so:
    /usr/share/jitsi/lib/native/libjnopus.so: wrong ELF-class:
    ELFCLASS32 (Possible cause: architecture word width mismatch)
    /

Does "architecture word width mismatch" refer to a 32/64bit problem?


#3

Merci! Reinstalling the 64bit package worked :slight_smile:

···

On 22 February 2015 at 16:45, Boris Grozev <boris@jitsi.org> wrote:

On 22/02/15 16:05, Cathryne Linenweaver wrote:

Hello,

I think I have the same problem as was discussed from
http://lists.jitsi.org/pipermail/dev/2014-October/022291.html to
http://lists.jitsi.org/pipermail/dev/2014-November/022558.html: Jitsi
unstable on Ubuntu 14.04 64bit finds only the "audiosilence" device.
Chatting with OTR works, but every audio or video call remains
unencrypted and no sound comes through.

I read through that thread and found the advice about JNI libraries:
They are present in /usr/share/jitsi/lib/native, but I'm not sure how
much more I can help debug this: The computer is with a relative and who
I can't ask for long TeamViewer sessions or direct via screen sharing in
Skype.

Here's the first warning from the logs that seems to be relevant:

    /WARNING: [13]
    org.jitsi.impl.neomedia.codec.FMJPlugInConfiguration.warn() Codec
    org.jitsi.impl.neomedia.codec.audio.opus.JNIDecoder is NOT
    successfully registered
    java.lang.UnsatisfiedLinkError:
    /usr/share/jitsi/lib/native/libjnopus.so:
    /usr/share/jitsi/lib/native/libjnopus.so: wrong ELF-class:
    ELFCLASS32 (Possible cause: architecture word width mismatch)
    /

Does "architecture word width mismatch" refer to a 32/64bit problem?

Yes. Did you somehow install the "i386" jitsi package? You need the
"amd64" one.

Regards,
Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev