[jitsi-dev] No audio devices found -- audiosilence on Ubuntu 14.04


#1

When I launch Jitsi from an icon in Unity's Launcher, I do not get any
sound. When I launch Jitsi manually from the shell, I get proper sound.
The symptom occurs only when launching from the Launcher and can also
be seen from Tools->Options->Audio System where it says "audiosilence"

This has been consistent since October or earlier and is quite
consistent. It is present even in Jitsi 2.9.5442-1

$ apt-cache policy jitsi
jitsi:
   Installed: 2.9.5442-1
   Candidate: 2.9.5442-1

Looking around, I see two .desktop files which seem not to be used:

/usr/share/app-install/desktop/jitsi:jitsi.desktop
/usr/share/applications/jitsi.desktop

The problem looks like it might be coming from
~/.local/share/applications/jitsi.desktop, which is the .desktop file
that Unity seems to decide to use when selecting "Lock to launcher" In
that file,

Exec=/usr/bin/java -classpath
/usr/share/jitsi/lib/felix.jar:/usr/share/jitsi/sc-bundles/sc-launcher.jar:/usr/share/jitsi/sc-bundles/util.jar:/usr/share/jitsi/lib
-Djna.library.path=/usr/share/jitsi/lib/native
-Dfelix.config.properties=file:/usr/share/jitsi/lib/felix.client.run.properties
-Djava.util.logging.config.file=/usr/share/jitsi/lib/logging.properties
-splash:splash.gif -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=.jitsi
net.java.sip.communicator.launcher.SIPCommunicator

Editing that .desktop file and replacing that Exec with the following
seems to prevent restriction of sound options to audio silence:

Exec=/usr/bin/jitsi

Deleting /.local/share/applications/jitsi.desktop makes the default
audiosilence problem come back.

Regards,
Lars