[jitsi-dev] new focus setting and jicofo?


#1

Hi,

I just updated to the latest jitsi meet nightly using the debian packages
and there seems to be a new component called jicofo related to server side
focus handling.
What are the new config options to get this to work? Is there any
documentation explaining what it does exactly and how it should be setup?

I ask this because now everytime I try to start a new conference, I get an
error about focus.jitsi-meet.my.domain not being available. If I uncomment
focus: focus.jitsi-meet.my.domain in my config.js, then I can't even try to
create a room (ie I get stuck at the welcome page without the room
generating algo and only the option to enter a room name - which does
nothing).

Previously I had everything working correctly with authentication and
anonymous domain enabled, but these changes seem to have broken that.

I see the jicofo git page has some info on its options and I see in prosody
logs that the focus component failed to authenticate, but I'm confused with
the proliferation of so many new subdomains and exactly how to configure
them.

Any help?

Cheers,
Peter


#2

Well I noticed that all the component secrets no longer matched so I had to
manually change the config files and now the components register as
expected. Maybe it was my setup but you should check to make sure the
postinst scripts didn't mess up your existing configs.

Anyway, If I comment out "focus: focus.jitsi-meet.my.domain" in my
config.js then I'm able to generate a room after authenticating like before
(still don't know why uncommenting that leaves me unable to generate a
room).
However when my guest clicks on the link all we can see is each other's
avatars - no audio or video. Looking at jvb logs one can see it is never
activated and lies there idle.

Looking at jicofo logs however may shed some light on the problem. The
focus appears to work ok until the connection error.
I hope this helps debugging latest nightly.

Cheers,
Peter

22:29:17.330 INFO: [44]
org.jitsi.jicofo.xmpp.FocusComponent.handleIQSet().209 Focus request for
room: 123@conference.meet.my.domain
22:29:17.330 INFO: [44]
org.jitsi.jicofo.FocusManager.createConference().220 Created new focus for
123@conference.meet.my.domain@auth.meet.my.domain conferences count: 1
options:
    channelLastN: -1
    adaptiveLastN: false
    adaptiveSimulcast: false
    bridge: jitsi-videobridge.meet.my.domain
    enableFirefoxHacks: false
    openSctp: true
*22:29:17.570 SEVERE: [47]
org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
connection temporary*
*stream:error (text)*
at org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:264)
at org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)
22:29:22.419 SEVERE: [45] org.jitsi.jicofo.util.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: Failed
to connect
net.java.sip.communicator.service.protocol.OperationFailedException: Failed
to connect
at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
Caused by: No response from the server.:
at
org.jivesoftware.smack.SASLAuthentication.bindResourceAndEstablishSession(SASLAuthentication.java:456)
at
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:352)
at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:151)
... 1 more
22:29:36.599 INFO: [18] org.jitsi.jicofo.FocusManager.expireLoop().442
Focus idle timeout for 123@conference.meet.my.domain
22:29:36.599 INFO: [18]
org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireConference().334
Nothing to expire - no conference allocated yet
22:29:36.599 SEVERE: [18]
org.jitsi.jicofo.JitsiMeetConference.leaveTheRoom().392 Chat room already
left!
22:29:36.751 INFO: [18]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP provider
Jabber:focus@auth.meet.my.domain/focus1743616970713371@localhost
disconnected
22:29:36.751 INFO: [18] org.jitsi.jicofo.FocusManager.conferenceEnded().250
Disposed conference for room: 123@conference.meet.my.domain conference
count: 0

···

On Mon, Dec 8, 2014 at 9:34 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hi,

I just updated to the latest jitsi meet nightly using the debian packages
and there seems to be a new component called jicofo related to server side
focus handling.
What are the new config options to get this to work? Is there any
documentation explaining what it does exactly and how it should be setup?

I ask this because now everytime I try to start a new conference, I get an
error about focus.jitsi-meet.my.domain not being available. If I uncomment
focus: focus.jitsi-meet.my.domain in my config.js, then I can't even try to
create a room (ie I get stuck at the welcome page without the room
generating algo and only the option to enter a room name - which does
nothing).

Previously I had everything working correctly with authentication and
anonymous domain enabled, but these changes seem to have broken that.

I see the jicofo git page has some info on its options and I see in
prosody logs that the focus component failed to authenticate, but I'm
confused with the proliferation of so many new subdomains and exactly how
to configure them.

Any help?

Cheers,
Peter


#3

Hello Peter,

Apologies for troubles with the nightly I'll try to come up with new
focus description today.

Your error looks like focus user is unable to connect. Do you have
'auth.meet.my.domain' virtual host configured in Prosody config? If
yes then it might be related to SSL, you may want to try removing
certifiacte config from 'auth.meet.my.domain' and see if that changes
anything.

Jicofo config that stores user/hosts/secrets is located in
/etc/jitsi/jicofo/config.

Regards,
Pawel

···

On Mon, Dec 8, 2014 at 11:43 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Well I noticed that all the component secrets no longer matched so I had to
manually change the config files and now the components register as
expected. Maybe it was my setup but you should check to make sure the
postinst scripts didn't mess up your existing configs.

Anyway, If I comment out "focus: focus.jitsi-meet.my.domain" in my
config.js then I'm able to generate a room after authenticating like before
(still don't know why uncommenting that leaves me unable to generate a
room).
However when my guest clicks on the link all we can see is each other's
avatars - no audio or video. Looking at jvb logs one can see it is never
activated and lies there idle.

Looking at jicofo logs however may shed some light on the problem. The focus
appears to work ok until the connection error.
I hope this helps debugging latest nightly.

Cheers,
Peter

22:29:17.330 INFO: [44]
org.jitsi.jicofo.xmpp.FocusComponent.handleIQSet().209 Focus request for
room: 123@conference.meet.my.domain
22:29:17.330 INFO: [44] org.jitsi.jicofo.FocusManager.createConference().220
Created new focus for 123@conference.meet.my.domain@auth.meet.my.domain
conferences count: 1 options:
    channelLastN: -1
    adaptiveLastN: false
    adaptiveSimulcast: false
    bridge: jitsi-videobridge.meet.my.domain
    enableFirefoxHacks: false
    openSctp: true
22:29:17.570 SEVERE: [47]
org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
connection temporary
stream:error (text)
at org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:264)
at org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)
22:29:22.419 SEVERE: [45] org.jitsi.jicofo.util.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: Failed
to connect
net.java.sip.communicator.service.protocol.OperationFailedException: Failed
to connect
at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
Caused by: No response from the server.:
at
org.jivesoftware.smack.SASLAuthentication.bindResourceAndEstablishSession(SASLAuthentication.java:456)
at
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:352)
at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:151)
... 1 more
22:29:36.599 INFO: [18] org.jitsi.jicofo.FocusManager.expireLoop().442 Focus
idle timeout for 123@conference.meet.my.domain
22:29:36.599 INFO: [18]
org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireConference().334
Nothing to expire - no conference allocated yet
22:29:36.599 SEVERE: [18]
org.jitsi.jicofo.JitsiMeetConference.leaveTheRoom().392 Chat room already
left!
22:29:36.751 INFO: [18]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP provider
Jabber:focus@auth.meet.my.domain/focus1743616970713371@localhost
disconnected
22:29:36.751 INFO: [18] org.jitsi.jicofo.FocusManager.conferenceEnded().250
Disposed conference for room: 123@conference.meet.my.domain conference
count: 0

On Mon, Dec 8, 2014 at 9:34 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:

Hi,

I just updated to the latest jitsi meet nightly using the debian packages
and there seems to be a new component called jicofo related to server side
focus handling.
What are the new config options to get this to work? Is there any
documentation explaining what it does exactly and how it should be setup?

I ask this because now everytime I try to start a new conference, I get an
error about focus.jitsi-meet.my.domain not being available. If I uncomment
focus: focus.jitsi-meet.my.domain in my config.js, then I can't even try to
create a room (ie I get stuck at the welcome page without the room
generating algo and only the option to enter a room name - which does
nothing).

Previously I had everything working correctly with authentication and
anonymous domain enabled, but these changes seem to have broken that.

I see the jicofo git page has some info on its options and I see in
prosody logs that the focus component failed to authenticate, but I'm
confused with the proliferation of so many new subdomains and exactly how to
configure them.

Any help?

Cheers,
Peter

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Hi Pawel,

Indeed I have the 'auth.meet.my.domain' virtual host in prosody config. I
believe it was inserted by the debian postinstall script.
I noticed there was no SSL configured for that virtual host, so I copied
over the SSL configs from the "meet.my.domain" virtual host.
Unfortunately the problem continues and I see the same error message in
jicofo logs. Do you think I have to generate a new certificate for
auth.meet.my.domain since the meet.my.domain one will have a hostname
mismatch? Could that be causing the failure to connect as seen in the
jicofo logs: 15:29:14.479 SEVERE: [89]
org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
connection temporary
stream:error (text). Is it possible to enable a greater debug level to see
what the "stream:error" is all about?

Cheers,
Peter

···

On Tue, Dec 9, 2014 at 9:49 AM, Paweł Domas <pawel.domas@jitsi.org> wrote:

Hello Peter,

Apologies for troubles with the nightly I'll try to come up with new
focus description today.

Your error looks like focus user is unable to connect. Do you have
'auth.meet.my.domain' virtual host configured in Prosody config? If
yes then it might be related to SSL, you may want to try removing
certifiacte config from 'auth.meet.my.domain' and see if that changes
anything.

Jicofo config that stores user/hosts/secrets is located in
/etc/jitsi/jicofo/config.

Regards,
Pawel

On Mon, Dec 8, 2014 at 11:43 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
> Well I noticed that all the component secrets no longer matched so I had
to
> manually change the config files and now the components register as
> expected. Maybe it was my setup but you should check to make sure the
> postinst scripts didn't mess up your existing configs.
>
> Anyway, If I comment out "focus: focus.jitsi-meet.my.domain" in my
> config.js then I'm able to generate a room after authenticating like
before
> (still don't know why uncommenting that leaves me unable to generate a
> room).
> However when my guest clicks on the link all we can see is each other's
> avatars - no audio or video. Looking at jvb logs one can see it is never
> activated and lies there idle.
>
> Looking at jicofo logs however may shed some light on the problem. The
focus
> appears to work ok until the connection error.
> I hope this helps debugging latest nightly.
>
> Cheers,
> Peter
>
>
>
> 22:29:17.330 INFO: [44]
> org.jitsi.jicofo.xmpp.FocusComponent.handleIQSet().209 Focus request for
> room: 123@conference.meet.my.domain
> 22:29:17.330 INFO: [44]
org.jitsi.jicofo.FocusManager.createConference().220
> Created new focus for 123@conference.meet.my.domain@auth.meet.my.domain
> conferences count: 1 options:
> channelLastN: -1
> adaptiveLastN: false
> adaptiveSimulcast: false
> bridge: jitsi-videobridge.meet.my.domain
> enableFirefoxHacks: false
> openSctp: true
> 22:29:17.570 SEVERE: [47]
> org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
> connection temporary
> stream:error (text)
> at
org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:264)
> at org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
> at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)
> 22:29:22.419 SEVERE: [45] org.jitsi.jicofo.util.RegisterThread.run().42
> net.java.sip.communicator.service.protocol.OperationFailedException:
Failed
> to connect
> net.java.sip.communicator.service.protocol.OperationFailedException:
Failed
> to connect
> at
>
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
> at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
> Caused by: No response from the server.:
> at
>
org.jivesoftware.smack.SASLAuthentication.bindResourceAndEstablishSession(SASLAuthentication.java:456)
> at
>
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:352)
> at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
> at
>
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:151)
> ... 1 more
> 22:29:36.599 INFO: [18] org.jitsi.jicofo.FocusManager.expireLoop().442
Focus
> idle timeout for 123@conference.meet.my.domain
> 22:29:36.599 INFO: [18]
>
org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireConference().334
> Nothing to expire - no conference allocated yet
> 22:29:36.599 SEVERE: [18]
> org.jitsi.jicofo.JitsiMeetConference.leaveTheRoom().392 Chat room already
> left!
> 22:29:36.751 INFO: [18]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP provider
> Jabber:focus@auth.meet.my.domain/focus1743616970713371@localhost
> disconnected
> 22:29:36.751 INFO: [18]
org.jitsi.jicofo.FocusManager.conferenceEnded().250
> Disposed conference for room: 123@conference.meet.my.domain conference
> count: 0
>
> On Mon, Dec 8, 2014 at 9:34 PM, Peter Villeneuve <petervnv1@gmail.com> > > wrote:
>>
>> Hi,
>>
>> I just updated to the latest jitsi meet nightly using the debian
packages
>> and there seems to be a new component called jicofo related to server
side
>> focus handling.
>> What are the new config options to get this to work? Is there any
>> documentation explaining what it does exactly and how it should be
setup?
>>
>> I ask this because now everytime I try to start a new conference, I get
an
>> error about focus.jitsi-meet.my.domain not being available. If I
uncomment
>> focus: focus.jitsi-meet.my.domain in my config.js, then I can't even
try to
>> create a room (ie I get stuck at the welcome page without the room
>> generating algo and only the option to enter a room name - which does
>> nothing).
>>
>> Previously I had everything working correctly with authentication and
>> anonymous domain enabled, but these changes seem to have broken that.
>>
>> I see the jicofo git page has some info on its options and I see in
>> prosody logs that the focus component failed to authenticate, but I'm
>> confused with the proliferation of so many new subdomains and exactly
how to
>> configure them.
>>
>> Any help?
>>
>> Cheers,
>> Peter
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

What is the hostname/ip address of prosody server ? It looks like some
problem with communication.

···

On Tue, Dec 9, 2014 at 4:41 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hi Pawel,

Indeed I have the 'auth.meet.my.domain' virtual host in prosody config. I
believe it was inserted by the debian postinstall script.
I noticed there was no SSL configured for that virtual host, so I copied
over the SSL configs from the "meet.my.domain" virtual host.
Unfortunately the problem continues and I see the same error message in
jicofo logs. Do you think I have to generate a new certificate for
auth.meet.my.domain since the meet.my.domain one will have a hostname
mismatch? Could that be causing the failure to connect as seen in the jicofo
logs: 15:29:14.479 SEVERE: [89]
org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
connection temporary
stream:error (text). Is it possible to enable a greater debug level to see
what the "stream:error" is all about?

Cheers,
Peter

On Tue, Dec 9, 2014 at 9:49 AM, Paweł Domas <pawel.domas@jitsi.org> wrote:

Hello Peter,

Apologies for troubles with the nightly I'll try to come up with new
focus description today.

Your error looks like focus user is unable to connect. Do you have
'auth.meet.my.domain' virtual host configured in Prosody config? If
yes then it might be related to SSL, you may want to try removing
certifiacte config from 'auth.meet.my.domain' and see if that changes
anything.

Jicofo config that stores user/hosts/secrets is located in
/etc/jitsi/jicofo/config.

Regards,
Pawel

On Mon, Dec 8, 2014 at 11:43 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:
> Well I noticed that all the component secrets no longer matched so I had
> to
> manually change the config files and now the components register as
> expected. Maybe it was my setup but you should check to make sure the
> postinst scripts didn't mess up your existing configs.
>
> Anyway, If I comment out "focus: focus.jitsi-meet.my.domain" in my
> config.js then I'm able to generate a room after authenticating like
> before
> (still don't know why uncommenting that leaves me unable to generate a
> room).
> However when my guest clicks on the link all we can see is each other's
> avatars - no audio or video. Looking at jvb logs one can see it is never
> activated and lies there idle.
>
> Looking at jicofo logs however may shed some light on the problem. The
> focus
> appears to work ok until the connection error.
> I hope this helps debugging latest nightly.
>
> Cheers,
> Peter
>
>
>
> 22:29:17.330 INFO: [44]
> org.jitsi.jicofo.xmpp.FocusComponent.handleIQSet().209 Focus request for
> room: 123@conference.meet.my.domain
> 22:29:17.330 INFO: [44]
> org.jitsi.jicofo.FocusManager.createConference().220
> Created new focus for 123@conference.meet.my.domain@auth.meet.my.domain
> conferences count: 1 options:
> channelLastN: -1
> adaptiveLastN: false
> adaptiveSimulcast: false
> bridge: jitsi-videobridge.meet.my.domain
> enableFirefoxHacks: false
> openSctp: true
> 22:29:17.570 SEVERE: [47]
> org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
> connection temporary
> stream:error (text)
> at
> org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:264)
> at org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
> at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)
> 22:29:22.419 SEVERE: [45] org.jitsi.jicofo.util.RegisterThread.run().42
> net.java.sip.communicator.service.protocol.OperationFailedException:
> Failed
> to connect
> net.java.sip.communicator.service.protocol.OperationFailedException:
> Failed
> to connect
> at
>
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
> at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
> Caused by: No response from the server.:
> at
>
> org.jivesoftware.smack.SASLAuthentication.bindResourceAndEstablishSession(SASLAuthentication.java:456)
> at
>
> org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:352)
> at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
> at
>
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:151)
> ... 1 more
> 22:29:36.599 INFO: [18] org.jitsi.jicofo.FocusManager.expireLoop().442
> Focus
> idle timeout for 123@conference.meet.my.domain
> 22:29:36.599 INFO: [18]
>
> org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireConference().334
> Nothing to expire - no conference allocated yet
> 22:29:36.599 SEVERE: [18]
> org.jitsi.jicofo.JitsiMeetConference.leaveTheRoom().392 Chat room
> already
> left!
> 22:29:36.751 INFO: [18]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP provider
> Jabber:focus@auth.meet.my.domain/focus1743616970713371@localhost
> disconnected
> 22:29:36.751 INFO: [18]
> org.jitsi.jicofo.FocusManager.conferenceEnded().250
> Disposed conference for room: 123@conference.meet.my.domain conference
> count: 0
>
> On Mon, Dec 8, 2014 at 9:34 PM, Peter Villeneuve <petervnv1@gmail.com> >> > wrote:
>>
>> Hi,
>>
>> I just updated to the latest jitsi meet nightly using the debian
>> packages
>> and there seems to be a new component called jicofo related to server
>> side
>> focus handling.
>> What are the new config options to get this to work? Is there any
>> documentation explaining what it does exactly and how it should be
>> setup?
>>
>> I ask this because now everytime I try to start a new conference, I get
>> an
>> error about focus.jitsi-meet.my.domain not being available. If I
>> uncomment
>> focus: focus.jitsi-meet.my.domain in my config.js, then I can't even
>> try to
>> create a room (ie I get stuck at the welcome page without the room
>> generating algo and only the option to enter a room name - which does
>> nothing).
>>
>> Previously I had everything working correctly with authentication and
>> anonymous domain enabled, but these changes seem to have broken that.
>>
>> I see the jicofo git page has some info on its options and I see in
>> prosody logs that the focus component failed to authenticate, but I'm
>> confused with the proliferation of so many new subdomains and exactly
>> how to
>> configure them.
>>
>> Any help?
>>
>> Cheers,
>> Peter
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

The prosody server is sitting on the same server as jitmeet.

Its hostname is my.domain

···

On Tue, Dec 9, 2014 at 3:48 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

What is the hostname/ip address of prosody server ? It looks like some
problem with communication.

On Tue, Dec 9, 2014 at 4:41 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
> Hi Pawel,
>
> Indeed I have the 'auth.meet.my.domain' virtual host in prosody config. I
> believe it was inserted by the debian postinstall script.
> I noticed there was no SSL configured for that virtual host, so I copied
> over the SSL configs from the "meet.my.domain" virtual host.
> Unfortunately the problem continues and I see the same error message in
> jicofo logs. Do you think I have to generate a new certificate for
> auth.meet.my.domain since the meet.my.domain one will have a hostname
> mismatch? Could that be causing the failure to connect as seen in the
jicofo
> logs: 15:29:14.479 SEVERE: [89]
> org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
> connection temporary
> stream:error (text). Is it possible to enable a greater debug level to
see
> what the "stream:error" is all about?
>
> Cheers,
> Peter
>
> On Tue, Dec 9, 2014 at 9:49 AM, Paweł Domas <pawel.domas@jitsi.org> > wrote:
>>
>> Hello Peter,
>>
>> Apologies for troubles with the nightly I'll try to come up with new
>> focus description today.
>>
>> Your error looks like focus user is unable to connect. Do you have
>> 'auth.meet.my.domain' virtual host configured in Prosody config? If
>> yes then it might be related to SSL, you may want to try removing
>> certifiacte config from 'auth.meet.my.domain' and see if that changes
>> anything.
>>
>> Jicofo config that stores user/hosts/secrets is located in
>> /etc/jitsi/jicofo/config.
>>
>> Regards,
>> Pawel
>>
>> On Mon, Dec 8, 2014 at 11:43 PM, Peter Villeneuve <petervnv1@gmail.com> > >> wrote:
>> > Well I noticed that all the component secrets no longer matched so I
had
>> > to
>> > manually change the config files and now the components register as
>> > expected. Maybe it was my setup but you should check to make sure the
>> > postinst scripts didn't mess up your existing configs.
>> >
>> > Anyway, If I comment out "focus: focus.jitsi-meet.my.domain" in my
>> > config.js then I'm able to generate a room after authenticating like
>> > before
>> > (still don't know why uncommenting that leaves me unable to generate a
>> > room).
>> > However when my guest clicks on the link all we can see is each
other's
>> > avatars - no audio or video. Looking at jvb logs one can see it is
never
>> > activated and lies there idle.
>> >
>> > Looking at jicofo logs however may shed some light on the problem. The
>> > focus
>> > appears to work ok until the connection error.
>> > I hope this helps debugging latest nightly.
>> >
>> > Cheers,
>> > Peter
>> >
>> >
>> >
>> > 22:29:17.330 INFO: [44]
>> > org.jitsi.jicofo.xmpp.FocusComponent.handleIQSet().209 Focus request
for
>> > room: 123@conference.meet.my.domain
>> > 22:29:17.330 INFO: [44]
>> > org.jitsi.jicofo.FocusManager.createConference().220
>> > Created new focus for 123@conference.meet.my.domain
@auth.meet.my.domain
>> > conferences count: 1 options:
>> > channelLastN: -1
>> > adaptiveLastN: false
>> > adaptiveSimulcast: false
>> > bridge: jitsi-videobridge.meet.my.domain
>> > enableFirefoxHacks: false
>> > openSctp: true
>> > 22:29:17.570 SEVERE: [47]
>> > org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
>> > connection temporary
>> > stream:error (text)
>> > at
>> >
org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:264)
>> > at
org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
>> > at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)
>> > 22:29:22.419 SEVERE: [45]
org.jitsi.jicofo.util.RegisterThread.run().42
>> > net.java.sip.communicator.service.protocol.OperationFailedException:
>> > Failed
>> > to connect
>> > net.java.sip.communicator.service.protocol.OperationFailedException:
>> > Failed
>> > to connect
>> > at
>> >
>> >
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
>> > at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
>> > Caused by: No response from the server.:
>> > at
>> >
>> >
org.jivesoftware.smack.SASLAuthentication.bindResourceAndEstablishSession(SASLAuthentication.java:456)
>> > at
>> >
>> >
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:352)
>> > at
org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
>> > at
>> >
>> >
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:151)
>> > ... 1 more
>> > 22:29:36.599 INFO: [18] org.jitsi.jicofo.FocusManager.expireLoop().442
>> > Focus
>> > idle timeout for 123@conference.meet.my.domain
>> > 22:29:36.599 INFO: [18]
>> >
>> >
org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireConference().334
>> > Nothing to expire - no conference allocated yet
>> > 22:29:36.599 SEVERE: [18]
>> > org.jitsi.jicofo.JitsiMeetConference.leaveTheRoom().392 Chat room
>> > already
>> > left!
>> > 22:29:36.751 INFO: [18]
>> > org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
provider
>> > Jabber:focus@auth.meet.my.domain/focus1743616970713371@localhost
>> > disconnected
>> > 22:29:36.751 INFO: [18]
>> > org.jitsi.jicofo.FocusManager.conferenceEnded().250
>> > Disposed conference for room: 123@conference.meet.my.domain
conference
>> > count: 0
>> >
>> > On Mon, Dec 8, 2014 at 9:34 PM, Peter Villeneuve <petervnv1@gmail.com > > > >> > wrote:
>> >>
>> >> Hi,
>> >>
>> >> I just updated to the latest jitsi meet nightly using the debian
>> >> packages
>> >> and there seems to be a new component called jicofo related to server
>> >> side
>> >> focus handling.
>> >> What are the new config options to get this to work? Is there any
>> >> documentation explaining what it does exactly and how it should be
>> >> setup?
>> >>
>> >> I ask this because now everytime I try to start a new conference, I
get
>> >> an
>> >> error about focus.jitsi-meet.my.domain not being available. If I
>> >> uncomment
>> >> focus: focus.jitsi-meet.my.domain in my config.js, then I can't even
>> >> try to
>> >> create a room (ie I get stuck at the welcome page without the room
>> >> generating algo and only the option to enter a room name - which does
>> >> nothing).
>> >>
>> >> Previously I had everything working correctly with authentication and
>> >> anonymous domain enabled, but these changes seem to have broken that.
>> >>
>> >> I see the jicofo git page has some info on its options and I see in
>> >> prosody logs that the focus component failed to authenticate, but I'm
>> >> confused with the proliferation of so many new subdomains and exactly
>> >> how to
>> >> configure them.
>> >>
>> >> Any help?
>> >>
>> >> Cheers,
>> >> Peter
>> >
>> >
>> >
>> > _______________________________________________
>> > dev mailing list
>> > dev@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/dev
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

There is config property that modifies the host. Jicofo package uses
'localhost' by default. Try adding JICOFO_HOST=my.domain to
/etc/jitsi/jicofo/config file and restarting Jicofo.

···

On Tue, Dec 9, 2014 at 6:23 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

The prosody server is sitting on the same server as jitmeet.

Its hostname is my.domain

On Tue, Dec 9, 2014 at 3:48 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

What is the hostname/ip address of prosody server ? It looks like some
problem with communication.

On Tue, Dec 9, 2014 at 4:41 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:
> Hi Pawel,
>
> Indeed I have the 'auth.meet.my.domain' virtual host in prosody config.
> I
> believe it was inserted by the debian postinstall script.
> I noticed there was no SSL configured for that virtual host, so I copied
> over the SSL configs from the "meet.my.domain" virtual host.
> Unfortunately the problem continues and I see the same error message in
> jicofo logs. Do you think I have to generate a new certificate for
> auth.meet.my.domain since the meet.my.domain one will have a hostname
> mismatch? Could that be causing the failure to connect as seen in the
> jicofo
> logs: 15:29:14.479 SEVERE: [89]
> org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
> connection temporary
> stream:error (text). Is it possible to enable a greater debug level to
> see
> what the "stream:error" is all about?
>
> Cheers,
> Peter
>
> On Tue, Dec 9, 2014 at 9:49 AM, Paweł Domas <pawel.domas@jitsi.org> >> > wrote:
>>
>> Hello Peter,
>>
>> Apologies for troubles with the nightly I'll try to come up with new
>> focus description today.
>>
>> Your error looks like focus user is unable to connect. Do you have
>> 'auth.meet.my.domain' virtual host configured in Prosody config? If
>> yes then it might be related to SSL, you may want to try removing
>> certifiacte config from 'auth.meet.my.domain' and see if that changes
>> anything.
>>
>> Jicofo config that stores user/hosts/secrets is located in
>> /etc/jitsi/jicofo/config.
>>
>> Regards,
>> Pawel
>>
>> On Mon, Dec 8, 2014 at 11:43 PM, Peter Villeneuve <petervnv1@gmail.com> >> >> wrote:
>> > Well I noticed that all the component secrets no longer matched so I
>> > had
>> > to
>> > manually change the config files and now the components register as
>> > expected. Maybe it was my setup but you should check to make sure the
>> > postinst scripts didn't mess up your existing configs.
>> >
>> > Anyway, If I comment out "focus: focus.jitsi-meet.my.domain" in my
>> > config.js then I'm able to generate a room after authenticating like
>> > before
>> > (still don't know why uncommenting that leaves me unable to generate
>> > a
>> > room).
>> > However when my guest clicks on the link all we can see is each
>> > other's
>> > avatars - no audio or video. Looking at jvb logs one can see it is
>> > never
>> > activated and lies there idle.
>> >
>> > Looking at jicofo logs however may shed some light on the problem.
>> > The
>> > focus
>> > appears to work ok until the connection error.
>> > I hope this helps debugging latest nightly.
>> >
>> > Cheers,
>> > Peter
>> >
>> >
>> >
>> > 22:29:17.330 INFO: [44]
>> > org.jitsi.jicofo.xmpp.FocusComponent.handleIQSet().209 Focus request
>> > for
>> > room: 123@conference.meet.my.domain
>> > 22:29:17.330 INFO: [44]
>> > org.jitsi.jicofo.FocusManager.createConference().220
>> > Created new focus for
>> > 123@conference.meet.my.domain@auth.meet.my.domain
>> > conferences count: 1 options:
>> > channelLastN: -1
>> > adaptiveLastN: false
>> > adaptiveSimulcast: false
>> > bridge: jitsi-videobridge.meet.my.domain
>> > enableFirefoxHacks: false
>> > openSctp: true
>> > 22:29:17.570 SEVERE: [47]
>> > org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes
>> > the
>> > connection temporary
>> > stream:error (text)
>> > at
>> >
>> > org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:264)
>> > at
>> > org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
>> > at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)
>> > 22:29:22.419 SEVERE: [45]
>> > org.jitsi.jicofo.util.RegisterThread.run().42
>> > net.java.sip.communicator.service.protocol.OperationFailedException:
>> > Failed
>> > to connect
>> > net.java.sip.communicator.service.protocol.OperationFailedException:
>> > Failed
>> > to connect
>> > at
>> >
>> >
>> > org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
>> > at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
>> > Caused by: No response from the server.:
>> > at
>> >
>> >
>> > org.jivesoftware.smack.SASLAuthentication.bindResourceAndEstablishSession(SASLAuthentication.java:456)
>> > at
>> >
>> >
>> > org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:352)
>> > at
>> > org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
>> > at
>> >
>> >
>> > org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:151)
>> > ... 1 more
>> > 22:29:36.599 INFO: [18]
>> > org.jitsi.jicofo.FocusManager.expireLoop().442
>> > Focus
>> > idle timeout for 123@conference.meet.my.domain
>> > 22:29:36.599 INFO: [18]
>> >
>> >
>> > org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireConference().334
>> > Nothing to expire - no conference allocated yet
>> > 22:29:36.599 SEVERE: [18]
>> > org.jitsi.jicofo.JitsiMeetConference.leaveTheRoom().392 Chat room
>> > already
>> > left!
>> > 22:29:36.751 INFO: [18]
>> > org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
>> > provider
>> > Jabber:focus@auth.meet.my.domain/focus1743616970713371@localhost
>> > disconnected
>> > 22:29:36.751 INFO: [18]
>> > org.jitsi.jicofo.FocusManager.conferenceEnded().250
>> > Disposed conference for room: 123@conference.meet.my.domain
>> > conference
>> > count: 0
>> >
>> > On Mon, Dec 8, 2014 at 9:34 PM, Peter Villeneuve >> >> > <petervnv1@gmail.com> >> >> > wrote:
>> >>
>> >> Hi,
>> >>
>> >> I just updated to the latest jitsi meet nightly using the debian
>> >> packages
>> >> and there seems to be a new component called jicofo related to
>> >> server
>> >> side
>> >> focus handling.
>> >> What are the new config options to get this to work? Is there any
>> >> documentation explaining what it does exactly and how it should be
>> >> setup?
>> >>
>> >> I ask this because now everytime I try to start a new conference, I
>> >> get
>> >> an
>> >> error about focus.jitsi-meet.my.domain not being available. If I
>> >> uncomment
>> >> focus: focus.jitsi-meet.my.domain in my config.js, then I can't even
>> >> try to
>> >> create a room (ie I get stuck at the welcome page without the room
>> >> generating algo and only the option to enter a room name - which
>> >> does
>> >> nothing).
>> >>
>> >> Previously I had everything working correctly with authentication
>> >> and
>> >> anonymous domain enabled, but these changes seem to have broken
>> >> that.
>> >>
>> >> I see the jicofo git page has some info on its options and I see in
>> >> prosody logs that the focus component failed to authenticate, but
>> >> I'm
>> >> confused with the proliferation of so many new subdomains and
>> >> exactly
>> >> how to
>> >> configure them.
>> >>
>> >> Any help?
>> >>
>> >> Cheers,
>> >> Peter
>> >
>> >
>> >
>> > _______________________________________________
>> > dev mailing list
>> > dev@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/dev
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Nope, that didn't do it either.
I guess that tomorrow I will try with new SSL certificates that take into
account the auth subdomain.

···

On Tue, Dec 9, 2014 at 5:30 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

There is config property that modifies the host. Jicofo package uses
'localhost' by default. Try adding JICOFO_HOST=my.domain to
/etc/jitsi/jicofo/config file and restarting Jicofo.

On Tue, Dec 9, 2014 at 6:23 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
> The prosody server is sitting on the same server as jitmeet.
>
> Its hostname is my.domain
>
> On Tue, Dec 9, 2014 at 3:48 PM, Paweł Domas <pawel.domas@jitsi.org> > wrote:
>>
>> What is the hostname/ip address of prosody server ? It looks like some
>> problem with communication.
>>
>> On Tue, Dec 9, 2014 at 4:41 PM, Peter Villeneuve <petervnv1@gmail.com> > >> wrote:
>> > Hi Pawel,
>> >
>> > Indeed I have the 'auth.meet.my.domain' virtual host in prosody
config.
>> > I
>> > believe it was inserted by the debian postinstall script.
>> > I noticed there was no SSL configured for that virtual host, so I
copied
>> > over the SSL configs from the "meet.my.domain" virtual host.
>> > Unfortunately the problem continues and I see the same error message
in
>> > jicofo logs. Do you think I have to generate a new certificate for
>> > auth.meet.my.domain since the meet.my.domain one will have a hostname
>> > mismatch? Could that be causing the failure to connect as seen in the
>> > jicofo
>> > logs: 15:29:14.479 SEVERE: [89]
>> > org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
>> > connection temporary
>> > stream:error (text). Is it possible to enable a greater debug level to
>> > see
>> > what the "stream:error" is all about?
>> >
>> > Cheers,
>> > Peter
>> >
>> > On Tue, Dec 9, 2014 at 9:49 AM, Paweł Domas <pawel.domas@jitsi.org> > >> > wrote:
>> >>
>> >> Hello Peter,
>> >>
>> >> Apologies for troubles with the nightly I'll try to come up with new
>> >> focus description today.
>> >>
>> >> Your error looks like focus user is unable to connect. Do you have
>> >> 'auth.meet.my.domain' virtual host configured in Prosody config? If
>> >> yes then it might be related to SSL, you may want to try removing
>> >> certifiacte config from 'auth.meet.my.domain' and see if that changes
>> >> anything.
>> >>
>> >> Jicofo config that stores user/hosts/secrets is located in
>> >> /etc/jitsi/jicofo/config.
>> >>
>> >> Regards,
>> >> Pawel
>> >>
>> >> On Mon, Dec 8, 2014 at 11:43 PM, Peter Villeneuve < > petervnv1@gmail.com> > >> >> wrote:
>> >> > Well I noticed that all the component secrets no longer matched so
I
>> >> > had
>> >> > to
>> >> > manually change the config files and now the components register as
>> >> > expected. Maybe it was my setup but you should check to make sure
the
>> >> > postinst scripts didn't mess up your existing configs.
>> >> >
>> >> > Anyway, If I comment out "focus: focus.jitsi-meet.my.domain" in my
>> >> > config.js then I'm able to generate a room after authenticating
like
>> >> > before
>> >> > (still don't know why uncommenting that leaves me unable to
generate
>> >> > a
>> >> > room).
>> >> > However when my guest clicks on the link all we can see is each
>> >> > other's
>> >> > avatars - no audio or video. Looking at jvb logs one can see it is
>> >> > never
>> >> > activated and lies there idle.
>> >> >
>> >> > Looking at jicofo logs however may shed some light on the problem.
>> >> > The
>> >> > focus
>> >> > appears to work ok until the connection error.
>> >> > I hope this helps debugging latest nightly.
>> >> >
>> >> > Cheers,
>> >> > Peter
>> >> >
>> >> >
>> >> >
>> >> > 22:29:17.330 INFO: [44]
>> >> > org.jitsi.jicofo.xmpp.FocusComponent.handleIQSet().209 Focus
request
>> >> > for
>> >> > room: 123@conference.meet.my.domain
>> >> > 22:29:17.330 INFO: [44]
>> >> > org.jitsi.jicofo.FocusManager.createConference().220
>> >> > Created new focus for
>> >> > 123@conference.meet.my.domain@auth.meet.my.domain
>> >> > conferences count: 1 options:
>> >> > channelLastN: -1
>> >> > adaptiveLastN: false
>> >> > adaptiveSimulcast: false
>> >> > bridge: jitsi-videobridge.meet.my.domain
>> >> > enableFirefoxHacks: false
>> >> > openSctp: true
>> >> > 22:29:17.570 SEVERE: [47]
>> >> > org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes
>> >> > the
>> >> > connection temporary
>> >> > stream:error (text)
>> >> > at
>> >> >
>> >> >
org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:264)
>> >> > at
>> >> >
org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
>> >> > at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)
>> >> > 22:29:22.419 SEVERE: [45]
>> >> > org.jitsi.jicofo.util.RegisterThread.run().42
>> >> >
net.java.sip.communicator.service.protocol.OperationFailedException:
>> >> > Failed
>> >> > to connect
>> >> >
net.java.sip.communicator.service.protocol.OperationFailedException:
>> >> > Failed
>> >> > to connect
>> >> > at
>> >> >
>> >> >
>> >> >
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
>> >> > at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
>> >> > Caused by: No response from the server.:
>> >> > at
>> >> >
>> >> >
>> >> >
org.jivesoftware.smack.SASLAuthentication.bindResourceAndEstablishSession(SASLAuthentication.java:456)
>> >> > at
>> >> >
>> >> >
>> >> >
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:352)
>> >> > at
>> >> >
org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
>> >> > at
>> >> >
>> >> >
>> >> >
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:151)
>> >> > ... 1 more
>> >> > 22:29:36.599 INFO: [18]
>> >> > org.jitsi.jicofo.FocusManager.expireLoop().442
>> >> > Focus
>> >> > idle timeout for 123@conference.meet.my.domain
>> >> > 22:29:36.599 INFO: [18]
>> >> >
>> >> >
>> >> >
org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireConference().334
>> >> > Nothing to expire - no conference allocated yet
>> >> > 22:29:36.599 SEVERE: [18]
>> >> > org.jitsi.jicofo.JitsiMeetConference.leaveTheRoom().392 Chat room
>> >> > already
>> >> > left!
>> >> > 22:29:36.751 INFO: [18]
>> >> > org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
>> >> > provider
>> >> > Jabber:focus@auth.meet.my.domain/focus1743616970713371@localhost
>> >> > disconnected
>> >> > 22:29:36.751 INFO: [18]
>> >> > org.jitsi.jicofo.FocusManager.conferenceEnded().250
>> >> > Disposed conference for room: 123@conference.meet.my.domain
>> >> > conference
>> >> > count: 0
>> >> >
>> >> > On Mon, Dec 8, 2014 at 9:34 PM, Peter Villeneuve > >> >> > <petervnv1@gmail.com> > >> >> > wrote:
>> >> >>
>> >> >> Hi,
>> >> >>
>> >> >> I just updated to the latest jitsi meet nightly using the debian
>> >> >> packages
>> >> >> and there seems to be a new component called jicofo related to
>> >> >> server
>> >> >> side
>> >> >> focus handling.
>> >> >> What are the new config options to get this to work? Is there any
>> >> >> documentation explaining what it does exactly and how it should be
>> >> >> setup?
>> >> >>
>> >> >> I ask this because now everytime I try to start a new conference,
I
>> >> >> get
>> >> >> an
>> >> >> error about focus.jitsi-meet.my.domain not being available. If I
>> >> >> uncomment
>> >> >> focus: focus.jitsi-meet.my.domain in my config.js, then I can't
even
>> >> >> try to
>> >> >> create a room (ie I get stuck at the welcome page without the room
>> >> >> generating algo and only the option to enter a room name - which
>> >> >> does
>> >> >> nothing).
>> >> >>
>> >> >> Previously I had everything working correctly with authentication
>> >> >> and
>> >> >> anonymous domain enabled, but these changes seem to have broken
>> >> >> that.
>> >> >>
>> >> >> I see the jicofo git page has some info on its options and I see
in
>> >> >> prosody logs that the focus component failed to authenticate, but
>> >> >> I'm
>> >> >> confused with the proliferation of so many new subdomains and
>> >> >> exactly
>> >> >> how to
>> >> >> configure them.
>> >> >>
>> >> >> Any help?
>> >> >>
>> >> >> Cheers,
>> >> >> Peter
>> >> >
>> >> >
>> >> >
>> >> > _______________________________________________
>> >> > dev mailing list
>> >> > dev@jitsi.org
>> >> > Unsubscribe instructions and other list options:
>> >> > http://lists.jitsi.org/mailman/listinfo/dev
>> >>
>> >> _______________________________________________
>> >> dev mailing list
>> >> dev@jitsi.org
>> >> Unsubscribe instructions and other list options:
>> >> http://lists.jitsi.org/mailman/listinfo/dev
>> >
>> >
>> >
>> > _______________________________________________
>> > dev mailing list
>> > dev@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/dev
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Has this change been deployed on meet.jit.si ? I am asking because if
so, I would like to organise testing by a larger group there.

thanks

karel

···

On 9.12.2014 20:16, Peter Villeneuve wrote:

Nope, that didn't do it either.
I guess that tomorrow I will try with new SSL certificates that take
into account the auth subdomain.

On Tue, Dec 9, 2014 at 5:30 PM, Paweł Domas <pawel.domas@jitsi.org > <mailto:pawel.domas@jitsi.org>> wrote:

    There is config property that modifies the host. Jicofo package uses
    'localhost' by default. Try adding JICOFO_HOST=my.domain to
    /etc/jitsi/jicofo/config file and restarting Jicofo.

    On Tue, Dec 9, 2014 at 6:23 PM, Peter Villeneuve > <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> wrote:
    > The prosody server is sitting on the same server as jitmeet.
    >
    > Its hostname is my.domain
    >
    > On Tue, Dec 9, 2014 at 3:48 PM, Paweł Domas > <pawel.domas@jitsi.org <mailto:pawel.domas@jitsi.org>> wrote:
    >>
    >> What is the hostname/ip address of prosody server ? It looks
    like some
    >> problem with communication.
    >>
    >> On Tue, Dec 9, 2014 at 4:41 PM, Peter Villeneuve > <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> > >> wrote:
    >> > Hi Pawel,
    >> >
    >> > Indeed I have the 'auth.meet.my.domain' virtual host in
    prosody config.
    >> > I
    >> > believe it was inserted by the debian postinstall script.
    >> > I noticed there was no SSL configured for that virtual host,
    so I copied
    >> > over the SSL configs from the "meet.my.domain" virtual host.
    >> > Unfortunately the problem continues and I see the same error
    message in
    >> > jicofo logs. Do you think I have to generate a new
    certificate for
    >> > auth.meet.my.domain since the meet.my.domain one will have a
    hostname
    >> > mismatch? Could that be causing the failure to connect as
    seen in the
    >> > jicofo
    >> > logs: 15:29:14.479 SEVERE: [89]
    >> > org.jivesoftware.smack.PacketReader.notifyConnectionError()
    Closes the
    >> > connection temporary
    >> > stream:error (text). Is it possible to enable a greater debug
    level to
    >> > see
    >> > what the "stream:error" is all about?
    >> >
    >> > Cheers,
    >> > Peter
    >> >
    >> > On Tue, Dec 9, 2014 at 9:49 AM, Paweł Domas > <pawel.domas@jitsi.org <mailto:pawel.domas@jitsi.org>> > >> > wrote:
    >> >>
    >> >> Hello Peter,
    >> >>
    >> >> Apologies for troubles with the nightly I'll try to come up
    with new
    >> >> focus description today.
    >> >>
    >> >> Your error looks like focus user is unable to connect. Do
    you have
    >> >> 'auth.meet.my.domain' virtual host configured in Prosody
    config? If
    >> >> yes then it might be related to SSL, you may want to try
    removing
    >> >> certifiacte config from 'auth.meet.my.domain' and see if
    that changes
    >> >> anything.
    >> >>
    >> >> Jicofo config that stores user/hosts/secrets is located in
    >> >> /etc/jitsi/jicofo/config.
    >> >>
    >> >> Regards,
    >> >> Pawel
    >> >>
    >> >> On Mon, Dec 8, 2014 at 11:43 PM, Peter Villeneuve > <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> > >> >> wrote:
    >> >> > Well I noticed that all the component secrets no longer
    matched so I
    >> >> > had
    >> >> > to
    >> >> > manually change the config files and now the components
    register as
    >> >> > expected. Maybe it was my setup but you should check to
    make sure the
    >> >> > postinst scripts didn't mess up your existing configs.
    >> >> >
    >> >> > Anyway, If I comment out "focus:
    focus.jitsi-meet.my.domain" in my
    >> >> > config.js then I'm able to generate a room after
    authenticating like
    >> >> > before
    >> >> > (still don't know why uncommenting that leaves me unable
    to generate
    >> >> > a
    >> >> > room).
    >> >> > However when my guest clicks on the link all we can see is
    each
    >> >> > other's
    >> >> > avatars - no audio or video. Looking at jvb logs one can
    see it is
    >> >> > never
    >> >> > activated and lies there idle.
    >> >> >
    >> >> > Looking at jicofo logs however may shed some light on the
    problem.
    >> >> > The
    >> >> > focus
    >> >> > appears to work ok until the connection error.
    >> >> > I hope this helps debugging latest nightly.
    >> >> >
    >> >> > Cheers,
    >> >> > Peter
    >> >> >
    >> >> >
    >> >> >
    >> >> > 22:29:17.330 INFO: [44]
    >> >> > org.jitsi.jicofo.xmpp.FocusComponent.handleIQSet().209
    Focus request
    >> >> > for
    >> >> > room: 123@conference.meet.my.domain
    >> >> > 22:29:17.330 INFO: [44]
    >> >> > org.jitsi.jicofo.FocusManager.createConference().220
    >> >> > Created new focus for
    >> >> > 123@conference.meet.my.domain@auth.meet.my.domain
    >> >> > conferences count: 1 options:
    >> >> > channelLastN: -1
    >> >> > adaptiveLastN: false
    >> >> > adaptiveSimulcast: false
    >> >> > bridge: jitsi-videobridge.meet.my.domain
    >> >> > enableFirefoxHacks: false
    >> >> > openSctp: true
    >> >> > 22:29:17.570 SEVERE: [47]
    >> >> >
    org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes
    >> >> > the
    >> >> > connection temporary
    >> >> > stream:error (text)
    >> >> > at
    >> >> >
    >> >> >
    org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:264)
    >> >> > at
    >> >> >
    org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
    >> >> > at
    org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)
    >> >> > 22:29:22.419 SEVERE: [45]
    >> >> > org.jitsi.jicofo.util.RegisterThread.run().42
    >> >> >
    net.java.sip.communicator.service.protocol.OperationFailedException:
    >> >> > Failed
    >> >> > to connect
    >> >> >
    net.java.sip.communicator.service.protocol.OperationFailedException:
    >> >> > Failed
    >> >> > to connect
    >> >> > at
    >> >> >
    >> >> >
    >> >> >
    org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
    >> >> > at
    org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
    >> >> > Caused by: No response from the server.:
    >> >> > at
    >> >> >
    >> >> >
    >> >> >
    org.jivesoftware.smack.SASLAuthentication.bindResourceAndEstablishSession(SASLAuthentication.java:456)
    >> >> > at
    >> >> >
    >> >> >
    >> >> >
    org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:352)
    >> >> > at
    >> >> >
    org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
    >> >> > at
    >> >> >
    >> >> >
    >> >> >
    org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:151)
    >> >> > ... 1 more
    >> >> > 22:29:36.599 INFO: [18]
    >> >> > org.jitsi.jicofo.FocusManager.expireLoop().442
    >> >> > Focus
    >> >> > idle timeout for 123@conference.meet.my.domain
    >> >> > 22:29:36.599 INFO: [18]
    >> >> >
    >> >> >
    >> >> >
    org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireConference().334
    >> >> > Nothing to expire - no conference allocated yet
    >> >> > 22:29:36.599 SEVERE: [18]
    >> >> > org.jitsi.jicofo.JitsiMeetConference.leaveTheRoom().392
    Chat room
    >> >> > already
    >> >> > left!
    >> >> > 22:29:36.751 INFO: [18]
    >> >> > org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info
    <http://org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info>() XMPP
    >> >> > provider
    >> >> >
    Jabber:focus@auth.meet.my.domain/focus1743616970713371@localhost
    >> >> > disconnected
    >> >> > 22:29:36.751 INFO: [18]
    >> >> > org.jitsi.jicofo.FocusManager.conferenceEnded().250
    >> >> > Disposed conference for room: 123@conference.meet.my.domain
    >> >> > conference
    >> >> > count: 0
    >> >> >
    >> >> > On Mon, Dec 8, 2014 at 9:34 PM, Peter Villeneuve > >> >> > <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> > >> >> > wrote:
    >> >> >>
    >> >> >> Hi,
    >> >> >>
    >> >> >> I just updated to the latest jitsi meet nightly using the
    debian
    >> >> >> packages
    >> >> >> and there seems to be a new component called jicofo
    related to
    >> >> >> server
    >> >> >> side
    >> >> >> focus handling.
    >> >> >> What are the new config options to get this to work? Is
    there any
    >> >> >> documentation explaining what it does exactly and how it
    should be
    >> >> >> setup?
    >> >> >>
    >> >> >> I ask this because now everytime I try to start a new
    conference, I
    >> >> >> get
    >> >> >> an
    >> >> >> error about focus.jitsi-meet.my.domain not being
    available. If I
    >> >> >> uncomment
    >> >> >> focus: focus.jitsi-meet.my.domain in my config.js, then I
    can't even
    >> >> >> try to
    >> >> >> create a room (ie I get stuck at the welcome page without
    the room
    >> >> >> generating algo and only the option to enter a room name
    - which
    >> >> >> does
    >> >> >> nothing).
    >> >> >>
    >> >> >> Previously I had everything working correctly with
    authentication
    >> >> >> and
    >> >> >> anonymous domain enabled, but these changes seem to have
    broken
    >> >> >> that.
    >> >> >>
    >> >> >> I see the jicofo git page has some info on its options
    and I see in
    >> >> >> prosody logs that the focus component failed to
    authenticate, but
    >> >> >> I'm
    >> >> >> confused with the proliferation of so many new subdomains and
    >> >> >> exactly
    >> >> >> how to
    >> >> >> configure them.
    >> >> >>
    >> >> >> Any help?
    >> >> >>
    >> >> >> Cheers,
    >> >> >> Peter
    >> >> >
    >> >> >
    >> >> >
    >> >> > _______________________________________________
    >> >> > dev mailing list
    >> >> > dev@jitsi.org <mailto:dev@jitsi.org>
    >> >> > Unsubscribe instructions and other list options:
    >> >> > http://lists.jitsi.org/mailman/listinfo/dev
    >> >>
    >> >> _______________________________________________
    >> >> dev mailing list
    >> >> dev@jitsi.org <mailto:dev@jitsi.org>
    >> >> Unsubscribe instructions and other list options:
    >> >> http://lists.jitsi.org/mailman/listinfo/dev
    >> >
    >> >
    >> >
    >> > _______________________________________________
    >> > dev mailing list
    >> > dev@jitsi.org <mailto:dev@jitsi.org>
    >> > Unsubscribe instructions and other list options:
    >> > http://lists.jitsi.org/mailman/listinfo/dev
    >>
    >> _______________________________________________
    >> dev mailing list
    >> dev@jitsi.org <mailto:dev@jitsi.org>
    >> Unsubscribe instructions and other list options:
    >> http://lists.jitsi.org/mailman/listinfo/dev
    >
    >
    >
    > _______________________________________________
    > dev mailing list
    > dev@jitsi.org <mailto:dev@jitsi.org>
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/dev

    _______________________________________________
    dev mailing list
    dev@jitsi.org <mailto:dev@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev