[jitsi-dev] Multiple issues with Jitsi


#1

Hi,

I'm mailing about several problems I have when I try to use Jitsi.

First of all, I cannot connect to my own Jabber server
(haar.student.utwente.nl) which is running Jabberd2. When I enter the
password, Jitsi keeps repeating asking for my password.
I see this in my console:
SASL authentication DIGEST-MD5 failed: incorrect-encoding:
        at
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:337)
        at
org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:246)
        at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:866)
        at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:669)
        at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:338)
        at
net.java.sip.communicator.impl.gui.main.login.LoginManager$RegisterProvider.run(LoginManager.java:405)

Another problem is that video calls to Jitsi on Ubuntu Hardy make it
crash with the following output:
warning: The VAD has been replaced by a hack pending a complete rewrite
net.java.sip.communicator.impl.galagonotification.DBusException: Failed
to execute dbus-launch to autolaunch D-Bus session
        at
net.java.sip.communicator.impl.galagonotification.GalagoNotification.dbus_bus_get_session(Native
Method)
        at
net.java.sip.communicator.impl.galagonotification.GalagoNotificationActivator.start(GalagoNotificationActivator.java:79)
        at
org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:629)
        at org.apache.felix.framework.Felix.activateBundle(Felix.java:1827)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1744)
        at
org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148)
        at
org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
        at java.lang.Thread.run(Thread.java:662)
/usr/bin/java: symbol lookup error:
/usr/lib/jitsi/lib/native/libjnportaudio.so: undefined symbol: clock_gettime

With my Gmail address, I can log in, but only not contacts show up as
online. In Psi, I have 61 contacts online out of 641. In Jitsi, I see
less than 50. I am not sure why. Some of the Google Translate bots are
missing for example, while others are there. Some output I see that may
be relevant:
Found invalid presence mode
Found invalid presence mode
23:19:07.300 SEVERE:
impl.protocol.jabber.ScServiceDiscoveryManager.discoverInfo().477
Invalid DiscoverInfo for
http://spectrum.im/transport#ZWebzrl6FebjuOW0Xgx3XPGaoSE=:
org.jivesoftware.smackx.packet.DiscoverInfo@c92945ed
(the last line is repeated many times, but the missing contacts are not
all on a Spectrum transport)

There is also the one way voice issue with Psi which I already checked
with Emil Ivov, but the related parts of Psi are being rewritten right
now. I think having the above issues fixed is more important.

Thank you very much in advance. Let me know if there is any more info I
can provide to help solve these issues.

Best regards,
Julius