[jitsi-dev] Missing Lock/Private conversation issues


#1

I've just been testing chatting from my PC to my Android phone (with
the latest apk) and I'm having some issues on the PC end, where the
chat window is not showing a lock icon at all.

Sending from the PC like this doesn't seem to get through to the
Android and I don't get any notifications. If I close the chat window
and look at right-click->Secure Chat, it shows Start Private
Conversation, so that hasn't started automatically, even though all
the options are ticked.

If I select Start Private Conversation, it doesn't open a chat window
which I'd expect it to do. If I open one manually, there's still no
lock icon and messages don't get sent to the Android.

If I then start a chat from the Android, it first says "message not
sent. Private messaging required" but then on the PC end it shows
"private conversation started" and the message comes through and after
that, messages from the PC are received on the Android. Still no lock
icon though so I don't really know if it's secured properly.

I'm a bit confused about closing a chat because if I close the chat
window on the PC, it doesn't seem to end the chat or notify the
Android that the chat has ended. On the Android, I can do "Close chat"
or "Close all chats" but that doesn't seem to notify the PC that it's
ended and I can't see an equivalent option on the PC.

Secure chat on the PC still shows "End Private Conversation" so it
doesn't appear to have ended it. If I end it manually on the PC, it
notifies the Android and says it should do the same but I don't see a
way to do this. If I then try to start a new chat from the Android, it
shows that I'm typing on the PC but the Android then says "the message
was not sent. Please end your private conversation" and again I don't
see how to do this.

Derek


#2

Hi Derek,

I've just been testing chatting from my PC to my Android phone (with
the latest apk) and I'm having some issues on the PC end, where the
chat window is not showing a lock icon at all.

Sending from the PC like this doesn't seem to get through to the
Android and I don't get any notifications. If I close the chat window
and look at right-click->Secure Chat, it shows Start Private
Conversation, so that hasn't started automatically, even though all
the options are ticked.

If I select Start Private Conversation, it doesn't open a chat window
which I'd expect it to do. If I open one manually, there's still no
lock icon and messages don't get sent to the Android.

If I then start a chat from the Android, it first says "message not
sent. Private messaging required" but then on the PC end it shows
"private conversation started" and the message comes through and after
that, messages from the PC are received on the Android. Still no lock
icon though so I don't really know if it's secured properly.

I'm a bit confused about closing a chat because if I close the chat
window on the PC, it doesn't seem to end the chat or notify the
Android that the chat has ended. On the Android, I can do "Close chat"
or "Close all chats" but that doesn't seem to notify the PC that it's
ended and I can't see an equivalent option on the PC.

Secure chat on the PC still shows "End Private Conversation" so it
doesn't appear to have ended it. If I end it manually on the PC, it
notifies the Android and says it should do the same but I don't see a
way to do this. If I then try to start a new chat from the Android, it
shows that I'm typing on the PC but the Android then says "the message
was not sent. Please end your private conversation" and again I don't
see how to do this.

Derek

Thanks for report. Issues you've described are easily reproductible
and we'll be looking into this issue soon. For now I've created a
ticked and copied you're mail to the description. You can track it's
progress here:
https://trac.jitsi.org/ticket/1232

Regards,
Pawel

···

On Tue, Dec 10, 2013 at 1:59 PM, Derek Moss <dmts@stoptheviolence.co.uk> wrote:


#3

Great, thanks Pawel

Regards
Derek

···

On 10 December 2013 14:41, Paweł Domas <pawel.domas@jitsi.org> wrote:>

Thanks for report. Issues you've described are easily reproductible
and we'll be looking into this issue soon. For now I've created a
ticked and copied you're mail to the description. You can track it's
progress here:
https://trac.jitsi.org/ticket/1232

Regards,
Pawel