[jitsi-dev] meet.jit.si: No connection between peers(Firefox 46)


#1

As Boris told that discussion problems here could be good idea, I will

Here must be picture

I haven't connection between peers(at all), for me seems strange that udp seems involved in it(which is not good idea for my provider network since only workable udp ports I know is around 2700*-2701*).

Since I don't know how to play around with the problem, I need your help to get it workable.
Please, help me understand what does mean all the N/A there. And how to get it workable.
BTW, the signal from microphone is exists since my preview in right lower corner is react when I speak by highlight it's borders more lighter.

···

----------------
Best regards,
Alex


#2

Hi Alex, are you testing FF 46 against https://meet.jit.si/ ? Can you type
in the URL box "about:webrtc", save the page and share it with us?

···

On Mon, Feb 1, 2016 at 12:50 PM, Alex Talker <alextalker@openmailbox.org> wrote:

As Boris told that discussion problems here could be good idea, I will

[image: Here must be picture]

I haven't connection between peers(at all), for me seems strange that udp
seems involved in it(which is not good idea for my provider network since
only workable udp ports I know is around 2700*-2701*).

Since I don't know how to play around with the problem, I need your help
to get it workable.
Please, help me understand what does mean all the N/A there. And how to
get it workable.
BTW, the signal from microphone is exists since my preview in right lower
corner is react when I speak by highlight it's borders more lighter.

----------------
Best regards,
Alex

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

The connection for multimedia is established via ICE. It will try both UDP and TCP and select the one that works.

Please post your console log as well.

Regards,
Boris

···

On 01/02/16 12:50, Alex Talker wrote:

As Boris told that discussion problems here could be good idea, I will

Here must be picture

I haven't connection between peers(at all), for me seems strange that
udp seems involved in it(which is not good idea for my provider network
since only workable udp ports I know is around 2700*-2701*).


#4

Since it's hard to quote both of you, I've quoted first one...
Hi, George! I've attached the file to message. Hope, it's the only one.
Boris, here's three files. First(before-join) is console when I create a room. Second(before-join-me) is the same console when other peer join. Third is console of the other peer.
BTW, seems like on hang on, I can't just leave a room, after a while it's start reporting errors in connection(through viewport).

Probably, if I stop js execution, I could catch the `hot moment` on hangout.

aboutWebrtc.html (40.5 KB)

after-join-me.txt (8.87 KB)

after-join-other.txt (10.3 KB)

before-join.txt (3.78 KB)

···

------------------
Best regards,
Alex

On 01.02.2016 22:00, George Politis wrote:

Hi Alex, are you testing FF 46 against https://meet.jit.si/ ? Can you type in the URL box "about:webrtc", save the page and share it with us?

On Mon, Feb 1, 2016 at 12:50 PM, Alex Talker > <alextalker@openmailbox.org <mailto:alextalker@openmailbox.org>> wrote:

    As Boris told that discussion problems here could be good idea, I will

    Here must be picture

    I haven't connection between peers(at all), for me seems strange
    that udp seems involved in it(which is not good idea for my
    provider network since only workable udp ports I know is around
    2700*-2701*).

    Since I don't know how to play around with the problem, I need
    your help to get it workable.
    Please, help me understand what does mean all the N/A there. And
    how to get it workable.
    BTW, the signal from microphone is exists since my preview in
    right lower corner is react when I speak by highlight it's borders
    more lighter.

    ----------------
    Best regards,
    Alex

    _______________________________________________
    dev mailing list
    dev@jitsi.org <mailto:dev@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

you're missing tcptype. Or Firefox does not like the srflx type for tcp.

···

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

From a quick look at the logs, it seems like ICE is consistently failing
and this is probably related to "Error parsing attribute: candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport 443",
which means we do something wrong with the SDP. We need to have a closer
look at the logs that you've sent.


#6

Hi Alex,

From a quick look at the logs, it seems like ICE is consistently failing

and this is probably related to "Error parsing attribute: candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport 443",
which means we do something wrong with the SDP. We need to have a closer
look at the logs that you've sent.

···

-
George

On Mon, Feb 1, 2016 at 1:11 PM, Alex Talker <alextalker@openmailbox.org> wrote:

Since it's hard to quote both of you, I've quoted first one...
Hi, George! I've attached the file to message. Hope, it's the only one.
Boris, here's three files. First(before-join) is console when I create a
room. Second(before-join-me) is the same console when other peer join.
Third is console of the other peer.
BTW, seems like on hang on, I can't just leave a room, after a while it's
start reporting errors in connection(through viewport).
Probably, if I stop js execution, I could catch the `hot moment` on
hangout.

------------------
Best regards,
Alex

On 01.02.2016 22:00, George Politis wrote:

Hi Alex, are you testing FF 46 against <https://meet.jit.si/>
https://meet.jit.si/ ? Can you type in the URL box "about:webrtc", save
the page and share it with us?

On Mon, Feb 1, 2016 at 12:50 PM, Alex Talker <alextalker@openmailbox.org> > wrote:

As Boris told that discussion problems here could be good idea, I will

[image: Here must be picture]

I haven't connection between peers(at all), for me seems strange that udp
seems involved in it(which is not good idea for my provider network since
only workable udp ports I know is around 2700*-2701*).

Since I don't know how to play around with the problem, I need your help
to get it workable.
Please, help me understand what does mean all the N/A there. And how to
get it workable.
BTW, the signal from microphone is exists since my preview in right lower
corner is react when I speak by highlight it's borders more lighter.

----------------
Best regards,
Alex

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing listdev@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Yeah, we fixed this relatively recently, not sure if it was before or after the last meet.jit.si update. Also, I don't know if ICE/TCP is still disabled by default in firefox.

Boris

···

On 01/02/16 13:30, Philipp Hancke wrote:

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

  From a quick look at the logs, it seems like ICE is consistently failing
and this is probably related to "Error parsing attribute: candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport 443",
which means we do something wrong with the SDP. We need to have a closer
look at the logs that you've sent.

you're missing tcptype. Or Firefox does not like the srflx type for tcp.


#8

So, if you're still interesting, I've develop-out the hell.
When I press the red button to hang on converstaion, then set rate, then press cancel, nothing happens. Then, after 5-10 seconds opens error window

Image of error window

Same for other peer. I have attached console logs and aboutwebrtc as well.
Hope, together we can fix it.

cancel-button-hell-me.txt (105 KB)

cancel-button-hell-other.txt (31.7 KB)

cancelbuttonhellAboutWebrtc.html (122 KB)

···

-------------
Best regards,
Alex

On 01.02.2016 22:11, Alex Talker wrote:

Since it's hard to quote both of you, I've quoted first one...
Hi, George! I've attached the file to message. Hope, it's the only one.
Boris, here's three files. First(before-join) is console when I create a room. Second(before-join-me) is the same console when other peer join. Third is console of the other peer.
BTW, seems like on hang on, I can't just leave a room, after a while it's start reporting errors in connection(through viewport).

Probably, if I stop js execution, I could catch the `hot moment` on hangout.

------------------
Best regards,
Alex

On 01.02.2016 22:00, George Politis wrote:

Hi Alex, are you testing FF 46 against https://meet.jit.si/ ? Can you type in the URL box "about:webrtc", save the page and share it with us?

On Mon, Feb 1, 2016 at 12:50 PM, Alex Talker >> <alextalker@openmailbox.org <mailto:alextalker@openmailbox.org>> wrote:

    As Boris told that discussion problems here could be good idea, I
    will

    Here must be picture

    I haven't connection between peers(at all), for me seems strange
    that udp seems involved in it(which is not good idea for my
    provider network since only workable udp ports I know is around
    2700*-2701*).

    Since I don't know how to play around with the problem, I need
    your help to get it workable.
    Please, help me understand what does mean all the N/A there. And
    how to get it workable.
    BTW, the signal from microphone is exists since my preview in
    right lower corner is react when I speak by highlight it's
    borders more lighter.

    ----------------
    Best regards,
    Alex

    _______________________________________________
    dev mailing list
    dev@jitsi.org <mailto:dev@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Huh, sounds pretty strange :slight_smile:

Also, can you explain me more what does sdp and what means srflx?

I've read on wikipedia that sdp is protocol to create sessions, independent from transport, but I would like know more :slight_smile:

BTW, I just run the same room in chromium and it...works....

Seems pretty strange to me....

Also, it's use tcp as well

Here's a shot:

Here's a shot

Hope now it will be a bit easy to you

···

------------------
Best regards,
Alex

On 01.02.2016 22:30, Philipp Hancke wrote:

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

From a quick look at the logs, it seems like ICE is consistently failing
and this is probably related to "Error parsing attribute: candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport 443",
which means we do something wrong with the SDP. We need to have a closer
look at the logs that you've sent.

you're missing tcptype. Or Firefox does not like the srflx type for tcp.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

How could I checkout that ICE/TCP disabled?

···

-------------------
Best regards,
Alex

On 01.02.2016 23:10, Boris Grozev wrote:

On 01/02/16 13:30, Philipp Hancke wrote:

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

  From a quick look at the logs, it seems like ICE is consistently failing
and this is probably related to "Error parsing attribute: candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport 443",
which means we do something wrong with the SDP. We need to have a closer
look at the logs that you've sent.

you're missing tcptype. Or Firefox does not like the srflx type for tcp.

Yeah, we fixed this relatively recently, not sure if it was before or after the last meet.jit.si update. Also, I don't know if ICE/TCP is still disabled by default in firefox.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#11

So, I've turn around and find out few things:
In version 46 and 45 media.peerconnection.ice.tcp option if false by default.
Unsure why since seems like it's fixed https://bugzilla.mozilla.org/show_bug.cgi?id=891551

Notice #2 is that I cannot get voip chromium <-> ff

Notice #3 is that when I ask one guy on ff 46 to help me test it out, he even didn't saw me in the room, what is pretty strange.
Yes, I asked the guy to turn the option on.

···

------------------
Best regards,

Alex

On 01.02.2016 23:15, Alex Talker wrote:

How could I checkout that ICE/TCP disabled?

-------------------
Best regards,
Alex

On 01.02.2016 23:10, Boris Grozev wrote:

On 01/02/16 13:30, Philipp Hancke wrote:

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

  From a quick look at the logs, it seems like ICE is consistently failing
and this is probably related to "Error parsing attribute: candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport 443",
which means we do something wrong with the SDP. We need to have a closer
look at the logs that you've sent.

you're missing tcptype. Or Firefox does not like the srflx type for tcp.

Yeah, we fixed this relatively recently, not sure if it was before or after the last meet.jit.si update. Also, I don't know if ICE/TCP is still disabled by default in firefox.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

https://bugzilla.mozilla.org/show_bug.cgi?id=1176382

···

------------------

Best regards,

Alex

On 01.02.2016 23:54, Alex Talker wrote:

So, I've turn around and find out few things:
In version 46 and 45 media.peerconnection.ice.tcp option if false by default.
Unsure why since seems like it's fixed https://bugzilla.mozilla.org/show_bug.cgi?id=891551

Notice #2 is that I cannot get voip chromium <-> ff

Notice #3 is that when I ask one guy on ff 46 to help me test it out, he even didn't saw me in the room, what is pretty strange.
Yes, I asked the guy to turn the option on.

------------------
Best regards,

Alex

On 01.02.2016 23:15, Alex Talker wrote:

How could I checkout that ICE/TCP disabled?

-------------------
Best regards,
Alex

On 01.02.2016 23:10, Boris Grozev wrote:

On 01/02/16 13:30, Philipp Hancke wrote:

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

  From a quick look at the logs, it seems like ICE is consistently failing
and this is probably related to "Error parsing attribute: candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport 443",
which means we do something wrong with the SDP. We need to have a closer
look at the logs that you've sent.

you're missing tcptype. Or Firefox does not like the srflx type for tcp.

Yeah, we fixed this relatively recently, not sure if it was before or after the last meet.jit.si update. Also, I don't know if ICE/TCP is still disabled by default in firefox.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#13

Hi Alex, can you give this one more try in our staging environment here
https://beta.meet.jit.si/ ? As Boris said, we believe this issue is fixed
but not deployed yet. Thank you.

···

-
George

On Mon, Feb 1, 2016 at 3:06 PM, Alex Talker <alextalker@openmailbox.org> wrote:

https://bugzilla.mozilla.org/show_bug.cgi?id=1176382

------------------

Best regards,

Alex

On 01.02.2016 23:54, Alex Talker wrote:

So, I've turn around and find out few things:
In version 46 and 45 media.peerconnection.ice.tcp option if false by
default.
Unsure why since seems like it's fixed
https://bugzilla.mozilla.org/show_bug.cgi?id=891551

Notice #2 is that I cannot get voip chromium <-> ff

Notice #3 is that when I ask one guy on ff 46 to help me test it out, he
even didn't saw me in the room, what is pretty strange.
Yes, I asked the guy to turn the option on.

------------------
Best regards,

Alex

On 01.02.2016 23:15, Alex Talker wrote:

How could I checkout that ICE/TCP disabled?

-------------------
Best regards,
Alex

On 01.02.2016 23:10, Boris Grozev wrote:

On 01/02/16 13:30, Philipp Hancke wrote:

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

  From a quick look at the logs, it seems like ICE is consistently
failing
and this is probably related to "Error parsing attribute: candidate:2
1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport
443",
which means we do something wrong with the SDP. We need to have a
closer
look at the logs that you've sent.

you're missing tcptype. Or Firefox does not like the srflx type for
tcp.

Yeah, we fixed this relatively recently, not sure if it was before or
after the last meet.jit.si update. Also, I don't know if ICE/TCP is
still disabled by default in firefox.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#14

Sorry but seems like the same thing.

Can I somehow force code to use tcp instead of udp?

Or maybe can I somehow run server here to test it out...?

···

------------------
Best regards,

Alex

On 02.02.2016 00:21, George Politis wrote:

Hi Alex, can you give this one more try in our staging environment here https://beta.meet.jit.si/ ? As Boris said, we believe this issue is fixed but not deployed yet. Thank you.

-
George

On Mon, Feb 1, 2016 at 3:06 PM, Alex Talker > <alextalker@openmailbox.org <mailto:alextalker@openmailbox.org>> wrote:

    https://bugzilla.mozilla.org/show_bug.cgi?id=1176382

    ------------------

    Best regards,

    Alex

    On 01.02.2016 23:54, Alex Talker wrote:

        So, I've turn around and find out few things:
        In version 46 and 45 media.peerconnection.ice.tcp option if
        false by default.
        Unsure why since seems like it's fixed
        https://bugzilla.mozilla.org/show_bug.cgi?id=891551

        Notice #2 is that I cannot get voip chromium <-> ff

        Notice #3 is that when I ask one guy on ff 46 to help me test
        it out, he even didn't saw me in the room, what is pretty strange.
        Yes, I asked the guy to turn the option on.

        ------------------
        Best regards,

        Alex

        On 01.02.2016 23:15, Alex Talker wrote:

            How could I checkout that ICE/TCP disabled?

            -------------------
            Best regards,
            Alex

            On 01.02.2016 23:10, Boris Grozev wrote:

                On 01/02/16 13:30, Philipp Hancke wrote:

                    Am 01.02.2016 um 11:27 schrieb George Politis:

                        Hi Alex,

                          From a quick look at the logs, it seems like
                        ICE is consistently failing
                        and this is probably related to "Error parsing
                        attribute: candidate:2 1 tcp
                        1694498815 104.192.142.217 443 typ srflx raddr
                        10.65.186.13 rport 443",
                        which means we do something wrong with the
                        SDP. We need to have a closer
                        look at the logs that you've sent.

                    you're missing tcptype. Or Firefox does not like
                    the srflx type for tcp.

                Yeah, we fixed this relatively recently, not sure if
                it was before or after the last meet.jit.si
                <http://meet.jit.si> update. Also, I don't know if
                ICE/TCP is still disabled by default in firefox.

                Boris

                _______________________________________________
                dev mailing list
                dev@jitsi.org <mailto:dev@jitsi.org>
                Unsubscribe instructions and other list options:
                http://lists.jitsi.org/mailman/listinfo/dev

            _______________________________________________
            dev mailing list
            dev@jitsi.org <mailto:dev@jitsi.org>
            Unsubscribe instructions and other list options:
            http://lists.jitsi.org/mailman/listinfo/dev

        _______________________________________________
        dev mailing list
        dev@jitsi.org <mailto:dev@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/dev

    _______________________________________________
    dev mailing list
    dev@jitsi.org <mailto:dev@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#15

Hi Alex, I suppose you have already tried enabling TCP in FF, right? If so,
then it might be a problem in our side that requires further investigation
because the fix should be deployed in beta.

You can run the server locally, we have instructions for that here :
https://github.com/jitsi/jitsi-meet/ but you shouldn't have to do that,
unless you want to try to debug the problem.

···

On Mon, Feb 1, 2016 at 3:31 PM, Alex Talker <alextalker@openmailbox.org> wrote:

Sorry but seems like the same thing.

Can I somehow force code to use tcp instead of udp?

Or maybe can I somehow run server here to test it out...?

------------------
Best regards,

Alex

On 02.02.2016 00:21, George Politis wrote:

Hi Alex, can you give this one more try in our staging environment here
https://beta.meet.jit.si/ ? As Boris said, we believe this issue is fixed
but not deployed yet. Thank you.

-
George

On Mon, Feb 1, 2016 at 3:06 PM, Alex Talker <alextalker@openmailbox.org> > wrote:

<https://bugzilla.mozilla.org/show_bug.cgi?id=1176382>
https://bugzilla.mozilla.org/show_bug.cgi?id=1176382

------------------

Best regards,

Alex

On 01.02.2016 23:54, Alex Talker wrote:

So, I've turn around and find out few things:
In version 46 and 45 media.peerconnection.ice.tcp option if false by
default.
Unsure why since seems like it's fixed
<https://bugzilla.mozilla.org/show_bug.cgi?id=891551>
https://bugzilla.mozilla.org/show_bug.cgi?id=891551

Notice #2 is that I cannot get voip chromium <-> ff

Notice #3 is that when I ask one guy on ff 46 to help me test it out, he
even didn't saw me in the room, what is pretty strange.
Yes, I asked the guy to turn the option on.

------------------
Best regards,

Alex

On 01.02.2016 23:15, Alex Talker wrote:

How could I checkout that ICE/TCP disabled?

-------------------
Best regards,
Alex

On 01.02.2016 23:10, Boris Grozev wrote:

On 01/02/16 13:30, Philipp Hancke wrote:

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

  From a quick look at the logs, it seems like ICE is consistently
failing
and this is probably related to "Error parsing attribute:
candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport
443",
which means we do something wrong with the SDP. We need to have a
closer
look at the logs that you've sent.

you're missing tcptype. Or Firefox does not like the srflx type for
tcp.

Yeah, we fixed this relatively recently, not sure if it was before or
after the last meet.jit.si update. Also, I don't know if ICE/TCP is
still disabled by default in firefox.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing listdev@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#16

Hi,

TCP is working with firefox Developer edition, it is still not enabled
in stable release [0]. You need to make sure the preference
media.peerconnection.ice.tcp is set to true and also "Enable
multi-process Firefox Developer Edition" is disabled.

Regards
damencho

[0] https://bugzilla.mozilla.org/show_bug.cgi?id=1206981

···

On Mon, Feb 1, 2016 at 3:46 PM, George Politis <gp@jitsi.org> wrote:

Hi Alex, I suppose you have already tried enabling TCP in FF, right? If so,
then it might be a problem in our side that requires further investigation
because the fix should be deployed in beta.

You can run the server locally, we have instructions for that here :
https://github.com/jitsi/jitsi-meet/ but you shouldn't have to do that,
unless you want to try to debug the problem.

On Mon, Feb 1, 2016 at 3:31 PM, Alex Talker <alextalker@openmailbox.org> > wrote:

Sorry but seems like the same thing.

Can I somehow force code to use tcp instead of udp?

Or maybe can I somehow run server here to test it out...?

------------------
Best regards,

Alex

On 02.02.2016 00:21, George Politis wrote:

Hi Alex, can you give this one more try in our staging environment here
https://beta.meet.jit.si/ ? As Boris said, we believe this issue is fixed
but not deployed yet. Thank you.

-
George

On Mon, Feb 1, 2016 at 3:06 PM, Alex Talker <alextalker@openmailbox.org> >> wrote:

https://bugzilla.mozilla.org/show_bug.cgi?id=1176382

------------------

Best regards,

Alex

On 01.02.2016 23:54, Alex Talker wrote:

So, I've turn around and find out few things:
In version 46 and 45 media.peerconnection.ice.tcp option if false by
default.
Unsure why since seems like it's fixed
https://bugzilla.mozilla.org/show_bug.cgi?id=891551

Notice #2 is that I cannot get voip chromium <-> ff

Notice #3 is that when I ask one guy on ff 46 to help me test it out, he
even didn't saw me in the room, what is pretty strange.
Yes, I asked the guy to turn the option on.

------------------
Best regards,

Alex

On 01.02.2016 23:15, Alex Talker wrote:

How could I checkout that ICE/TCP disabled?

-------------------
Best regards,
Alex

On 01.02.2016 23:10, Boris Grozev wrote:

On 01/02/16 13:30, Philipp Hancke wrote:

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

  From a quick look at the logs, it seems like ICE is consistently
failing
and this is probably related to "Error parsing attribute:
candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport
443",
which means we do something wrong with the SDP. We need to have a
closer
look at the logs that you've sent.

you're missing tcptype. Or Firefox does not like the srflx type for
tcp.

Yeah, we fixed this relatively recently, not sure if it was before or
after the last meet.jit.si update. Also, I don't know if ICE/TCP is still
disabled by default in firefox.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#17

Hi again,

Today I see some errors and it is not working for me. I will be
looking at it again.

Regards
damencho

···

On Fri, Feb 19, 2016 at 4:37 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

TCP is working with firefox Developer edition, it is still not enabled
in stable release [0]. You need to make sure the preference
media.peerconnection.ice.tcp is set to true and also "Enable
multi-process Firefox Developer Edition" is disabled.

Regards
damencho

[0] https://bugzilla.mozilla.org/show_bug.cgi?id=1206981

On Mon, Feb 1, 2016 at 3:46 PM, George Politis <gp@jitsi.org> wrote:

Hi Alex, I suppose you have already tried enabling TCP in FF, right? If so,
then it might be a problem in our side that requires further investigation
because the fix should be deployed in beta.

You can run the server locally, we have instructions for that here :
https://github.com/jitsi/jitsi-meet/ but you shouldn't have to do that,
unless you want to try to debug the problem.

On Mon, Feb 1, 2016 at 3:31 PM, Alex Talker <alextalker@openmailbox.org> >> wrote:

Sorry but seems like the same thing.

Can I somehow force code to use tcp instead of udp?

Or maybe can I somehow run server here to test it out...?

------------------
Best regards,

Alex

On 02.02.2016 00:21, George Politis wrote:

Hi Alex, can you give this one more try in our staging environment here
https://beta.meet.jit.si/ ? As Boris said, we believe this issue is fixed
but not deployed yet. Thank you.

-
George

On Mon, Feb 1, 2016 at 3:06 PM, Alex Talker <alextalker@openmailbox.org> >>> wrote:

https://bugzilla.mozilla.org/show_bug.cgi?id=1176382

------------------

Best regards,

Alex

On 01.02.2016 23:54, Alex Talker wrote:

So, I've turn around and find out few things:
In version 46 and 45 media.peerconnection.ice.tcp option if false by
default.
Unsure why since seems like it's fixed
https://bugzilla.mozilla.org/show_bug.cgi?id=891551

Notice #2 is that I cannot get voip chromium <-> ff

Notice #3 is that when I ask one guy on ff 46 to help me test it out, he
even didn't saw me in the room, what is pretty strange.
Yes, I asked the guy to turn the option on.

------------------
Best regards,

Alex

On 01.02.2016 23:15, Alex Talker wrote:

How could I checkout that ICE/TCP disabled?

-------------------
Best regards,
Alex

On 01.02.2016 23:10, Boris Grozev wrote:

On 01/02/16 13:30, Philipp Hancke wrote:

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

  From a quick look at the logs, it seems like ICE is consistently
failing
and this is probably related to "Error parsing attribute:
candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport
443",
which means we do something wrong with the SDP. We need to have a
closer
look at the logs that you've sent.

you're missing tcptype. Or Firefox does not like the srflx type for
tcp.

Yeah, we fixed this relatively recently, not sure if it was before or
after the last meet.jit.si update. Also, I don't know if ICE/TCP is still
disabled by default in firefox.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#18

Hi,

It was a problem with debian packages, it is fixed now and even
version 44 is working after just enabling
media.peerconnection.ice.tcp. Meet deployment will still have this
issue till we upgrade it.

Regards
damencho

···

On Mon, Feb 22, 2016 at 1:25 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi again,

Today I see some errors and it is not working for me. I will be
looking at it again.

Regards
damencho

On Fri, Feb 19, 2016 at 4:37 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

TCP is working with firefox Developer edition, it is still not enabled
in stable release [0]. You need to make sure the preference
media.peerconnection.ice.tcp is set to true and also "Enable
multi-process Firefox Developer Edition" is disabled.

Regards
damencho

[0] https://bugzilla.mozilla.org/show_bug.cgi?id=1206981

On Mon, Feb 1, 2016 at 3:46 PM, George Politis <gp@jitsi.org> wrote:

Hi Alex, I suppose you have already tried enabling TCP in FF, right? If so,
then it might be a problem in our side that requires further investigation
because the fix should be deployed in beta.

You can run the server locally, we have instructions for that here :
https://github.com/jitsi/jitsi-meet/ but you shouldn't have to do that,
unless you want to try to debug the problem.

On Mon, Feb 1, 2016 at 3:31 PM, Alex Talker <alextalker@openmailbox.org> >>> wrote:

Sorry but seems like the same thing.

Can I somehow force code to use tcp instead of udp?

Or maybe can I somehow run server here to test it out...?

------------------
Best regards,

Alex

On 02.02.2016 00:21, George Politis wrote:

Hi Alex, can you give this one more try in our staging environment here
https://beta.meet.jit.si/ ? As Boris said, we believe this issue is fixed
but not deployed yet. Thank you.

-
George

On Mon, Feb 1, 2016 at 3:06 PM, Alex Talker <alextalker@openmailbox.org> >>>> wrote:

https://bugzilla.mozilla.org/show_bug.cgi?id=1176382

------------------

Best regards,

Alex

On 01.02.2016 23:54, Alex Talker wrote:

So, I've turn around and find out few things:
In version 46 and 45 media.peerconnection.ice.tcp option if false by
default.
Unsure why since seems like it's fixed
https://bugzilla.mozilla.org/show_bug.cgi?id=891551

Notice #2 is that I cannot get voip chromium <-> ff

Notice #3 is that when I ask one guy on ff 46 to help me test it out, he
even didn't saw me in the room, what is pretty strange.
Yes, I asked the guy to turn the option on.

------------------
Best regards,

Alex

On 01.02.2016 23:15, Alex Talker wrote:

How could I checkout that ICE/TCP disabled?

-------------------
Best regards,
Alex

On 01.02.2016 23:10, Boris Grozev wrote:

On 01/02/16 13:30, Philipp Hancke wrote:

Am 01.02.2016 um 11:27 schrieb George Politis:

Hi Alex,

  From a quick look at the logs, it seems like ICE is consistently
failing
and this is probably related to "Error parsing attribute:
candidate:2 1 tcp
1694498815 104.192.142.217 443 typ srflx raddr 10.65.186.13 rport
443",
which means we do something wrong with the SDP. We need to have a
closer
look at the logs that you've sent.

you're missing tcptype. Or Firefox does not like the srflx type for
tcp.

Yeah, we fixed this relatively recently, not sure if it was before or
after the last meet.jit.si update. Also, I don't know if ICE/TCP is still
disabled by default in firefox.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev