[jitsi-dev] macOS Firefox doesn't show H264


#1

I created issues at


It's likely because there is no

    a=fmtp:99
profile-level-id=42e01f;level-asymmetry-allowed=1;packetization-mode=1

in the SDP, so Firefox doesn't know what profile to choose and ignores.

Currently, the issue is to be fixed in Jicofo since it returns SDP in
non-p2p mode. Also, I believe it can be worked around in lib-jitsi-meet,
but it's less reliable.

···

On Tue, Nov 21, 2017 at 12:50 PM <dev-request@jitsi.org> wrote:

I just tried apprtc with firefox 56 and 57 and it looks like maybe
something broke/changed in 57. I can't get firefox 57 to do h264 with
chrome on apprtc, but 56 was working. I tried messing with a couple of the
config settings, but that didn't seem to help. Seems like it might be
worth asking on the discuss-webrtc list.

On Mon, Nov 20, 2017 at 12:16 PM, Sergiy Kukunin <sergey.kukunin@gmail.com > > > wrote:

> Hello. I try to use `lib-jitsi-meet` library to create a custom streaming
> solution. In it, I need to have the support of Safari 11, so I had to
> switch to H264.
>
> Also, I patched the library to enable video support for Safari.
Everything
> works well except Firefox 57, which doesn't render H264 stream.
>
> For some reason, localDescription includes the only VP8 codec, but not
> H264.
>
> I went further and removed VP8/VP9 codecs from remoteDescription totally,
> and in this case, Firefox returns only `BUNDLE audio data`, and there is
> only VP8 codec listed in `m=video`.
>
> I checked `about:config` and set
`media.peerconnection.video.h264_enabled`
> to true.
>
> The weirdest thing that the same browser works here: https://safari.
> opentokrtc.com/, in pair with Safari and Chrome. And I checked, it uses
> H264.
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev