[jitsi-dev] Logon Dialog disappears when using some webcams


#1

I've hit an odd issue/bug. When using authentication: after granting
mic/camera permissions, the login dialog would disappear immediately.
The camera and mic would work fine if no authentication was used, or if
permission was granted after completing authentication.

While troubleshooting the issue, I found that once I changed the webcam,
everything worked as expected. In my case, the camera that exposed the
issue was a logitech c310.

Tested using firefox and chrome from different workstations, against
different installations, from within different environments . All yielded
the same results which indicate a potential server side bug.

Is it possible to request camera/mic access after authentication occurs? I
believe this might be a suitable work around.

Please let me know if you need more information

Thanks,
Sean


#2

Hi Sean,

We are already tracking this, which seems to happen due to a race condition. Hopefully it’s fix in the upcoming weeks.

Cheers,

···

On Nov 7, 2017, at 15:56, Not Speedy <notspeedy01@gmail.com> wrote:

I've hit an odd issue/bug. When using authentication: after granting mic/camera permissions, the login dialog would disappear immediately. The camera and mic would work fine if no authentication was used, or if permission was granted after completing authentication.

While troubleshooting the issue, I found that once I changed the webcam, everything worked as expected. In my case, the camera that exposed the issue was a logitech c310.

Tested using firefox and chrome from different workstations, against different installations, from within different environments . All yielded the same results which indicate a potential server side bug.

Is it possible to request camera/mic access after authentication occurs? I believe this might be a suitable work around.

Please let me know if you need more information

--
Saúl


#3

That's great! thank you!
-Sean

···

On Wed, Nov 8, 2017 at 4:28 AM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

> On Nov 7, 2017, at 15:56, Not Speedy <notspeedy01@gmail.com> wrote:
>
> I've hit an odd issue/bug. When using authentication: after granting
mic/camera permissions, the login dialog would disappear immediately. The
camera and mic would work fine if no authentication was used, or if
permission was granted after completing authentication.
>
> While troubleshooting the issue, I found that once I changed the webcam,
everything worked as expected. In my case, the camera that exposed the
issue was a logitech c310.
>
> Tested using firefox and chrome from different workstations, against
different installations, from within different environments . All yielded
the same results which indicate a potential server side bug.
>
> Is it possible to request camera/mic access after authentication occurs?
I believe this might be a suitable work around.
>
> Please let me know if you need more information
>

Hi Sean,

We are already tracking this, which seems to happen due to a race
condition. Hopefully it’s fix in the upcoming weeks.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Saúl,
Do you have a link to your issue tracker on this? Id like to follow the
process if possible.
Thanks again!
-Sean

···

On Wed, Nov 8, 2017 at 4:28 AM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

> On Nov 7, 2017, at 15:56, Not Speedy <notspeedy01@gmail.com> wrote:
>
> I've hit an odd issue/bug. When using authentication: after granting
mic/camera permissions, the login dialog would disappear immediately. The
camera and mic would work fine if no authentication was used, or if
permission was granted after completing authentication.
>
> While troubleshooting the issue, I found that once I changed the webcam,
everything worked as expected. In my case, the camera that exposed the
issue was a logitech c310.
>
> Tested using firefox and chrome from different workstations, against
different installations, from within different environments . All yielded
the same results which indicate a potential server side bug.
>
> Is it possible to request camera/mic access after authentication occurs?
I believe this might be a suitable work around.
>
> Please let me know if you need more information
>

Hi Sean,

We are already tracking this, which seems to happen due to a race
condition. Hopefully it’s fix in the upcoming weeks.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

It’s not on a publicly available bug tracker. Feel free to open an issue on GitHub.

Cheers,

···

On Nov 17, 2017, at 16:48, Not Speedy <notspeedy01@gmail.com> wrote:

Saúl,
Do you have a link to your issue tracker on this? Id like to follow the process if possible.
Thanks again!
-Sean

On Wed, Nov 8, 2017 at 4:28 AM, Saúl Ibarra Corretgé <scorretge@atlassian.com> wrote:

> On Nov 7, 2017, at 15:56, Not Speedy <notspeedy01@gmail.com> wrote:
>
> I've hit an odd issue/bug. When using authentication: after granting mic/camera permissions, the login dialog would disappear immediately. The camera and mic would work fine if no authentication was used, or if permission was granted after completing authentication.
>
> While troubleshooting the issue, I found that once I changed the webcam, everything worked as expected. In my case, the camera that exposed the issue was a logitech c310.
>
> Tested using firefox and chrome from different workstations, against different installations, from within different environments . All yielded the same results which indicate a potential server side bug.
>
> Is it possible to request camera/mic access after authentication occurs? I believe this might be a suitable work around.
>
> Please let me know if you need more information
>

Hi Sean,

We are already tracking this, which seems to happen due to a race condition. Hopefully it’s fix in the upcoming weeks.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl