[jitsi-dev] Local Jabber account not connecting


#1

Hello,

With the latest Jitsi version (3781) my local Jabber account doesnt work anymore. It works with Pidgin though.
Also my Gmail and Facebook accounts seem to work fine.

My Jabber server that is reachable via a VPN. The idea is that all communications to be routed through the VPN.
The thing is that it worked until this version so the latest changes must have broken something.

There is nothing in the logs. Nothing shows up if i tick/untick the account on the account list. The account is in the "connecting..." state but does not connect.

OS: Debian 32-bit, JItsi 3781.

···

--
O zi buna,

Kertesz Laszlo

Using Opera's revolutionary email client: http://www.opera.com/mail/


#2

Hey Laszlo

I have made some changes on how the DNS resolution for Jabber works, so it's very well possible something went wrong there.

Could you please give me some more details:
- How is your local account set up (server name and port in the account tab "Connection")?
- Do you have an SRV record in DNS for your account?

Regards,
Ingo

···

-----Original Message-----
From: Kertesz Laszlo [mailto:laszlo.kertesz@gmail.com]
Sent: Freitag, 18. November 2011 09:45
To: dev@jitsi.java.net
Subject: [jitsi-dev] Local Jabber account not connecting
Hello,

With the latest Jitsi version (3781) my local Jabber account doesnt work
anymore. It works with Pidgin though.
Also my Gmail and Facebook accounts seem to work fine.

My Jabber server that is reachable via a VPN. The idea is that all
communications to be routed through the VPN.
The thing is that it worked until this version so the latest changes must
have broken something.

There is nothing in the logs. Nothing shows up if i tick/untick the
account on the account list. The account is in the "connecting..." state
but does not connect.

OS: Debian 32-bit, JItsi 3781.


#3

Well. It works if i set the server address as the name i have in /etc/hosts for the servers ip. Thanks for the tip.
But why doesnt it work with the direct IP address?

···

On Fri, 18 Nov 2011 10:54:48 +0200, Bauersachs Ingo <ingo.bauersachs@fhnw.ch> wrote:

Hey Laszlo

I have made some changes on how the DNS resolution for Jabber works, so it's very well possible something went wrong there.

Could you please give me some more details:
- How is your local account set up (server name and port in the account tab "Connection")?
- Do you have an SRV record in DNS for your account?

Regards,
Ingo

-----Original Message-----
From: Kertesz Laszlo [mailto:laszlo.kertesz@gmail.com]
Sent: Freitag, 18. November 2011 09:45
To: dev@jitsi.java.net
Subject: [jitsi-dev] Local Jabber account not connecting
Hello,

With the latest Jitsi version (3781) my local Jabber account doesnt work
anymore. It works with Pidgin though.
Also my Gmail and Facebook accounts seem to work fine.

My Jabber server that is reachable via a VPN. The idea is that all
communications to be routed through the VPN.
The thing is that it worked until this version so the latest changes must
have broken something.

There is nothing in the logs. Nothing shows up if i tick/untick the
account on the account list. The account is in the "connecting..." state
but does not connect.

OS: Debian 32-bit, JItsi 3781.

--
O zi buna,

Kertesz Laszlo

Using Opera's revolutionary email client: http://www.opera.com/mail/


#4

Hey

We use our own DNS handling in order to deal with routers that don't support SRV queries and for IPv6 support. My changes around simplifying and reducing the number of lookups simply forgot about directly entered IP addresses.

I just committed a fix for that, it should be available with build 3782.

Thanks for reporting!

Regards,
Ingo

···

-----Original Message-----
From: Kertesz Laszlo [mailto:laszlo.kertesz@gmail.com]
Sent: Freitag, 18. November 2011 17:29
To: dev@jitsi.java.net; Bauersachs Ingo
Subject: Re: [jitsi-dev] Re: Local Jabber account not connecting
Well. It works if i set the server address as the name i have in
/etc/hosts for the servers ip. Thanks for the tip.
But why doesnt it work with the direct IP address?

On Fri, 18 Nov 2011 10:54:48 +0200, Bauersachs Ingo > <ingo.bauersachs@fhnw.ch> wrote:

Hey Laszlo

I have made some changes on how the DNS resolution for Jabber works, so
it's very well possible something went wrong there.

Could you please give me some more details:
- How is your local account set up (server name and port in the account
tab "Connection")?
- Do you have an SRV record in DNS for your account?

Regards,
Ingo

-----Original Message-----
From: Kertesz Laszlo [mailto:laszlo.kertesz@gmail.com]
Sent: Freitag, 18. November 2011 09:45
To: dev@jitsi.java.net
Subject: [jitsi-dev] Local Jabber account not connecting
Hello,

With the latest Jitsi version (3781) my local Jabber account doesnt work
anymore. It works with Pidgin though.
Also my Gmail and Facebook accounts seem to work fine.

My Jabber server that is reachable via a VPN. The idea is that all
communications to be routed through the VPN.
The thing is that it worked until this version so the latest changes
must
have broken something.

There is nothing in the logs. Nothing shows up if i tick/untick the
account on the account list. The account is in the "connecting..." state
but does not connect.

OS: Debian 32-bit, JItsi 3781.


#5

Bauersachs Ingo wrote:

Hey

We use our own DNS handling in order to deal with routers that don't support SRV queries and for IPv6 support. My changes around simplifying and reducing the number of lookups simply forgot about directly entered IP addresses.

I just committed a fix for that, it should be available with build 3782.

It works now, thank you.

···

Thanks for reporting!

Regards,
Ingo

-----Original Message-----
From: Kertesz Laszlo [mailto:laszlo.kertesz@gmail.com]
Sent: Freitag, 18. November 2011 17:29
To: dev@jitsi.java.net; Bauersachs Ingo
Subject: Re: [jitsi-dev] Re: Local Jabber account not connecting
Well. It works if i set the server address as the name i have in
/etc/hosts for the servers ip. Thanks for the tip.
But why doesnt it work with the direct IP address?

On Fri, 18 Nov 2011 10:54:48 +0200, Bauersachs Ingo >> <ingo.bauersachs@fhnw.ch> wrote:

Hey Laszlo

I have made some changes on how the DNS resolution for Jabber works, so
it's very well possible something went wrong there.

Could you please give me some more details:
- How is your local account set up (server name and port in the account
tab "Connection")?
- Do you have an SRV record in DNS for your account?

Regards,
Ingo

-----Original Message-----
From: Kertesz Laszlo [mailto:laszlo.kertesz@gmail.com]
Sent: Freitag, 18. November 2011 09:45
To: dev@jitsi.java.net
Subject: [jitsi-dev] Local Jabber account not connecting
Hello,

With the latest Jitsi version (3781) my local Jabber account doesnt work
anymore. It works with Pidgin though.
Also my Gmail and Facebook accounts seem to work fine.

My Jabber server that is reachable via a VPN. The idea is that all
communications to be routed through the VPN.
The thing is that it worked until this version so the latest changes
must
have broken something.

There is nothing in the logs. Nothing shows up if i tick/untick the
account on the account list. The account is in the "connecting..." state
but does not connect.

OS: Debian 32-bit, JItsi 3781.

--
O zi buna,
Kertesz Laszlo