[jitsi-dev] line ending in source


#1

Hi devs,

currently there is a problem with line endings of the source. We need
to fix this and here is a solution for it:
https://help.github.com/articles/dealing-with-line-endings.

I think we need to add to all our projects:
*.c text
*.java text
....

The problem is if we enable it, and if the developer updates its
local repo, will get a lot of files to be committed. But this is
described in the document in section: Re-normalizing a repository

With this change we will improve commit history, as it is currently
broken when a file is edited on linux/mac and then on windows
(https://github.com/jitsi/jitsi/commit/57c03920a685cc9a2a008b7084053907c05c1028)

WDYT?

Regards
damencho


#2

currently there is a problem with line endings of the source. We need to
fix this and here is a solution for it:
https://help.github.com/articles/dealing-with-line-endings.

I think we need to add to all our projects:
*.c text
*.java text
....

The problem is if we enable it, and if the developer updates its
local repo, will get a lot of files to be committed. But this is
described in the document in section: Re-normalizing a repository

With this change we will improve commit history, as it is currently
broken when a file is edited on linux/mac and then on windows
(https://github.com/jitsi/jitsi/commit/57c03920a685cc9a2a008b7084053907c0
5c10 28)

WDYT?

We didn't have a problem until ~week ago. What changed in the meantime? In
general, this is only a Windows problem and I tried hard to not cause a
mess. So either the repo is corrupt (i.e. there are CRLFs inside files in
the repo that come from the SVN migration) or someone's local git settings
are messed up...

Regards
damencho

Ingo


#3

Ok, you are right. I currently see there are around 22 file that have
CRLFs in the repo. But no SIPCommunicator.java, maybe it had those
line endings before Lubo edit it...
Or those line endings has changed while I was updating locally cause
of my git config.
Hum, will keep an eye on this.

ยทยทยท

On Mon, Nov 25, 2013 at 2:32 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

currently there is a problem with line endings of the source. We need to
fix this and here is a solution for it:
https://help.github.com/articles/dealing-with-line-endings.

I think we need to add to all our projects:
*.c text
*.java text
....

The problem is if we enable it, and if the developer updates its
local repo, will get a lot of files to be committed. But this is
described in the document in section: Re-normalizing a repository

With this change we will improve commit history, as it is currently
broken when a file is edited on linux/mac and then on windows
(https://github.com/jitsi/jitsi/commit/57c03920a685cc9a2a008b7084053907c0
5c10 28)

WDYT?

We didn't have a problem until ~week ago. What changed in the meantime? In
general, this is only a Windows problem and I tried hard to not cause a
mess. So either the repo is corrupt (i.e. there are CRLFs inside files in
the repo that come from the SVN migration) or someone's local git settings
are messed up...

Regards
damencho

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev