[jitsi-dev] [libjitsi] Update build.xml to support ld --as-needed (#6)


#1

Ubuntu uses the linker option "--as-needed" by default. This requires that libraries are added in the correct order to the linker command line (i.e. after the objects requesting external symbols). This change fixes the build on Ubuntu.
You can merge this Pull Request by running:

  git pull https://github.com/Ampelbein/libjitsi patch-1

Or you can view, comment on it, or merge it online at:

  https://github.com/jitsi/libjitsi/pull/6

-- Commit Summary --

  * Update build.xml to support ld --as-needed

-- File Changes --

    M src/native/build.xml (4)

-- Patch Links --

https://github.com/jitsi/libjitsi/pull/6.patch
https://github.com/jitsi/libjitsi/pull/6.diff

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/libjitsi/pull/6


#2

This was independently added in commit 0d0cd062333bc76525732a2f088d9c166ae05e1f.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/libjitsi/pull/6#issuecomment-145335609


#3

Closed #6.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/libjitsi/pull/6#event-426174890