[jitsi-dev] lib-jitsi-meet bundling error


#1

After updating lib-jisti-meet we are getting a SyntaxError when bundling
(recent head d6a3e8fb3c867e7dc458b647a5e0ae28aaf3ebf2).

Bundling the project with gulp/browserify/bablify results in a SyntaxError
in lib-jitsi-meet. Tried various presets 'es2015', 'es2016', 'es2017'..

SyntaxError: Unexpected token (6:12) while parsing
/Users/johann.steinbrecher/repos/lib-jitsi-meet/JitsiMeetJS.js while
parsing file: /Users/johann.steinbrecher/repos/lib-jitsi-meet/JitsiMeetJS.js

The breaking commit is
https://github.com/SymphonyOSF/lib-jitsi-meet/commit/b2cbb92895bc10d9996e870af4270f3cf347fe78
"fix(package.json): failing build from jitsi-meet project".

Is there a specific preset required for bablify? We are using presets
'es2015' and 'react'.

ยทยทยท

--
Johann Steinbrecher, Ph.D.
Engineer, Developer, Computer Scientist
+1 408 750 7765

Disclaimer

The information contained in this communication from the sender is confidential. It is intended solely for use by the recipient and others authorized to receive it. If you are not the recipient, you are hereby notified that any disclosure, copying, distribution or taking action in relation of the contents of this information is strictly prohibited and may be unlawful.