[jitsi-dev] Jitsivideobridge / jitsimeet stereo ability


#1

Hi there!

I tried to play stereo music through jitsi-meet. I've done it the same
way I used to do it for p2p web-rtc between two computers :
passing stereo=1 (and why not maxaveragebitrate=64000 or more) in
to opus codec
This is done by modifying bridge SDP (opus' fmtp line) in
colibrifocus.js and the same for each answer created to bridge offer.

Althougt webrtc-internals show that SDP are ok for stereo, audio is
mono and opus remain in voip mode which leads to poor music quality.
The same SDP applied in classic one-to-one webrtc connection give excellent quality, as expected with opus.

So, what's wrong with stereo in jitsivideobridge ? If is not supported,
can you explain why? As far as I have understood, the bridge is just
relaying rtp packets, so what is the problem ? Is there any workaroud ?
Thanks


#2

Hi there!

I tried to play stereo music through jitsi-meet. I've done it the same
way I used to do it for p2p web-rtc between two computers :
passing stereo=1 (and why not maxaveragebitrate=64000 or more) in
to opus codec
This is done by modifying bridge SDP (opus' fmtp line) in
colibrifocus.js and the same for each answer created to bridge offer.

Althougt webrtc-internals show that SDP are ok for stereo, audio is
mono and opus remain in voip mode which leads to poor music quality.
The same SDP applied in classic one-to-one webrtc connection give excellent quality, as expected with opus.

So, what's wrong with stereo in jitsivideobridge ? If is not supported,
can you explain why? As far as I have understood, the bridge is just
relaying rtp packets,

You are right, it does. Nothing would change for the bridge when you
move from stereo to mono.

so what is the problem ?

No idea. My guess would be that not all SDP got modified the way it
needed to be. There are many SLD/SRD calls in Jitsi Meet.

Is there any workaroud ?

Don't know. We'd have to look into that more deeply.

Emil

···

On Wed, Sep 10, 2014 at 6:24 PM, eerf <seb772002-250@yahoo.fr> wrote:

_______________________________________________

dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org


#3

Thanks !
So I'll try to catch the guilty SRD /SLD !

···

On Wed, 10 Sep 2014 18:32:06 -0400 Emil Ivov <emcho@jitsi.org> wrote:

On Wed, Sep 10, 2014 at 6:24 PM, eerf <seb772002-250@yahoo.fr> wrote:
> Hi there!
>
> I tried to play stereo music through jitsi-meet. I've done it the
> same way I used to do it for p2p web-rtc between two computers :
> passing stereo=1 (and why not maxaveragebitrate=64000 or more) in
> to opus codec
> This is done by modifying bridge SDP (opus' fmtp line) in
> colibrifocus.js and the same for each answer created to bridge
> offer.
>
> Althougt webrtc-internals show that SDP are ok for stereo, audio is
> mono and opus remain in voip mode which leads to poor music quality.
> The same SDP applied in classic one-to-one webrtc connection give
> excellent quality, as expected with opus.
>
> So, what's wrong with stereo in jitsivideobridge ? If is not
> supported, can you explain why? As far as I have understood, the
> bridge is just relaying rtp packets,

You are right, it does. Nothing would change for the bridge when you
move from stereo to mono.

> so what is the problem ?

No idea. My guess would be that not all SDP got modified the way it
needed to be. There are many SLD/SRD calls in Jitsi Meet.

> Is there any workaroud ?

Don't know. We'd have to look into that more deeply.

Emil

_______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev


#4

is this signalled via jingle as well? I.e. does it appear in the setRemoteDescription calls shown in webrtc-internals for the client?
It's probably worth checking whether chrome dislikes or requires spaces between individual fmtp parameters.

https://groups.google.com/forum/#!topic/discuss-webrtc/4hoyfMhMTwM might be helpful, too.

···

Am 11.09.2014 um 00:24 schrieb eerf:

Hi there!

I tried to play stereo music through jitsi-meet. I've done it the same
way I used to do it for p2p web-rtc between two computers :
passing stereo=1 (and why not maxaveragebitrate=64000 or more) in
to opus codec
This is done by modifying bridge SDP (opus' fmtp line) in
colibrifocus.js and the same for each answer created to bridge offer.


#5

> Hi there!
>
> I tried to play stereo music through jitsi-meet. I've done it the
> same way I used to do it for p2p web-rtc between two computers :
> passing stereo=1 (and why not maxaveragebitrate=64000 or more) in
> to opus codec
> This is done by modifying bridge SDP (opus' fmtp line) in
> colibrifocus.js and the same for each answer created to bridge
> offer.

is this signalled via jingle as well? I.e. does it appear in the
setRemoteDescription calls shown in webrtc-internals for the client?

yes, fmtp lines are well converted into jingle iq and appear in remote
SDP as expected.

It's probably worth checking whether chrome dislikes or requires
spaces between individual fmtp parameters.

parameters must be separated by semi-clolomn. I assume extra spaces are
ignored bry chrome but worth to double check. By the way, fmtp line is
the same that is working in p2p connection.

https://groups.google.com/forum/#!topic/discuss-webrtc/4hoyfMhMTwM
might be helpful, too.

Thanks.

I've just check webrtc-internal. It seems that last SRD of the focus
doesn't got the right fmtp line, just the default one. I'll track where
and why this appears.

···

On Thu, 11 Sep 2014 08:04:34 +0200 Philipp Hancke <fippo@goodadvice.pages.de> wrote:

Am 11.09.2014 um 00:24 schrieb eerf:


#6

[...]

I've just check webrtc-internal. It seems that last SRD of the focus
doesn't got the right fmtp line, just the default one. I'll track where
and why this appears.

do a console log of the sdp passed to setRemotedescription.
-- webrtc-internals mangles stuff before showing it which is really unhelpful in cases like this.


#7

Thanks for the trick.
I managed to get it work in a durty way. I've the fmtp line hardcoded
in traceablepeerconection.setremotesdp et set localsdp. So no signaling
but I can ensure that every call to SRD/SLD will have the
setero=1 param. Next step : coding a cleaner way.
Thanks for your help

Thu, 11 Sep 2014 10:30:35 +0200

···

Philipp Hancke <fippo@goodadvice.pages.de> wrote:

[...]
> I've just check webrtc-internal. It seems that last SRD of the focus
> doesn't got the right fmtp line, just the default one. I'll track
> where and why this appears.

do a console log of the sdp passed to setRemotedescription.
-- webrtc-internals mangles stuff before showing it which is really
unhelpful in cases like this.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev