[jitsi-dev] ./jitsivideo/jvb.sh --host=localhost --domain=chat.example.net --port=5347 --secret=emiljitsi


#1

Hi Developers,

Following this guide:
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

root@chat:~# ./jitsivideo/jvb.sh --host=localhost --domain=chat.example.net
--port=5347 --secret=emiljitsi

SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further
details.
Exception in thread "main" org.xmpp.component.ComponentException: host-unknown
        at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)
        at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
        at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
        at org.jitsi.videobridge.Main.main(Main.java:173)

http://www.slf4j.org/codes.html#StaticLoggerBinder shows:
This error is reported when the org.slf4j.impl.StaticLoggerBinder class
could not be loaded into memory. This happens when no appropriate SLF4J
binding could be found on the class path. Placing one (and only one) of
slf4j-nop.jar, slf4j-simple.jar, slf4j-log4j12.jar, slf4j-jdk14.jar or
logback-classic.jar on the class path should solve the problem.

Which do I need to load and where?

Also, in regards to: https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

Where do I find a turn server? Can I make my server that videbridge is on
the turn server?

thanks,
Jungle

···

--
inum: 883510009027723
sip: jungleboogie@sip2sip.info
xmpp: jungle-boogie@jit.si


#2

#3

Hi Developers,

Following this guide:
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

root@chat:~# ./jitsivideo/jvb.sh --host=localhost --domain=chat.example.net
--port=5347 --secret=emiljitsi

SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further
details.
Exception in thread "main" org.xmpp.component.ComponentException: host-unknown
         at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)
         at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
         at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
         at org.jitsi.videobridge.Main.main(Main.java:173)

Your xmpp server is telling the JVB that it does not have a configuration for the hostname the bridge is trying to connect as. which should be jitsi-videobridge.chat.example.net.

http://www.slf4j.org/codes.html#StaticLoggerBinder shows:
This error is reported when the org.slf4j.impl.StaticLoggerBinder class
could not be loaded into memory. This happens when no appropriate SLF4J
binding could be found on the class path. Placing one (and only one) of
slf4j-nop.jar, slf4j-simple.jar, slf4j-log4j12.jar, slf4j-jdk14.jar or
logback-classic.jar on the class path should solve the problem.

Which do I need to load and where?

Also, in regards to: https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

Where do I find a turn server? Can I make my server that videbridge is on
the turn server?

yeah. https://github.com/andyet/otalk-server/tree/master/restund has installation instructions for a modified version of restund.

hope that helps

···

Am 09.05.2014 01:35, schrieb Jungle Boogie:


#4

Hi Phillipp,

Hi Developers,

Following this guide:
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

root@chat:~# ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net
--port=5347 --secret=emiljitsi

SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further
details.
Exception in thread "main" org.xmpp.component.ComponentException:
host-unknown
         at

org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)
         at

org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
         at

org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
         at org.jitsi.videobridge.Main.main(Main.java:173)

Your xmpp server is telling the JVB that it does not have a configuration
for the hostname the bridge is trying to connect as. which should be
jitsi-videobridge.chat.example.net.

This and setting up the /etc/restund.conf are exactly what was needed.

Thanks so much for pointing this host error to me. I thought for sure
something was missing on my system but I didn't fully read the error!

For the posterity (and my memory):

chat.conf: http://pastiebin.com/53700d2aced07
config.js: http://pastiebin.com/53700d64a8df4
nginx.conf: http://pastiebin.com/53700dc3ea015
prosody.cfg.lua: http://pastiebin.com/53700df553875
restund.conf: http://pastiebin.com/53700e38378c6

There are my config files. If anyone finds an error, I'll update at pastiebin.

http://www.slf4j.org/codes.html#StaticLoggerBinder shows:
This error is reported when the org.slf4j.impl.StaticLoggerBinder class
could not be loaded into memory. This happens when no appropriate SLF4J
binding could be found on the class path. Placing one (and only one) of
slf4j-nop.jar, slf4j-simple.jar, slf4j-log4j12.jar, slf4j-jdk14.jar or
logback-classic.jar on the class path should solve the problem.

Which do I need to load and where?

Also, in regards to:
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

Where do I find a turn server? Can I make my server that videbridge is on
the turn server?

yeah. https://github.com/andyet/otalk-server/tree/master/restund has
installation instructions for a modified version of restund.

hope that helps

Yes, thanks and thank you for your development efforts on andyet and
of course, jitsi meet. I'm sure you and all the brilliant Jitsi people
will have new things very soon!

···

On 10 May 2014 23:17, Philipp Hancke <fippo@goodadvice.pages.de> wrote:

Am 09.05.2014 01:35, schrieb Jungle Boogie:

--
-------
inum: 883510009027723
sip: jungleboogie@sip2sip.info
xmpp: jungle-boogie@jit.si


#5

Hi jungleboogie0, in prosody config smacks3 smacks2 are superseded and all included in a module just labelled smacks. Publishing logs of prosody and nginx servers might also be useful. Regards - John

···

On 12/05/2014 02:03, jungleboogie0 wrote:

Hi Phillipp,

On 10 May 2014 23:17, Philipp Hancke <fippo@goodadvice.pages.de> wrote:

Am 09.05.2014 01:35, schrieb Jungle Boogie:

Hi Developers,

Following this guide:
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

root@chat:~# ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net
--port=5347 --secret=emiljitsi

SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further
details.
Exception in thread "main" org.xmpp.component.ComponentException:
host-unknown
          at

org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)
          at

org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
          at

org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
          at org.jitsi.videobridge.Main.main(Main.java:173)

Your xmpp server is telling the JVB that it does not have a configuration
for the hostname the bridge is trying to connect as. which should be
jitsi-videobridge.chat.example.net.

This and setting up the /etc/restund.conf are exactly what was needed.

Thanks so much for pointing this host error to me. I thought for sure
something was missing on my system but I didn't fully read the error!

For the posterity (and my memory):

chat.conf: http://pastiebin.com/53700d2aced07
config.js: http://pastiebin.com/53700d64a8df4
nginx.conf: http://pastiebin.com/53700dc3ea015
prosody.cfg.lua: http://pastiebin.com/53700df553875
restund.conf: http://pastiebin.com/53700e38378c6

There are my config files. If anyone finds an error, I'll update at pastiebin.

http://www.slf4j.org/codes.html#StaticLoggerBinder shows:
This error is reported when the org.slf4j.impl.StaticLoggerBinder class
could not be loaded into memory. This happens when no appropriate SLF4J
binding could be found on the class path. Placing one (and only one) of
slf4j-nop.jar, slf4j-simple.jar, slf4j-log4j12.jar, slf4j-jdk14.jar or
logback-classic.jar on the class path should solve the problem.

Which do I need to load and where?

Also, in regards to:
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

Where do I find a turn server? Can I make my server that videbridge is on
the turn server?

yeah. https://github.com/andyet/otalk-server/tree/master/restund has
installation instructions for a modified version of restund.

hope that helps

Yes, thanks and thank you for your development efforts on andyet and
of course, jitsi meet. I'm sure you and all the brilliant Jitsi people
will have new things very soon!


#6

Hi John,

···

--------------------------------------------------------
From: john <zbeiley@gmx.de>
Sent: Mon, 12 May 2014 11:17:02 +0200
To: Jitsi Developers
Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net --port=5347 --secret=emiljitsi

Hi jungleboogie0, in prosody config smacks3 smacks2 are superseded and all
included in a module just labelled smacks. Publishing logs of prosody and
nginx servers might also be useful. Regards - John

So I can just list "smacks"; as a module and delete?:
"smacks3";
"smacks2";

Regarding logging:
-- Logging configuration
-- For advanced logging see http://prosody.im/doc/logging
log = {
info = "/var/log/prosody/prosody.log"; -- Change 'info' to 'debug' for
verbose logging
error = "/var/log/prosody/prosody.err";

For nginx:
error_log /var/log/nginx/error.log warn;
and
it looks like there's already a /var/log/nginx/access.log

Is this sufficient?

I also updated restund.conf to include correct IP addresses for udp_listen
& tcp_listen. The install instructions mention "Configure addresses and
ports as desired" but nothing specific is listed.

I don't know if I supposed to telnet localhost 5582 but the connection is
refused each time.

root@chat:~# telnet localhost 5582
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused

--
inum: 883510009027723
sip: jungleboogie@sip2sip.info
xmpp: jungle-boogie@jit.si


#7

Hello,

···

On 15/05/14 22:59, Jungle Boogie wrote:

Hi John,
--------------------------------------------------------
From: john <zbeiley@gmx.de>
Sent: Mon, 12 May 2014 11:17:02 +0200
To: Jitsi Developers
Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net --port=5347 --secret=emiljitsi

Hi jungleboogie0, in prosody config smacks3 smacks2 are superseded and all
included in a module just labelled smacks. Publishing logs of prosody and
nginx servers might also be useful. Regards - John

So I can just list "smacks"; as a module and delete?:
"smacks3";
"smacks2";

Yes. You might be reading an older document somewhere, we updated this
on the official instructions[1] with this.

I don't know about the rest.

Regard,
Boris

[1] https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md


#8

Hi Jungle, yeah your telnet access won't work until you don't enable this in your prosody configuration file

"admin_telnet"; -- Opens telnet console interface on localhost port 5582

Actually that looks commented out in the file you posted, that step is also not mentioned in the jitmeet template and instructions.

/var/log/nginx/error.log , /var/log/nginx/access.log, /var/log/prosody/prosody.log and /var/log/prosody/prosody.err are good places where to look at , in order to see what's going on and on bad way.

Regards - Johhn

···

On 15/05/2014 22:59, Jungle Boogie wrote:

Hi John,
--------------------------------------------------------
From: john <zbeiley@gmx.de>
Sent: Mon, 12 May 2014 11:17:02 +0200
To: Jitsi Developers
Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net --port=5347 --secret=emiljitsi

Hi jungleboogie0, in prosody config smacks3 smacks2 are superseded and all
included in a module just labelled smacks. Publishing logs of prosody and
nginx servers might also be useful. Regards - John

So I can just list "smacks"; as a module and delete?:
"smacks3";
"smacks2";

Regarding logging:
-- Logging configuration
-- For advanced logging see http://prosody.im/doc/logging
log = {
info = "/var/log/prosody/prosody.log"; -- Change 'info' to 'debug' for
verbose logging
error = "/var/log/prosody/prosody.err";

For nginx:
error_log /var/log/nginx/error.log warn;
and
it looks like there's already a /var/log/nginx/access.log

Is this sufficient?

I also updated restund.conf to include correct IP addresses for udp_listen
& tcp_listen. The install instructions mention "Configure addresses and
ports as desired" but nothing specific is listed.

I don't know if I supposed to telnet localhost 5582 but the connection is
refused each time.

root@chat:~# telnet localhost 5582
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused


#9

Hi Boris,

···

--------------------------------------------------------
From: Boris Grozev <boris@jitsi.org>
Sent: Thu, 15 May 2014 23:09:10 +0200
To: Jitsi Developers
Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net --port=5347 --secret=emiljitsi

Hello,

On 15/05/14 22:59, Jungle Boogie wrote:

Hi John,
--------------------------------------------------------
From: john <zbeiley@gmx.de>
Sent: Mon, 12 May 2014 11:17:02 +0200
To: Jitsi Developers
Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net --port=5347 --secret=emiljitsi

Hi jungleboogie0, in prosody config smacks3 smacks2 are superseded and all
included in a module just labelled smacks. Publishing logs of prosody and
nginx servers might also be useful. Regards - John

So I can just list "smacks"; as a module and delete?:
"smacks3";
"smacks2";

Yes. You might be reading an older document somewhere, we updated this
on the official instructions[1] with this.

Thanks, I updated my pastie[0]

For the record smack2 and smack3 were listed in this file:
https://www.dropbox.com/sh/jgp4s8kp6xuyubr/AAByA3NUMu-x7_57vvbEg5dGa/prosody.cfg.lua

Which can be obtained from the link you provided:
"There are also some complete example config files available[1], mentioned
in each section."

I don't know about the rest.

Regard,
Boris

Best,
Jungle

[0] http://pastiebin.com/53700df553875/rev/33275
[1] https://www.dropbox.com/sh/jgp4s8kp6xuyubr/5FACgJmqLD

[1] https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

--
inum: 883510009027723
sip: jungleboogie@sip2sip.info
xmpp: jungle-boogie@jit.si


#10

Ah, good catch, thanks! I updated the examples and moved them to the
github repo.

Regards,
Boris

···

On 15/05/14 23:21, Jungle Boogie wrote:

Hi Boris,
--------------------------------------------------------
From: Boris Grozev <boris@jitsi.org>
Sent: Thu, 15 May 2014 23:09:10 +0200
To: Jitsi Developers
Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net --port=5347 --secret=emiljitsi

Hello,

On 15/05/14 22:59, Jungle Boogie wrote:

Hi John,
--------------------------------------------------------
From: john <zbeiley@gmx.de>
Sent: Mon, 12 May 2014 11:17:02 +0200
To: Jitsi Developers
Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net --port=5347 --secret=emiljitsi

Hi jungleboogie0, in prosody config smacks3 smacks2 are superseded and all
included in a module just labelled smacks. Publishing logs of prosody and
nginx servers might also be useful. Regards - John

So I can just list "smacks"; as a module and delete?:
"smacks3";
"smacks2";

Yes. You might be reading an older document somewhere, we updated this
on the official instructions[1] with this.

Thanks, I updated my pastie[0]

For the record smack2 and smack3 were listed in this file:
https://www.dropbox.com/sh/jgp4s8kp6xuyubr/AAByA3NUMu-x7_57vvbEg5dGa/prosody.cfg.lua

Which can be obtained from the link you provided:
"There are also some complete example config files available[1], mentioned
in each section."


#11

Hi John,

···

--------------------------------------------------------
From: john <zbeiley@gmx.de>
Sent: Fri, 16 May 2014 13:17:52 +0200
To: Jitsi Developers
Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net --port=5347 --secret=emiljitsi

Hi Jungle, yeah your telnet access won't work until you don't enable this
in your prosody configuration file

"admin_telnet"; -- Opens telnet console interface on localhost port 5582

Actually that looks commented out in the file you posted, that step is
also not mentioned in the jitmeet template and instructions.

Yeah, I noticed this too.

Boris,

Maybe you could amend the install instructions[0] to remove:
prosodyctl reload
telnet localhost 5582
module:reload("turncredentials", "jitsi.example.com")
quit

Since the prosody config file[1] has telnet disabled.

Also, could it be explained how etherpad is installed on meet.jit.si ?

Thanks,
Jungle

[0] https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md
[1]
https://github.com/jitsi/jitsi-meet/blob/master/doc/example-config-files/prosody.cfg.lua.example

/var/log/nginx/error.log , /var/log/nginx/access.log,
/var/log/prosody/prosody.log and /var/log/prosody/prosody.err are good
places where to look at , in order to see what's going on and on bad way.

Regards - Johhn

On 15/05/2014 22:59, Jungle Boogie wrote:

Hi John,
--------------------------------------------------------
From: john <zbeiley@gmx.de>
Sent: Mon, 12 May 2014 11:17:02 +0200
To: Jitsi Developers
Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net --port=5347 --secret=emiljitsi

Hi jungleboogie0, in prosody config smacks3 smacks2 are superseded and all
included in a module just labelled smacks. Publishing logs of prosody and
nginx servers might also be useful. Regards - John

So I can just list "smacks"; as a module and delete?:
"smacks3";
"smacks2";

Regarding logging:
-- Logging configuration
-- For advanced logging see http://prosody.im/doc/logging
log = {
info = "/var/log/prosody/prosody.log"; -- Change 'info' to 'debug' for
verbose logging
error = "/var/log/prosody/prosody.err";

For nginx:
error_log /var/log/nginx/error.log warn;
and
it looks like there's already a /var/log/nginx/access.log

Is this sufficient?

I also updated restund.conf to include correct IP addresses for udp_listen
& tcp_listen. The install instructions mention "Configure addresses and
ports as desired" but nothing specific is listed.

I don't know if I supposed to telnet localhost 5582 but the connection is
refused each time.

root@chat:~# telnet localhost 5582
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused

--
inum: 883510009027723
sip: jungleboogie@sip2sip.info
xmpp: jungle-boogie@jit.si


#12

Replaced it with 'prosodyctl restart'. Thanks!

Regards,
Boris

···

On 16/05/14 20:51, Jungle Boogie wrote:

Hi John,
--------------------------------------------------------
From: john <zbeiley@gmx.de>
Sent: Fri, 16 May 2014 13:17:52 +0200
To: Jitsi Developers
Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
--domain=chat.example.net --port=5347 --secret=emiljitsi

Hi Jungle, yeah your telnet access won't work until you don't enable this
in your prosody configuration file

"admin_telnet"; -- Opens telnet console interface on localhost port 5582

Actually that looks commented out in the file you posted, that step is
also not mentioned in the jitmeet template and instructions.

Yeah, I noticed this too.

Boris,

Maybe you could amend the install instructions[0] to remove:
prosodyctl reload
telnet localhost 5582
module:reload("turncredentials", "jitsi.example.com")
quit

Since the prosody config file[1] has telnet disabled.


#13

Hi,

Just to note, that was intentional with the reload, in order to have
instructions to enable modules without restarting the server and kill all
running meetings.

Regards
damencho

--sent from my mobile

···

On May 16, 2014 11:42 PM, "Boris Grozev" <boris@jitsi.org> wrote:

On 16/05/14 20:51, Jungle Boogie wrote:
> Hi John,
> --------------------------------------------------------
> From: john <zbeiley@gmx.de>
> Sent: Fri, 16 May 2014 13:17:52 +0200
> To: Jitsi Developers
> Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
> --domain=chat.example.net --port=5347 --secret=emiljitsi
>> Hi Jungle, yeah your telnet access won't work until you don't enable
this
>> in your prosody configuration file
>>
>> "admin_telnet"; -- Opens telnet console interface on localhost port 5582
>>
>> Actually that looks commented out in the file you posted, that step is
>> also not mentioned in the jitmeet template and instructions.
>
> Yeah, I noticed this too.
>
> Boris,
>
> Maybe you could amend the install instructions[0] to remove:
> prosodyctl reload
> telnet localhost 5582
> module:reload("turncredentials", "jitsi.example.com")
> quit
>
> Since the prosody config file[1] has telnet disabled.

Replaced it with 'prosodyctl restart'. Thanks!

Regards,
Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#14

Di Damian,

Hi,

Just to note, that was intentional with the reload, in order to have
instructions to enable modules without restarting the server and kill all
running meetings.

At what prompt would you actually type "module:reload("
turncredentials", "jitsi.example.com")", the shell prompt? Doing this
will give an error as it doesn't know what you're trying to do.

The telnet listener is disabled in the prosody.cfg.lua.example[0] so
that's why Boris removed it from the instructions.

Reviewing the prosodyctl[1], it does not look like there's an option
to reload modules, simply "prosodyctl reload" would probably be
sufficient and now the instructions have "prosody restart".

The turn server section[2] could also use it's own full example and
some more instructions on configuring, since this is what's used to
send/receive video/audio. My restund.conf example[3] shows the IP
address needing to be updated in a few places.

Regards
damencho

Regards,
Jungle

[0] https://github.com/jitsi/jitsi-meet/blob/master/doc/example-config-files/prosody.cfg.lua.example
[1] https://prosody.im/doc/prosodyctl
[2] https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md#install-turn-server
[3] http://pastiebin.com/53700e38378c6

···

On 17 May 2014 02:01, Damian Minkov <damencho@jitsi.org> wrote:

--sent from my mobile

On May 16, 2014 11:42 PM, "Boris Grozev" <boris@jitsi.org> wrote:

On 16/05/14 20:51, Jungle Boogie wrote:
> Hi John,
> --------------------------------------------------------
> From: john <zbeiley@gmx.de>
> Sent: Fri, 16 May 2014 13:17:52 +0200
> To: Jitsi Developers
> Subject: Re: [jitsi-dev] ./jitsivideo/jvb.sh --host=localhost
> --domain=chat.example.net --port=5347 --secret=emiljitsi
>> Hi Jungle, yeah your telnet access won't work until you don't enable
>> this
>> in your prosody configuration file
>>
>> "admin_telnet"; -- Opens telnet console interface on localhost port
>> 5582
>>
>> Actually that looks commented out in the file you posted, that step is
>> also not mentioned in the jitmeet template and instructions.
>
> Yeah, I noticed this too.
>
> Boris,
>
> Maybe you could amend the install instructions[0] to remove:
> prosodyctl reload
> telnet localhost 5582
> module:reload("turncredentials", "jitsi.example.com")
> quit
>
> Since the prosody config file[1] has telnet disabled.

Replaced it with 'prosodyctl restart'. Thanks!

Regards,
Boris

--
-------
inum: 883510009027723
sip: jungleboogie@sip2sip.info
xmpp: jungle-boogie@jit.si


#15

Yes, I thought so. Do you want me to revert it and enable to admin
console instead?

Boris

···

On 17/05/14 11:01, Damian Minkov wrote:

Hi,

Just to note, that was intentional with the reload, in order to have
instructions to enable modules without restarting the server and kill
all running meetings.


#16

No, its ok now. I was thinking of something like: (if you have or if you
enable telnet module you can load module turn .... like this ....) Just one
more description near current restart of prosody that you've added.
I think just reloading was not working, or there was a reason to do this
telnet stuff in order not to restart meet.jit.si when adding turn there,
and there can be other similar occasions.

Thanks
--sent from my mobile

···

On May 17, 2014 11:35 PM, "Boris Grozev" <boris@jitsi.org> wrote:

On 17/05/14 11:01, Damian Minkov wrote:
> Hi,
>
> Just to note, that was intentional with the reload, in order to have
> instructions to enable modules without restarting the server and kill
> all running meetings.

Yes, I thought so. Do you want me to revert it and enable to admin
console instead?

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev