[jitsi-dev] Jitsi - Videobridge


#1

Hello, Carlos

Please use the dev@jitsi.org mailing list (included in this reply) for such questions.

Hello Boris, I am trying to setup the Jitsi videobridge running on a
ubuntu ec2 instance. I was able to get pretty far, but I have seem to
hit a wall.
When I try to start the bridge I get the following error:

java.lang.Exception: InfluxDBLoggingService is disabled in the
configuration.

This is just a (very long and confusing) message which informs you that you have not enabled the optional logging functionality. It does not cause any problems and getting rid of it is on my list.

18:29:14.163 INFO: [9]
org.jitsi.videobridge.osgi.OSGiBundleActivator.info()
net.java.sip.communicator.SC_HOME_DIR_NAME=...
18:29:14.164 INFO: [9]
org.jitsi.videobridge.osgi.OSGiBundleActivator.info()
net.java.sip.communicator.SC_HOME_DIR_LOCATION=...
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for
further details.
18:29:14.205 SEVERE: [1] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[main,5,main] and message
was: conflict
org.xmpp.component.ComponentException: conflict

This means that there is already an XMPP component registered for jitsi-videobridge.YOURDOMAIN. Do you have another jitsi-videobridge instance running?

Regards,
Boris

···

On 13/11/14 20:45, Carlos Fernandez wrote:


#2

Thank you for your reply.

I have register the sub-domain and pointed to the same EC2 instance. But I do not have another instance running.

···

Boris Grozev <mailto:boris@jitsi.org>
November 13, 2014 at 2:08 PM
Hello, Carlos

Please use the dev@jitsi.org mailing list (included in this reply) for such questions.

On 13/11/14 20:45, Carlos Fernandez wrote:

Hello Boris, I am trying to setup the Jitsi videobridge running on a
ubuntu ec2 instance. I was able to get pretty far, but I have seem to
hit a wall.
When I try to start the bridge I get the following error:

java.lang.Exception: InfluxDBLoggingService is disabled in the
configuration.

This is just a (very long and confusing) message which informs you that you have not enabled the optional logging functionality. It does not cause any problems and getting rid of it is on my list.

18:29:14.163 INFO: [9]
org.jitsi.videobridge.osgi.OSGiBundleActivator.info()
net.java.sip.communicator.SC_HOME_DIR_NAME=...
18:29:14.164 INFO: [9]
org.jitsi.videobridge.osgi.OSGiBundleActivator.info()
net.java.sip.communicator.SC_HOME_DIR_LOCATION=...
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for
further details.
18:29:14.205 SEVERE: [1] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[main,5,main] and message
was: conflict
org.xmpp.component.ComponentException: conflict

This means that there is already an XMPP component registered for jitsi-videobridge.YOURDOMAIN. Do you have another jitsi-videobridge instance running?

Regards,
Boris
Carlos Fernandez <mailto:fernandez.carlos.cesar@gmail.com>
November 13, 2014 at 1:45 PM
Hello Boris, I am trying to setup the Jitsi videobridge running on a ubuntu ec2 instance. I was able to get pretty far, but I have seem to hit a wall.
When I try to start the bridge I get the following error:

java.lang.Exception: InfluxDBLoggingService is disabled in the configuration.
    at org.jitsi.videobridge.log.InfluxDBLoggingService.<init>(InfluxDBLoggingService.java:99)

    at org.jitsi.videobridge.log.LoggingBundleActivator.start(LoggingBundleActivator.java:37)

    at org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:293)
    at org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:460)

    at org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:126)

    at org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:111)

    at org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:17)

    at org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:220)
18:29:14.060 SEVERE: [9] org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged() Error changing start level
org.osgi.framework.BundleException: BundleActivator.start
    at org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:313)
    at org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:460)

    at org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:126)

    at org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:111)

    at org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:17)

    at org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:220)
Caused by: java.lang.Exception: InfluxDBLoggingService is disabled in the configuration.
    at org.jitsi.videobridge.log.InfluxDBLoggingService.<init>(InfluxDBLoggingService.java:99)

    at org.jitsi.videobridge.log.LoggingBundleActivator.start(LoggingBundleActivator.java:37)

    at org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:293)
    ... 5 more
18:29:14.163 INFO: [9] org.jitsi.videobridge.osgi.OSGiBundleActivator.info() net.java.sip.communicator.SC_HOME_DIR_NAME=.sip-communicator
18:29:14.164 INFO: [9] org.jitsi.videobridge.osgi.OSGiBundleActivator.info() net.java.sip.communicator.SC_HOME_DIR_LOCATION=/root
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
18:29:14.205 SEVERE: [1] util.UtilActivator.uncaughtException().108 An uncaught exception occurred in thread=Thread[main,5,main] and message was: conflict
org.xmpp.component.ComponentException: conflict
    at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)

    at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)

    at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)

    at org.jitsi.videobridge.Main.main(Main.java:264)

Regards,

Carlos


#3

I mean another jitsi-videobridge process, possibly running in the background somewhere.

Regards,
Boris

···

On 13/11/14 21:15, Carlos Fernandez wrote:

Thank you for your reply.

I have register the sub-domain and pointed to the same EC2 instance. But
I do not have another instance running.