[jitsi-dev] [jitsi-videobridge] Version 1.3.1 doesn't work with Openfire-3.9.3 (#24)


#1

Server is debian 7. I can confirm that our openfire server 3.9.3 used to be working with earlier version 1.3.0 but it stopped working since the upgrade to version 1.3.1.

Jitsi videobridge doesn't show up in the installed plugins list after installing from 'available plugins' window.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/24


#2

From openfire `error.log`:

2014.09.28 14:24:01 org.jivesoftware.openfire.container.PluginManager - Error loading plugin: /usr/share/openfire     /plugins/jitsivideobridge
java.lang.UnsupportedClassVersionError: org/jitsi/videobridge/openfire/PluginImpl : Unsupported major.minor versi     on 51.0
         at java.lang.ClassLoader.defineClass1(Native Method)
         at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
         at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
         at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
         at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
         at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
         at java.security.AccessController.doPrivileged(Native Method)
         at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
         at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
         at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
         at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java:420)
         at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java:80)
         at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManager.java:1074)
         at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
         at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:351)
         at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:178)
         at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExe     cutor.java:165)
         at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.j     ava:267)
         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
         at java.lang.Thread.run(Thread.java:679)
···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/24#issuecomment-57094889


#3

Closed #24.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/24#event-171311396


#4

Hello and thanks for your report!

The error states that the plugin has been compiled to be ran with java 1.7 or higher. Its a packaging problem of the plugin which is downloaded from igniterealtime.org, report the problem there.

  Note however that as our "Bugs and Issues" page [0] explains, we expect
  reports to be submitted in the issue tracker once they have been
discussed
  and confirmed as such on our dev mailing list [1]. This is really
  important to us and we've tried to make it clear throughout the site. You
  may also like to check the following page [2] for the rationale behind
our
  decision.

  For all these reason we may be marking this issue as Invalid. In all
  cases, please report it on dev@jitsi.org so that we can have a proper
  discussion.

  [0] http://www.jitsi.org/index.php/Development/BugsAndIssues
  [1] dev@jitsi.org
  [2] http://producingoss.com/en/bug-tracker.html#bug-filtering

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/24#issuecomment-57120812