[jitsi-dev] [jitsi-videobridge] Simulcast Setting Documentation (#138)


#1

Not having any luck getting simulcast working properly.
What setting should be in sip-communicator.properties to enable rewrite mode?

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/138


#2

Hi @stongo there's no special configuration in the bridge as it gets setup based on COLIBRI signaling. If you correctly configure your client to stream simulcast and you signal that to the bridge, it should enable all the required bits and pieces automatically. The bridge rewrites into the first SSRC of the simulcast group.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/138#issuecomment-185289858


#3

Closed #138.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/138#event-553893299


#4

You can find more about the COLIBRI required in the simulcast documentation [here](https://github.com/jitsi/jitsi-videobridge/blob/master/doc/simulcast.md). If you think there's something missing from the documentation please open a specific issue.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/138#issuecomment-185310055


#5

Is simulcast required now? Is there a way to disable simulcast?

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/138#issuecomment-185322047


#6

Simulcast is not required, but it is enabled by default. You can disable if you want to by setting `disableSimulcast: true` in your `config.js`. That's not documented anywhere, that's a mistake on our side.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/138#issuecomment-185322644


#7

@gpolitis: I'm not running Jitsi Meet in this case.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/138#issuecomment-185336029


#8

Oh, so no, it's not enabled by default. It is enabled if you use appropriate signaling with COLIBRI.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/138#issuecomment-185782616


#9

I think I was being confused by this https://github.com/jitsi/jitsi-videobridge/blob/4de4792074a6282986c413ac6eec371101d18782/src/main/java/org/jitsi/videobridge/VideoChannel.java#L1024-L1030
"Aborting: simulcast mode is not set, but it is required." was misleading

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/138#issuecomment-185784821


#10

I see now, this should probably be a debug log, not a warning. And it should also be less scary :slight_smile:

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/138#issuecomment-185816571